OCamllabs icon Home|Differences with the last checks|Previous runs


Building on spring

(from freebsd)
2024-06-04 23:03.38 ---> using "77d5fe31836124b4684d554707425c4fde23f9ef3df0a804431a47419573778d" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/local/bin/opam-dev /usr/local/bin/opam"))
2024-06-04 23:03.39 ---> using "a2b22593046b56fadc85e22b0da7b84e903c1f5aa4d42a7c481121ceec28b31f" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q 5979d639be2999663a41c1d1b8a73ce3036dcb41"))
2024-06-04 23:03.39 ---> using "2e94e5004b03fe08a15876e59bd907e053f5652a7b55cefeb621755911d262e4" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare ~/opam-repository"))
No configuration file found, using built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2024-06-04 23:03.40 ---> using "b4bc54507f76941ccbefe785580d5364ddec85b9b50664d9209890a6feda03ee" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.14.1' 'ocaml-base-compiler.4.14.1'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.14.1"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved ocaml-config.2  (cached)
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> installed ocaml-options-vanilla.1
-> retrieved ocaml-base-compiler.4.14.1  (cached)
-> installed ocaml-base-compiler.4.14.1
-> installed ocaml-config.2
-> installed ocaml.4.14.1
Done.
# Run eval $(opam env --switch=4.14.1) to update the current shell environment
2024-06-04 23:03.40 ---> using "e855cd2b85c6094a1ea1ba91b125bd826adfb63b8e9b574f01526e51b39ae9ac" from cache

/: (run (network host)
        (shell "opam update --depexts"))
[WARNING] Unknown update command for bsd, skipping system update
2024-06-04 23:03.41 ---> using "6cb695ec395392559b6be09284f12b2de41beca3380655387f54a53db6e3412a" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"bap-analyze.2.5.0\"\
               \nopam install -vy \"bap-analyze.2.5.0\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"bap-analyze.2.5.0\" | grep -q '\"freebsd\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] bap-analyze.2.5.0 is not installed.

Nothing to do.
The following actions will be performed:
=== install 122 packages
  - install angstrom            0.16.0  [required by uri]
  - install bap-analyze         2.5.0
  - install bap-build           2.5.0   [required by bap-core-theory]
  - install bap-bundle          2.5.0   [required by bap-std]
  - install bap-core-theory     2.5.0   [required by bap-analyze]
  - install bap-future          2.5.0   [required by bap-std]
  - install bap-knowledge       2.5.0   [required by bap-analyze]
  - install bap-main            2.5.0   [required by bap-analyze]
  - install bap-plugins         2.5.0   [required by bap-std]
  - install bap-recipe          2.5.0   [required by bap-main]
  - install bap-relation        2.5.0   [required by bap-std]
  - install bap-std             2.5.0   [required by bap-analyze]
  - install base                v0.14.3 [required by bitvec-order, bap-main, bap-relation]
  - install base-bytes          base    [required by ocplib-endian]
  - install base_bigstring      v0.14.0 [required by core_kernel]
  - install base_quickcheck     v0.14.1 [required by core_kernel, ppx_bap]
  - install bigarray-compat     1.1.0   [required by mmap]
  - install bigstringaf         0.9.1   [required by angstrom]
  - install bin_prot            v0.14.1 [required by bap-std]
  - install bitvec              2.5.0   [required by bap-analyze]
  - install bitvec-binprot      2.5.0   [required by bap-core-theory]
  - install bitvec-order        2.5.0   [required by bap-core-theory, bap-std]
  - install bitvec-sexp         2.5.0   [required by bap-core-theory]
  - install camlzip             1.11    [required by bap-std]
  - install cmdliner            1.3.0   [required by bap-std]
  - install conf-binutils       0.3     [required by bap-std]
  - install conf-clang          1       [required by bap-std]
  - install conf-gmp            4       [required by bap-std]
  - install conf-m4             1       [required by bap-std]
  - install conf-perl           2       [required by bap-std]
  - install conf-pkg-config     3       [required by conf-zlib]
  - install conf-which          1       [required by bap-std]
  - install conf-zlib           1       [required by bap-std]
  - install core_kernel         v0.14.2 [required by bap-analyze]
  - install cppo                1.6.9   [required by utop]
  - install csexp               1.5.2   [required by dune-configurator]
  - install dune                3.15.3  [required by linenoise]
  - install dune-configurator   3.15.3  [required by base]
  - install fieldslib           v0.14.0 [required by core_kernel]
  - install fileutils           0.6.4   [required by bap-std]
  - install graphlib            2.5.0   [required by bap-std]
  - install jane-street-headers v0.14.0 [required by core_kernel]
  - install jst-config          v0.14.1 [required by core_kernel]
  - install lambda-term         3.3.2   [required by utop]
  - install linenoise           1.5.1   [required by bap-analyze]
  - install logs                0.7.0   [required by utop]
  - install lwt                 5.7.0   [required by utop]
  - install lwt_react           1.2.0   [required by utop]
  - install mew                 0.1.0   [required by mew_vi]
  - install mew_vi              0.5.0   [required by lambda-term]
  - install mmap                1.2.0   [required by bap-std]
  - install monads              2.5.0   [required by bap-analyze]
  - install num                 1.5     [required by sexplib]
  - install oasis               0.4.11  [required by bap-core-theory, bap-std]
  - install ocaml-compiler-libs v0.12.4 [required by ppxlib]
  - install ocaml-syntax-shims  1.0.0   [required by angstrom]
  - install ocamlbuild          0.14.3  [required by bap-build]
  - install ocamlfind           1.9.6   [required by bap-std]
  - install ocamlgraph          2.1.0   [required by graphlib]
  - install ocamlify            0.0.1   [required by oasis]
  - install ocamlmod            0.0.9   [required by oasis]
  - install ocplib-endian       1.2     [required by lwt]
  - install octavius            1.2.2   [required by ppx_js_style]
  - install ogre                2.5.0   [required by bap-std]
  - install parsexp             v0.14.2 [required by bap-recipe]
  - install ppx_assert          v0.14.0 [required by core_kernel, ppx_bap]
  - install ppx_bap             v0.14.0 [required by bap-analyze]
  - install ppx_base            v0.14.0 [required by core_kernel]
  - install ppx_bench           v0.14.1 [required by ppx_bap]
  - install ppx_bin_prot        v0.14.0 [required by ppx_bap]
  - install ppx_cold            v0.14.0 [required by ppx_bap]
  - install ppx_compare         v0.14.0 [required by ppx_bap]
  - install ppx_custom_printf   v0.14.1 [required by ppx_jane]
  - install ppx_derivers        1.2.1   [required by ppxlib]
  - install ppx_enumerate       v0.14.0 [required by ppx_bap]
  - install ppx_expect          v0.14.2 [required by ppx_jane]
  - install ppx_fields_conv     v0.14.2 [required by ppx_bap]
  - install ppx_fixed_literal   v0.14.0 [required by ppx_jane]
  - install ppx_hash            v0.14.0 [required by core_kernel, ppx_bap]
  - install ppx_here            v0.14.0 [required by ppx_bap]
  - install ppx_inline_test     v0.14.1 [required by core_kernel]
  - install ppx_jane            v0.14.0 [required by core_kernel]
  - install ppx_js_style        v0.14.1 [required by ppx_base]
  - install ppx_let             v0.14.0 [required by ppx_jane]
  - install ppx_module_timer    v0.14.0 [required by ppx_jane]
  - install ppx_optcomp         v0.14.3 [required by core_kernel, ppx_bap]
  - install ppx_optional        v0.14.0 [required by ppx_jane]
  - install ppx_pipebang        v0.14.0 [required by ppx_jane]
  - install ppx_sexp_conv       v0.14.3 [required by core_kernel, ppx_bap]
  - install ppx_sexp_message    v0.14.1 [required by core_kernel]
  - install ppx_sexp_value      v0.14.0 [required by ppx_bap]
  - install ppx_stable          v0.14.1 [required by ppx_jane]
  - install ppx_string          v0.14.1 [required by ppx_jane]
  - install ppx_typerep_conv    v0.14.2 [required by ppx_jane]
  - install ppx_variants_conv   v0.14.2 [required by ppx_bap]
  - install ppxlib              0.25.1  [required by ppx_bap]
  - install re                  1.11.0  [required by ppx_expect]
  - install react               1.2.2   [required by utop]
  - install regular             2.5.0   [required by bap-std]
  - install result              1.5     [required by bap-std]
  - install seq                 base    [required by fileutils]
  - install sexplib             v0.14.0 [required by core_kernel]
  - install sexplib0            v0.14.0 [required by bitvec-sexp]
  - install splittable_random   v0.14.0 [required by core_kernel]
  - install stdio               v0.14.0 [required by bap-main]
  - install stdlib-shims        0.3.0   [required by bap-recipe, ocamlgraph]
  - install stringext           1.6.0   [required by uri]
  - install time_now            v0.14.0 [required by core_kernel]
  - install topkg               1.0.7   [required by uuidm, logs]
  - install trie                1.0.0   [required by mew]
  - install typerep             v0.14.0 [required by core_kernel]
  - install uchar               0.0.2   [required by zed]
  - install uri                 4.4.0   [required by bap-std]
  - install utop                2.14.0  [required by bap-std]
  - install uucp                15.1.0  [required by zed]
  - install uuidm               0.9.8   [required by bap-std]
  - install uuseg               15.1.0  [required by zed]
  - install uutf                1.0.3   [required by zed]
  - install variantslib         v0.14.0 [required by core_kernel]
  - install xdg                 3.15.3  [required by utop]
  - install zarith              1.13    [required by bap-std]
  - install zed                 3.2.3   [required by utop]

The following system packages will first need to be installed:
    gmp

<><> Handling external dependencies <><><><><><><><><><><><><><><><><><><><><><>

opam believes some required external dependencies are missing. opam can:
> 1. Run pkg to install them (may need root/sudo access)
  2. Display the recommended pkg command and wait while you run it manually (e.g. in another terminal)
  3. Continue anyway, and, upon success, permanently register that this external dependency is present, but not detectable
  4. Abort the installation

[1/2/3/4] 1

+ /usr/local/bin/sudo "pkg" "install" "-y" "gmp"
- Updating FreeBSD repository catalogue...
- [spring] Fetching data.pkg: ...
- ....
- ... done
- Processing entries: 
- ..
- .
- .
- ..
- ..
- .
- . done
- FreeBSD repository update completed. 34088 packages processed.
- All repositories are up to date.
- New version of pkg detected; it needs to be installed first.
- The following 1 package(s) will be affected (of 0 checked):
- 
- Installed packages to be UPGRADED:
- 	pkg: 1.21.2 -> 1.21.3
- 
- Number of packages to be upgraded: 1
- 
- 12 MiB to be downloaded.
- [spring] [1/1] Fetching pkg-1.21.3.pkg: 
- ....
- ...... done
- Checking integrity... done (0 conflicting)
- [spring] [1/1] Upgrading pkg from 1.21.2 to 1.21.3...
- [spring] [1/1] Extracting pkg-1.21.3: .......... done
- Updating FreeBSD repository catalogue...
- FreeBSD repository is up to date.
- All repositories are up to date.
- The following 1 package(s) will be affected (of 0 checked):
- 
- New packages to be INSTALLED:
- 	gmp: 6.3.0
- 
- Number of packages to be installed: 1
- 
- The process will require 3 MiB more space.
- 498 KiB to be downloaded.
- [spring] [1/1] Fetching gmp-6.3.0.pkg: .......... done
- Checking integrity... done (0 conflicting)
- [spring] [1/1] Installing gmp-6.3.0...
- [spring] [1/1] Extracting gmp-6.3.0: .......... done

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Processing  1/346:
Processing  2/346: [bap-analyze.2.5.0, bap-build.2.5.0, bap-bundle.2.5.0, bap-core-theory.2.5.0, bap-future.2.5.0, bap-knowledge.2.5.0, bap-main.2.5.0, bap-plugins.2.5.0, bap-recipe.2.5.0, bap-relation.2.5.0, bap-std.2.5.0, bitvec.2.5.0, bitvec-binprot.2.5.0, bitvec-order.2.5.0, bitvec-sexp.2.5.0, graphlib.2.5.0, monads.2.5.0, ogre.2.5.0, regular.2.5.0: http]
Processing  3/346: [bap-analyze.2.5.0, bap-build.2.5.0, bap-bundle.2.5.0, bap-core-theory.2.5.0, bap-future.2.5.0, bap-knowledge.2.5.0, bap-main.2.5.0, bap-plugins.2.5.0, bap-recipe.2.5.0, bap-relation.2.5.0, bap-std.2.5.0, bitvec.2.5.0, bitvec-binprot.2.5.0, bitvec-order.2.5.0, bitvec-sexp.2.5.0, graphlib.2.5.0, monads.2.5.0, ogre.2.5.0, regular.2.5.0: http]
-> retrieved angstrom.0.16.0  (cached)
Processing  4/346: [bap-analyze.2.5.0, bap-build.2.5.0, bap-bundle.2.5.0, bap-core-theory.2.5.0, bap-future.2.5.0, bap-knowledge.2.5.0, bap-main.2.5.0, bap-plugins.2.5.0, bap-recipe.2.5.0, bap-relation.2.5.0, bap-std.2.5.0, bitvec.2.5.0, bitvec-binprot.2.5.0, bitvec-order.2.5.0, bitvec-sexp.2.5.0, graphlib.2.5.0, monads.2.5.0, ogre.2.5.0, regular.2.5.0: http]
Processing  5/346: [bap-analyze.2.5.0, bap-build.2.5.0, bap-bundle.2.5.0, bap-core-theory.2.5.0, bap-future.2.5.0, bap-knowledge.2.5.0, bap-main.2.5.0, bap-plugins.2.5.0, bap-recipe.2.5.0, bap-relation.2.5.0, bap-std.2.5.0, bitvec.2.5.0, bitvec-binprot.2.5.0, bitvec-order.2.5.0, bitvec-sexp.2.5.0, graphlib.2.5.0, monads.2.5.0, ogre.2.5.0, regular.2.5.0: http] [base_bigstring.v0.14.0: http]
-> retrieved base.v0.14.3  (cached)
Processing  6/346: [bap-analyze.2.5.0, bap-build.2.5.0, bap-bundle.2.5.0, bap-core-theory.2.5.0, bap-future.2.5.0, bap-knowledge.2.5.0, bap-main.2.5.0, bap-plugins.2.5.0, bap-recipe.2.5.0, bap-relation.2.5.0, bap-std.2.5.0, bitvec.2.5.0, bitvec-binprot.2.5.0, bitvec-order.2.5.0, bitvec-sexp.2.5.0, graphlib.2.5.0, monads.2.5.0, ogre.2.5.0, regular.2.5.0: http] [base_bigstring.v0.14.0: http] [base_quickcheck.v0.14.1: http]
Processing  6/346: [bap-analyze.2.5.0, bap-build.2.5.0, bap-bundle.2.5.0, bap-core-theory.2.5.0, bap-future.2.5.0, bap-knowledge.2.5.0, bap-main.2.5.0, bap-plugins.2.5.0, bap-recipe.2.5.0, bap-relation.2.5.0, bap-std.2.5.0, bitvec.2.5.0, bitvec-binprot.2.5.0, bitvec-order.2.5.0, bitvec-sexp.2.5.0, graphlib.2.5.0, monads.2.5.0, ogre.2.5.0, regular.2.5.0: http] [base_quickcheck.v0.14.1: http]
-> retrieved base_bigstring.v0.14.0  (https://ocaml.janestreet.com/ocaml-core/v0.14/files/base_bigstring-v0.14.0.tar.gz)
Processing  7/346: [bap-analyze.2.5.0, bap-build.2.5.0, bap-bundle.2.5.0, bap-core-theory.2.5.0, bap-future.2.5.0, bap-knowledge.2.5.0, bap-main.2.5.0, bap-plugins.2.5.0, bap-recipe.2.5.0, bap-relation.2.5.0, bap-std.2.5.0, bitvec.2.5.0, bitvec-binprot.2.5.0, bitvec-order.2.5.0, bitvec-sexp.2.5.0, graphlib.2.5.0, monads.2.5.0, ogre.2.5.0, regular.2.5.0: http] [base_quickcheck.v0.14.1: http]
-> retrieved bigarray-compat.1.1.0  (cached)
Processing  8/346: [bap-analyze.2.5.0, bap-build.2.5.0, bap-bundle.2.5.0, bap-core-theory.2.5.0, bap-future.2.5.0, bap-knowledge.2.5.0, bap-main.2.5.0, bap-plugins.2.5.0, bap-recipe.2.5.0, bap-relation.2.5.0, bap-std.2.5.0, bitvec.2.5.0, bitvec-binprot.2.5.0, bitvec-order.2.5.0, bitvec-sexp.2.5.0, graphlib.2.5.0, monads.2.5.0, ogre.2.5.0, regular.2.5.0: http] [base_quickcheck.v0.14.1: http]
-> retrieved bigstringaf.0.9.1  (cached)
Processing  9/346: [bap-analyze.2.5.0, bap-build.2.5.0, bap-bundle.2.5.0, bap-core-theory.2.5.0, bap-future.2.5.0, bap-knowledge.2.5.0, bap-main.2.5.0, bap-plugins.2.5.0, bap-recipe.2.5.0, bap-relation.2.5.0, bap-std.2.5.0, bitvec.2.5.0, bitvec-binprot.2.5.0, bitvec-order.2.5.0, bitvec-sexp.2.5.0, graphlib.2.5.0, monads.2.5.0, ogre.2.5.0, regular.2.5.0: http] [base_quickcheck.v0.14.1: http] [bin_prot.v0.14.1: http]
Processing  9/346: [bap-analyze.2.5.0, bap-build.2.5.0, bap-bundle.2.5.0, bap-core-theory.2.5.0, bap-future.2.5.0, bap-knowledge.2.5.0, bap-main.2.5.0, bap-plugins.2.5.0, bap-recipe.2.5.0, bap-relation.2.5.0, bap-std.2.5.0, bitvec.2.5.0, bitvec-binprot.2.5.0, bitvec-order.2.5.0, bitvec-sexp.2.5.0, graphlib.2.5.0, monads.2.5.0, ogre.2.5.0, regular.2.5.0: http] [bin_prot.v0.14.1: http]
-> retrieved base_quickcheck.v0.14.1  (https://github.com/janestreet/base_quickcheck/archive/v0.14.1.tar.gz)
Processing 10/346: [bap-analyze.2.5.0, bap-build.2.5.0, bap-bundle.2.5.0, bap-core-theory.2.5.0, bap-future.2.5.0, bap-knowledge.2.5.0, bap-main.2.5.0, bap-plugins.2.5.0, bap-recipe.2.5.0, bap-relation.2.5.0, bap-std.2.5.0, bitvec.2.5.0, bitvec-binprot.2.5.0, bitvec-order.2.5.0, bitvec-sexp.2.5.0, graphlib.2.5.0, monads.2.5.0, ogre.2.5.0, regular.2.5.0: http] [bin_prot.v0.14.1: http]
-> retrieved camlzip.1.11  (cached)
Processing 11/346: [bap-analyze.2.5.0, bap-build.2.5.0, bap-bundle.2.5.0, bap-core-theory.2.5.0, bap-future.2.5.0, bap-knowledge.2.5.0, bap-main.2.5.0, bap-plugins.2.5.0, bap-recipe.2.5.0, bap-relation.2.5.0, bap-std.2.5.0, bitvec.2.5.0, bitvec-binprot.2.5.0, bitvec-order.2.5.0, bitvec-sexp.2.5.0, graphlib.2.5.0, monads.2.5.0, ogre.2.5.0, regular.2.5.0: http] [bin_prot.v0.14.1: http]
-> retrieved cmdliner.1.3.0  (cached)
Processing 12/346: [bap-analyze.2.5.0, bap-build.2.5.0, bap-bundle.2.5.0, bap-core-theory.2.5.0, bap-future.2.5.0, bap-knowledge.2.5.0, bap-main.2.5.0, bap-plugins.2.5.0, bap-recipe.2.5.0, bap-relation.2.5.0, bap-std.2.5.0, bitvec.2.5.0, bitvec-binprot.2.5.0, bitvec-order.2.5.0, bitvec-sexp.2.5.0, graphlib.2.5.0, monads.2.5.0, ogre.2.5.0, regular.2.5.0: http] [bin_prot.v0.14.1: http] [conf-binutils.0.3/find-binutils.ml.in: dl]
Processing 13/346: [bap-analyze.2.5.0, bap-build.2.5.0, bap-bundle.2.5.0, bap-core-theory.2.5.0, bap-future.2.5.0, bap-knowledge.2.5.0, bap-main.2.5.0, bap-plugins.2.5.0, bap-recipe.2.5.0, bap-relation.2.5.0, bap-std.2.5.0, bitvec.2.5.0, bitvec-binprot.2.5.0, bitvec-order.2.5.0, bitvec-sexp.2.5.0, graphlib.2.5.0, monads.2.5.0, ogre.2.5.0, regular.2.5.0: http] [bin_prot.v0.14.1: http] [conf-binutils.0.3/find-binutils.ml.in: dl] [cmdliner: gmake all]
Processing 13/346: [bin_prot.v0.14.1: http] [conf-binutils.0.3/find-binutils.ml.in: dl] [cmdliner: gmake all]
-> retrieved conf-binutils.0.3  (https://raw.githubusercontent.com/ocaml/opam-source-archives/main/patches/conf-binutils/find-binutils.ml.in.0.3)
Processing 13/346: [bin_prot.v0.14.1: http] [cmdliner: gmake all]
Processing 14/346: [bin_prot.v0.14.1: http] [cmdliner: gmake all]
-> retrieved conf-gmp.4  (cached)
Processing 15/346: [bin_prot.v0.14.1: http] [cmdliner: gmake all]
Processing 16/346: [bin_prot.v0.14.1: http] [cmdliner: gmake all]
Processing 17/346: [bin_prot.v0.14.1: http] [cmdliner: gmake all]
Processing 18/346: [bin_prot.v0.14.1: http] [cmdliner: gmake all]
Processing 19/346: [bin_prot.v0.14.1: http] [cmdliner: gmake all]
Processing 20/346: [bin_prot.v0.14.1: http] [cmdliner: gmake all]
Processing 21/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all]
[conf-binutils: subst] expanding opam variables in find-binutils.ml.in, generating find-binutils.ml
Processing 22/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma]
Processing 23/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma] [conf-clang: clang]
Processing 24/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma] [conf-clang: clang] [conf-gmp: sh]
Processing 25/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma] [conf-clang: clang] [conf-gmp: sh] [conf-m4: sh echo | m4]
Processing 26/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma] [conf-clang: clang] [conf-gmp: sh] [conf-m4: sh echo | m4] [conf-perl: perl]
Processing 27/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma] [conf-clang: clang] [conf-gmp: sh] [conf-m4: sh echo | m4] [conf-perl: perl] [conf-pkg-config: pkg-config]
+ /usr/local/bin/perl "--version" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/conf-perl.2)
- 
- This is perl 5, version 36, subversion 3 (v5.36.3) built for amd64-freebsd-thread-multi
- 
- Copyright 1987-2023, Larry Wall
- 
- Perl may be copied only under the terms of either the Artistic License or the
- GNU General Public License, which may be found in the Perl 5 source kit.
- 
- Complete documentation for Perl, including FAQ lists, should be found on
- this system using "man perl" or "perldoc perl".  If you have access to the
- Internet, point your browser at https://www.perl.org/, the Perl Home Page.
- 
-> compiled  conf-perl.2
Processing 27/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma] [conf-clang: clang] [conf-gmp: sh] [conf-m4: sh echo | m4] [conf-pkg-config: pkg-config]
Processing 28/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma] [conf-clang: clang] [conf-gmp: sh] [conf-m4: sh echo | m4] [conf-pkg-config: pkg-config] [conf-which: which which]
-> installed conf-perl.2
Processing 29/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma] [conf-clang: clang] [conf-gmp: sh] [conf-m4: sh echo | m4] [conf-pkg-config: pkg-config] [conf-which: which which]
+ /usr/bin/which "which" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/conf-which.1)
- /usr/bin/which
-> compiled  conf-which.1
Processing 29/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma] [conf-clang: clang] [conf-gmp: sh] [conf-m4: sh echo | m4] [conf-pkg-config: pkg-config]
-> installed conf-which.1
Processing 30/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma] [conf-clang: clang] [conf-gmp: sh] [conf-m4: sh echo | m4] [conf-pkg-config: pkg-config]
+ /usr/local/bin/pkg-config "--help" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/conf-pkg-config.3)
- usage: pkgconf [OPTIONS] [LIBRARIES]
- 
- basic options:
- 
-   --help                            this message
-   --about                           print pkgconf version and license to stdout
-   --version                         print supported pkg-config version to stdout
-   --verbose                         print additional information
-   --atleast-pkgconfig-version       check whether or not pkgconf is compatible
-                                     with a specified pkg-config version
-   --errors-to-stdout                print all errors on stdout instead of stderr
-   --print-errors                    ensure all errors are printed
-   --short-errors                    be less verbose about some errors
-   --silence-errors                  explicitly be silent about errors
-   --list-all                        list all known packages
-   --list-package-names              list all known package names
-   --simulate                        simulate walking the calculated dependency graph
-   --no-cache                        do not cache already seen packages when
-                                     walking the dependency graph
-   --log-file=filename               write an audit log to a specified file
-   --with-path=path                  adds a directory to the search path
-   --define-prefix                   override the prefix variable with one that is guessed based on
-                                     the location of the .pc file
-   --dont-define-prefix              do not override the prefix variable under any circumstances
-   --prefix-variable=varname         sets the name of the variable that pkgconf considers
-                                     to be the package prefix
-   --relocate=path                   relocates a path and exits (mostly for testsuite)
-   --dont-relocate-paths             disables path relocation support
- 
- cross-compilation personality support:
- 
-   --personality=triplet|filename    sets the personality to 'triplet' or a file named 'filename'
-   --dump-personality                dumps details concerning selected personality
- 
- checking specific pkg-config database entries:
- 
-   --atleast-version                 require a specific version of a module
-   --exact-version                   require an exact version of a module
-   --max-version                     require a maximum version of a module
-   --exists                          check whether or not a module exists
-   --uninstalled                     check whether or not an uninstalled module will be used
-   --no-uninstalled                  never use uninstalled modules when satisfying dependencies
-   --no-provides                     do not use 'provides' rules to resolve dependencies
-   --maximum-traverse-depth          maximum allowed depth for dependency graph
-   --static                          be more aggressive when computing dependency graph
-                                     (for static linking)
-   --shared                          use a simplified dependency graph (usually default)
-   --pure                            optimize a static dependency graph as if it were a normal
-                                     dependency graph
-   --env-only                        look only for package entries in PKG_CONFIG_PATH
-   --ignore-conflicts                ignore 'conflicts' rules in modules
-   --validate                        validate specific .pc files for correctness
- 
- querying specific pkg-config database fields:
- 
-   --define-variable=varname=value   define variable 'varname' as 'value'
-   --variable=varname                print specified variable entry to stdout
-   --cflags                          print required CFLAGS to stdout
-   --cflags-only-I                   print required include-dir CFLAGS to stdout
-   --cflags-only-other               print required non-include-dir CFLAGS to stdout
-   --libs                            print required linker flags to stdout
-   --libs-only-L                     print required LDPATH linker flags to stdout
-   --libs-only-l                     print required LIBNAME linker flags to stdout
-   --libs-only-other                 print required other linker flags to stdout
-   --print-requires                  print required dependency frameworks to stdout
-   --print-requires-private          print required dependency frameworks for static
-                                     linking to stdout
-   --print-provides                  print provided dependencies to stdout
-   --print-variables                 print all known variables in module to stdout
-   --digraph                         print entire dependency graph in graphviz 'dot' format
-   --solution                        print dependency graph solution in a simple format
-   --keep-system-cflags              keep -I/usr/include entries in cflags output
-   --keep-system-libs                keep -L/usr/lib entries in libs output
-   --path                            show the exact filenames for any matching .pc files
-   --modversion                      print the specified module's version to stdout
-   --internal-cflags                 do not filter 'internal' cflags from output
-   --license                         print the specified module's license to stdout if known
- 
- filtering output:
- 
-   --msvc-syntax                     print translatable fragments in MSVC syntax
-   --fragment-filter=types           filter output fragments to the specified types
- 
- report bugs to <https://github.com/pkgconf/pkgconf/issues/new>.
-> compiled  conf-pkg-config.3
Processing 30/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma] [conf-clang: clang] [conf-gmp: sh] [conf-m4: sh echo | m4]
-> installed conf-pkg-config.3
Processing 31/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma] [conf-clang: clang] [conf-gmp: sh] [conf-m4: sh echo | m4]
Processing 32/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma] [conf-clang: clang] [conf-gmp: sh] [conf-m4: sh echo | m4] [conf-zlib: pkg-config zlib]
+ /bin/sh "-exc" "echo | m4" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/conf-m4.1)
- + echo
- + m4
- 
-> compiled  conf-m4.1
Processing 32/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma] [conf-clang: clang] [conf-gmp: sh] [conf-zlib: pkg-config zlib]
-> installed conf-m4.1
Processing 33/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma] [conf-clang: clang] [conf-gmp: sh] [conf-zlib: pkg-config zlib]
+ /usr/local/bin/pkg-config "zlib" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/conf-zlib.1)
-> compiled  conf-zlib.1
Processing 33/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma] [conf-clang: clang] [conf-gmp: sh]
-> installed conf-zlib.1
Processing 34/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma] [conf-clang: clang] [conf-gmp: sh]
+ /bin/sh "-exc" "cc -c $CFLAGS -I/usr/local/include test.c" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/conf-gmp.4)
- + cc -c -I/usr/local/include test.c
-> compiled  conf-gmp.4
Processing 34/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma] [conf-clang: clang]
-> installed conf-gmp.4
Processing 35/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma] [conf-clang: clang]
+ /usr/bin/clang "--version" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/conf-clang.1)
- FreeBSD clang version 16.0.6 (https://github.com/llvm/llvm-project.git llvmorg-16.0.6-0-g7cbf1a259152)
- Target: x86_64-unknown-freebsd14.0
- Thread model: posix
- InstalledDir: /usr/bin
-> compiled  conf-clang.1
Processing 35/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma]
-> installed conf-clang.1
Processing 36/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all] [conf-binutils: ocaml unix.cma]
+ /home/opam/.opam/4.14.1/bin/ocaml "unix.cma" "find-binutils.ml" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/conf-binutils.0.3)
- File "./find-binutils.ml", line 35, characters 11-21:
- 35 |       r := String.sub s (i + 1) (!j - i - 1) :: !r;
-                 ^^^^^^^^^^
- Warning 6 [labels-omitted]: labels pos, len were omitted in the application of this function.
- File "./find-binutils.ml", line 39, characters 2-12:
- 39 |   String.sub s 0 !j :: !r
-        ^^^^^^^^^^
- Warning 6 [labels-omitted]: labels pos, len were omitted in the application of this function.
- File "./find-binutils.ml", line 42, characters 2-10:
- 42 |   List.map String.trim (split_on_char on str) |>
-        ^^^^^^^^
- Warning 6 [labels-omitted]: label f was omitted in the application of this function.
- File "./find-binutils.ml", line 109, characters 13-26:
- 109 |   let deps = String.concat "\n" deps in
-                    ^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label sep was omitted in the application of this function.
- File "./find-binutils.ml", line 110, characters 13-26:
- 110 |   let vars = String.concat "\n" vars in
-                    ^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label sep was omitted in the application of this function.
- File "./find-binutils.ml", line 176, characters 2-12:
- 176 |   String.sub str 0 len = pref
-         ^^^^^^^^^^
- Warning 6 [labels-omitted]: labels pos, len were omitted in the application of this function.
-> compiled  conf-binutils.0.3
Processing 36/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all]
-> installed conf-binutils.0.3
Processing 37/346: [bin_prot.v0.14.1: http] [core_kernel.v0.14.2: http] [cmdliner: gmake all]
Processing 37/346: [bin_prot.v0.14.1: http] [cmdliner: gmake all]
-> retrieved bap-analyze.2.5.0, bap-build.2.5.0, bap-bundle.2.5.0, bap-core-theory.2.5.0, bap-future.2.5.0, bap-knowledge.2.5.0, bap-main.2.5.0, bap-plugins.2.5.0, bap-recipe.2.5.0, bap-relation.2.5.0, bap-std.2.5.0, bitvec.2.5.0, bitvec-binprot.2.5.0, bitvec-order.2.5.0, bitvec-sexp.2.5.0, graphlib.2.5.0, monads.2.5.0, ogre.2.5.0, regular.2.5.0  (https://github.com/BinaryAnalysisPlatform/bap/archive/v2.5.0.tar.gz)
Processing 38/346: [bin_prot.v0.14.1: http] [cmdliner: gmake all]
-> retrieved core_kernel.v0.14.2  (https://github.com/janestreet/core_kernel/archive/v0.14.2.tar.gz)
Processing 39/346: [bin_prot.v0.14.1: http] [cmdliner: gmake all]
-> retrieved cppo.1.6.9  (cached)
Processing 40/346: [bin_prot.v0.14.1: http] [cmdliner: gmake all]
+ /usr/local/bin/gmake "all" "PREFIX=/home/opam/.opam/4.14.1" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/cmdliner.1.3.0)
- ocaml build.ml cma
- ocaml build.ml cmxa
- ocaml build.ml cmxs
-> compiled  cmdliner.1.3.0
Processing 40/346: [bin_prot.v0.14.1: http]
Processing 41/346: [bin_prot.v0.14.1: http] [cmdliner: gmake install]
-> retrieved dune.3.15.3, dune-configurator.3.15.3, xdg.3.15.3  (cached)
Processing 42/346: [bin_prot.v0.14.1: http] [fieldslib.v0.14.0: http] [cmdliner: gmake install]
Processing 43/346: [bin_prot.v0.14.1: http] [fieldslib.v0.14.0: http] [dune: ocaml 7] [cmdliner: gmake install]
Processing 43/346: [bin_prot.v0.14.1: http] [dune: ocaml 7] [cmdliner: gmake install]
+ /usr/local/bin/gmake "install" "LIBDIR=/home/opam/.opam/4.14.1/lib/cmdliner" "DOCDIR=/home/opam/.opam/4.14.1/doc/cmdliner" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/cmdliner.1.3.0)
- install -d "/home/opam/.opam/4.14.1/lib/cmdliner"
- install pkg/META _build/cmdliner.mli _build/cmdliner.cmi _build/cmdliner.cmti "/home/opam/.opam/4.14.1/lib/cmdliner"
- install cmdliner.opam "/home/opam/.opam/4.14.1/lib/cmdliner/opam"
- install _build/cmdliner.cma "/home/opam/.opam/4.14.1/lib/cmdliner"
- install _build/cmdliner.cmxa _build/cmdliner.a _build/cmdliner.cmx _build/cmdliner_arg.cmx _build/cmdliner_base.cmx _build/cmdliner_cline.cmx _build/cmdliner_cmd.cmx _build/cmdliner_docgen.cmx _build/cmdliner_eval.cmx _build/cmdliner_exit.cmx _build/cmdliner_info.cmx _build/cmdliner_manpage.cmx _build/cmdliner_msg.cmx _build/cmdliner_term.cmx _build/cmdliner_term_deprecated.cmx _build/cmdliner_trie.cmx \
-   "/home/opam/.opam/4.14.1/lib/cmdliner"
- install _build/cmdliner.cmxs "/home/opam/.opam/4.14.1/lib/cmdliner"
Processing 43/346: [bin_prot.v0.14.1: http] [dune: ocaml 7] [cmdliner: gmake install-doc]
-> retrieved fieldslib.v0.14.0  (https://ocaml.janestreet.com/ocaml-core/v0.14/files/fieldslib-v0.14.0.tar.gz)
Processing 44/346: [bin_prot.v0.14.1: http] [dune: ocaml 7] [cmdliner: gmake install-doc]
-> retrieved csexp.1.5.2  (cached)
Processing 45/346: [bin_prot.v0.14.1: http] [dune: ocaml 7] [cmdliner: gmake install-doc]
-> retrieved fileutils.0.6.4  (cached)
Processing 46/346: [bin_prot.v0.14.1: http] [dune: ocaml 7] [cmdliner: gmake install-doc]
-> retrieved jane-street-headers.v0.14.0  (cached)
Processing 47/346: [bin_prot.v0.14.1: http] [dune: ocaml 7] [cmdliner: gmake install-doc]
Processing 47/346: [dune: ocaml 7] [cmdliner: gmake install-doc]
-> retrieved lambda-term.3.3.2  (cached)
Processing 48/346: [dune: ocaml 7] [cmdliner: gmake install-doc]
-> retrieved bin_prot.v0.14.1  (https://github.com/janestreet/bin_prot/archive/refs/tags/v0.14.1.tar.gz)
Processing 49/346: [dune: ocaml 7] [cmdliner: gmake install-doc]
-> retrieved jst-config.v0.14.1  (cached)
Processing 50/346: [dune: ocaml 7] [cmdliner: gmake install-doc]
-> retrieved logs.0.7.0  (cached)
Processing 51/346: [dune: ocaml 7] [cmdliner: gmake install-doc]
-> retrieved lwt.5.7.0  (cached)
Processing 52/346: [dune: ocaml 7] [cmdliner: gmake install-doc]
-> retrieved linenoise.1.5.1  (cached)
Processing 53/346: [dune: ocaml 7] [cmdliner: gmake install-doc]
-> retrieved mew.0.1.0  (cached)
Processing 54/346: [dune: ocaml 7] [cmdliner: gmake install-doc]
-> retrieved mew_vi.0.5.0  (cached)
Processing 55/346: [dune: ocaml 7] [cmdliner: gmake install-doc]
-> retrieved mmap.1.2.0  (cached)
Processing 56/346: [oasis.0.4.11: http] [dune: ocaml 7] [cmdliner: gmake install-doc]
-> retrieved lwt_react.1.2.0  (cached)
Processing 57/346: [oasis.0.4.11: http] [dune: ocaml 7] [cmdliner: gmake install-doc]
-> retrieved num.1.5  (cached)
Processing 58/346: [oasis.0.4.11: http] [dune: ocaml 7] [cmdliner: gmake install-doc]
Processing 59/346: [oasis.0.4.11: http] [dune: ocaml 7] [num: gmake opam-legacy] [cmdliner: gmake install-doc]
-> retrieved ocaml-syntax-shims.1.0.0  (cached)
Processing 60/346: [oasis.0.4.11: http] [dune: ocaml 7] [num: gmake opam-legacy] [cmdliner: gmake install-doc]
-> retrieved ocaml-compiler-libs.v0.12.4  (cached)
Processing 61/346: [oasis.0.4.11: http] [dune: ocaml 7] [num: gmake opam-legacy] [cmdliner: gmake install-doc]
Processing 61/346: [dune: ocaml 7] [num: gmake opam-legacy] [cmdliner: gmake install-doc]
+ /usr/local/bin/gmake "install-doc" "LIBDIR=/home/opam/.opam/4.14.1/lib/cmdliner" "DOCDIR=/home/opam/.opam/4.14.1/doc/cmdliner" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/cmdliner.1.3.0)
- install -d "/home/opam/.opam/4.14.1/doc/cmdliner/odoc-pages"
- install CHANGES.md LICENSE.md README.md "/home/opam/.opam/4.14.1/doc/cmdliner"
- install doc/index.mld doc/cli.mld doc/examples.mld doc/tutorial.mld \
-            doc/tool_man.mld "/home/opam/.opam/4.14.1/doc/cmdliner/odoc-pages"
-> installed cmdliner.1.3.0
Processing 61/346: [dune: ocaml 7] [num: gmake opam-legacy]
-> retrieved ocamlfind.1.9.6  (cached)
Processing 62/346: [dune: ocaml 7] [num: gmake opam-legacy]
[ocamlfind: patch] applying 0001-Harden-test-for-OCaml-5.patch
Processing 63/346: [dune: ocaml 7] [num: gmake opam-legacy] [ocamlfind: patch]
Processing 63/346: [oasis.0.4.11/oasis.install: dl] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlfind: patch]
Processing 63/346: [oasis.0.4.11/oasis.install: dl] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlfind: ./configure]
-> retrieved ocamlgraph.2.1.0  (cached)
Processing 64/346: [oasis.0.4.11/oasis.install: dl] [ocamlify.0.0.1: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlfind: ./configure]
-> retrieved oasis.0.4.11  (https://download.ocamlcore.org/oasis/oasis/0.4.11/oasis-0.4.11.tar.gz)
Processing 64/346: [ocamlify.0.0.1: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlfind: ./configure]
Processing 65/346: [ocamlify.0.0.1: http] [ocamlmod.0.0.9: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlfind: ./configure]
-> retrieved ocamlbuild.0.14.3  (cached)
Processing 66/346: [ocamlify.0.0.1: http] [ocamlmod.0.0.9: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlfind: ./configure]
Processing 67/346: [ocamlify.0.0.1: http] [ocamlmod.0.0.9: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake configure.make] [ocamlfind: ./configure]
-> retrieved ocplib-endian.1.2  (cached)
Processing 68/346: [ocamlify.0.0.1: http] [ocamlmod.0.0.9: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake configure.make] [ocamlfind: ./configure]
Processing 68/346: [ocamlmod.0.0.9: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake configure.make] [ocamlfind: ./configure]
-> retrieved octavius.1.2.2  (cached)
Processing 69/346: [ocamlmod.0.0.9: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake configure.make] [ocamlfind: ./configure]
-> retrieved parsexp.v0.14.2  (cached)
Processing 70/346: [ocamlmod.0.0.9: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake configure.make] [ocamlfind: ./configure]
Processing 70/346: [ocamlify.0.0.1/ocamlify.install: dl] [ocamlmod.0.0.9: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake configure.make] [ocamlfind: ./configure]
-> retrieved ppx_assert.v0.14.0  (cached)
Processing 71/346: [ocamlify.0.0.1/ocamlify.install: dl] [ocamlmod.0.0.9: http] [ppx_bap.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake configure.make] [ocamlfind: ./configure]
+ /usr/local/bin/gmake "-f" "configure.make" "all" "OCAMLBUILD_PREFIX=/home/opam/.opam/4.14.1" "OCAMLBUILD_BINDIR=/home/opam/.opam/4.14.1/bin" "OCAMLBUILD_LIBDIR=/home/opam/.opam/4.14.1/lib" "OCAMLBUILD_MANDIR=/home/opam/.opam/4.14.1/man" "OCAML_NATIVE=true" "OCAML_NATIVE_TOOLS=true" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ocamlbuild.0.14.3)
- (echo "# This file was generated from configure.make"; \
- echo ;\
- echo "OCAML_PREFIX="; \
- echo "OCAML_BINDIR=/home/opam/.opam/4.14.1/bin"; \
- echo "OCAML_LIBDIR=/home/opam/.opam/4.14.1/lib/ocaml"; \
- echo "OCAML_MANDIR=/home/opam/.opam/4.14.1/man"; \
- echo ;\
- echo "EXT_OBJ=.o"; \
- echo "EXT_ASM=.s"; \
- echo "EXT_LIB=.a"; \
- echo "EXT_DLL=.so"; \
- echo "EXE="; \
- echo ;\
- echo "OCAML_NATIVE=true"; \
- echo "OCAML_NATIVE_TOOLS=true"; \
- echo "NATDYNLINK=true"; \
- echo "SUPPORT_SHARED_LIBRARIES=true"; \
- echo ;\
- echo "PREFIX=/home/opam/.opam/4.14.1"; \
- echo "BINDIR=/home/opam/.opam/4.14.1/bin"; \
- echo "LIBDIR=/home/opam/.opam/4.14.1/lib"; \
- echo "MANDIR=/home/opam/.opam/4.14.1/man"; \
- ) > Makefile.config
- (echo "(* This file was generated from ../configure.make *)"; \
- echo ;\
- echo 'let bindir = "/home/opam/.opam/4.14.1/bin"'; \
- echo 'let libdir = "/home/opam/.opam/4.14.1/lib"'; \
- echo 'let ocaml_libdir = "/home/opam/.opam/4.14.1/lib/ocaml"'; \
- echo 'let libdir_abs = "/home/opam/.opam/4.14.1/lib"'; \
- echo 'let ocaml_native = true'; \
- echo 'let ocaml_native_tools = true'; \
- echo 'let supports_shared_libraries = true';\
- echo 'let a = "a"'; \
- echo 'let o = "o"'; \
- echo 'let so = "so"'; \
- echo 'let ext_dll = ".so"'; \
- echo 'let exe = ""'; \
- echo 'let version = "0.14.3"'; \
- ) > src/ocamlbuild_config.ml
Processing 71/346: [ocamlify.0.0.1/ocamlify.install: dl] [ocamlmod.0.0.9: http] [ppx_bap.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ocamlify.0.0.1  (https://download.ocamlcore.org/ocamlify/ocamlify/0.0.1/ocamlify-0.0.1.tar.gz)
Processing 71/346: [ocamlmod.0.0.9: http] [ppx_bap.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
Processing 72/346: [ocamlmod.0.0.9: http] [ppx_bap.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
Processing 72/346: [ppx_bap.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_base.v0.14.0  (cached)
Processing 73/346: [ppx_bap.v0.14.0: http] [ppx_bench.v0.14.1: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
Processing 73/346: [ocamlmod.0.0.9/_oasis_remove_.ml: dl] [ppx_bap.v0.14.0: http] [ppx_bench.v0.14.1: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
Processing 73/346: [ocamlmod.0.0.9/_oasis_remove_.ml: dl] [ppx_bench.v0.14.1: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_bap.v0.14.0  (https://github.com/BinaryAnalysisPlatform/ppx_bap/archive/v0.14.tar.gz)
Processing 74/346: [ocamlmod.0.0.9/_oasis_remove_.ml: dl] [ppx_bench.v0.14.1: http] [ppx_bin_prot.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
Processing 74/346: [ocamlmod.0.0.9/ocamlmod.install: dl] [ppx_bench.v0.14.1: http] [ppx_bin_prot.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ocamlmod.0.0.9  (https://download.ocamlcore.org/ocamlmod/ocamlmod/0.0.9/ocamlmod-0.0.9.tar.gz)
Processing 74/346: [ppx_bench.v0.14.1: http] [ppx_bin_prot.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
Processing 75/346: [ppx_bench.v0.14.1: http] [ppx_bin_prot.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_cold.v0.14.0  (cached)
Processing 76/346: [ppx_bench.v0.14.1: http] [ppx_bin_prot.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_compare.v0.14.0  (cached)
Processing 77/346: [ppx_bench.v0.14.1: http] [ppx_bin_prot.v0.14.0: http] [ppx_custom_printf.v0.14.1: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
Processing 77/346: [ppx_bin_prot.v0.14.0: http] [ppx_custom_printf.v0.14.1: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
Processing 77/346: [ppx_custom_printf.v0.14.1: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_bin_prot.v0.14.0  (https://ocaml.janestreet.com/ocaml-core/v0.14/files/ppx_bin_prot-v0.14.0.tar.gz)
Processing 78/346: [ppx_custom_printf.v0.14.1: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_bench.v0.14.1  (https://github.com/janestreet/ppx_bench/archive/v0.14.1.tar.gz)
Processing 79/346: [ppx_custom_printf.v0.14.1: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_enumerate.v0.14.0  (cached)
Processing 80/346: [ppx_custom_printf.v0.14.1: http] [ppx_expect.v0.14.2: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_derivers.1.2.1  (cached)
Processing 81/346: [ppx_custom_printf.v0.14.1: http] [ppx_expect.v0.14.2: http] [ppx_fields_conv.v0.14.2: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
Processing 81/346: [ppx_expect.v0.14.2: http] [ppx_fields_conv.v0.14.2: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
Processing 81/346: [ppx_fields_conv.v0.14.2: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_custom_printf.v0.14.1  (https://github.com/janestreet/ppx_custom_printf/archive/v0.14.1.tar.gz)
Processing 82/346: [ppx_fields_conv.v0.14.2: http] [ppx_fixed_literal.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_expect.v0.14.2  (https://github.com/janestreet/ppx_expect/archive/v0.14.2.tar.gz)
Processing 83/346: [ppx_fields_conv.v0.14.2: http] [ppx_fixed_literal.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_hash.v0.14.0  (cached)
Processing 84/346: [ppx_fields_conv.v0.14.2: http] [ppx_fixed_literal.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
Processing 84/346: [ppx_fixed_literal.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_here.v0.14.0  (cached)
Processing 85/346: [ppx_fixed_literal.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
Processing 85/346: [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_inline_test.v0.14.1  (cached)
Processing 86/346: [ppx_jane.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_fixed_literal.v0.14.0  (https://ocaml.janestreet.com/ocaml-core/v0.14/files/ppx_fixed_literal-v0.14.0.tar.gz)
Processing 87/346: [ppx_jane.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_fields_conv.v0.14.2  (https://github.com/janestreet/ppx_fields_conv/archive/v0.14.2.tar.gz)
Processing 88/346: [ppx_jane.v0.14.0: http] [ppx_let.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_js_style.v0.14.1  (cached)
Processing 89/346: [ppx_jane.v0.14.0: http] [ppx_let.v0.14.0: http] [ppx_module_timer.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
Processing 89/346: [ppx_let.v0.14.0: http] [ppx_module_timer.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_jane.v0.14.0  (https://ocaml.janestreet.com/ocaml-core/v0.14/files/ppx_jane-v0.14.0.tar.gz)
Processing 90/346: [ppx_let.v0.14.0: http] [ppx_module_timer.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
Processing 90/346: [ppx_module_timer.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_optcomp.v0.14.3  (cached)
Processing 91/346: [ppx_module_timer.v0.14.0: http] [ppx_optional.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
Processing 91/346: [ppx_optional.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_let.v0.14.0  (https://ocaml.janestreet.com/ocaml-core/v0.14/files/ppx_let-v0.14.0.tar.gz)
Processing 92/346: [ppx_optional.v0.14.0: http] [ppx_pipebang.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_module_timer.v0.14.0  (https://ocaml.janestreet.com/ocaml-core/v0.14/files/ppx_module_timer-v0.14.0.tar.gz)
Processing 93/346: [ppx_optional.v0.14.0: http] [ppx_pipebang.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: ./configure]
+ /home/opam/.opam/4.14.1/.opam-switch/build/ocamlfind.1.9.6/./configure "-bindir" "/home/opam/.opam/4.14.1/bin" "-sitelib" "/home/opam/.opam/4.14.1/lib" "-mandir" "/home/opam/.opam/4.14.1/man" "-config" "/home/opam/.opam/4.14.1/lib/findlib.conf" "-no-custom" "-no-camlp4" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ocamlfind.1.9.6)
- Welcome to findlib version 1.9.6
- Configuring core...
- Checking for #remove_directory...
- Testing threading model...
- systhread_supported: true
- Testing DLLs...
- Testing whether ppxopt can be supported...
- Checking for ocamlc -opaque...
- Checking for ocamlopt -g...
- Querying installation: META list not found
- make install will double-check installed META files
- Configuring libraries...
- unix: found
- dynlink: found
- bigarray: found
- compiler-libs: found
- dbm: not present (normal since 4.00)
- graphics: not present (normal since 4.09)
- num: not present (normal since 4.06)
- ocamlbuild: not present (normal since 4.03)
- ocamldoc: found (in +ocamldoc)
- raw_spacetime: not present (normal since 4.12)
- threads: found (in +threads)
- str: found
- labltk: not present (normal since 4.02)
- native dynlink: found
- camlp4: disabled
- bytes: found, installing fake library
- Configuration for stdlib written to site-lib-src/stdlib/META
- Configuration for unix written to site-lib-src/unix/META
- Configuration for dynlink written to site-lib-src/dynlink/META
- Configuration for bigarray written to site-lib-src/bigarray/META
- Configuration for compiler-libs written to site-lib-src/compiler-libs/META
- Configuration for ocamldoc written to site-lib-src/ocamldoc/META
- Configuration for threads written to site-lib-src/threads/META
- Configuration for str written to site-lib-src/str/META
- Configuration for bytes written to site-lib-src/bytes/META
- Detecting compiler arguments: (extractor built) ok
- 
- About the OCAML core installation:
-     Standard library:      /home/opam/.opam/4.14.1/lib/ocaml
-     Binaries:              /home/opam/.opam/4.14.1/bin
-     Manual pages:          /home/opam/.opam/4.14.1/man
-     Multi-threading type:  posix
- The directory of site-specific packages will be
-     site-lib:              /home/opam/.opam/4.14.1/lib
- The configuration file is written to:
-     findlib config file:   /home/opam/.opam/4.14.1/lib/findlib.conf
- Software will be installed:
-     Libraries:             in <site-lib>/findlib
-     Binaries:              /home/opam/.opam/4.14.1/bin
-     Manual pages:          /home/opam/.opam/4.14.1/man
-     topfind script:        /home/opam/.opam/4.14.1/lib/ocaml
- Topfind ppxopt support:    yes
- Toolbox:                   no
- Link custom runtime:       no
- Need bytes compatibility:  no
- 
- Configuration has been written to Makefile.config
- 
- You can now do 'make all', and optionally 'make opt', to build ocamlfind.
Processing 93/346: [ppx_optional.v0.14.0: http] [ppx_pipebang.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved ppx_sexp_conv.v0.14.3  (cached)
Processing 94/346: [ppx_optional.v0.14.0: http] [ppx_pipebang.v0.14.0: http] [ppx_sexp_message.v0.14.1: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
Processing 94/346: [ppx_pipebang.v0.14.0: http] [ppx_sexp_message.v0.14.1: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved ppx_optional.v0.14.0  (https://ocaml.janestreet.com/ocaml-core/v0.14/files/ppx_optional-v0.14.0.tar.gz)
Processing 95/346: [ppx_pipebang.v0.14.0: http] [ppx_sexp_message.v0.14.1: http] [ppx_sexp_value.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
Processing 95/346: [ppx_sexp_message.v0.14.1: http] [ppx_sexp_value.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved ppx_pipebang.v0.14.0  (https://ocaml.janestreet.com/ocaml-core/v0.14/files/ppx_pipebang-v0.14.0.tar.gz)
Processing 96/346: [ppx_sexp_message.v0.14.1: http] [ppx_sexp_value.v0.14.0: http] [ppx_stable.v0.14.1: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
Processing 96/346: [ppx_sexp_message.v0.14.1: http] [ppx_stable.v0.14.1: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved ppx_sexp_value.v0.14.0  (https://ocaml.janestreet.com/ocaml-core/v0.14/files/ppx_sexp_value-v0.14.0.tar.gz)
Processing 97/346: [ppx_sexp_message.v0.14.1: http] [ppx_stable.v0.14.1: http] [ppx_string.v0.14.1: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
Processing 97/346: [ppx_stable.v0.14.1: http] [ppx_string.v0.14.1: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved ppx_sexp_message.v0.14.1  (https://github.com/janestreet/ppx_sexp_message/archive/v0.14.1.tar.gz)
Processing 98/346: [ppx_stable.v0.14.1: http] [ppx_string.v0.14.1: http] [ppx_typerep_conv.v0.14.2: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
Processing 98/346: [ppx_stable.v0.14.1: http] [ppx_typerep_conv.v0.14.2: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved ppx_string.v0.14.1  (https://github.com/janestreet/ppx_string/archive/v0.14.1.tar.gz)
Processing 99/346: [ppx_stable.v0.14.1: http] [ppx_typerep_conv.v0.14.2: http] [ppx_variants_conv.v0.14.2: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
Processing 99/346: [ppx_stable.v0.14.1: http] [ppx_variants_conv.v0.14.2: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
Processing 99/346: [ppx_variants_conv.v0.14.2: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved ppx_typerep_conv.v0.14.2  (https://github.com/janestreet/ppx_typerep_conv/archive/v0.14.2.tar.gz)
Processing 100/346: [ppx_variants_conv.v0.14.2: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved ppx_stable.v0.14.1  (https://github.com/janestreet/ppx_stable/archive/v0.14.1.tar.gz)
Processing 101/346: [ppx_variants_conv.v0.14.2: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved re.1.11.0  (cached)
Processing 102/346: [ppx_variants_conv.v0.14.2: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
Processing 102/346: [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved react.1.2.2  (cached)
Processing 103/346: [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved ppx_variants_conv.v0.14.2  (https://github.com/janestreet/ppx_variants_conv/archive/v0.14.2.tar.gz)
-> retrieved seq.base  (cached)
Processing 104/346: [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
Processing 105/346: [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
Processing 106/346: [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> installed seq.base
Processing 107/346: [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved result.1.5  (cached)
Processing 108/346: [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved sexplib.v0.14.0  (cached)
Processing 109/346: [splittable_random.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved sexplib0.v0.14.0  (cached)
Processing 110/346: [splittable_random.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved ppxlib.0.25.1  (cached)
Processing 111/346: [splittable_random.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved stdio.v0.14.0  (cached)
Processing 112/346: [splittable_random.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved stdlib-shims.0.3.0  (cached)
Processing 113/346: [splittable_random.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved time_now.v0.14.0  (cached)
Processing 114/346: [splittable_random.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved stringext.1.6.0  (cached)
Processing 115/346: [splittable_random.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
Processing 115/346: [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved trie.1.0.0  (cached)
Processing 116/346: [typerep.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved splittable_random.v0.14.0  (https://ocaml.janestreet.com/ocaml-core/v0.14/files/splittable_random-v0.14.0.tar.gz)
Processing 117/346: [typerep.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved topkg.1.0.7  (cached)
Processing 118/346: [typerep.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved uchar.0.0.2  (cached)
Processing 119/346: [typerep.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
Processing 119/346: [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved utop.2.14.0  (cached)
Processing 120/346: [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved uri.4.4.0  (cached)
Processing 121/346: [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved typerep.v0.14.0  (https://ocaml.janestreet.com/ocaml-core/v0.14/files/typerep-v0.14.0.tar.gz)
Processing 122/346: [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved uuidm.0.9.8  (cached)
Processing 123/346: [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved uutf.1.0.3  (cached)
Processing 124/346: [variantslib.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved uuseg.15.1.0  (cached)
Processing 125/346: [variantslib.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved zarith.1.13  (cached)
Processing 126/346: [variantslib.v0.14.0: http] [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
Processing 126/346: [dune: ocaml 7] [num: gmake opam-legacy] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved zed.3.2.3  (cached)
-> retrieved variantslib.v0.14.0  (https://ocaml.janestreet.com/ocaml-core/v0.14/files/variantslib-v0.14.0.tar.gz)
+ /usr/local/bin/gmake "PROFILE=release" "opam-legacy" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/num.1.5)
- /usr/local/bin/gmake -C src all
- gmake[1]: Entering directory '/home/opam/.opam/4.14.1/.opam-switch/build/num.1.5/src'
- ocamlc -ccopt -DBNG_ARCH_amd64 -c bng.c
- ocamlc -ccopt -DBNG_ARCH_amd64 -c nat_stubs.c
- ocamlmklib -oc nums bng.o nat_stubs.o
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c int_misc.mli
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c int_misc.ml
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c nat.mli
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c nat.ml
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c big_int.mli
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c big_int.ml
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c arith_flags.mli
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c arith_flags.ml
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c ratio.mli
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c ratio.ml
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c num.mli
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c num.ml
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c arith_status.mli
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c arith_status.ml
- ocamlmklib -o nums -oc nums -linkall int_misc.cmo nat.cmo big_int.cmo arith_flags.cmo ratio.cmo num.cmo arith_status.cmo
- cp ../toplevel/num_top_printers.mli ../toplevel/num_top.mli ../toplevel/num_top_printers.ml ../toplevel/num_top.ml .
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c num_top_printers.mli
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c num_top_printers.ml
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c num_top.mli
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c num_top.ml
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -a -o num_top.cma num_top_printers.cmo num_top.cmo
- echo 'version = "1.6~dev"' > META.top
- cat META.num-top.in >> META.top
- ocamlopt -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c int_misc.ml
- ocamlopt -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c nat.ml
- ocamlopt -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c big_int.ml
- ocamlopt -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c arith_flags.ml
- ocamlopt -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c ratio.ml
- ocamlopt -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c num.ml
- ocamlopt -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c arith_status.ml
- ocamlmklib -o nums -oc nums -linkall int_misc.cmx nat.cmx big_int.cmx arith_flags.cmx ratio.cmx num.cmx arith_status.cmx
- ocamlopt -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -I . -shared -o nums.cmxs nums.cmxa
- gmake[1]: Leaving directory '/home/opam/.opam/4.14.1/.opam-switch/build/num.1.5/src'
- cp src/num-legacy.install num.install
-> compiled  num.1.5
Processing 126/346: [dune: ocaml 7] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> installed num.1.5
Processing 127/346: [dune: ocaml 7] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake all]
-> retrieved uucp.15.1.0  (cached)
+ /usr/local/bin/gmake "all" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ocamlfind.1.9.6)
- for p in findlib; do ( cd src/$p; /usr/local/bin/gmake all ) || exit; done
- gmake[1]: Entering directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlfind.1.9.6/src/findlib'
- ocamllex fl_meta.mll
- 22 states, 392 transitions, table size 1700 bytes
- USE_CYGPATH="0"; \
- export USE_CYGPATH; \
- cat findlib_config.mlp | \
-          ../../tools/patch '@CONFIGFILE@' '/home/opam/.opam/4.14.1/lib/findlib.conf' | \
-          ../../tools/patch '@STDLIB@' '/home/opam/.opam/4.14.1/lib/ocaml' | \
- 	sed -e 's;@AUTOLINK@;true;g' \
- 	    -e 's;@SYSTEM@;freebsd;g' \
- 	     >findlib_config.ml
- if [ "true" = "true" ]; then                 \
- 	cp topfind.ml.in topfind.ml;                             \
- else                                                             \
- 	sed -e '/PPXOPT_BEGIN/,/PPXOPT_END/ d' topfind.ml.in     \
- 		> topfind.ml ;                                   \
- fi
- ocamldep *.ml *.mli >depend
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c findlib_config.ml
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c fl_split.ml
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c fl_metatoken.ml
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c fl_meta.ml
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -c fl_metascanner.mli
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c fl_metascanner.ml
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -c fl_topo.mli
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c fl_topo.ml
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -c fl_package_base.mli
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c fl_package_base.ml
- File "fl_package_base.ml", line 304, characters 22-40:
- 304 | 	 let pkg_ancestors = query_requirements predlist pkg in
-       	                     ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 350, characters 18-36:
- 350 |   let ancestors = query_requirements predlist package_name in
-                         ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 375, characters 23-41:
- 375 | 	  let pkg_ancestors = query_requirements predlist pkg in
-       	                      ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 510, characters 16-35:
- 510 | 	     ( let c = package_definitions search_path pkg.package_name in
-       	               ^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label search_path was omitted in the application of this function.
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -c findlib.mli
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c findlib.ml
- File "findlib.ml", line 390, characters 2-26:
- 390 |   Fl_package_base.requires predlist pkg
-         ^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "findlib.ml", line 396, characters 2-33:
- 396 |   Fl_package_base.requires_deeply predlist pkglist
-         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c fl_args.ml
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c fl_lint.ml
- ocamlc -I +compiler-libs -a -o findlib.cma findlib_config.cmo fl_split.cmo fl_metatoken.cmo fl_meta.cmo fl_metascanner.cmo fl_topo.cmo fl_package_base.cmo findlib.cmo fl_args.cmo fl_lint.cmo
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c ocaml_args.ml
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c frontend.ml
- File "frontend.ml", line 859, characters 10-39:
- 859 |           Fl_package_base.package_users predicates1 packages1
-                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- ocamlc -I +compiler-libs  -o ocamlfind -g findlib.cma unix.cma \
-            -I +unix -I +dynlink ocaml_args.cmo frontend.cmo
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -c topfind.mli
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c topfind.ml
- File "topfind.ml", line 128, characters 40-63:
- 128 |                      match Hashtbl.find Toploop.directive_table "ppx" with
-                                               ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 258, characters 4-27:
- 258 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 268, characters 4-27:
- 268 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 280, characters 4-27:
- 280 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 293, characters 4-27:
- 293 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 307, characters 4-27:
- 307 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 319, characters 4-27:
- 319 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- ocamlc -I +compiler-libs -a -o findlib_top.cma topfind.cmo
- USE_CYGPATH="0"; \
- export USE_CYGPATH; \
- cat topfind_rd1.p | \
-          ../../tools/patch '@SITELIB@' '/home/opam/.opam/4.14.1/lib' \
-     	    >topfind
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -c fl_dynload.mli
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c fl_dynload.ml
- ocamlc -I +compiler-libs -a -o findlib_dynload.cma fl_dynload.cmo
- gmake[1]: Leaving directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlfind.1.9.6/src/findlib'
- /usr/local/bin/gmake all-config
- gmake[1]: Entering directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlfind.1.9.6'
- USE_CYGPATH="0"; \
- export USE_CYGPATH; \
- cat findlib.conf.in | \
-      tools/patch '@SITELIB@' '/home/opam/.opam/4.14.1/lib' | \
- 		 tools/patch '@FINDLIB_PATH@' '/home/opam/.opam/4.14.1/lib' -p >findlib.conf
- if ./tools/cmd_from_same_dir ocamlc; then \
- 	echo 'ocamlc="ocamlc.opt"' >>findlib.conf; \
- fi
- if ./tools/cmd_from_same_dir ocamlopt; then \
- 	echo 'ocamlopt="ocamlopt.opt"' >>findlib.conf; \
- fi
- if ./tools/cmd_from_same_dir ocamldep; then \
- 	echo 'ocamldep="ocamldep.opt"' >>findlib.conf; \
- fi
- if ./tools/cmd_from_same_dir ocamldoc; then \
- 	echo 'ocamldoc="ocamldoc.opt"' >>findlib.conf; \
- fi
- gmake[1]: Leaving directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlfind.1.9.6'
Processing 127/346: [dune: ocaml 7] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake opt]
+ /usr/local/bin/gmake "opt" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ocamlfind.1.9.6)
- for p in findlib; do ( cd src/$p; /usr/local/bin/gmake opt ) || exit; done
- gmake[1]: Entering directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlfind.1.9.6/src/findlib'
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c findlib_config.ml
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c fl_split.ml
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c fl_metatoken.ml
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c fl_meta.ml
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c fl_metascanner.ml
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c fl_topo.ml
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c fl_package_base.ml
- File "fl_package_base.ml", line 304, characters 22-40:
- 304 | 	 let pkg_ancestors = query_requirements predlist pkg in
-       	                     ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 350, characters 18-36:
- 350 |   let ancestors = query_requirements predlist package_name in
-                         ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 375, characters 23-41:
- 375 | 	  let pkg_ancestors = query_requirements predlist pkg in
-       	                      ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 510, characters 16-35:
- 510 | 	     ( let c = package_definitions search_path pkg.package_name in
-       	               ^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label search_path was omitted in the application of this function.
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c findlib.ml
- File "findlib.ml", line 390, characters 2-26:
- 390 |   Fl_package_base.requires predlist pkg
-         ^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "findlib.ml", line 396, characters 2-33:
- 396 |   Fl_package_base.requires_deeply predlist pkglist
-         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c fl_args.ml
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c fl_lint.ml
- ocamlopt -I +compiler-libs -g -a -o findlib.cmxa findlib_config.cmx fl_split.cmx fl_metatoken.cmx fl_meta.cmx fl_metascanner.cmx fl_topo.cmx fl_package_base.cmx findlib.cmx fl_args.cmx fl_lint.cmx
- if [ 1 -gt 0 ]; then \
-     ocamlopt -I +compiler-libs -g -shared -o findlib.cmxs findlib_config.cmx fl_split.cmx fl_metatoken.cmx fl_meta.cmx fl_metascanner.cmx fl_topo.cmx fl_package_base.cmx findlib.cmx fl_args.cmx fl_lint.cmx; \
- fi
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c ocaml_args.ml
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c frontend.ml
- File "frontend.ml", line 859, characters 10-39:
- 859 |           Fl_package_base.package_users predicates1 packages1
-                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- ocamlopt -I +compiler-libs -g -o ocamlfind_opt findlib.cmxa unix.cmxa \
- 	   -I +unix -I +dynlink ocaml_args.cmx frontend.cmx
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c topfind.ml
- File "topfind.ml", line 128, characters 40-63:
- 128 |                      match Hashtbl.find Toploop.directive_table "ppx" with
-                                               ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 258, characters 4-27:
- 258 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 268, characters 4-27:
- 268 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 280, characters 4-27:
- 280 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 293, characters 4-27:
- 293 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 307, characters 4-27:
- 307 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 319, characters 4-27:
- 319 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- ocamlopt -I +compiler-libs -g -a -o findlib_top.cmxa topfind.cmx
- if [ 1 -gt 0 ]; then \
-     ocamlopt -I +compiler-libs -g -shared -o findlib_top.cmxs topfind.cmx; \
- fi
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c fl_dynload.ml
- ocamlopt -I +compiler-libs -g -a -o findlib_dynload.cmxa fl_dynload.cmx
- if [ 1 -gt 0 ]; then \
-     ocamlopt -I +compiler-libs -g -shared -o findlib_dynload.cmxs fl_dynload.cmx; \
- fi
- gmake[1]: Leaving directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlfind.1.9.6/src/findlib'
-> compiled  ocamlfind.1.9.6
Processing 127/346: [dune: ocaml 7] [ocamlbuild: gmake check-if-preinstalled]
Processing 128/346: [dune: ocaml 7] [ocamlbuild: gmake check-if-preinstalled] [ocamlfind: gmake install]
+ /usr/local/bin/gmake "install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ocamlfind.1.9.6)
- if [ "1" -eq 1 ]; then \
-     for x in camlp4 dbm graphics labltk num ocamlbuild; do \
-       if [ -f "/home/opam/.opam/4.14.1/lib/$x/META" ]; then \
-         if ! grep -Fq '[distributed with Ocaml]' "//home/opam/.opam/4.14.1/lib/$x/META"; then \
-           rm -f site-lib-src/$x/META; \
-         fi; \
-       fi; \
-     done; \
-     test -f "site-lib-src/num/META" || rm -f "site-lib-src/num-top/META"; \
-   fi
- echo 'SITELIB_META =' > Makefile.packages.in
- for x in `ls site-lib-src`; do test ! -f "site-lib-src/$x/META" || echo $x >> Makefile.packages.in; done
- tr '\n' ' ' < Makefile.packages.in > Makefile.packages
- rm Makefile.packages.in
- install -d "/home/opam/.opam/4.14.1/bin"
- install -d "/home/opam/.opam/4.14.1/man"
- /usr/local/bin/gmake install-config
- gmake[1]: Entering directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlfind.1.9.6'
- install -d "`dirname \"/home/opam/.opam/4.14.1/lib/findlib.conf\"`"
- test -f "/home/opam/.opam/4.14.1/lib/findlib.conf" || install -c findlib.conf "/home/opam/.opam/4.14.1/lib/findlib.conf"
- gmake[1]: Leaving directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlfind.1.9.6'
- for p in findlib; do ( cd src/$p; /usr/local/bin/gmake install ); done
- gmake[1]: Entering directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlfind.1.9.6/src/findlib'
- install -d "/home/opam/.opam/4.14.1/lib/findlib"
- install -d "/home/opam/.opam/4.14.1/bin"
- test 1 -eq 0 || install -d "/home/opam/.opam/4.14.1/lib/ocaml"
- test 1 -eq 0 || install -c topfind "/home/opam/.opam/4.14.1/lib/ocaml/"
- files=` ../../tools/collect_files ../../Makefile.config \
- findlib.cmi findlib.mli findlib.cma findlib.cmxa findlib.a findlib.cmxs \
- findlib_config.cmi findlib_config.ml topfind.cmi topfind.mli \
- fl_args.cmi fl_lint.cmi fl_meta.cmi fl_split.cmi fl_topo.cmi ocaml_args.cmi \
- fl_package_base.mli fl_package_base.cmi fl_metascanner.mli fl_metascanner.cmi \
- fl_metatoken.cmi findlib_top.cma findlib_top.cmxa findlib_top.a findlib_top.cmxs \
- findlib_dynload.cma findlib_dynload.cmxa findlib_dynload.a findlib_dynload.cmxs fl_dynload.mli fl_dynload.cmi \
- META` && \
- install -c $files "/home/opam/.opam/4.14.1/lib/findlib/"
- f="ocamlfind"; { test -f ocamlfind_opt && f="ocamlfind_opt"; }; \
- install -c $f "/home/opam/.opam/4.14.1/bin/ocamlfind"
- # the following "if" block is only needed for 4.00beta2
- if [ 1 -eq 0 -a -f "/home/opam/.opam/4.14.1/lib/ocaml/compiler-libs/topdirs.cmi" ]; then \
-     cd "/home/opam/.opam/4.14.1/lib/ocaml/compiler-libs/"; \
-     install -c topdirs.cmi toploop.cmi "/home/opam/.opam/4.14.1/lib/findlib/"; \
- fi
- gmake[1]: Leaving directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlfind.1.9.6/src/findlib'
- /usr/local/bin/gmake install-meta
- gmake[1]: Entering directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlfind.1.9.6'
- for x in bigarray bytes compiler-libs dynlink ocamldoc stdlib str threads unix ; do install -d "/home/opam/.opam/4.14.1/lib/$x"; install -c site-lib-src/$x/META "/home/opam/.opam/4.14.1/lib/$x/META.tmp" && mv "/home/opam/.opam/4.14.1/lib/$x/META.tmp" "/home/opam/.opam/4.14.1/lib/$x/META"; done
- install -d "/home/opam/.opam/4.14.1/lib/findlib"; install -c Makefile.packages "/home/opam/.opam/4.14.1/lib/findlib/Makefile.packages"
- gmake[1]: Leaving directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlfind.1.9.6'
- test ! -f 'site-lib-src/num-top/META' || { cd src/findlib; /usr/local/bin/gmake install-num-top; }
- test ! -f 'site-lib-src/camlp4/META' ||	install -c tools/safe_camlp4 "/home/opam/.opam/4.14.1/bin"
- /usr/local/bin/gmake install-doc
- gmake[1]: Entering directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlfind.1.9.6'
- install -d "/home/opam/.opam/4.14.1/man/man1" "/home/opam/.opam/4.14.1/man/man3" "/home/opam/.opam/4.14.1/man/man5"
- install -c doc/ref-man/ocamlfind.1 "/home/opam/.opam/4.14.1/man/man1"
- install -c doc/ref-man/META.5 doc/ref-man/site-lib.5 doc/ref-man/findlib.conf.5 "/home/opam/.opam/4.14.1/man/man5"
- gmake[1]: Leaving directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlfind.1.9.6'
-> installed ocamlfind.1.9.6
Processing 128/346: [dune: ocaml 7] [ocamlbuild: gmake check-if-preinstalled]
Processing 129/346: [dune: ocaml 7] [ocamlbuild: gmake check-if-preinstalled]
Processing 130/346: [camlzip: gmake all] [dune: ocaml 7] [ocamlbuild: gmake check-if-preinstalled]
Processing 131/346: [camlzip: gmake all] [dune: ocaml 7] [ocamlbuild: gmake check-if-preinstalled] [zarith: sh]
-> installed base-bytes.base
Processing 132/346: [camlzip: gmake all] [dune: ocaml 7] [ocamlbuild: gmake check-if-preinstalled] [zarith: sh]
+ /bin/sh "-exc" "LDFLAGS=\"$LDFLAGS -L/usr/local/lib\" CFLAGS=\"$CFLAGS -I/usr/local/include\" ./configure" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/zarith.1.13)
- + LDFLAGS=' -L/usr/local/lib' CFLAGS=' -I/usr/local/include' ./configure
- binary ocaml: found in /home/opam/.opam/4.14.1/bin
- binary ocamlc: found in /home/opam/.opam/4.14.1/bin
- binary ocamldep: found in /home/opam/.opam/4.14.1/bin
- binary ocamlmklib: found in /home/opam/.opam/4.14.1/bin
- binary ocamldoc: found in /home/opam/.opam/4.14.1/bin
- binary ocamlopt: found in /home/opam/.opam/4.14.1/bin
- checking compilation with ocamlc -O3 -Wall -Wextra  -I/usr/local/include: working
- include caml/mlvalues.h: found
- library dynlink.cmxa: found
- binary ocamlfind: found in /home/opam/.opam/4.14.1/bin
- OCaml's word size is 64
- package gmp: found
- OCaml supports -bin-annot to produce documentation
- 
- detected configuration:
- 
-   native-code:          yes
-   dynamic linking:      yes
-   defines:              -DHAS_GMP 
-   includes:             -I/home/opam/.opam/4.14.1/lib/ocaml  -I/usr/local/include
-   libraries:             -L/usr/local/lib -lgmp
-   linker options:        -L/usr/local/lib
-   C options:            -O3 -Wall -Wextra  -I/usr/local/include
-   installation path:    /home/opam/.opam/4.14.1/lib
-   installation method   findlib
- 
- configuration successful!
- now type "make" to build
- then type "make install" or "sudo make install" to install
Processing 132/346: [camlzip: gmake all] [dune: ocaml 7] [ocamlbuild: gmake check-if-preinstalled] [zarith: gmake]
+ /usr/local/bin/gmake "all" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/camlzip.1.11)
- ocamlfind ocamlc -g -safe-string -bin-annot -c -ccopt -g  zlibstubs.c
- ocamlfind ocamlmklib -oc camlzip zlibstubs.o  -lz
- ocamlfind ocamlc -g -safe-string -bin-annot -c zlib.mli
- ocamlfind ocamlc -g -safe-string -bin-annot -c zlib.ml
- ocamlfind ocamlc -g -safe-string -bin-annot -c zip.mli
- ocamlfind ocamlc -g -safe-string -bin-annot -c zip.ml
- ocamlfind ocamlc -g -safe-string -bin-annot -c gzip.mli
- ocamlfind ocamlc -g -safe-string -bin-annot -c gzip.ml
- ocamlfind ocamlmklib -o zip -oc camlzip zlib.cmo zip.cmo gzip.cmo  -lz
- ocamlfind ocamlopt -safe-string -c zlib.ml
- ocamlfind ocamlopt -safe-string -c zip.ml
- ocamlfind ocamlopt -safe-string -c gzip.ml
- ocamlfind ocamlmklib -o zip -oc camlzip zlib.cmx zip.cmx gzip.cmx  -lz
- ocamlfind ocamlopt -safe-string -shared -linkall -I ./ -o zip.cmxs zip.cmxa libcamlzip.a
-> compiled  camlzip.1.11
Processing 132/346: [dune: ocaml 7] [ocamlbuild: gmake check-if-preinstalled] [zarith: gmake]
Processing 133/346: [dune: ocaml 7] [ocamlbuild: gmake check-if-preinstalled] [zarith: gmake] [camlzip: gmake install]
+ /usr/local/bin/gmake "install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/camlzip.1.11)
- cp META-zip META && \
-         ocamlfind install zip META *.cma *.a *.mli *.cmi *.cmti *.cmt gzip.cmx zip.cmx zlib.cmx zip.cmxa zip.cmxs dllcamlzip.so && \
-         rm META
- Installed /home/opam/.opam/4.14.1/lib/zip/zip.cmxs
- Installed /home/opam/.opam/4.14.1/lib/zip/zip.cmxa
- Installed /home/opam/.opam/4.14.1/lib/zip/zlib.cmx
- Installed /home/opam/.opam/4.14.1/lib/zip/zip.cmx
- Installed /home/opam/.opam/4.14.1/lib/zip/gzip.cmx
- Installed /home/opam/.opam/4.14.1/lib/zip/zlib.cmt
- Installed /home/opam/.opam/4.14.1/lib/zip/zip.cmt
- Installed /home/opam/.opam/4.14.1/lib/zip/gzip.cmt
- Installed /home/opam/.opam/4.14.1/lib/zip/zlib.cmti
- Installed /home/opam/.opam/4.14.1/lib/zip/zip.cmti
- Installed /home/opam/.opam/4.14.1/lib/zip/gzip.cmti
- Installed /home/opam/.opam/4.14.1/lib/zip/zlib.cmi
- Installed /home/opam/.opam/4.14.1/lib/zip/zip.cmi
- Installed /home/opam/.opam/4.14.1/lib/zip/gzip.cmi
- Installed /home/opam/.opam/4.14.1/lib/zip/zlib.mli
- Installed /home/opam/.opam/4.14.1/lib/zip/zip.mli
- Installed /home/opam/.opam/4.14.1/lib/zip/gzip.mli
- Installed /home/opam/.opam/4.14.1/lib/zip/zip.a
- Installed /home/opam/.opam/4.14.1/lib/zip/libcamlzip.a
- Installed /home/opam/.opam/4.14.1/lib/zip/zip.cma
- Installed /home/opam/.opam/4.14.1/lib/stublibs/dllcamlzip.so
- Installed /home/opam/.opam/4.14.1/lib/stublibs/dllcamlzip.so.owner
- ocamlfind: [WARNING] You have installed DLLs but the directory /home/opam/.opam/4.14.1/lib/stublibs is not mentioned in ld.conf
- Installed /home/opam/.opam/4.14.1/lib/zip/META
- cp META-camlzip META && \
-         ocamlfind install camlzip META && \
-         rm META
- Installed /home/opam/.opam/4.14.1/lib/camlzip/META
-> installed camlzip.1.11
Processing 133/346: [dune: ocaml 7] [ocamlbuild: gmake check-if-preinstalled] [zarith: gmake]
+ /usr/local/bin/gmake "check-if-preinstalled" "all" "opam-install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ocamlbuild.0.14.3)
- if test -d /home/opam/.opam/4.14.1/lib/ocaml/ocamlbuild; then\
-   >&2 echo "ERROR: Preinstalled ocamlbuild detected at"\
-        "/home/opam/.opam/4.14.1/lib/ocaml/ocamlbuild";\
-   >&2 echo "Installation aborted; if you want to bypass this"\
-         "safety check, pass CHECK_IF_PREINSTALLED=false to make";\
-   exit 2;\
- fi
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/const.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/loc.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/loc.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/discard_printf.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/discard_printf.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/signatures.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/my_std.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/my_std.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/my_unix.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/my_unix.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/tags.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/tags.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/display.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/display.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/log.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/log.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/shell.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/shell.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/bool.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/bool.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_ast.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_ast.ml
- ocamllex.opt src/glob_lexer.mll
- 55 states, 419 transitions, table size 2006 bytes
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_lexer.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_lexer.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/glob.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/glob.ml
- ocamllex.opt src/lexers.mll
- 251 states, 1051 transitions, table size 5710 bytes
- 4334 additional bytes used for bindings
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/lexers.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/lexers.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/param_tags.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/param_tags.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/command.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/command.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_config.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_where.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_where.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/slurp.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/slurp.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/options.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/options.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/pathname.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/pathname.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/configuration.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/configuration.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/flags.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/flags.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/hygiene.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/hygiene.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/digest_cache.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/digest_cache.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/resource.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/resource.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/rule.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/rule.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/solver.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/solver.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/report.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/report.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/tools.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/tools.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/fda.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/fda.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/findlib.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/findlib.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_arch.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_arch.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_utils.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_utils.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_dependencies.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_dependencies.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_compiler.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_compiler.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_tools.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_tools.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_specific.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_specific.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/exit_codes.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/exit_codes.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/plugin.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/plugin.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/hooks.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/hooks.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/main.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/main.ml
- mkdir -p tmp
- ocamlc.opt -pack src/const.cmo src/loc.cmo src/discard_printf.cmo src/signatures.cmi src/my_std.cmo src/my_unix.cmo src/tags.cmo src/display.cmo src/log.cmo src/shell.cmo src/bool.cmo src/glob_ast.cmo src/glob_lexer.cmo src/glob.cmo src/lexers.cmo src/param_tags.cmo src/command.cmo src/ocamlbuild_config.cmo src/ocamlbuild_where.cmo src/slurp.cmo src/options.cmo src/pathname.cmo src/configuration.cmo src/flags.cmo src/hygiene.cmo src/digest_cache.cmo src/resource.cmo src/rule.cmo src/solver.cmo src/report.cmo src/tools.cmo src/fda.cmo src/findlib.cmo src/ocaml_arch.cmo src/ocaml_utils.cmo src/ocaml_dependencies.cmo src/ocaml_compiler.cmo src/ocaml_tools.cmo src/ocaml_specific.cmo src/exit_codes.cmo src/plugin.cmo src/hooks.cmo src/main.cmo -o tmp/ocamlbuild_pack.cmo
- mv tmp/ocamlbuild_pack.cmi src/ocamlbuild_pack.cmi
- mv tmp/ocamlbuild_pack.cmo src/ocamlbuild_pack.cmo
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c plugin-lib/ocamlbuild_plugin.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c plugin-lib/ocamlbuild_plugin.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c plugin-lib/ocamlbuild_executor.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c plugin-lib/ocamlbuild_executor.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c plugin-lib/ocamlbuild_unix_plugin.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c plugin-lib/ocamlbuild_unix_plugin.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c bin/ocamlbuild.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c bin/ocamlbuild.ml
- ocamlc.opt -I +unix -I src -o ocamlbuild.byte unix.cma src/ocamlbuild_pack.cmo plugin-lib/ocamlbuild_plugin.cmo plugin-lib/ocamlbuild_executor.cmo plugin-lib/ocamlbuild_unix_plugin.cmo bin/ocamlbuild.cmo
- ocamlc.opt -a -o plugin-lib/ocamlbuildlib.cma src/ocamlbuild_pack.cmo plugin-lib/ocamlbuild_plugin.cmo plugin-lib/ocamlbuild_executor.cmo plugin-lib/ocamlbuild_unix_plugin.cmo
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/const.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/loc.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/discard_printf.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/my_std.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/my_unix.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/tags.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/display.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/log.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/shell.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/bool.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_ast.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_lexer.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/glob.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/lexers.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/param_tags.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/command.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_config.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_where.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/slurp.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/options.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/pathname.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/configuration.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/flags.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/hygiene.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/digest_cache.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/resource.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/rule.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/solver.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/report.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/tools.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/fda.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/findlib.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_arch.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_utils.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_dependencies.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_compiler.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_tools.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_specific.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/exit_codes.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/plugin.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/hooks.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c src/main.ml
- mkdir -p tmp
- ocamlopt.opt -pack src/const.cmx src/loc.cmx src/discard_printf.cmx src/signatures.cmi src/my_std.cmx src/my_unix.cmx src/tags.cmx src/display.cmx src/log.cmx src/shell.cmx src/bool.cmx src/glob_ast.cmx src/glob_lexer.cmx src/glob.cmx src/lexers.cmx src/param_tags.cmx src/command.cmx src/ocamlbuild_config.cmx src/ocamlbuild_where.cmx src/slurp.cmx src/options.cmx src/pathname.cmx src/configuration.cmx src/flags.cmx src/hygiene.cmx src/digest_cache.cmx src/resource.cmx src/rule.cmx src/solver.cmx src/report.cmx src/tools.cmx src/fda.cmx src/findlib.cmx src/ocaml_arch.cmx src/ocaml_utils.cmx src/ocaml_dependencies.cmx src/ocaml_compiler.cmx src/ocaml_tools.cmx src/ocaml_specific.cmx src/exit_codes.cmx src/plugin.cmx src/hooks.cmx src/main.cmx -o tmp/ocamlbuild_pack.cmx
- mv tmp/ocamlbuild_pack.cmx src/ocamlbuild_pack.cmx
- mv tmp/ocamlbuild_pack.o src/ocamlbuild_pack.o
- ocamlopt.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c plugin-lib/ocamlbuild_plugin.ml
- ocamlopt.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c plugin-lib/ocamlbuild_executor.ml
- ocamlopt.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c plugin-lib/ocamlbuild_unix_plugin.ml
- ocamlopt.opt -w +L -w +R -w +Z -I src -I plugin-lib -I bin -I +unix -safe-string -bin-annot -strict-sequence -c bin/ocamlbuild.ml
- ocamlopt.opt -I +unix -I src -o ocamlbuild.native unix.cmxa src/ocamlbuild_pack.cmx plugin-lib/ocamlbuild_plugin.cmx plugin-lib/ocamlbuild_executor.cmx plugin-lib/ocamlbuild_unix_plugin.cmx bin/ocamlbuild.cmx
- ocamlopt.opt -a -o plugin-lib/ocamlbuildlib.cmxa src/ocamlbuild_pack.cmx plugin-lib/ocamlbuild_plugin.cmx plugin-lib/ocamlbuild_executor.cmx plugin-lib/ocamlbuild_unix_plugin.cmx
- ocamlc.opt src/ocamlbuild_pack.cmo -I src man/options_man.ml -o man/options_man.byte
- ./man/options_man.byte > man/ocamlbuild.options.1
- cat man/ocamlbuild.header.1 man/ocamlbuild.options.1 man/ocamlbuild.footer.1 > man/ocamlbuild.1
- /usr/local/bin/gmake ocamlbuild.install
- gmake[1]: Entering directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlbuild.0.14.3'
- rm -f ocamlbuild.install
- touch ocamlbuild.install
- /usr/local/bin/gmake install-bin-opam
- gmake[2]: Entering directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlbuild.0.14.3'
- echo 'bin: [' >> ocamlbuild.install
- echo '  "ocamlbuild.byte" {"ocamlbuild.byte"}' >> ocamlbuild.install
- echo '  "ocamlbuild.native" {"ocamlbuild.native"}' >> ocamlbuild.install
- echo '  "ocamlbuild.native" {"ocamlbuild"}' >> ocamlbuild.install
- echo ']' >> ocamlbuild.install
- echo >> ocamlbuild.install
- gmake[2]: Leaving directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlbuild.0.14.3'
- /usr/local/bin/gmake install-lib-opam
- gmake[2]: Entering directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlbuild.0.14.3'
- echo 'lib: [' >> ocamlbuild.install
- /usr/local/bin/gmake install-lib-basics-opam
- gmake[3]: Entering directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlbuild.0.14.3'
- echo '  "ocamlbuild.opam" {"opam"}' >> ocamlbuild.install
- echo '  "META"' >> ocamlbuild.install
- for lib in src/signatures.mli src/signatures.cmi src/signatures.cmti; do \
-   echo "  \"$lib\" {\"$(basename $lib)\"}" >> ocamlbuild.install; \
- done
- gmake[3]: Leaving directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlbuild.0.14.3'
- /usr/local/bin/gmake install-lib-byte-opam
- gmake[3]: Entering directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlbuild.0.14.3'
- for lib in plugin-lib/ocamlbuildlib.cma bin/ocamlbuild.cmo src/ocamlbuild_pack.cmi plugin-lib/ocamlbuild_plugin.cmi plugin-lib/ocamlbuild_executor.cmi plugin-lib/ocamlbuild_unix_plugin.cmi; do \
-   echo "  \"$lib\" {\"$(basename $lib)\"}" >> ocamlbuild.install; \
- done
- gmake[3]: Leaving directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlbuild.0.14.3'
- /usr/local/bin/gmake install-lib-native-opam
- gmake[3]: Entering directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlbuild.0.14.3'
- for lib in plugin-lib/ocamlbuildlib.cmxa plugin-lib/ocamlbuildlib.a bin/ocamlbuild.cmx bin/ocamlbuild.o src/ocamlbuild_pack.cmx plugin-lib/ocamlbuild_plugin.cmx plugin-lib/ocamlbuild_executor.cmx plugin-lib/ocamlbuild_unix_plugin.cmx plugin-lib/ocamlbuild_plugin.o plugin-lib/ocamlbuild_executor.o plugin-lib/ocamlbuild_unix_plugin.o; do \
-   echo "  \"$lib\" {\"$(basename $lib)\"}" >> ocamlbuild.install; \
- done
- gmake[3]: Leaving directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlbuild.0.14.3'
- echo ']' >> ocamlbuild.install
- echo >> ocamlbuild.install
- gmake[2]: Leaving directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlbuild.0.14.3'
- /usr/local/bin/gmake install-man-opam
- gmake[2]: Entering directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlbuild.0.14.3'
- echo 'man: [' >> ocamlbuild.install
- echo '  "man/ocamlbuild.1" {"man1/ocamlbuild.1"}' >> ocamlbuild.install
- echo ']' >> ocamlbuild.install
- echo >> ocamlbuild.install
- gmake[2]: Leaving directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlbuild.0.14.3'
- /usr/local/bin/gmake install-doc-opam
- gmake[2]: Entering directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlbuild.0.14.3'
- echo 'doc: [' >> ocamlbuild.install
- echo '  "LICENSE"' >> ocamlbuild.install
- echo '  "Changes"' >> ocamlbuild.install
- echo '  "Readme.md"' >> ocamlbuild.install
- echo ']' >> ocamlbuild.install
- gmake[2]: Leaving directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlbuild.0.14.3'
- gmake[1]: Leaving directory '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlbuild.0.14.3'
-> compiled  ocamlbuild.0.14.3
Processing 133/346: [dune: ocaml 7] [zarith: gmake]
-> installed ocamlbuild.0.14.3
Processing 134/346: [dune: ocaml 7] [zarith: gmake]
Processing 135/346: [dune: ocaml 7] [ocamlify: ocaml setup.ml] [zarith: gmake]
Processing 136/346: [dune: ocaml 7] [ocamlify: ocaml setup.ml] [ocamlmod: ocaml setup.ml] [zarith: gmake]
Processing 137/346: [dune: ocaml 7] [ocamlify: ocaml setup.ml] [ocamlmod: ocaml setup.ml] [topkg: ocaml build] [zarith: gmake]
Processing 138/346: [dune: ocaml 7] [ocamlify: ocaml setup.ml] [ocamlmod: ocaml setup.ml] [topkg: ocaml build] [uchar: ocaml] [zarith: gmake]
+ /home/opam/.opam/4.14.1/bin/ocaml "pkg/git.ml" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/uchar.0.0.2)
+ /home/opam/.opam/4.14.1/bin/ocaml "pkg/build.ml" "native=true" "native-dynlink=true" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/uchar.0.0.2)
-> compiled  uchar.0.0.2
Processing 138/346: [dune: ocaml 7] [ocamlify: ocaml setup.ml] [ocamlmod: ocaml setup.ml] [topkg: ocaml build] [zarith: gmake]
-> installed uchar.0.0.2
Processing 139/346: [dune: ocaml 7] [ocamlify: ocaml setup.ml] [ocamlmod: ocaml setup.ml] [topkg: ocaml build] [zarith: gmake]
+ /home/opam/.opam/4.14.1/bin/ocaml "setup.ml" "-configure" "--prefix" "/home/opam/.opam/4.14.1" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ocamlify.0.0.1)
- File "/home/gildor/programmation/oasis/src/oasis/PropList.ml", line 93, characters 13-29:
- Alert deprecated: Stdlib.String.lowercase
- Use String.lowercase_ascii/StringLabels.lowercase_ascii instead.
- File "/home/gildor/programmation/oasis/src/oasis/OASISMessage.ml", line 64, characters 37-52:
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "/home/gildor/programmation/oasis/src/oasis/OASISUtils.ml", line 106, characters 10-26:
- Alert deprecated: Stdlib.String.lowercase
- Use String.lowercase_ascii/StringLabels.lowercase_ascii instead.
- File "/home/gildor/programmation/oasis/src/oasis/OASISExpr.ml", line 99, characters 24-40:
- Alert deprecated: Stdlib.String.lowercase
- Use String.lowercase_ascii/StringLabels.lowercase_ascii instead.
- File "/home/gildor/programmation/oasis/src/oasis/OASISLibrary.ml", line 28, characters 21-40:
- Alert deprecated: Stdlib.String.uncapitalize
- Use String.uncapitalize_ascii/StringLabels.uncapitalize_ascii instead.
- File "/home/gildor/programmation/oasis/src/oasis/OASISLibrary.ml", line 29, characters 21-38:
- Alert deprecated: Stdlib.String.capitalize
- Use String.capitalize_ascii/StringLabels.capitalize_ascii instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 24, characters 10-27:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 30, characters 10-21:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 33, characters 23-34:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 36, characters 20-34:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 39, characters 10-27:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 42, characters 16-28:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 43, characters 15-27:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 43, characters 32-42:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 43, characters 48-61:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 44, characters 16-27:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 45, characters 16-27:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 46, characters 16-27:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 62, characters 4-21:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 83, characters 24-40:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 85, characters 21-33:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 86, characters 20-32:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 86, characters 41-53:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 88, characters 20-32:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 88, characters 41-54:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 90, characters 20-32:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 90, characters 50-62:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 92, characters 20-32:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 92, characters 50-63:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 94, characters 20-32:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 107, characters 15-27:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/plugins/internal/InternalInstallPlugin.ml", line 146, characters 31-50:
- Alert deprecated: Stdlib.String.uncapitalize
- Use String.uncapitalize_ascii/StringLabels.uncapitalize_ascii instead.
- File "/home/gildor/programmation/oasis/src/plugins/internal/InternalInstallPlugin.ml", line 147, characters 31-48:
- Alert deprecated: Stdlib.String.capitalize
- Use String.capitalize_ascii/StringLabels.capitalize_ascii instead.
- File "/home/gildor/programmation/oasis/src/plugins/internal/InternalInstallPlugin.ml", line 148, characters 31-50:
- Alert deprecated: Stdlib.String.uncapitalize
- Use String.uncapitalize_ascii/StringLabels.uncapitalize_ascii instead.
- File "/home/gildor/programmation/oasis/src/plugins/internal/InternalInstallPlugin.ml", line 149, characters 31-48:
- Alert deprecated: Stdlib.String.capitalize
- Use String.capitalize_ascii/StringLabels.capitalize_ascii instead.
- I: Running command '/home/opam/.opam/4.14.1/bin/ocamlc.opt -config > /tmp/oasis-1adff4.txt'
- I: Running command '/home/opam/.opam/4.14.1/bin/ocamlfind query -format %v findlib > /tmp/oasis-cbc7f7.txt'
- 
- Configuration: 
- 
- OCamlbuild additional flags: ................... 
- Compile with ocaml profile flag on.: ........... false
- Compile with ocaml debug flag on.: ............. true
- Remove a directory.: ........................... rm -rf
- Remove a file.: ................................ rm -f
- suffix_program: ................................ 
- is_native: ..................................... true
- findlib_version: ............................... 1.9.6
- PS documentation: .............................. $docdir
- PDF documentation: ............................. $docdir
- DVI documentation: ............................. $docdir
- HTML documentation: ............................ $docdir
- Documentation root: ............................ $datarootdir/doc/$pkg_name
- Man documentation: ............................. $datarootdir/man
- Locale-dependent data: ......................... $datarootdir/locale
- Info documentation: ............................ $datarootdir/info
- Read-only architecture-independent data: ....... $datarootdir
- Read-only arch-independent data root: .......... $prefix/share
- Object code libraries: ......................... $exec_prefix/lib
- Modifiable single-machine data: ................ $prefix/var
- Modifiable architecture-independent data: ...... $prefix/com
- Read-only single-machine data: ................. $prefix/etc
- Program executables: ........................... $exec_prefix/libexec
- System admin executables: ...................... $exec_prefix/sbin
- User executables: .............................. $exec_prefix/bin
- Install architecture-dependent files in dir: ... $prefix
- Install architecture-independent files dir: .... /home/opam/.opam/4.14.1
- systhread_supported: ........................... true
- default_executable_name: ....................... a.out
- ext_dll: ....................................... .so
- ext_lib: ....................................... .a
- ext_asm: ....................................... .s
- ext_obj: ....................................... .o
- model: ......................................... default
- native_c_compiler: ............................. cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- bytecomp_c_compiler: ........................... cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- standard_library: .............................. /home/opam/.opam/4.14.1/lib/ocaml
- standard_library_default: ...................... /home/opam/.opam/4.14.1/lib/ocaml
- ocaml_version: ................................. 4.14.1
- ccomp_type: .................................... cc
- architecture: .................................. amd64
- system: ........................................ freebsd
- os_type: ....................................... Unix
- Package version: ............................... 0.0.1
- Package name: .................................. ocamlify
- ocamlbuild: .................................... /home/opam/.opam/4.14.1/bin/ocamlbuild
- ocamlopt: ...................................... /home/opam/.opam/4.14.1/bin/ocamlopt.opt
- ocamlc: ........................................ /home/opam/.opam/4.14.1/bin/ocamlc.opt
- ocamlfind: ..................................... /home/opam/.opam/4.14.1/bin/ocamlfind
- 
+ /usr/local/bin/gmake  (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/zarith.1.13)
- (echo "let"; grep "version" META | head -1) > zarith_version.ml
- ocamldep  zarith_version.ml z.ml q.ml big_int_Z.ml z.mli q.mli big_int_Z.mli > depend
- ocamlc -g -I +compiler-libs -bin-annot  -c zarith_version.ml
- ocamlc -g -I +compiler-libs -bin-annot  -c z.mli
- ocamlc -g -I +compiler-libs -bin-annot  -c z.ml
- ocamlc -g -I +compiler-libs -bin-annot  -c q.mli
- ocamlc -g -I +compiler-libs -bin-annot  -c q.ml
- ocamlc -g -I +compiler-libs -bin-annot  -c big_int_Z.mli
- ocamlc -g -I +compiler-libs -bin-annot  -c big_int_Z.ml
- ocamlmklib -g -failsafe -o zarith zarith_version.cmo z.cmo q.cmo big_int_Z.cmo -L/usr/local/lib -lgmp -L/usr/local/lib
- ocamlc -ccopt "-I/home/opam/.opam/4.14.1/lib/ocaml  -I/usr/local/include -DHAS_GMP  -O3 -Wall -Wextra  -I/usr/local/include" -c caml_z.c
- ocamlmklib -g -failsafe -o zarith caml_z.o -L/usr/local/lib -lgmp -L/usr/local/lib
- ocamlc -g -I +compiler-libs -bin-annot  -c zarith_top.ml
- ocamlc -g -o zarith_top.cma -a zarith_top.cmo
- ocamlopt -g -I +compiler-libs  -c zarith_version.ml
- ocamlopt -g -I +compiler-libs  -c z.ml
- ocamlopt -g -I +compiler-libs  -c q.ml
- ocamlopt -g -I +compiler-libs  -c big_int_Z.ml
- ocamlmklib -g -failsafe -o zarith zarith_version.cmx z.cmx q.cmx big_int_Z.cmx -L/usr/local/lib -lgmp -L/usr/local/lib
- ocamlopt -shared -o zarith.cmxs -I . zarith.cmxa -linkall
-> compiled  zarith.1.13
Processing 139/346: [dune: ocaml 7] [ocamlify: ocaml setup.ml] [ocamlmod: ocaml setup.ml] [topkg: ocaml build]
Processing 140/346: [dune: ocaml 7] [ocamlify: ocaml setup.ml] [ocamlmod: ocaml setup.ml] [topkg: ocaml build] [zarith: gmake install]
+ /usr/local/bin/gmake "install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/zarith.1.13)
- ocamlfind install -destdir "/home/opam/.opam/4.14.1/lib" zarith META zarith.cma libzarith.a z.cmi q.cmi big_int_Z.cmi zarith_top.cma z.mli zarith.cmxa zarith_version.cmx z.cmx q.cmx big_int_Z.cmx zarith.cmxs zarith.h q.mli big_int_Z.mli zarith.a z.cmti q.cmti big_int_Z.cmti -optional dllzarith.so
- Installed /home/opam/.opam/4.14.1/lib/zarith/big_int_Z.cmti
- Installed /home/opam/.opam/4.14.1/lib/zarith/q.cmti
- Installed /home/opam/.opam/4.14.1/lib/zarith/z.cmti
- Installed /home/opam/.opam/4.14.1/lib/zarith/zarith.a
- Installed /home/opam/.opam/4.14.1/lib/zarith/big_int_Z.mli
- Installed /home/opam/.opam/4.14.1/lib/zarith/q.mli
- Installed /home/opam/.opam/4.14.1/lib/zarith/zarith.h
- Installed /home/opam/.opam/4.14.1/lib/zarith/zarith.cmxs
- Installed /home/opam/.opam/4.14.1/lib/zarith/big_int_Z.cmx
- Installed /home/opam/.opam/4.14.1/lib/zarith/q.cmx
- Installed /home/opam/.opam/4.14.1/lib/zarith/z.cmx
- Installed /home/opam/.opam/4.14.1/lib/zarith/zarith_version.cmx
- Installed /home/opam/.opam/4.14.1/lib/zarith/zarith.cmxa
- Installed /home/opam/.opam/4.14.1/lib/zarith/z.mli
- Installed /home/opam/.opam/4.14.1/lib/zarith/zarith_top.cma
- Installed /home/opam/.opam/4.14.1/lib/zarith/big_int_Z.cmi
- Installed /home/opam/.opam/4.14.1/lib/zarith/q.cmi
- Installed /home/opam/.opam/4.14.1/lib/zarith/z.cmi
- Installed /home/opam/.opam/4.14.1/lib/zarith/libzarith.a
- Installed /home/opam/.opam/4.14.1/lib/zarith/zarith.cma
- Installed /home/opam/.opam/4.14.1/lib/stublibs/dllzarith.so
- Installed /home/opam/.opam/4.14.1/lib/stublibs/dllzarith.so.owner
- ocamlfind: [WARNING] You have installed DLLs but the directory /home/opam/.opam/4.14.1/lib/stublibs is not mentioned in ld.conf
- Installed /home/opam/.opam/4.14.1/lib/zarith/META
-> installed zarith.1.13
Processing 140/346: [dune: ocaml 7] [ocamlify: ocaml setup.ml] [ocamlmod: ocaml setup.ml] [topkg: ocaml build]
+ /home/opam/.opam/4.14.1/bin/ocaml "setup.ml" "-configure" "--prefix" "/home/opam/.opam/4.14.1" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ocamlmod.0.0.9)
- File "./setup.ml", line 596, characters 4-15:
- 596 |     Stream.from next
-           ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "./setup.ml", line 624, characters 19-36:
- 624 |         let strm = Stream.of_channel chn in
-                          ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "./setup.ml", line 631, characters 37-48:
- 631 |                 Buffer.add_char buf (Stream.next strm);
-                                            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "./setup.ml", line 634, characters 17-31:
- 634 |             with Stream.Failure ->
-                        ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "./setup.ml", line 1452, characters 16-33:
- 1452 |       let lxr = Genlex.make_lexer [] in
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "./setup.ml", line 1454, characters 22-38:
- 1454 |         let st = lxr (Stream.of_string s) in
-                              ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "./setup.ml", line 1455, characters 14-26:
- 1455 |         match Stream.npeek 3 st with
-                      ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "./setup.ml", line 1456, characters 11-23:
- 1456 |         | [Genlex.Ident fn; Genlex.Ident nm] -> Call(fn, Ident nm)
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "./setup.ml", line 1456, characters 28-40:
- 1456 |         | [Genlex.Ident fn; Genlex.Ident nm] -> Call(fn, Ident nm)
-                                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "./setup.ml", line 1457, characters 11-23:
- 1457 |         | [Genlex.Ident fn; Genlex.String str] -> Call(fn, String str)
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "./setup.ml", line 1457, characters 28-41:
- 1457 |         | [Genlex.Ident fn; Genlex.String str] -> Call(fn, String str)
-                                    ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "./setup.ml", line 1458, characters 11-24:
- 1458 |         | [Genlex.String str] -> String str
-                   ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "./setup.ml", line 1459, characters 11-23:
- 1459 |         | [Genlex.Ident nm] -> Ident nm
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "./setup.ml", line 1796, characters 22-40:
- 1796 |         let compare = Pervasives.compare
-                              ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "setup.ml", line 3176, characters 8-19:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3179, characters 21-32:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3182, characters 18-32:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3184, characters 6-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3187, characters 12-24:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 9-21:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 26-36:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 42-55:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 8-19:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 25-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 42-53:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3201, characters 17-34:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3326, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3345, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3347, characters 17-29:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 37-49:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 37-50:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 46-58:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 46-59:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3356, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3369, characters 13-25:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3467, characters 16-34:
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "setup.ml", line 4518, characters 21-38:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4520, characters 19-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 16-29:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 33-46:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 15-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 32-43:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- 
- Configuration:
- ocamlfind: ........................................... /home/opam/.opam/4.14.1/bin/ocamlfind
- ocamlc: .............................................. /home/opam/.opam/4.14.1/bin/ocamlc.opt
- ocamlopt: ............................................ /home/opam/.opam/4.14.1/bin/ocamlopt.opt
- ocamlbuild: .......................................... /home/opam/.opam/4.14.1/bin/ocamlbuild
- Package name: ........................................ ocamlmod
- Package version: ..................................... 0.0.9
- os_type: ............................................. Unix
- system: .............................................. freebsd
- architecture: ........................................ amd64
- ccomp_type: .......................................... cc
- ocaml_version: ....................................... 4.14.1
- standard_library_default: ............................ /home/opam/.opam/4.14.1/lib/ocaml
- standard_library: .................................... /home/opam/.opam/4.14.1/lib/ocaml
- bytecomp_c_compiler: ................................. cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- native_c_compiler: ................................... cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- model: ............................................... default
- ext_obj: ............................................. .o
- ext_asm: ............................................. .s
- ext_lib: ............................................. .a
- ext_dll: ............................................. .so
- default_executable_name: ............................. a.out
- systhread_supported: ................................. true
- Install architecture-independent files dir: .......... /home/opam/.opam/4.14.1
- Install architecture-dependent files in dir: ......... $prefix
- User executables: .................................... $exec_prefix/bin
- System admin executables: ............................ $exec_prefix/sbin
- Program executables: ................................. $exec_prefix/libexec
- Read-only single-machine data: ....................... $prefix/etc
- Modifiable architecture-independent data: ............ $prefix/com
- Modifiable single-machine data: ...................... $prefix/var
- Object code libraries: ............................... $exec_prefix/lib
- Read-only arch-independent data root: ................ $prefix/share
- Read-only architecture-independent data: ............. $datarootdir
- Info documentation: .................................. $datarootdir/info
- Locale-dependent data: ............................... $datarootdir/locale
- Man documentation: ................................... $datarootdir/man
- Documentation root: .................................. $datarootdir/doc/$pkg_name
- HTML documentation: .................................. $docdir
- DVI documentation: ................................... $docdir
- PDF documentation: ................................... $docdir
- PS documentation: .................................... $docdir
- findlib_version: ..................................... 1.9.6
- is_native: ........................................... true
- suffix_program: ......................................
- Remove a file.: ...................................... rm -f
- Remove a directory.: ................................. rm -rf
- Turn ocaml debug flag on: ............................ true
- Turn ocaml profile flag on: .......................... false
- Compiler support generation of .cmxs.: ............... true
- OCamlbuild additional flags: .........................
- Create documentations: ............................... true
- Compile tests executable and library and run them: ... false
- pkg_str: ............................................. /home/opam/.opam/4.14.1/lib/ocaml
- 
+ /home/opam/.opam/4.14.1/bin/ocaml "setup.ml" "-build" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ocamlmod.0.0.9)
- File "./setup.ml", line 596, characters 4-15:
- 596 |     Stream.from next
-           ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "./setup.ml", line 624, characters 19-36:
- 624 |         let strm = Stream.of_channel chn in
-                          ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "./setup.ml", line 631, characters 37-48:
- 631 |                 Buffer.add_char buf (Stream.next strm);
-                                            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "./setup.ml", line 634, characters 17-31:
- 634 |             with Stream.Failure ->
-                        ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "./setup.ml", line 1452, characters 16-33:
- 1452 |       let lxr = Genlex.make_lexer [] in
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "./setup.ml", line 1454, characters 22-38:
- 1454 |         let st = lxr (Stream.of_string s) in
-                              ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "./setup.ml", line 1455, characters 14-26:
- 1455 |         match Stream.npeek 3 st with
-                      ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "./setup.ml", line 1456, characters 11-23:
- 1456 |         | [Genlex.Ident fn; Genlex.Ident nm] -> Call(fn, Ident nm)
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "./setup.ml", line 1456, characters 28-40:
- 1456 |         | [Genlex.Ident fn; Genlex.Ident nm] -> Call(fn, Ident nm)
-                                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "./setup.ml", line 1457, characters 11-23:
- 1457 |         | [Genlex.Ident fn; Genlex.String str] -> Call(fn, String str)
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "./setup.ml", line 1457, characters 28-41:
- 1457 |         | [Genlex.Ident fn; Genlex.String str] -> Call(fn, String str)
-                                    ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "./setup.ml", line 1458, characters 11-24:
- 1458 |         | [Genlex.String str] -> String str
-                   ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "./setup.ml", line 1459, characters 11-23:
- 1459 |         | [Genlex.Ident nm] -> Ident nm
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "./setup.ml", line 1796, characters 22-40:
- 1796 |         let compare = Pervasives.compare
-                              ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "setup.ml", line 3176, characters 8-19:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3179, characters 21-32:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3182, characters 18-32:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3184, characters 6-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3187, characters 12-24:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 9-21:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 26-36:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 42-55:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 8-19:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 25-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 42-53:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3201, characters 17-34:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3326, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3345, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3347, characters 17-29:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 37-49:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 37-50:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 46-58:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 46-59:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3356, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3369, characters 13-25:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3467, characters 16-34:
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "setup.ml", line 4518, characters 21-38:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4520, characters 19-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 16-29:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 33-46:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 15-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 32-43:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- /home/opam/.opam/4.14.1/bin/ocamlopt.opt unix.cmxa -I /home/opam/.opam/4.14.1/lib/ocamlbuild /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuildlib.cmxa myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- File "_tags", line 21, characters 18-27:
- Warning: the tag "pkg_oUnit" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 23, characters 19-28:
- Warning: the tag "pkg_oUnit" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package str -modules src/ocamlmod.ml > src/ocamlmod.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package str -modules src/ocamlmodConf.ml > src/ocamlmodConf.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -package str -I src -o src/ocamlmodConf.cmo src/ocamlmodConf.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -package str -I src -o src/ocamlmod.cmo src/ocamlmod.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -package str -I src -o src/ocamlmod.cmo src/ocamlmod.ml
- File "src/ocamlmod.ml", line 52, characters 4-21:
- 52 |     String.capitalize
-          ^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.String.capitalize
- Use String.capitalize_ascii/StringLabels.capitalize_ascii instead.
- File "src/ocamlmod.ml", line 29, characters 6-13:
- 29 |   let real_fn =
-            ^^^^^^^
- Warning 26 [unused-var]: unused variable real_fn.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -g -linkpkg -package str -I src src/ocamlmodConf.cmo src/ocamlmod.cmo -o src/ocamlmod.byte
- + /home/opam/.opam/4.14.1/bin/ocamlopt.opt unix.cmxa -I /home/opam/.opam/4.14.1/lib/ocamlbuild /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuildlib.cmxa myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- File "myocamlbuild.ml", line 454, characters 8-19:
- 454 |         Stream.from
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 457, characters 21-32:
- 457 |                match Stream.next st with
-                            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 460, characters 18-32:
- 460 |              with Stream.Failure -> None)
-                         ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 462, characters 6-23:
- 462 |       Genlex.make_lexer ["="] st_line
-             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 465, characters 12-24:
- 465 |       match Stream.npeek 3 lxr with
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 9-21:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 26-36:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                 ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 42-55:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                 ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 8-19:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 25-36:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 42-53:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 479, characters 17-34:
- 479 |         let st = Stream.of_channel chn in
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
-> compiled  ocamlmod.0.0.9
Processing 140/346: [dune: ocaml 7] [ocamlify: ocaml setup.ml] [topkg: ocaml build]
Processing 141/346: [dune: ocaml 7] [ocamlify: ocaml setup.ml] [topkg: ocaml build] [ocamlmod: ocaml setup.ml]
+ /home/opam/.opam/4.14.1/bin/ocaml "setup.ml" "-build" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ocamlify.0.0.1)
- File "/home/gildor/programmation/oasis/src/oasis/PropList.ml", line 93, characters 13-29:
- Alert deprecated: Stdlib.String.lowercase
- Use String.lowercase_ascii/StringLabels.lowercase_ascii instead.
- File "/home/gildor/programmation/oasis/src/oasis/OASISMessage.ml", line 64, characters 37-52:
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "/home/gildor/programmation/oasis/src/oasis/OASISUtils.ml", line 106, characters 10-26:
- Alert deprecated: Stdlib.String.lowercase
- Use String.lowercase_ascii/StringLabels.lowercase_ascii instead.
- File "/home/gildor/programmation/oasis/src/oasis/OASISExpr.ml", line 99, characters 24-40:
- Alert deprecated: Stdlib.String.lowercase
- Use String.lowercase_ascii/StringLabels.lowercase_ascii instead.
- File "/home/gildor/programmation/oasis/src/oasis/OASISLibrary.ml", line 28, characters 21-40:
- Alert deprecated: Stdlib.String.uncapitalize
- Use String.uncapitalize_ascii/StringLabels.uncapitalize_ascii instead.
- File "/home/gildor/programmation/oasis/src/oasis/OASISLibrary.ml", line 29, characters 21-38:
- Alert deprecated: Stdlib.String.capitalize
- Use String.capitalize_ascii/StringLabels.capitalize_ascii instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 24, characters 10-27:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 30, characters 10-21:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 33, characters 23-34:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 36, characters 20-34:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 39, characters 10-27:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 42, characters 16-28:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 43, characters 15-27:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 43, characters 32-42:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 43, characters 48-61:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 44, characters 16-27:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 45, characters 16-27:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 46, characters 16-27:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 62, characters 4-21:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 83, characters 24-40:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 85, characters 21-33:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 86, characters 20-32:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 86, characters 41-53:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 88, characters 20-32:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 88, characters 41-54:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 90, characters 20-32:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 90, characters 50-62:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 92, characters 20-32:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 92, characters 50-63:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 94, characters 20-32:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 107, characters 15-27:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/plugins/internal/InternalInstallPlugin.ml", line 146, characters 31-50:
- Alert deprecated: Stdlib.String.uncapitalize
- Use String.uncapitalize_ascii/StringLabels.uncapitalize_ascii instead.
- File "/home/gildor/programmation/oasis/src/plugins/internal/InternalInstallPlugin.ml", line 147, characters 31-48:
- Alert deprecated: Stdlib.String.capitalize
- Use String.capitalize_ascii/StringLabels.capitalize_ascii instead.
- File "/home/gildor/programmation/oasis/src/plugins/internal/InternalInstallPlugin.ml", line 148, characters 31-50:
- Alert deprecated: Stdlib.String.uncapitalize
- Use String.uncapitalize_ascii/StringLabels.uncapitalize_ascii instead.
- File "/home/gildor/programmation/oasis/src/plugins/internal/InternalInstallPlugin.ml", line 149, characters 31-48:
- Alert deprecated: Stdlib.String.capitalize
- Use String.capitalize_ascii/StringLabels.capitalize_ascii instead.
- I: Running command '/home/opam/.opam/4.14.1/bin/ocamlbuild src/ocamlify.byte -tag debug'
- /home/opam/.opam/4.14.1/bin/ocamlopt.opt unix.cmxa -I /home/opam/.opam/4.14.1/lib/ocamlbuild /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuildlib.cmxa myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- ocamlfind ocamldep -modules src/ocamlify.ml > src/ocamlify.ml.depends
- ocamlfind ocamldep -modules src/OCamlifyConfig.ml > src/OCamlifyConfig.ml.depends
- ocamlfind ocamlc -c -g -I src -o src/OCamlifyConfig.cmo src/OCamlifyConfig.ml
- ocamlfind ocamlc -c -g -I src -o src/ocamlify.cmo src/ocamlify.ml
- + ocamlfind ocamlc -c -g -I src -o src/ocamlify.cmo src/ocamlify.ml
- File "src/ocamlify.ml", line 22, characters 5-11:
- 22 | open Genlex;;
-           ^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/ocamlify.ml", line 133, characters 16-27:
- 133 |       to_list ((Stream.next str) :: acc) str
-                       ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/ocamlify.ml", line 134, characters 9-23:
- 134 |     with Stream.Failure ->
-                ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/ocamlify.ml", line 175, characters 27-44:
- 175 |         to_list [] (lexer (Stream.of_channel fd))
-                                  ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- ocamlfind ocamlc -g -linkpkg -I src src/OCamlifyConfig.cmo src/ocamlify.cmo -o src/ocamlify.byte
- + /home/opam/.opam/4.14.1/bin/ocamlopt.opt unix.cmxa -I /home/opam/.opam/4.14.1/lib/ocamlbuild /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuildlib.cmxa myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 24, characters 10-27:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 30, characters 10-21:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 33, characters 23-34:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 36, characters 20-34:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 39, characters 10-27:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 42, characters 16-28:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 43, characters 15-27:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 43, characters 32-42:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 43, characters 48-61:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 44, characters 16-27:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 45, characters 16-27:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 46, characters 16-27:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- I: Running command 'cp '_build/src/ocamlify.byte' '_build/src/ocamlify''
-> compiled  ocamlify.0.0.1
Processing 141/346: [dune: ocaml 7] [topkg: ocaml build] [ocamlmod: ocaml setup.ml]
+ /home/opam/.opam/4.14.1/bin/ocaml "setup.ml" "-install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ocamlmod.0.0.9)
- File "./setup.ml", line 596, characters 4-15:
- 596 |     Stream.from next
-           ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "./setup.ml", line 624, characters 19-36:
- 624 |         let strm = Stream.of_channel chn in
-                          ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "./setup.ml", line 631, characters 37-48:
- 631 |                 Buffer.add_char buf (Stream.next strm);
-                                            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "./setup.ml", line 634, characters 17-31:
- 634 |             with Stream.Failure ->
-                        ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "./setup.ml", line 1452, characters 16-33:
- 1452 |       let lxr = Genlex.make_lexer [] in
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "./setup.ml", line 1454, characters 22-38:
- 1454 |         let st = lxr (Stream.of_string s) in
-                              ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "./setup.ml", line 1455, characters 14-26:
- 1455 |         match Stream.npeek 3 st with
-                      ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "./setup.ml", line 1456, characters 11-23:
- 1456 |         | [Genlex.Ident fn; Genlex.Ident nm] -> Call(fn, Ident nm)
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "./setup.ml", line 1456, characters 28-40:
- 1456 |         | [Genlex.Ident fn; Genlex.Ident nm] -> Call(fn, Ident nm)
-                                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "./setup.ml", line 1457, characters 11-23:
- 1457 |         | [Genlex.Ident fn; Genlex.String str] -> Call(fn, String str)
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "./setup.ml", line 1457, characters 28-41:
- 1457 |         | [Genlex.Ident fn; Genlex.String str] -> Call(fn, String str)
-                                    ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "./setup.ml", line 1458, characters 11-24:
- 1458 |         | [Genlex.String str] -> String str
-                   ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "./setup.ml", line 1459, characters 11-23:
- 1459 |         | [Genlex.Ident nm] -> Ident nm
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "./setup.ml", line 1796, characters 22-40:
- 1796 |         let compare = Pervasives.compare
-                              ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "setup.ml", line 3176, characters 8-19:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3179, characters 21-32:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3182, characters 18-32:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3184, characters 6-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3187, characters 12-24:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 9-21:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 26-36:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 42-55:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 8-19:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 25-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 42-53:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3201, characters 17-34:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3326, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3345, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3347, characters 17-29:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 37-49:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 37-50:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 46-58:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 46-59:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3356, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3369, characters 13-25:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3467, characters 16-34:
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "setup.ml", line 4518, characters 21-38:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4520, characters 19-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 16-29:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 33-46:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 15-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 32-43:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
-> installed ocamlmod.0.0.9
Processing 141/346: [dune: ocaml 7] [topkg: ocaml build]
Processing 142/346: [dune: ocaml 7] [topkg: ocaml build] [ocamlify: ocaml setup.ml]
+ /home/opam/.opam/4.14.1/bin/ocaml "pkg/pkg.ml" "build" "--pkg-name" "topkg" "--dev-pkg" "false" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/topkg.1.0.7)
- ocamlfind ocamldep -modules src/topkg.ml > src/topkg.ml.depends
- ocamlfind ocamldep -modules src/topkg.mli > src/topkg.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg.cmi src/topkg.mli
- ocamlfind ocamldep -modules src/topkg_build.ml > src/topkg_build.ml.depends
- ocamlfind ocamldep -modules src/topkg_build.mli > src/topkg_build.mli.depends
- ocamlfind ocamldep -modules src/topkg_cmd.mli > src/topkg_cmd.mli.depends
- ocamlfind ocamldep -modules src/topkg_fpath.mli > src/topkg_fpath.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_fpath.cmi src/topkg_fpath.mli
- ocamlfind ocamldep -modules src/topkg_codec.mli > src/topkg_codec.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_cmd.cmi src/topkg_cmd.mli
- ocamlfind ocamldep -modules src/topkg_result.mli > src/topkg_result.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_result.cmi src/topkg_result.mli
- ocamlfind ocamldep -modules src/topkg_conf.mli > src/topkg_conf.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_codec.cmi src/topkg_codec.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_conf.cmi src/topkg_conf.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_build.cmi src/topkg_build.mli
- ocamlfind ocamldep -modules src/topkg_cmd.ml > src/topkg_cmd.ml.depends
- ocamlfind ocamldep -modules src/topkg_fpath.ml > src/topkg_fpath.ml.depends
- ocamlfind ocamldep -modules src/topkg_string.ml > src/topkg_string.ml.depends
- ocamlfind ocamldep -modules src/topkg_string.mli > src/topkg_string.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_string.cmi src/topkg_string.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_string.cmx src/topkg_string.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_fpath.cmx src/topkg_fpath.ml
- ocamlfind ocamldep -modules src/topkg_codec.ml > src/topkg_codec.ml.depends
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_cmd.cmx src/topkg_cmd.ml
- ocamlfind ocamldep -modules src/topkg_os.ml > src/topkg_os.ml.depends
- ocamlfind ocamldep -modules src/topkg_os.mli > src/topkg_os.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_os.cmi src/topkg_os.mli
- ocamlfind ocamldep -modules src/topkg_log.ml > src/topkg_log.ml.depends
- ocamlfind ocamldep -modules src/topkg_log.mli > src/topkg_log.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_log.cmi src/topkg_log.mli
- ocamlfind ocamldep -modules src/topkg_result.ml > src/topkg_result.ml.depends
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_result.cmx src/topkg_result.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_log.cmx src/topkg_log.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_os.cmx src/topkg_os.ml
- ocamlfind ocamldep -modules src/topkg_conf.ml > src/topkg_conf.ml.depends
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_codec.cmx src/topkg_codec.ml
- ocamlfind ocamldep -modules src/topkg_vcs.ml > src/topkg_vcs.ml.depends
- ocamlfind ocamldep -modules src/topkg_vcs.mli > src/topkg_vcs.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_vcs.cmi src/topkg_vcs.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_vcs.cmx src/topkg_vcs.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_conf.cmx src/topkg_conf.ml
- ocamlfind ocamldep -modules src/topkg_distrib.ml > src/topkg_distrib.ml.depends
- ocamlfind ocamldep -modules src/topkg_distrib.mli > src/topkg_distrib.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_distrib.cmi src/topkg_distrib.mli
- ocamlfind ocamldep -modules src/topkg_opam.ml > src/topkg_opam.ml.depends
- ocamlfind ocamldep -modules src/topkg_opam.mli > src/topkg_opam.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_opam.cmi src/topkg_opam.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_opam.cmx src/topkg_opam.ml
- ocamlfind ocamldep -modules src/topkg_fexts.ml > src/topkg_fexts.ml.depends
- ocamlfind ocamldep -modules src/topkg_fexts.mli > src/topkg_fexts.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_fexts.cmi src/topkg_fexts.mli
- ocamlfind ocamldep -modules src/topkg_install.ml > src/topkg_install.ml.depends
- ocamlfind ocamldep -modules src/topkg_install.mli > src/topkg_install.mli.depends
- ocamlfind ocamldep -modules src/topkg_test.mli > src/topkg_test.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_test.cmi src/topkg_test.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_install.cmi src/topkg_install.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_fexts.cmx src/topkg_fexts.ml
- ocamlfind ocamldep -modules src/topkg_test.ml > src/topkg_test.ml.depends
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_test.cmx src/topkg_test.ml
- ocamlfind ocamldep -modules src/topkg_ipc.ml > src/topkg_ipc.ml.depends
- ocamlfind ocamldep -modules src/topkg_ipc.mli > src/topkg_ipc.mli.depends
- ocamlfind ocamldep -modules src/topkg_pkg.mli > src/topkg_pkg.mli.depends
- ocamlfind ocamldep -modules src/topkg_publish.mli > src/topkg_publish.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_publish.cmi src/topkg_publish.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_pkg.cmi src/topkg_pkg.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_ipc.cmi src/topkg_ipc.mli
- ocamlfind ocamldep -modules src/topkg_pkg.ml > src/topkg_pkg.ml.depends
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_build.cmx src/topkg_build.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_distrib.cmx src/topkg_distrib.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_install.cmx src/topkg_install.ml
- ocamlfind ocamldep -modules src/topkg_publish.ml > src/topkg_publish.ml.depends
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_publish.cmx src/topkg_publish.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_pkg.cmx src/topkg_pkg.ml
- ocamlfind ocamldep -modules src/topkg_main.ml > src/topkg_main.ml.depends
- ocamlfind ocamldep -modules src/topkg_main.mli > src/topkg_main.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_main.cmi src/topkg_main.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_ipc.cmx src/topkg_ipc.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_main.cmx src/topkg_main.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg.cmx src/topkg.ml
- ocamlfind ocamlopt -a -I src src/topkg_string.cmx src/topkg_fpath.cmx src/topkg_cmd.cmx src/topkg_result.cmx src/topkg_log.cmx src/topkg_os.cmx src/topkg_codec.cmx src/topkg_vcs.cmx src/topkg_conf.cmx src/topkg_build.cmx src/topkg_opam.cmx src/topkg_distrib.cmx src/topkg_fexts.cmx src/topkg_test.cmx src/topkg_install.cmx src/topkg_publish.cmx src/topkg_pkg.cmx src/topkg_ipc.cmx src/topkg_main.cmx src/topkg.cmx -o src/topkg.cmxa
- ocamlfind ocamlopt -shared -linkall -I src src/topkg.cmxa -o src/topkg.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg.cmo src/topkg.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_build.cmo src/topkg_build.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_cmd.cmo src/topkg_cmd.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_codec.cmo src/topkg_codec.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_conf.cmo src/topkg_conf.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_distrib.cmo src/topkg_distrib.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_fexts.cmo src/topkg_fexts.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_fpath.cmo src/topkg_fpath.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_install.cmo src/topkg_install.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_ipc.cmo src/topkg_ipc.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_log.cmo src/topkg_log.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_main.cmo src/topkg_main.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_opam.cmo src/topkg_opam.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_os.cmo src/topkg_os.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_pkg.cmo src/topkg_pkg.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_publish.cmo src/topkg_publish.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_result.cmo src/topkg_result.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_string.cmo src/topkg_string.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_test.cmo src/topkg_test.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_vcs.cmo src/topkg_vcs.ml
- ocamlfind ocamlc -a -I src src/topkg_string.cmo src/topkg_fpath.cmo src/topkg_cmd.cmo src/topkg_result.cmo src/topkg_log.cmo src/topkg_os.cmo src/topkg_codec.cmo src/topkg_vcs.cmo src/topkg_conf.cmo src/topkg_build.cmo src/topkg_opam.cmo src/topkg_distrib.cmo src/topkg_fexts.cmo src/topkg_test.cmo src/topkg_install.cmo src/topkg_publish.cmo src/topkg_pkg.cmo src/topkg_ipc.cmo src/topkg_main.cmo src/topkg.cmo -o src/topkg.cma
- # Parallel statistics: { count(total): 2(84), max: 20, min: 2, average(total): 11.000(1.238) }
-> compiled  topkg.1.0.7
Processing 142/346: [dune: ocaml 7] [ocamlify: ocaml setup.ml]
+ /home/opam/.opam/4.14.1/bin/ocaml "setup.ml" "-install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ocamlify.0.0.1)
- File "/home/gildor/programmation/oasis/src/oasis/PropList.ml", line 93, characters 13-29:
- Alert deprecated: Stdlib.String.lowercase
- Use String.lowercase_ascii/StringLabels.lowercase_ascii instead.
- File "/home/gildor/programmation/oasis/src/oasis/OASISMessage.ml", line 64, characters 37-52:
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "/home/gildor/programmation/oasis/src/oasis/OASISUtils.ml", line 106, characters 10-26:
- Alert deprecated: Stdlib.String.lowercase
- Use String.lowercase_ascii/StringLabels.lowercase_ascii instead.
- File "/home/gildor/programmation/oasis/src/oasis/OASISExpr.ml", line 99, characters 24-40:
- Alert deprecated: Stdlib.String.lowercase
- Use String.lowercase_ascii/StringLabels.lowercase_ascii instead.
- File "/home/gildor/programmation/oasis/src/oasis/OASISLibrary.ml", line 28, characters 21-40:
- Alert deprecated: Stdlib.String.uncapitalize
- Use String.uncapitalize_ascii/StringLabels.uncapitalize_ascii instead.
- File "/home/gildor/programmation/oasis/src/oasis/OASISLibrary.ml", line 29, characters 21-38:
- Alert deprecated: Stdlib.String.capitalize
- Use String.capitalize_ascii/StringLabels.capitalize_ascii instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 24, characters 10-27:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 30, characters 10-21:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 33, characters 23-34:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 36, characters 20-34:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 39, characters 10-27:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 42, characters 16-28:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 43, characters 15-27:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 43, characters 32-42:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 43, characters 48-61:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 44, characters 16-27:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 45, characters 16-27:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnvLight.ml", line 46, characters 16-27:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 62, characters 4-21:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 83, characters 24-40:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 85, characters 21-33:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 86, characters 20-32:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 86, characters 41-53:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 88, characters 20-32:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 88, characters 41-54:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 90, characters 20-32:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 90, characters 50-62:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 92, characters 20-32:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 92, characters 50-63:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 94, characters 20-32:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/base/BaseEnv.ml", line 107, characters 15-27:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "/home/gildor/programmation/oasis/src/plugins/internal/InternalInstallPlugin.ml", line 146, characters 31-50:
- Alert deprecated: Stdlib.String.uncapitalize
- Use String.uncapitalize_ascii/StringLabels.uncapitalize_ascii instead.
- File "/home/gildor/programmation/oasis/src/plugins/internal/InternalInstallPlugin.ml", line 147, characters 31-48:
- Alert deprecated: Stdlib.String.capitalize
- Use String.capitalize_ascii/StringLabels.capitalize_ascii instead.
- File "/home/gildor/programmation/oasis/src/plugins/internal/InternalInstallPlugin.ml", line 148, characters 31-50:
- Alert deprecated: Stdlib.String.uncapitalize
- Use String.uncapitalize_ascii/StringLabels.uncapitalize_ascii instead.
- File "/home/gildor/programmation/oasis/src/plugins/internal/InternalInstallPlugin.ml", line 149, characters 31-48:
- Alert deprecated: Stdlib.String.capitalize
- Use String.capitalize_ascii/StringLabels.capitalize_ascii instead.
- I: Copying file '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlify.0.0.1/_build/src/ocamlify' to '/home/opam/.opam/4.14.1/bin/ocamlify'
- I: Running command 'cp '/home/opam/.opam/4.14.1/.opam-switch/build/ocamlify.0.0.1/_build/src/ocamlify' '/home/opam/.opam/4.14.1/bin/ocamlify''
-> installed ocamlify.0.0.1
Processing 142/346: [dune: ocaml 7]
Processing 143/346: [dune: ocaml 7] [oasis: ocaml setup.ml]
-> installed topkg.1.0.7
Processing 144/346: [dune: ocaml 7] [oasis: ocaml setup.ml]
Processing 145/346: [dune: ocaml 7] [oasis: ocaml setup.ml] [react: ocaml build]
Processing 146/346: [dune: ocaml 7] [oasis: ocaml setup.ml] [react: ocaml build] [uucp: ocaml build]
Processing 147/346: [dune: ocaml 7] [oasis: ocaml setup.ml] [react: ocaml build] [uucp: ocaml build] [uuidm: ocaml build]
Processing 148/346: [dune: ocaml 7] [oasis: ocaml setup.ml] [react: ocaml build] [uucp: ocaml build] [uuidm: ocaml build] [uutf: ocaml build]
+ /home/opam/.opam/4.14.1/bin/ocaml "pkg/pkg.ml" "build" "--dev-pkg" "false" "--with-cmdliner" "true" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/uuidm.0.9.8)
- ocamlfind ocamldep -modules src/uuidm.ml > src/uuidm.ml.depends
- ocamlfind ocamldep -modules src/uuidm.mli > src/uuidm.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/uuidm.cmi src/uuidm.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/uuidm.cmx src/uuidm.ml
- ocamlfind ocamlopt -a -I src src/uuidm.cmx -o src/uuidm.cmxa
- ocamlfind ocamlopt -shared -linkall -I src src/uuidm.cmxa -o src/uuidm.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/uuidm.cmo src/uuidm.ml
- ocamlfind ocamlc -a -I src src/uuidm.cmo -o src/uuidm.cma
- ocamlfind ocamldep -package cmdliner -modules test/uuidtrip.ml > test/uuidtrip.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package cmdliner -I test -I src -o test/uuidtrip.cmo test/uuidtrip.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package cmdliner -I test -I src -o test/uuidtrip.cmx test/uuidtrip.ml
- ocamlfind ocamlopt -linkpkg -g -package cmdliner -I src -I test src/uuidm.cmx test/uuidtrip.cmx -o test/uuidtrip.native
- # No parallelism done
-> compiled  uuidm.0.9.8
Processing 148/346: [dune: ocaml 7] [oasis: ocaml setup.ml] [react: ocaml build] [uucp: ocaml build] [uutf: ocaml build]
-> installed uuidm.0.9.8
Processing 149/346: [dune: ocaml 7] [oasis: ocaml setup.ml] [react: ocaml build] [uucp: ocaml build] [uutf: ocaml build]
+ /home/opam/.opam/4.14.1/bin/ocaml "pkg/pkg.ml" "build" "--dev-pkg" "false" "--with-cmdliner" "true" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/uutf.1.0.3)
- ocamlfind ocamldep -modules src/uutf.ml > src/uutf.ml.depends
- ocamlfind ocamldep -modules src/uutf.mli > src/uutf.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/uutf.cmi src/uutf.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/uutf.cmx src/uutf.ml
- ocamlfind ocamlopt -a -I src src/uutf.cmx -o src/uutf.cmxa
- ocamlfind ocamlopt -shared -linkall -I src src/uutf.cmxa -o src/uutf.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/uutf.cmo src/uutf.ml
- ocamlfind ocamlc -a -I src src/uutf.cmo -o src/uutf.cma
- ocamlfind ocamldep -package unix -package cmdliner -modules test/utftrip.ml > test/utftrip.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package unix -package cmdliner -I test -I src -o test/utftrip.cmo test/utftrip.ml
- + ocamlfind ocamlc -c -g -bin-annot -safe-string -package unix -package cmdliner -I test -I src -o test/utftrip.cmo test/utftrip.ml
- File "test/utftrip.ml", line 385, characters 8-12:
- 385 |   Term.(pure do_cmd $ cmd $ file $ sin $ sout $ use_unix $ usize $
-               ^^^^
- Alert deprecated: Cmdliner.Term.pure
- Use Term.const instead.
- File "test/utftrip.ml", line 387, characters 2-11:
- 387 |   Term.info "utftrip" ~version:"v1.0.3" ~doc ~man
-         ^^^^^^^^^
- Alert deprecated: Cmdliner.Term.info
- Use Cmd.info instead.
- File "test/utftrip.ml", line 389, characters 15-24:
- 389 | let () = match Term.eval cmd with
-                      ^^^^^^^^^
- Alert deprecated: Cmdliner.Term.eval
- Use Cmd.v and one of Cmd.eval* instead.
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package unix -package cmdliner -I test -I src -o test/utftrip.cmx test/utftrip.ml
- + ocamlfind ocamlopt -c -g -bin-annot -safe-string -package unix -package cmdliner -I test -I src -o test/utftrip.cmx test/utftrip.ml
- File "test/utftrip.ml", line 385, characters 8-12:
- 385 |   Term.(pure do_cmd $ cmd $ file $ sin $ sout $ use_unix $ usize $
-               ^^^^
- Alert deprecated: Cmdliner.Term.pure
- Use Term.const instead.
- File "test/utftrip.ml", line 387, characters 2-11:
- 387 |   Term.info "utftrip" ~version:"v1.0.3" ~doc ~man
-         ^^^^^^^^^
- Alert deprecated: Cmdliner.Term.info
- Use Cmd.info instead.
- File "test/utftrip.ml", line 389, characters 15-24:
- 389 | let () = match Term.eval cmd with
-                      ^^^^^^^^^
- Alert deprecated: Cmdliner.Term.eval
- Use Cmd.v and one of Cmd.eval* instead.
- ocamlfind ocamlopt -linkpkg -g -package unix -package cmdliner -I src -I test src/uutf.cmx test/utftrip.cmx -o test/utftrip.native
- # No parallelism done
-> compiled  uutf.1.0.3
Processing 149/346: [dune: ocaml 7] [oasis: ocaml setup.ml] [react: ocaml build] [uucp: ocaml build]
-> installed uutf.1.0.3
Processing 150/346: [dune: ocaml 7] [oasis: ocaml setup.ml] [react: ocaml build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/ocaml "pkg/pkg.ml" "build" "--dev-pkg" "false" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/react.1.2.2)
- ocamlfind ocamldep -modules src/react.ml > src/react.ml.depends
- ocamlfind ocamldep -modules src/react.mli > src/react.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/react.cmi src/react.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/react.cmx src/react.ml
- ocamlfind ocamlopt -a -I src src/react.cmx -o src/react.cmxa
- ocamlfind ocamlopt -shared -linkall -I src src/react.cmxa -o src/react.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/react.cmo src/react.ml
- ocamlfind ocamlc -a -I src src/react.cmo -o src/react.cma
- ocamlfind ocamldep -package compiler-libs.toplevel -modules src/react_top.ml > src/react_top.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package compiler-libs.toplevel -I src -I test -o src/react_top.cmo src/react_top.ml
- + ocamlfind ocamlc -c -g -bin-annot -safe-string -package compiler-libs.toplevel -I src -I test -o src/react_top.cmo src/react_top.ml
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.14.1/lib/ocaml, /home/opam/.opam/4.14.1/lib/ocaml/compiler-libs
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package compiler-libs.toplevel -I src -I test -o src/react_top.cmx src/react_top.ml
- + ocamlfind ocamlopt -c -g -bin-annot -safe-string -package compiler-libs.toplevel -I src -I test -o src/react_top.cmx src/react_top.ml
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.14.1/lib/ocaml, /home/opam/.opam/4.14.1/lib/ocaml/compiler-libs
- ocamlfind ocamlopt -a -package compiler-libs.toplevel -I src src/react_top.cmx -o src/react_top.cmxa
- + ocamlfind ocamlopt -a -package compiler-libs.toplevel -I src src/react_top.cmx -o src/react_top.cmxa
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.14.1/lib/ocaml, /home/opam/.opam/4.14.1/lib/ocaml/compiler-libs
- ocamlfind ocamlopt -shared -linkall -package compiler-libs.toplevel -I src src/react_top.cmxa -o src/react_top.cmxs
- + ocamlfind ocamlopt -shared -linkall -package compiler-libs.toplevel -I src src/react_top.cmxa -o src/react_top.cmxs
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.14.1/lib/ocaml, /home/opam/.opam/4.14.1/lib/ocaml/compiler-libs
- ocamlfind ocamlc -a -package compiler-libs.toplevel -I src src/react_top.cmo -o src/react_top.cma
- + ocamlfind ocamlc -a -package compiler-libs.toplevel -I src src/react_top.cmo -o src/react_top.cma
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.14.1/lib/ocaml, /home/opam/.opam/4.14.1/lib/ocaml/compiler-libs
- # No parallelism done
-> compiled  react.1.2.2
Processing 150/346: [dune: ocaml 7] [oasis: ocaml setup.ml] [uucp: ocaml build]
-> installed react.1.2.2
Processing 151/346: [dune: ocaml 7] [oasis: ocaml setup.ml] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/ocaml "setup.ml" "-configure" "--prefix" "/home/opam/.opam/4.14.1" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/oasis.0.4.11)
- File "src/oasis/OASISFileSystem.ml", line 107, characters 4-15:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISFileSystem.ml", line 135, characters 19-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISFileSystem.ml", line 142, characters 37-48:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISFileSystem.ml", line 145, characters 17-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 85, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 87, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 88, characters 14-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 89, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 89, characters 28-40:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 90, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 90, characters 28-41:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 91, characters 11-24:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 92, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISFeatures.ml", line 32, characters 22-40:
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "src/base/BaseEnvLight.ml", line 37, characters 8-19:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 40, characters 21-32:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 43, characters 18-32:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 45, characters 6-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 48, characters 12-24:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 49, characters 9-21:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 49, characters 26-36:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 49, characters 42-55:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 50, characters 8-19:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 50, characters 25-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 50, characters 42-53:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 62, characters 17-34:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 69, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 88, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 90, characters 17-29:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 91, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 91, characters 37-49:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 93, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 93, characters 37-50:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 95, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 95, characters 46-58:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 97, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 97, characters 46-59:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 99, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 112, characters 13-25:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 210, characters 16-34:
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "src/base/BaseLog.ml", line 49, characters 21-38:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 51, characters 19-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 52, characters 16-29:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 52, characters 33-46:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 54, characters 15-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 54, characters 32-43:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- 
- Configuration:
- ocamlfind: ................................................... /home/opam/.opam/4.14.1/bin/ocamlfind
- ocamlc: ...................................................... /home/opam/.opam/4.14.1/bin/ocamlc.opt
- ocamlopt: .................................................... /home/opam/.opam/4.14.1/bin/ocamlopt.opt
- ocamlbuild: .................................................. /home/opam/.opam/4.14.1/bin/ocamlbuild
- Package name: ................................................ oasis
- Package version: ............................................. 0.4.11
- os_type: ..................................................... Unix
- system: ...................................................... freebsd
- architecture: ................................................ amd64
- ccomp_type: .................................................. cc
- ocaml_version: ............................................... 4.14.1
- standard_library_default: .................................... /home/opam/.opam/4.14.1/lib/ocaml
- standard_library: ............................................ /home/opam/.opam/4.14.1/lib/ocaml
- bytecomp_c_compiler: ......................................... cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- native_c_compiler: ........................................... cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- model: ....................................................... default
- ext_obj: ..................................................... .o
- ext_asm: ..................................................... .s
- ext_lib: ..................................................... .a
- ext_dll: ..................................................... .so
- default_executable_name: ..................................... a.out
- systhread_supported: ......................................... true
- Install architecture-independent files dir: .................. /home/opam/.opam/4.14.1
- Install architecture-dependent files in dir: ................. $prefix
- User executables: ............................................ $exec_prefix/bin
- System admin executables: .................................... $exec_prefix/sbin
- Program executables: ......................................... $exec_prefix/libexec
- Read-only single-machine data: ............................... $prefix/etc
- Modifiable architecture-independent data: .................... $prefix/com
- Modifiable single-machine data: .............................. $prefix/var
- Object code libraries: ....................................... $exec_prefix/lib
- Read-only arch-independent data root: ........................ $prefix/share
- Read-only architecture-independent data: ..................... $datarootdir
- Info documentation: .......................................... $datarootdir/info
- Locale-dependent data: ....................................... $datarootdir/locale
- Man documentation: ........................................... $datarootdir/man
- Documentation root: .......................................... $datarootdir/doc/$pkg_name
- HTML documentation: .......................................... $docdir
- DVI documentation: ........................................... $docdir
- PDF documentation: ........................................... $docdir
- PS documentation: ............................................ $docdir
- findlib_version: ............................................. 1.9.6
- is_native: ................................................... true
- suffix_program: ..............................................
- Remove a file.: .............................................. rm -f
- Remove a directory.: ......................................... rm -rf
- Turn ocaml debug flag on: .................................... true
- Turn ocaml profile flag on: .................................. false
- Compiler support generation of .cmxs.: ....................... true
- OCamlbuild additional flags: .................................
- Install OASIS and base libraries, for plugins development: ... true
- Build OASIS tools for development: ........................... false
- Build test-quickstart: ....................................... true
- Build test-omake: ............................................ false
- Build test-devel: ............................................ false
- Create documentations: ....................................... true
- Compile tests executable and library and run them: ........... false
- make: ........................................................ /usr/bin/make
- ocamlmod: .................................................... /home/opam/.opam/4.14.1/bin/ocamlmod
- ocamlyacc: ................................................... /home/opam/.opam/4.14.1/bin/ocamlyacc
- ocamllex: .................................................... /home/opam/.opam/4.14.1/bin/ocamllex
- ocamlify: .................................................... /home/opam/.opam/4.14.1/bin/ocamlify
- pkg_unix: .................................................... /home/opam/.opam/4.14.1/lib/ocaml
- pkg_ocamlbuild: .............................................. /home/opam/.opam/4.14.1/lib/ocamlbuild
- ocamldoc: .................................................... /home/opam/.opam/4.14.1/bin/ocamldoc
- pkg_dynlink: ................................................. /home/opam/.opam/4.14.1/lib/ocaml
- pkg_findlib: ................................................. /home/opam/.opam/4.14.1/lib/findlib
- 
+ /home/opam/.opam/4.14.1/bin/ocaml "boot/bootstrap.ml" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/dune.3.15.3)
- ocamlc -output-complete-exe -w -24 -g -o .duneboot.exe -I boot unix.cma boot/libs.ml boot/duneboot.ml
- /tmp/camlobj83600b.c:16598:14: warning: a function declaration without a prototype is deprecated in all versions of C and is treated as a zero-parameter prototype in C2x, conflicting with a previous declaration [-Wdeprecated-non-prototype]
- extern value caml_get_public_method();
-              ^
- /home/opam/.opam/4.14.1/lib/ocaml/caml/mlvalues.h:236:18: note: conflicting prototype is here
- CAMLextern value caml_get_public_method (value obj, value tag);
-                  ^
- /tmp/camlobj83600b.c:16780:14: warning: a function declaration without a prototype is deprecated in all versions of C and is treated as a zero-parameter prototype in C2x, conflicting with a previous declaration [-Wdeprecated-non-prototype]
- extern value caml_set_oo_id();
-              ^
- /home/opam/.opam/4.14.1/lib/ocaml/caml/mlvalues.h:413:18: note: conflicting prototype is here
- CAMLextern value caml_set_oo_id(value obj);
-                  ^
- 2 warnings generated.
- ./.duneboot.exe -j 7
- cd _boot && /home/opam/.opam/4.14.1/bin/ocamlopt.opt -c -g -no-alias-deps -w -49-6 -alert -unstable -I +threads opamLocal.ml
- File "vendor/opam/src/repository/opamLocal.ml", lines 109-114, characters 46-34:
- Warning 8 [partial-match]: this pattern-matching is not exhaustive.
- Here is an example of a case that is not matched:
- Checksum_mismatch _
- File "vendor/opam/src/repository/opamLocal.ml", lines 170-189, characters 44-56:
- Warning 8 [partial-match]: this pattern-matching is not exhaustive.
- Here is an example of a case that is not matched:
- Checksum_mismatch _
- File "vendor/opam/src/repository/opamLocal.ml", lines 209-231, characters 8-44:
- Warning 8 [partial-match]: this pattern-matching is not exhaustive.
- Here is an example of a case that is not matched:
- Checksum_mismatch _
- cd _boot && /home/opam/.opam/4.14.1/bin/ocamlopt.opt -c -g -no-alias-deps -w -49-6 -alert -unstable -I +threads opamVCS.ml
- File "vendor/opam/src/repository/opamVCS.ml", lines 179-182, characters 11-40:
- Warning 8 [partial-match]: this pattern-matching is not exhaustive.
- Here is an example of a case that is not matched:
- Checksum_mismatch _
- cd _boot && /home/opam/.opam/4.14.1/bin/ocamlopt.opt -c -g -no-alias-deps -w -49-6 -alert -unstable -I +threads opamDownload.ml
- File "vendor/opam/src/repository/opamDownload.ml", lines 323-361, characters 42-41:
- Warning 8 [partial-match]: this pattern-matching is not exhaustive.
- Here is an example of a case that is not matched:
- Checksum_mismatch _
- cd _boot && /home/opam/.opam/4.14.1/bin/ocamlopt.opt -c -g -no-alias-deps -w -49-6 -alert -unstable -I +threads opamRepository.ml
- File "vendor/opam/src/repository/opamRepository.ml", lines 88-90, characters 45-77:
- Warning 8 [partial-match]: this pattern-matching is not exhaustive.
- Here is an example of a case that is not matched:
- Checksum_mismatch _
- File "vendor/opam/src/repository/opamRepository.ml", lines 277-281, characters 38-17:
- Warning 8 [partial-match]: this pattern-matching is not exhaustive.
- Here is an example of a case that is not matched:
- Checksum_mismatch _
- File "vendor/opam/src/repository/opamRepository.ml", lines 423-427, characters 12-42:
- Warning 8 [partial-match]: this pattern-matching is not exhaustive.
- Here is an example of a case that is not matched:
- (_, Checksum_mismatch _)
- 

Processing 151/346: [dune: ./_boot/dune.exe build] [oasis: ocaml setup.ml] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/.opam-switch/build/dune.3.15.3/./_boot/dune.exe "build" "dune.install" "--release" "--profile" "dune-bootstrap" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/dune.3.15.3)
-> compiled  dune.3.15.3
Processing 151/346: [oasis: ocaml setup.ml] [uucp: ocaml build]
-> installed dune.3.15.3
Processing 152/346: [oasis: ocaml setup.ml] [uucp: ocaml build]
Processing 153/346: [bigarray-compat: dune build] [oasis: ocaml setup.ml] [uucp: ocaml build]
Processing 154/346: [bigarray-compat: dune build] [cppo: dune build] [oasis: ocaml setup.ml] [uucp: ocaml build]
Processing 155/346: [bigarray-compat: dune build] [cppo: dune build] [csexp: dune build] [oasis: ocaml setup.ml] [uucp: ocaml build]
Processing 156/346: [bigarray-compat: dune build] [cppo: dune build] [csexp: dune build] [jane-street-headers: dune build] [oasis: ocaml setup.ml] [uucp: ocaml build]
Processing 157/346: [bigarray-compat: dune build] [cppo: dune build] [csexp: dune build] [jane-street-headers: dune build] [linenoise: dune build] [oasis: ocaml setup.ml] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "jane-street-headers" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/jane-street-headers.v0.14.0)
-> compiled  jane-street-headers.v0.14.0
Processing 157/346: [bigarray-compat: dune build] [cppo: dune build] [csexp: dune build] [linenoise: dune build] [oasis: ocaml setup.ml] [uucp: ocaml build]
Processing 158/346: [bigarray-compat: dune build] [cppo: dune build] [csexp: dune build] [linenoise: dune build] [oasis: ocaml setup.ml] [ocaml-compiler-libs: dune build] [uucp: ocaml build]
-> installed jane-street-headers.v0.14.0
Processing 159/346: [bigarray-compat: dune build] [cppo: dune build] [csexp: dune build] [linenoise: dune build] [oasis: ocaml setup.ml] [ocaml-compiler-libs: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "bigarray-compat" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bigarray-compat.1.1.0)
-> compiled  bigarray-compat.1.1.0
Processing 159/346: [cppo: dune build] [csexp: dune build] [linenoise: dune build] [oasis: ocaml setup.ml] [ocaml-compiler-libs: dune build] [uucp: ocaml build]
Processing 160/346: [cppo: dune build] [csexp: dune build] [linenoise: dune build] [oasis: ocaml setup.ml] [ocaml-compiler-libs: dune build] [ocaml-syntax-shims: dune build] [uucp: ocaml build]
-> installed bigarray-compat.1.1.0
Processing 161/346: [cppo: dune build] [csexp: dune build] [linenoise: dune build] [oasis: ocaml setup.ml] [ocaml-compiler-libs: dune build] [ocaml-syntax-shims: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "csexp" "-j" "7" "@install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/csexp.1.5.2)
-> compiled  csexp.1.5.2
Processing 161/346: [cppo: dune build] [linenoise: dune build] [oasis: ocaml setup.ml] [ocaml-compiler-libs: dune build] [ocaml-syntax-shims: dune build] [uucp: ocaml build]
Processing 162/346: [cppo: dune build] [linenoise: dune build] [mmap: dune build] [oasis: ocaml setup.ml] [ocaml-compiler-libs: dune build] [ocaml-syntax-shims: dune build] [uucp: ocaml build]
-> installed csexp.1.5.2
Processing 163/346: [cppo: dune build] [linenoise: dune build] [mmap: dune build] [oasis: ocaml setup.ml] [ocaml-compiler-libs: dune build] [ocaml-syntax-shims: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "mmap" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/mmap.1.2.0)
-> compiled  mmap.1.2.0
Processing 163/346: [cppo: dune build] [linenoise: dune build] [oasis: ocaml setup.ml] [ocaml-compiler-libs: dune build] [ocaml-syntax-shims: dune build] [uucp: ocaml build]
Processing 164/346: [cppo: dune build] [dune-configurator: rm] [linenoise: dune build] [oasis: ocaml setup.ml] [ocaml-compiler-libs: dune build] [ocaml-syntax-shims: dune build] [uucp: ocaml build]
-> installed mmap.1.2.0
Processing 165/346: [cppo: dune build] [dune-configurator: rm] [linenoise: dune build] [oasis: ocaml setup.ml] [ocaml-compiler-libs: dune build] [ocaml-syntax-shims: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ocaml-syntax-shims" "-j" "7" "@install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ocaml-syntax-shims.1.0.0)
-> compiled  ocaml-syntax-shims.1.0.0
Processing 165/346: [cppo: dune build] [dune-configurator: rm] [linenoise: dune build] [oasis: ocaml setup.ml] [ocaml-compiler-libs: dune build] [uucp: ocaml build]
Processing 166/346: [cppo: dune build] [dune-configurator: rm] [linenoise: dune build] [oasis: ocaml setup.ml] [ocaml-compiler-libs: dune build] [octavius: dune build] [uucp: ocaml build]
-> installed ocaml-syntax-shims.1.0.0
Processing 167/346: [cppo: dune build] [dune-configurator: rm] [linenoise: dune build] [oasis: ocaml setup.ml] [ocaml-compiler-libs: dune build] [octavius: dune build] [uucp: ocaml build]
+ /bin/rm "-rf" "vendor/csexp" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/dune-configurator.3.15.3)
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ocaml-compiler-libs" "-j" "7" "@install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ocaml-compiler-libs.v0.12.4)
-> compiled  ocaml-compiler-libs.v0.12.4
Processing 167/346: [cppo: dune build] [dune-configurator: rm] [linenoise: dune build] [oasis: ocaml setup.ml] [octavius: dune build] [uucp: ocaml build]
Processing 168/346: [cppo: dune build] [dune-configurator: rm] [linenoise: dune build] [oasis: ocaml setup.ml] [octavius: dune build] [ppx_derivers: dune build] [uucp: ocaml build]
-> installed ocaml-compiler-libs.v0.12.4
Processing 169/346: [cppo: dune build] [dune-configurator: rm] [linenoise: dune build] [oasis: ocaml setup.ml] [octavius: dune build] [ppx_derivers: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "@install" "-p" "linenoise" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/linenoise.1.5.1)
-> compiled  linenoise.1.5.1
Processing 169/346: [cppo: dune build] [dune-configurator: rm] [oasis: ocaml setup.ml] [octavius: dune build] [ppx_derivers: dune build] [uucp: ocaml build]
Processing 170/346: [cppo: dune build] [dune-configurator: rm] [oasis: ocaml setup.ml] [octavius: dune build] [ppx_derivers: dune build] [re: dune build] [uucp: ocaml build]
-> installed linenoise.1.5.1
Processing 171/346: [cppo: dune build] [dune-configurator: rm] [oasis: ocaml setup.ml] [octavius: dune build] [ppx_derivers: dune build] [re: dune build] [uucp: ocaml build]
+ /bin/rm "-rf" "vendor/pp" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/dune-configurator.3.15.3)
Processing 171/346: [cppo: dune build] [dune-configurator: dune build] [oasis: ocaml setup.ml] [octavius: dune build] [ppx_derivers: dune build] [re: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "cppo" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/cppo.1.6.9)
-> compiled  cppo.1.6.9
Processing 171/346: [dune-configurator: dune build] [oasis: ocaml setup.ml] [octavius: dune build] [ppx_derivers: dune build] [re: dune build] [uucp: ocaml build]
Processing 172/346: [dune-configurator: dune build] [oasis: ocaml setup.ml] [octavius: dune build] [ppx_derivers: dune build] [re: dune build] [result: dune build] [uucp: ocaml build]
-> installed cppo.1.6.9
Processing 173/346: [dune-configurator: dune build] [oasis: ocaml setup.ml] [octavius: dune build] [ppx_derivers: dune build] [re: dune build] [result: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "result" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/result.1.5)
-> compiled  result.1.5
Processing 173/346: [dune-configurator: dune build] [oasis: ocaml setup.ml] [octavius: dune build] [ppx_derivers: dune build] [re: dune build] [uucp: ocaml build]
Processing 174/346: [dune-configurator: dune build] [oasis: ocaml setup.ml] [ocplib-endian: dune build] [octavius: dune build] [ppx_derivers: dune build] [re: dune build] [uucp: ocaml build]
-> installed result.1.5
Processing 175/346: [dune-configurator: dune build] [oasis: ocaml setup.ml] [ocplib-endian: dune build] [octavius: dune build] [ppx_derivers: dune build] [re: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_derivers" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_derivers.1.2.1)
-> compiled  ppx_derivers.1.2.1
Processing 175/346: [dune-configurator: dune build] [oasis: ocaml setup.ml] [ocplib-endian: dune build] [octavius: dune build] [re: dune build] [uucp: ocaml build]
Processing 176/346: [dune-configurator: dune build] [oasis: ocaml setup.ml] [ocplib-endian: dune build] [octavius: dune build] [re: dune build] [sexplib0: dune build] [uucp: ocaml build]
-> installed ppx_derivers.1.2.1
Processing 177/346: [dune-configurator: dune build] [oasis: ocaml setup.ml] [ocplib-endian: dune build] [octavius: dune build] [re: dune build] [sexplib0: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ocplib-endian" "-j" "7" "@install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ocplib-endian.1.2)
-> compiled  ocplib-endian.1.2
Processing 177/346: [dune-configurator: dune build] [oasis: ocaml setup.ml] [octavius: dune build] [re: dune build] [sexplib0: dune build] [uucp: ocaml build]
Processing 178/346: [dune-configurator: dune build] [oasis: ocaml setup.ml] [octavius: dune build] [re: dune build] [sexplib0: dune build] [stdlib-shims: dune build] [uucp: ocaml build]
-> installed ocplib-endian.1.2
Processing 179/346: [dune-configurator: dune build] [oasis: ocaml setup.ml] [octavius: dune build] [re: dune build] [sexplib0: dune build] [stdlib-shims: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "octavius" "-j" "7" "@install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/octavius.1.2.2)
-> compiled  octavius.1.2.2
Processing 179/346: [dune-configurator: dune build] [oasis: ocaml setup.ml] [re: dune build] [sexplib0: dune build] [stdlib-shims: dune build] [uucp: ocaml build]
Processing 180/346: [dune-configurator: dune build] [oasis: ocaml setup.ml] [re: dune build] [sexplib0: dune build] [stdlib-shims: dune build] [stringext: dune build] [uucp: ocaml build]
-> installed octavius.1.2.2
Processing 181/346: [dune-configurator: dune build] [oasis: ocaml setup.ml] [re: dune build] [sexplib0: dune build] [stdlib-shims: dune build] [stringext: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "stdlib-shims" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/stdlib-shims.0.3.0)
-> compiled  stdlib-shims.0.3.0
Processing 181/346: [dune-configurator: dune build] [oasis: ocaml setup.ml] [re: dune build] [sexplib0: dune build] [stringext: dune build] [uucp: ocaml build]
Processing 182/346: [dune-configurator: dune build] [oasis: ocaml setup.ml] [re: dune build] [sexplib0: dune build] [stringext: dune build] [trie: dune build] [uucp: ocaml build]
-> installed stdlib-shims.0.3.0
Processing 183/346: [dune-configurator: dune build] [oasis: ocaml setup.ml] [re: dune build] [sexplib0: dune build] [stringext: dune build] [trie: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "sexplib0" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/sexplib0.v0.14.0)
- (cd _build/default && /home/opam/.opam/4.14.1/bin/ocamlc.opt -w -40 -g -bin-annot -I src/.sexplib0.objs/byte -intf-suffix .ml -no-alias-deps -open Sexplib0__ -o src/.sexplib0.objs/byte/sexplib0__Sexp_conv.cmo -c -impl src/sexp_conv.ml)
- File "src/sexp_conv.ml", line 132, characters 17-36:
- 132 |       let ephe = Ephemeron.K1.create () in
-                        ^^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Stdlib.Ephemeron.K1.create
- This function won't be available in 5.0
- File "src/sexp_conv.ml", line 133, characters 6-27:
- 133 |       Ephemeron.K1.set_data ephe sexp_of_exn;
-             ^^^^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Stdlib.Ephemeron.K1.set_data
- This function won't be available in 5.0
- File "src/sexp_conv.ml", line 134, characters 6-26:
- 134 |       Ephemeron.K1.set_key ephe extension_constructor;
-             ^^^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Stdlib.Ephemeron.K1.set_key
- This function won't be available in 5.0
- File "src/sexp_conv.ml", line 159, characters 12-33:
- 159 |       match Ephemeron.K1.get_data ephe with
-                   ^^^^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Stdlib.Ephemeron.K1.get_data
- This function won't be available in 5.0
- File "src/sexp_conv.ml", line 166, characters 12-33:
- 166 |       match Ephemeron.K1.get_data ephe with
-                   ^^^^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Stdlib.Ephemeron.K1.get_data
- This function won't be available in 5.0
- File "src/sexp_conv.ml", line 431, characters 32-46:
- 431 |         [%extension_constructor Stream.Failure],
-                                       ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/sexp_conv.ml", line 433, characters 12-26:
- 433 |           | Stream.Failure -> Atom "Stream.Failure"
-                   ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/sexp_conv.ml", line 436, characters 32-44:
- 436 |         [%extension_constructor Stream.Error],
-                                       ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/sexp_conv.ml", line 438, characters 12-24:
- 438 |           | Stream.Error arg -> List [Atom "Stream.Error"; Atom arg ]
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- (cd _build/default && /home/opam/.opam/4.14.1/bin/ocamlopt.opt -w -40 -g -I src/.sexplib0.objs/byte -I src/.sexplib0.objs/native -intf-suffix .ml -no-alias-deps -open Sexplib0__ -o src/.sexplib0.objs/native/sexplib0__Sexp_conv.cmx -c -impl src/sexp_conv.ml)
- File "src/sexp_conv.ml", line 132, characters 17-36:
- 132 |       let ephe = Ephemeron.K1.create () in
-                        ^^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Stdlib.Ephemeron.K1.create
- This function won't be available in 5.0
- File "src/sexp_conv.ml", line 133, characters 6-27:
- 133 |       Ephemeron.K1.set_data ephe sexp_of_exn;
-             ^^^^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Stdlib.Ephemeron.K1.set_data
- This function won't be available in 5.0
- File "src/sexp_conv.ml", line 134, characters 6-26:
- 134 |       Ephemeron.K1.set_key ephe extension_constructor;
-             ^^^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Stdlib.Ephemeron.K1.set_key
- This function won't be available in 5.0
- File "src/sexp_conv.ml", line 159, characters 12-33:
- 159 |       match Ephemeron.K1.get_data ephe with
-                   ^^^^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Stdlib.Ephemeron.K1.get_data
- This function won't be available in 5.0
- File "src/sexp_conv.ml", line 166, characters 12-33:
- 166 |       match Ephemeron.K1.get_data ephe with
-                   ^^^^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Stdlib.Ephemeron.K1.get_data
- This function won't be available in 5.0
- File "src/sexp_conv.ml", line 431, characters 32-46:
- 431 |         [%extension_constructor Stream.Failure],
-                                       ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/sexp_conv.ml", line 433, characters 12-26:
- 433 |           | Stream.Failure -> Atom "Stream.Failure"
-                   ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/sexp_conv.ml", line 436, characters 32-44:
- 436 |         [%extension_constructor Stream.Error],
-                                       ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/sexp_conv.ml", line 438, characters 12-24:
- 438 |           | Stream.Error arg -> List [Atom "Stream.Error"; Atom arg ]
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
-> compiled  sexplib0.v0.14.0
Processing 183/346: [dune-configurator: dune build] [oasis: ocaml setup.ml] [re: dune build] [stringext: dune build] [trie: dune build] [uucp: ocaml build]
Processing 184/346: [dune-configurator: dune build] [fileutils: dune build] [oasis: ocaml setup.ml] [re: dune build] [stringext: dune build] [trie: dune build] [uucp: ocaml build]
-> installed sexplib0.v0.14.0
Processing 185/346: [dune-configurator: dune build] [fileutils: dune build] [oasis: ocaml setup.ml] [re: dune build] [stringext: dune build] [trie: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "stringext" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/stringext.1.6.0)
-> compiled  stringext.1.6.0
Processing 185/346: [dune-configurator: dune build] [fileutils: dune build] [oasis: ocaml setup.ml] [re: dune build] [trie: dune build] [uucp: ocaml build]
Processing 186/346: [dune-configurator: dune build] [fileutils: dune build] [oasis: ocaml setup.ml] [ocamlgraph: dune build] [re: dune build] [trie: dune build] [uucp: ocaml build]
-> installed stringext.1.6.0
Processing 187/346: [dune-configurator: dune build] [fileutils: dune build] [oasis: ocaml setup.ml] [ocamlgraph: dune build] [re: dune build] [trie: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "trie" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/trie.1.0.0)
-> compiled  trie.1.0.0
Processing 187/346: [dune-configurator: dune build] [fileutils: dune build] [oasis: ocaml setup.ml] [ocamlgraph: dune build] [re: dune build] [uucp: ocaml build]
Processing 188/346: [dune-configurator: dune build] [fileutils: dune build] [oasis: ocaml setup.ml] [ocamlgraph: dune build] [ppxlib: dune build] [re: dune build] [uucp: ocaml build]
-> installed trie.1.0.0
Processing 189/346: [dune-configurator: dune build] [fileutils: dune build] [oasis: ocaml setup.ml] [ocamlgraph: dune build] [ppxlib: dune build] [re: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "re" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/re.1.11.0)
-> compiled  re.1.11.0
Processing 189/346: [dune-configurator: dune build] [fileutils: dune build] [oasis: ocaml setup.ml] [ocamlgraph: dune build] [ppxlib: dune build] [uucp: ocaml build]
Processing 190/346: [dune-configurator: dune build] [fileutils: dune build] [mew: dune build] [oasis: ocaml setup.ml] [ocamlgraph: dune build] [ppxlib: dune build] [uucp: ocaml build]
-> installed re.1.11.0
Processing 191/346: [dune-configurator: dune build] [fileutils: dune build] [mew: dune build] [oasis: ocaml setup.ml] [ocamlgraph: dune build] [ppxlib: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "dune-configurator" "-j" "7" "@install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/dune-configurator.3.15.3)
-> compiled  dune-configurator.3.15.3
Processing 191/346: [fileutils: dune build] [mew: dune build] [oasis: ocaml setup.ml] [ocamlgraph: dune build] [ppxlib: dune build] [uucp: ocaml build]
Processing 192/346: [fileutils: dune build] [mew: dune build] [oasis: ocaml setup.ml] [ocamlgraph: dune build] [ppxlib: dune build] [uucp: ocaml build] [xdg: rm]
-> installed dune-configurator.3.15.3
Processing 193/346: [fileutils: dune build] [mew: dune build] [oasis: ocaml setup.ml] [ocamlgraph: dune build] [ppxlib: dune build] [uucp: ocaml build] [xdg: rm]
+ /bin/rm "-rf" "vendor/csexp" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/xdg.3.15.3)
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "mew" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/mew.0.1.0)
-> compiled  mew.0.1.0
Processing 193/346: [fileutils: dune build] [oasis: ocaml setup.ml] [ocamlgraph: dune build] [ppxlib: dune build] [uucp: ocaml build] [xdg: rm]
Processing 194/346: [base: dune build] [fileutils: dune build] [oasis: ocaml setup.ml] [ocamlgraph: dune build] [ppxlib: dune build] [uucp: ocaml build] [xdg: rm]
-> installed mew.0.1.0
Processing 195/346: [base: dune build] [fileutils: dune build] [oasis: ocaml setup.ml] [ocamlgraph: dune build] [ppxlib: dune build] [uucp: ocaml build] [xdg: rm]
+ /bin/rm "-rf" "vendor/pp" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/xdg.3.15.3)
Processing 195/346: [base: dune build] [fileutils: dune build] [oasis: ocaml setup.ml] [ocamlgraph: dune build] [ppxlib: dune build] [uucp: ocaml build] [xdg: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "fileutils" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/fileutils.0.6.4)
-> compiled  fileutils.0.6.4
Processing 195/346: [base: dune build] [oasis: ocaml setup.ml] [ocamlgraph: dune build] [ppxlib: dune build] [uucp: ocaml build] [xdg: dune build]
Processing 196/346: [base: dune build] [bigstringaf: dune build] [oasis: ocaml setup.ml] [ocamlgraph: dune build] [ppxlib: dune build] [uucp: ocaml build] [xdg: dune build]
-> installed fileutils.0.6.4
Processing 197/346: [base: dune build] [bigstringaf: dune build] [oasis: ocaml setup.ml] [ocamlgraph: dune build] [ppxlib: dune build] [uucp: ocaml build] [xdg: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ocamlgraph" "-j" "7" "@install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ocamlgraph.2.1.0)
-> compiled  ocamlgraph.2.1.0
Processing 197/346: [base: dune build] [bigstringaf: dune build] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build] [xdg: dune build]
Processing 198/346: [base: dune build] [bigstringaf: dune build] [lwt: dune exec] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build] [xdg: dune build]
-> installed ocamlgraph.2.1.0
Processing 199/346: [base: dune build] [bigstringaf: dune build] [lwt: dune exec] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build] [xdg: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "bigstringaf" "-j" "7" "@install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bigstringaf.0.9.1)
-> compiled  bigstringaf.0.9.1
Processing 199/346: [base: dune build] [lwt: dune exec] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build] [xdg: dune build]
Processing 200/346: [base: dune build] [lwt: dune exec] [mew_vi: dune build] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build] [xdg: dune build]
-> installed bigstringaf.0.9.1
Processing 201/346: [base: dune build] [lwt: dune exec] [mew_vi: dune build] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build] [xdg: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "xdg" "-j" "7" "@install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/xdg.3.15.3)
-> compiled  xdg.3.15.3
Processing 201/346: [base: dune build] [lwt: dune exec] [mew_vi: dune build] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build]
Processing 202/346: [angstrom: dune build] [base: dune build] [lwt: dune exec] [mew_vi: dune build] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build]
-> installed xdg.3.15.3
Processing 203/346: [angstrom: dune build] [base: dune build] [lwt: dune exec] [mew_vi: dune build] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "mew_vi" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/mew_vi.0.5.0)
-> compiled  mew_vi.0.5.0
Processing 203/346: [angstrom: dune build] [base: dune build] [lwt: dune exec] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build]
-> installed mew_vi.0.5.0
Processing 204/346: [angstrom: dune build] [base: dune build] [lwt: dune exec] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "angstrom" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/angstrom.0.16.0)
-> compiled  angstrom.0.16.0
Processing 204/346: [base: dune build] [lwt: dune exec] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build]
-> installed angstrom.0.16.0
Processing 205/346: [base: dune build] [lwt: dune exec] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build]
Processing 206/346: [base: dune build] [lwt: dune exec] [oasis: ocaml setup.ml] [ppxlib: dune build] [uri: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "exec" "-p" "lwt" "src/unix/config/discover.exe" "--" "--save" "--use-libev" "false" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/lwt.5.7.0)
Processing 206/346: [base: dune build] [lwt: dune build] [oasis: ocaml setup.ml] [ppxlib: dune build] [uri: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "uri" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/uri.4.4.0)
-> compiled  uri.4.4.0
Processing 206/346: [base: dune build] [lwt: dune build] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build]
-> installed uri.4.4.0
Processing 207/346: [base: dune build] [lwt: dune build] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "lwt" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/lwt.5.7.0)
- (cd _build/default && /home/opam/.opam/4.14.1/bin/ocamlc.opt -w -40 -w +A-29 -g -bin-annot -I src/core/.lwt.objs/byte -intf-suffix .ml -no-alias-deps -o src/core/.lwt.objs/byte/lwt_stream.cmo -c -impl src/core/lwt_stream.ml)
- File "src/core/lwt_stream.ml", line 46, characters 2-55:
- 46 |   mutable push_external : Obj.t [@ocaml.warning "-69"];
-        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 69 [unused-field]: record field push_external is never read.
- (However, this field is used to build or mutate values.)
- File "src/core/lwt_stream.ml", line 67, characters 2-56:
- 67 |   mutable pushb_external : Obj.t [@ocaml.warning "-69"];
-        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 69 [unused-field]: record field pushb_external is never read.
- (However, this field is used to build or mutate values.)
- (cd _build/default && /home/opam/.opam/4.14.1/bin/ocamlopt.opt -w -40 -w +A-29 -g -I src/core/.lwt.objs/byte -I src/core/.lwt.objs/native -intf-suffix .ml -no-alias-deps -o src/core/.lwt.objs/native/lwt_stream.cmx -c -impl src/core/lwt_stream.ml)
- File "src/core/lwt_stream.ml", line 46, characters 2-55:
- 46 |   mutable push_external : Obj.t [@ocaml.warning "-69"];
-        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 69 [unused-field]: record field push_external is never read.
- (However, this field is used to build or mutate values.)
- File "src/core/lwt_stream.ml", line 67, characters 2-56:
- 67 |   mutable pushb_external : Obj.t [@ocaml.warning "-69"];
-        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 69 [unused-field]: record field pushb_external is never read.
- (However, this field is used to build or mutate values.)
-> compiled  lwt.5.7.0
Processing 207/346: [base: dune build] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build]
-> installed lwt.5.7.0
Processing 208/346: [base: dune build] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build]
Processing 209/346: [base: dune build] [logs: ocaml build] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build]
Processing 210/346: [base: dune build] [logs: ocaml build] [lwt_react: dune build] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "lwt_react" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/lwt_react.1.2.0)
-> compiled  lwt_react.1.2.0
Processing 210/346: [base: dune build] [logs: ocaml build] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build]
-> installed lwt_react.1.2.0
Processing 211/346: [base: dune build] [logs: ocaml build] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/ocaml "pkg/pkg.ml" "build" "--pinned" "false" "--with-js_of_ocaml" "false" "--with-fmt" "false" "--with-cmdliner" "true" "--with-lwt" "true" "--with-base-threads" "true" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/logs.0.7.0)
- ocamlfind ocamldep -modules src/logs.ml > src/logs.ml.depends
- ocamlfind ocamldep -modules src/logs.mli > src/logs.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/logs.cmi src/logs.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/logs.cmx src/logs.ml
- ocamlfind ocamlopt -a -I src src/logs.cmx -o src/logs.cmxa
- ocamlfind ocamlopt -shared -linkall -I src src/logs.cmxa -o src/logs.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/logs.cmo src/logs.ml
- ocamlfind ocamlc -a -I src src/logs.cmo -o src/logs.cma
- ocamlfind ocamldep -package cmdliner -modules src/logs_cli.ml > src/logs_cli.ml.depends
- ocamlfind ocamldep -package cmdliner -modules src/logs_cli.mli > src/logs_cli.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package cmdliner -I src -I test -o src/logs_cli.cmi src/logs_cli.mli
- + ocamlfind ocamlc -c -g -bin-annot -safe-string -package cmdliner -I src -I test -o src/logs_cli.cmi src/logs_cli.mli
- File "src/logs_cli.mli", line 15, characters 17-33:
- 15 | val level : ?env:Cmdliner.Arg.env -> ?docs:string -> unit ->
-                       ^^^^^^^^^^^^^^^^
- Alert deprecated: Cmdliner.Arg.env
- Use Cmd.Env.info instead.
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package cmdliner -I src -I test -o src/logs_cli.cmx src/logs_cli.ml
- ocamlfind ocamlopt -a -package cmdliner -I src src/logs_cli.cmx -o src/logs_cli.cmxa
- ocamlfind ocamlopt -shared -linkall -package cmdliner -I src src/logs_cli.cmxa -o src/logs_cli.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package cmdliner -I src -I test -o src/logs_cli.cmo src/logs_cli.ml
- ocamlfind ocamlc -a -package cmdliner -I src src/logs_cli.cmo -o src/logs_cli.cma
- ocamlfind ocamldep -package lwt -modules src/logs_lwt.ml > src/logs_lwt.ml.depends
- ocamlfind ocamldep -package lwt -modules src/logs_lwt.mli > src/logs_lwt.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package lwt -I src -I test -o src/logs_lwt.cmi src/logs_lwt.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package lwt -I src -I test -o src/logs_lwt.cmx src/logs_lwt.ml
- ocamlfind ocamlopt -a -package lwt -I src src/logs_lwt.cmx -o src/logs_lwt.cmxa
- ocamlfind ocamlopt -shared -linkall -package lwt -I src src/logs_lwt.cmxa -o src/logs_lwt.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package lwt -I src -I test -o src/logs_lwt.cmo src/logs_lwt.ml
- ocamlfind ocamlc -a -package lwt -I src src/logs_lwt.cmo -o src/logs_lwt.cma
- ocamlfind ocamldep -package threads -modules src/logs_threaded.ml > src/logs_threaded.ml.depends
- ocamlfind ocamldep -package threads -modules src/logs_threaded.mli > src/logs_threaded.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -thread -package threads -I src -I test -o src/logs_threaded.cmi src/logs_threaded.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -thread -package threads -I src -I test -o src/logs_threaded.cmx src/logs_threaded.ml
- ocamlfind ocamlopt -a -thread -package threads -I src src/logs_threaded.cmx -o src/logs_threaded.cmxa
- ocamlfind ocamlopt -shared -linkall -thread -package threads -I src src/logs_threaded.cmxa -o src/logs_threaded.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -thread -package threads -I src -I test -o src/logs_threaded.cmo src/logs_threaded.ml
- ocamlfind ocamlc -a -thread -package threads -I src src/logs_threaded.cmo -o src/logs_threaded.cma
- # No parallelism done
-> compiled  logs.0.7.0
Processing 211/346: [base: dune build] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build]
-> installed logs.0.7.0
Processing 212/346: [base: dune build] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "base" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/base.v0.14.3)
-> compiled  base.v0.14.3
Processing 212/346: [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build]
-> installed base.v0.14.3
Processing 213/346: [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build]
Processing 214/346: [fieldslib: dune build] [oasis: ocaml setup.ml] [ppxlib: dune build] [uucp: ocaml build]
Processing 215/346: [fieldslib: dune build] [oasis: ocaml setup.ml] [parsexp: dune build] [ppxlib: dune build] [uucp: ocaml build]
Processing 216/346: [fieldslib: dune build] [oasis: ocaml setup.ml] [parsexp: dune build] [ppxlib: dune build] [stdio: dune build] [uucp: ocaml build]
Processing 217/346: [fieldslib: dune build] [oasis: ocaml setup.ml] [parsexp: dune build] [ppxlib: dune build] [stdio: dune build] [typerep: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "fieldslib" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/fieldslib.v0.14.0)
-> compiled  fieldslib.v0.14.0
Processing 217/346: [oasis: ocaml setup.ml] [parsexp: dune build] [ppxlib: dune build] [stdio: dune build] [typerep: dune build] [uucp: ocaml build]
Processing 218/346: [oasis: ocaml setup.ml] [parsexp: dune build] [ppxlib: dune build] [stdio: dune build] [typerep: dune build] [uucp: ocaml build] [variantslib: dune build]
-> installed fieldslib.v0.14.0
Processing 219/346: [oasis: ocaml setup.ml] [parsexp: dune build] [ppxlib: dune build] [stdio: dune build] [typerep: dune build] [uucp: ocaml build] [variantslib: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "stdio" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/stdio.v0.14.0)
-> compiled  stdio.v0.14.0
Processing 219/346: [oasis: ocaml setup.ml] [parsexp: dune build] [ppxlib: dune build] [typerep: dune build] [uucp: ocaml build] [variantslib: dune build]
-> installed stdio.v0.14.0
Processing 220/346: [oasis: ocaml setup.ml] [parsexp: dune build] [ppxlib: dune build] [typerep: dune build] [uucp: ocaml build] [variantslib: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "variantslib" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/variantslib.v0.14.0)
-> compiled  variantslib.v0.14.0
Processing 220/346: [oasis: ocaml setup.ml] [parsexp: dune build] [ppxlib: dune build] [typerep: dune build] [uucp: ocaml build]
-> installed variantslib.v0.14.0
Processing 221/346: [oasis: ocaml setup.ml] [parsexp: dune build] [ppxlib: dune build] [typerep: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "typerep" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/typerep.v0.14.0)
-> compiled  typerep.v0.14.0
Processing 221/346: [oasis: ocaml setup.ml] [parsexp: dune build] [ppxlib: dune build] [uucp: ocaml build]
-> installed typerep.v0.14.0
Processing 222/346: [oasis: ocaml setup.ml] [parsexp: dune build] [ppxlib: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppxlib" "-j" "7" "@install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppxlib.0.25.1)
-> compiled  ppxlib.0.25.1
Processing 222/346: [oasis: ocaml setup.ml] [parsexp: dune build] [uucp: ocaml build]
-> installed ppxlib.0.25.1
Processing 223/346: [oasis: ocaml setup.ml] [parsexp: dune build] [uucp: ocaml build]
Processing 224/346: [oasis: ocaml setup.ml] [parsexp: dune build] [ppx_cold: dune build] [uucp: ocaml build]
Processing 225/346: [oasis: ocaml setup.ml] [parsexp: dune build] [ppx_cold: dune build] [ppx_compare: dune build] [uucp: ocaml build]
Processing 226/346: [oasis: ocaml setup.ml] [parsexp: dune build] [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [uucp: ocaml build]
Processing 227/346: [oasis: ocaml setup.ml] [parsexp: dune build] [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "parsexp" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/parsexp.v0.14.2)
-> compiled  parsexp.v0.14.2
Processing 227/346: [oasis: ocaml setup.ml] [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [uucp: ocaml build]
Processing 228/346: [oasis: ocaml setup.ml] [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [uucp: ocaml build]
-> installed parsexp.v0.14.2
Processing 229/346: [oasis: ocaml setup.ml] [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_cold" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_cold.v0.14.0)
-> compiled  ppx_cold.v0.14.0
Processing 229/346: [oasis: ocaml setup.ml] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [uucp: ocaml build]
Processing 230/346: [oasis: ocaml setup.ml] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [uucp: ocaml build]
-> installed ppx_cold.v0.14.0
Processing 231/346: [oasis: ocaml setup.ml] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_fields_conv" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_fields_conv.v0.14.2)
-> compiled  ppx_fields_conv.v0.14.2
Processing 231/346: [oasis: ocaml setup.ml] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [uucp: ocaml build]
Processing 232/346: [oasis: ocaml setup.ml] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [uucp: ocaml build]
-> installed ppx_fields_conv.v0.14.2
Processing 233/346: [oasis: ocaml setup.ml] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_compare" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_compare.v0.14.0)
-> compiled  ppx_compare.v0.14.0
Processing 233/346: [oasis: ocaml setup.ml] [ppx_enumerate: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [uucp: ocaml build]
Processing 234/346: [oasis: ocaml setup.ml] [ppx_enumerate: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [uucp: ocaml build]
-> installed ppx_compare.v0.14.0
Processing 235/346: [oasis: ocaml setup.ml] [ppx_enumerate: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_fixed_literal" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_fixed_literal.v0.14.0)
-> compiled  ppx_fixed_literal.v0.14.0
Processing 235/346: [oasis: ocaml setup.ml] [ppx_enumerate: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [uucp: ocaml build]
Processing 236/346: [oasis: ocaml setup.ml] [ppx_enumerate: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build] [uucp: ocaml build]
-> installed ppx_fixed_literal.v0.14.0
Processing 237/346: [oasis: ocaml setup.ml] [ppx_enumerate: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_enumerate" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_enumerate.v0.14.0)
-> compiled  ppx_enumerate.v0.14.0
Processing 237/346: [oasis: ocaml setup.ml] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build] [uucp: ocaml build]
Processing 238/346: [oasis: ocaml setup.ml] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [uucp: ocaml build]
-> installed ppx_enumerate.v0.14.0
Processing 239/346: [oasis: ocaml setup.ml] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [uucp: ocaml build]
+ /home/opam/.opam/4.14.1/bin/ocaml "pkg/pkg.ml" "build" "--dev-pkg" "false" "--with-uunf" "false" "--with-cmdliner" "true" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/uucp.15.1.0)
- ocamlfind ocamldep -modules src/uucp.ml > src/uucp.ml.depends
- ocamlfind ocamldep -modules src/uucp.mli > src/uucp.mli.depends
- ocamlfind ocamldep -modules src/uucp__age.mli > src/uucp__age.mli.depends
- ocamlfind ocamldep -modules src/uucp__alpha.mli > src/uucp__alpha.mli.depends
- ocamlfind ocamldep -modules src/uucp__block.mli > src/uucp__block.mli.depends
- ocamlfind ocamldep -modules src/uucp__break.mli > src/uucp__break.mli.depends
- ocamlfind ocamldep -modules src/uucp__case.mli > src/uucp__case.mli.depends
- ocamlfind ocamldep -modules src/uucp__case_fold.mli > src/uucp__case_fold.mli.depends
- ocamlfind ocamldep -modules src/uucp__case_map.mli > src/uucp__case_map.mli.depends
- ocamlfind ocamldep -modules src/uucp__case_nfkc.mli > src/uucp__case_nfkc.mli.depends
- ocamlfind ocamldep -modules src/uucp__case_nfkc_simple.mli > src/uucp__case_nfkc_simple.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__case_fold.cmi src/uucp__case_fold.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__case_map.cmi src/uucp__case_map.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__case_nfkc.cmi src/uucp__case_nfkc.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__case_nfkc_simple.cmi src/uucp__case_nfkc_simple.mli
- ocamlfind ocamldep -modules src/uucp__cjk.mli > src/uucp__cjk.mli.depends
- ocamlfind ocamldep -modules src/uucp__emoji.mli > src/uucp__emoji.mli.depends
- ocamlfind ocamldep -modules src/uucp__func.mli > src/uucp__func.mli.depends
- ocamlfind ocamldep -modules src/uucp__gc.mli > src/uucp__gc.mli.depends
- ocamlfind ocamldep -modules src/uucp__gen.mli > src/uucp__gen.mli.depends
- ocamlfind ocamldep -modules src/uucp__hangul.mli > src/uucp__hangul.mli.depends
- ocamlfind ocamldep -modules src/uucp__id.mli > src/uucp__id.mli.depends
- ocamlfind ocamldep -modules src/uucp__name.mli > src/uucp__name.mli.depends
- ocamlfind ocamldep -modules src/uucp__num.mli > src/uucp__num.mli.depends
- ocamlfind ocamldep -modules src/uucp__script.mli > src/uucp__script.mli.depends
- ocamlfind ocamldep -modules src/uucp__white.mli > src/uucp__white.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__age.cmi src/uucp__age.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__alpha.cmi src/uucp__alpha.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__block.cmi src/uucp__block.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__break.cmi src/uucp__break.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__case.cmi src/uucp__case.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__cjk.cmi src/uucp__cjk.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__emoji.cmi src/uucp__emoji.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__func.cmi src/uucp__func.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__gc.cmi src/uucp__gc.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__gen.cmi src/uucp__gen.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__hangul.cmi src/uucp__hangul.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__id.cmi src/uucp__id.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__name.cmi src/uucp__name.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__num.cmi src/uucp__num.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__script.cmi src/uucp__script.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__white.cmi src/uucp__white.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp.cmi src/uucp.mli
- ocamlfind ocamldep -modules src/uucp__age.ml > src/uucp__age.ml.depends
- ocamlfind ocamldep -modules src/uucp_age_data.ml > src/uucp_age_data.ml.depends
- ocamlfind ocamldep -modules src/uucp_rmap.ml > src/uucp_rmap.ml.depends
- ocamlfind ocamldep -modules src/uucp_fmt.ml > src/uucp_fmt.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_fmt.cmo src/uucp_fmt.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_rmap.cmo src/uucp_rmap.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_age_data.cmo src/uucp_age_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_fmt.cmx src/uucp_fmt.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_rmap.cmx src/uucp_rmap.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_age_data.cmx src/uucp_age_data.ml
- ocamlfind ocamldep -modules src/uucp__alpha.ml > src/uucp__alpha.ml.depends
- ocamlfind ocamldep -modules src/uucp_alpha_data.ml > src/uucp_alpha_data.ml.depends
- ocamlfind ocamldep -modules src/uucp_tmapbool.ml > src/uucp_tmapbool.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_tmapbool.cmo src/uucp_tmapbool.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_alpha_data.cmo src/uucp_alpha_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_tmapbool.cmx src/uucp_tmapbool.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_alpha_data.cmx src/uucp_alpha_data.ml
- ocamlfind ocamldep -modules src/uucp__block.ml > src/uucp__block.ml.depends
- ocamlfind ocamldep -modules src/uucp_block_base.ml > src/uucp_block_base.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_block_base.cmo src/uucp_block_base.ml
- ocamlfind ocamldep -modules src/uucp_block_data.ml > src/uucp_block_data.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_block_data.cmo src/uucp_block_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_block_base.cmx src/uucp_block_base.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_block_data.cmx src/uucp_block_data.ml
- ocamlfind ocamldep -modules src/uucp__break.ml > src/uucp__break.ml.depends
- ocamlfind ocamldep -modules src/uucp__gc.ml > src/uucp__gc.ml.depends
- ocamlfind ocamldep -modules src/uucp_gc_base.ml > src/uucp_gc_base.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_gc_base.cmo src/uucp_gc_base.ml
- ocamlfind ocamldep -modules src/uucp_gc_data.ml > src/uucp_gc_data.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_gc_data.cmo src/uucp_gc_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_gc_base.cmx src/uucp_gc_base.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_gc_data.cmx src/uucp_gc_data.ml
- ocamlfind ocamldep -modules src/uucp_break_base.ml > src/uucp_break_base.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_break_base.cmo src/uucp_break_base.ml
- ocamlfind ocamldep -modules src/uucp_break_data.ml > src/uucp_break_data.ml.depends
- ocamlfind ocamldep -modules src/uucp_tmapbyte.ml > src/uucp_tmapbyte.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_tmapbyte.cmo src/uucp_tmapbyte.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_break_data.cmo src/uucp_break_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_break_base.cmx src/uucp_break_base.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_tmapbyte.cmx src/uucp_tmapbyte.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__gc.cmx src/uucp__gc.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_break_data.cmx src/uucp_break_data.ml
- ocamlfind ocamldep -modules src/uucp__case.ml > src/uucp__case.ml.depends
- ocamlfind ocamldep -modules src/uucp__case_fold.ml > src/uucp__case_fold.ml.depends
- ocamlfind ocamldep -modules src/uucp_case_fold_data.ml > src/uucp_case_fold_data.ml.depends
- ocamlfind ocamldep -modules src/uucp_tmap.ml > src/uucp_tmap.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_tmap.cmo src/uucp_tmap.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_case_fold_data.cmo src/uucp_case_fold_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_tmap.cmx src/uucp_tmap.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_case_fold_data.cmx src/uucp_case_fold_data.ml
- ocamlfind ocamldep -modules src/uucp__case_map.ml > src/uucp__case_map.ml.depends
- ocamlfind ocamldep -modules src/uucp_case_map_data.ml > src/uucp_case_map_data.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_case_map_data.cmo src/uucp_case_map_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_case_map_data.cmx src/uucp_case_map_data.ml
- ocamlfind ocamldep -modules src/uucp__case_nfkc.ml > src/uucp__case_nfkc.ml.depends
- ocamlfind ocamldep -modules src/uucp_case_nfkc_data.ml > src/uucp_case_nfkc_data.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_case_nfkc_data.cmo src/uucp_case_nfkc_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_case_nfkc_data.cmx src/uucp_case_nfkc_data.ml
- ocamlfind ocamldep -modules src/uucp__case_nfkc_simple.ml > src/uucp__case_nfkc_simple.ml.depends
- ocamlfind ocamldep -modules src/uucp_case_nfkc_simple_data.ml > src/uucp_case_nfkc_simple_data.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_case_nfkc_simple_data.cmo src/uucp_case_nfkc_simple_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_case_nfkc_simple_data.cmx src/uucp_case_nfkc_simple_data.ml
- ocamlfind ocamldep -modules src/uucp_case_data.ml > src/uucp_case_data.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_case_data.cmo src/uucp_case_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__case_fold.cmx src/uucp__case_fold.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__case_map.cmx src/uucp__case_map.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__case_nfkc.cmx src/uucp__case_nfkc.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__case_nfkc_simple.cmx src/uucp__case_nfkc_simple.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_case_data.cmx src/uucp_case_data.ml
- ocamlfind ocamldep -modules src/uucp__cjk.ml > src/uucp__cjk.ml.depends
- ocamlfind ocamldep -modules src/uucp_cjk_data.ml > src/uucp_cjk_data.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_cjk_data.cmo src/uucp_cjk_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_cjk_data.cmx src/uucp_cjk_data.ml
- ocamlfind ocamldep -modules src/uucp__emoji.ml > src/uucp__emoji.ml.depends
- ocamlfind ocamldep -modules src/uucp_emoji_data.ml > src/uucp_emoji_data.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_emoji_data.cmo src/uucp_emoji_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_emoji_data.cmx src/uucp_emoji_data.ml
- ocamlfind ocamldep -modules src/uucp__func.ml > src/uucp__func.ml.depends
- ocamlfind ocamldep -modules src/uucp_func_data.ml > src/uucp_func_data.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_func_data.cmo src/uucp_func_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_func_data.cmx src/uucp_func_data.ml
- ocamlfind ocamldep -modules src/uucp__gen.ml > src/uucp__gen.ml.depends
- ocamlfind ocamldep -modules src/uucp_gen_data.ml > src/uucp_gen_data.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_gen_data.cmo src/uucp_gen_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_gen_data.cmx src/uucp_gen_data.ml
- ocamlfind ocamldep -modules src/uucp__hangul.ml > src/uucp__hangul.ml.depends
- ocamlfind ocamldep -modules src/uucp_hangul_base.ml > src/uucp_hangul_base.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_hangul_base.cmo src/uucp_hangul_base.ml
- ocamlfind ocamldep -modules src/uucp_hangul_data.ml > src/uucp_hangul_data.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_hangul_data.cmo src/uucp_hangul_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_hangul_base.cmx src/uucp_hangul_base.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_hangul_data.cmx src/uucp_hangul_data.ml
- ocamlfind ocamldep -modules src/uucp__id.ml > src/uucp__id.ml.depends
- ocamlfind ocamldep -modules src/uucp_id_data.ml > src/uucp_id_data.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_id_data.cmo src/uucp_id_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_id_data.cmx src/uucp_id_data.ml
- ocamlfind ocamldep -modules src/uucp__name.ml > src/uucp__name.ml.depends
- ocamlfind ocamldep -modules src/uucp_cmap.ml > src/uucp_cmap.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_cmap.cmo src/uucp_cmap.ml
- ocamlfind ocamldep -modules src/uucp_name_base.ml > src/uucp_name_base.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_name_base.cmo src/uucp_name_base.ml
- ocamlfind ocamldep -modules src/uucp_name_data.ml > src/uucp_name_data.ml.depends
- ocamlfind ocamldep -modules src/uucp_tmap5bytes.ml > src/uucp_tmap5bytes.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_tmap5bytes.cmo src/uucp_tmap5bytes.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_name_data.cmo src/uucp_name_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_cmap.cmx src/uucp_cmap.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_name_base.cmx src/uucp_name_base.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_tmap5bytes.cmx src/uucp_tmap5bytes.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_name_data.cmx src/uucp_name_data.ml
- ocamlfind ocamldep -modules src/uucp__num.ml > src/uucp__num.ml.depends
- ocamlfind ocamldep -modules src/uucp_num_base.ml > src/uucp_num_base.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_num_base.cmo src/uucp_num_base.ml
- ocamlfind ocamldep -modules src/uucp_num_data.ml > src/uucp_num_data.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_num_data.cmo src/uucp_num_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_num_base.cmx src/uucp_num_base.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_num_data.cmx src/uucp_num_data.ml
- ocamlfind ocamldep -modules src/uucp__script.ml > src/uucp__script.ml.depends
- ocamlfind ocamldep -modules src/uucp_script_base.ml > src/uucp_script_base.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_script_base.cmo src/uucp_script_base.ml
- ocamlfind ocamldep -modules src/uucp_script_data.ml > src/uucp_script_data.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_script_data.cmo src/uucp_script_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_script_base.cmx src/uucp_script_base.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_script_data.cmx src/uucp_script_data.ml
- ocamlfind ocamldep -modules src/uucp__white.ml > src/uucp__white.ml.depends
- ocamlfind ocamldep -modules src/uucp_white_data.ml > src/uucp_white_data.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_white_data.cmo src/uucp_white_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_white_data.cmx src/uucp_white_data.ml
- ocamlfind ocamldep -modules src/uucp_version_data.ml > src/uucp_version_data.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_version_data.cmo src/uucp_version_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__age.cmx src/uucp__age.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__alpha.cmx src/uucp__alpha.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__block.cmx src/uucp__block.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__break.cmx src/uucp__break.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__case.cmx src/uucp__case.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__cjk.cmx src/uucp__cjk.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__emoji.cmx src/uucp__emoji.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__func.cmx src/uucp__func.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__gen.cmx src/uucp__gen.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__hangul.cmx src/uucp__hangul.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__id.cmx src/uucp__id.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__name.cmx src/uucp__name.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__num.cmx src/uucp__num.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__script.cmx src/uucp__script.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__white.cmx src/uucp__white.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp_version_data.cmx src/uucp_version_data.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp.cmx src/uucp.ml
- ocamlfind ocamlopt -a -I src src/uucp_fmt.cmx src/uucp_rmap.cmx src/uucp_age_data.cmx src/uucp__age.cmx src/uucp_tmapbool.cmx src/uucp_alpha_data.cmx src/uucp__alpha.cmx src/uucp_block_base.cmx src/uucp_block_data.cmx src/uucp__block.cmx src/uucp_gc_base.cmx src/uucp_gc_data.cmx src/uucp__gc.cmx src/uucp_break_base.cmx src/uucp_tmapbyte.cmx src/uucp_break_data.cmx src/uucp__break.cmx src/uucp_tmap.cmx src/uucp_case_fold_data.cmx src/uucp__case_fold.cmx src/uucp_case_map_data.cmx src/uucp__case_map.cmx src/uucp_case_nfkc_data.cmx src/uucp__case_nfkc.cmx src/uucp_case_nfkc_simple_data.cmx src/uucp__case_nfkc_simple.cmx src/uucp_case_data.cmx src/uucp__case.cmx src/uucp_cjk_data.cmx src/uucp__cjk.cmx src/uucp_emoji_data.cmx src/uucp__emoji.cmx src/uucp_func_data.cmx src/uucp__func.cmx src/uucp_gen_data.cmx src/uucp__gen.cmx src/uucp_hangul_base.cmx src/uucp_hangul_data.cmx src/uucp__hangul.cmx src/uucp_id_data.cmx src/uucp__id.cmx src/uucp_cmap.cmx src/uucp_name_base.cmx src/uucp_tmap5bytes.cmx src/uucp_name_data.cmx src/uucp__name.cmx src/uucp_num_base.cmx src/uucp_num_data.cmx src/uucp__num.cmx src/uucp_script_base.cmx src/uucp_script_data.cmx src/uucp__script.cmx src/uucp_white_data.cmx src/uucp__white.cmx src/uucp_version_data.cmx src/uucp.cmx -o src/uucp.cmxa
- ocamlfind ocamlopt -shared -linkall -I src src/uucp.cmxa -o src/uucp.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp.cmo src/uucp.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__age.cmo src/uucp__age.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__alpha.cmo src/uucp__alpha.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__block.cmo src/uucp__block.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__break.cmo src/uucp__break.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__case.cmo src/uucp__case.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__case_fold.cmo src/uucp__case_fold.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__case_map.cmo src/uucp__case_map.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__case_nfkc.cmo src/uucp__case_nfkc.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__case_nfkc_simple.cmo src/uucp__case_nfkc_simple.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__cjk.cmo src/uucp__cjk.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__emoji.cmo src/uucp__emoji.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__func.cmo src/uucp__func.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__gc.cmo src/uucp__gc.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__gen.cmo src/uucp__gen.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__hangul.cmo src/uucp__hangul.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__id.cmo src/uucp__id.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__name.cmo src/uucp__name.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__num.cmo src/uucp__num.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__script.cmo src/uucp__script.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -no-alias-deps -I src -I support -I test -o src/uucp__white.cmo src/uucp__white.ml
- ocamlfind ocamlc -a -I src src/uucp_fmt.cmo src/uucp_rmap.cmo src/uucp_age_data.cmo src/uucp__age.cmo src/uucp_tmapbool.cmo src/uucp_alpha_data.cmo src/uucp__alpha.cmo src/uucp_block_base.cmo src/uucp_block_data.cmo src/uucp__block.cmo src/uucp_gc_base.cmo src/uucp_gc_data.cmo src/uucp__gc.cmo src/uucp_break_base.cmo src/uucp_tmapbyte.cmo src/uucp_break_data.cmo src/uucp__break.cmo src/uucp_tmap.cmo src/uucp_case_fold_data.cmo src/uucp__case_fold.cmo src/uucp_case_map_data.cmo src/uucp__case_map.cmo src/uucp_case_nfkc_data.cmo src/uucp__case_nfkc.cmo src/uucp_case_nfkc_simple_data.cmo src/uucp__case_nfkc_simple.cmo src/uucp_case_data.cmo src/uucp__case.cmo src/uucp_cjk_data.cmo src/uucp__cjk.cmo src/uucp_emoji_data.cmo src/uucp__emoji.cmo src/uucp_func_data.cmo src/uucp__func.cmo src/uucp_gen_data.cmo src/uucp__gen.cmo src/uucp_hangul_base.cmo src/uucp_hangul_data.cmo src/uucp__hangul.cmo src/uucp_id_data.cmo src/uucp__id.cmo src/uucp_cmap.cmo src/uucp_name_base.cmo src/uucp_tmap5bytes.cmo src/uucp_name_data.cmo src/uucp__name.cmo src/uucp_num_base.cmo src/uucp_num_data.cmo src/uucp__num.cmo src/uucp_script_base.cmo src/uucp_script_data.cmo src/uucp__script.cmo src/uucp_white_data.cmo src/uucp__white.cmo src/uucp_version_data.cmo src/uucp.cmo -o src/uucp.cma
- # Parallel statistics: { count(total): 6(156), max: 21, min: 2, average(total): 10.667(1.372) }
-> compiled  uucp.15.1.0
Processing 239/346: [oasis: ocaml setup.ml] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build]
Processing 240/346: [oasis: ocaml setup.ml] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build]
-> installed uucp.15.1.0
Processing 241/346: [oasis: ocaml setup.ml] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_let" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_let.v0.14.0)
-> compiled  ppx_let.v0.14.0
Processing 241/346: [oasis: ocaml setup.ml] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build]
Processing 242/346: [oasis: ocaml setup.ml] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build]
-> installed ppx_let.v0.14.0
Processing 243/346: [oasis: ocaml setup.ml] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_here" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_here.v0.14.0)
-> compiled  ppx_here.v0.14.0
Processing 243/346: [oasis: ocaml setup.ml] [ppx_js_style: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build]
Processing 244/346: [oasis: ocaml setup.ml] [ppx_js_style: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build]
-> installed ppx_here.v0.14.0
Processing 245/346: [oasis: ocaml setup.ml] [ppx_js_style: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_optcomp" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_optcomp.v0.14.3)
-> compiled  ppx_optcomp.v0.14.3
Processing 245/346: [oasis: ocaml setup.ml] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build]
Processing 246/346: [oasis: ocaml setup.ml] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build]
-> installed ppx_optcomp.v0.14.3
Processing 247/346: [oasis: ocaml setup.ml] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_js_style" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_js_style.v0.14.1)
-> compiled  ppx_js_style.v0.14.1
Processing 247/346: [oasis: ocaml setup.ml] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build]
Processing 248/346: [oasis: ocaml setup.ml] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_js_style.v0.14.1
Processing 249/346: [oasis: ocaml setup.ml] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_optional" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_optional.v0.14.0)
-> compiled  ppx_optional.v0.14.0
Processing 249/346: [oasis: ocaml setup.ml] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
Processing 250/346: [oasis: ocaml setup.ml] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build] [sexplib: dune build]
-> installed ppx_optional.v0.14.0
Processing 251/346: [oasis: ocaml setup.ml] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build] [sexplib: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_pipebang" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_pipebang.v0.14.0)
-> compiled  ppx_pipebang.v0.14.0
Processing 251/346: [oasis: ocaml setup.ml] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build] [sexplib: dune build]
Processing 252/346: [oasis: ocaml setup.ml] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build] [sexplib: dune build] [uuseg: ocaml build]
-> installed ppx_pipebang.v0.14.0
Processing 253/346: [oasis: ocaml setup.ml] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build] [sexplib: dune build] [uuseg: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_stable" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_stable.v0.14.1)
-> compiled  ppx_stable.v0.14.1
Processing 253/346: [oasis: ocaml setup.ml] [ppx_sexp_conv: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build] [sexplib: dune build] [uuseg: ocaml build]
-> installed ppx_stable.v0.14.1
Processing 254/346: [oasis: ocaml setup.ml] [ppx_sexp_conv: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build] [sexplib: dune build] [uuseg: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_variants_conv" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_variants_conv.v0.14.2)
-> compiled  ppx_variants_conv.v0.14.2
Processing 254/346: [oasis: ocaml setup.ml] [ppx_sexp_conv: dune build] [ppx_typerep_conv: dune build] [sexplib: dune build] [uuseg: ocaml build]
-> installed ppx_variants_conv.v0.14.2
Processing 255/346: [oasis: ocaml setup.ml] [ppx_sexp_conv: dune build] [ppx_typerep_conv: dune build] [sexplib: dune build] [uuseg: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_typerep_conv" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_typerep_conv.v0.14.2)
-> compiled  ppx_typerep_conv.v0.14.2
Processing 255/346: [oasis: ocaml setup.ml] [ppx_sexp_conv: dune build] [sexplib: dune build] [uuseg: ocaml build]
-> installed ppx_typerep_conv.v0.14.2
Processing 256/346: [oasis: ocaml setup.ml] [ppx_sexp_conv: dune build] [sexplib: dune build] [uuseg: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "sexplib" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/sexplib.v0.14.0)
-> compiled  sexplib.v0.14.0
Processing 256/346: [oasis: ocaml setup.ml] [ppx_sexp_conv: dune build] [uuseg: ocaml build]
-> installed sexplib.v0.14.0
Processing 257/346: [oasis: ocaml setup.ml] [ppx_sexp_conv: dune build] [uuseg: ocaml build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_sexp_conv" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_sexp_conv.v0.14.3)
-> compiled  ppx_sexp_conv.v0.14.3
Processing 257/346: [oasis: ocaml setup.ml] [uuseg: ocaml build]
-> installed ppx_sexp_conv.v0.14.3
Processing 258/346: [oasis: ocaml setup.ml] [uuseg: ocaml build]
Processing 259/346: [oasis: ocaml setup.ml] [ppx_assert: dune build] [uuseg: ocaml build]
Processing 260/346: [oasis: ocaml setup.ml] [ppx_assert: dune build] [ppx_custom_printf: dune build] [uuseg: ocaml build]
Processing 261/346: [oasis: ocaml setup.ml] [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_hash: dune build] [uuseg: ocaml build]
Processing 262/346: [oasis: ocaml setup.ml] [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_hash: dune build] [ppx_sexp_message: dune build] [uuseg: ocaml build]
Processing 263/346: [oasis: ocaml setup.ml] [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_hash: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build] [uuseg: ocaml build]
+ /home/opam/.opam/4.14.1/bin/ocaml "pkg/pkg.ml" "build" "--dev-pkg" "false" "--with-uutf" "true" "--with-cmdliner" "true" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/uuseg.15.1.0)
- ocamlfind ocamldep -package uucp -modules src/uuseg_base.ml > src/uuseg_base.ml.depends
- ocamlfind ocamldep -package uucp -modules src/uuseg_base.mli > src/uuseg_base.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg_base.cmi src/uuseg_base.mli
- ocamlfind ocamldep -package uucp -modules src/uuseg_buf.ml > src/uuseg_buf.ml.depends
- ocamlfind ocamldep -package uucp -modules src/uuseg_buf.mli > src/uuseg_buf.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg_buf.cmi src/uuseg_buf.mli
- ocamlfind ocamldep -package uucp -modules src/uuseg_grapheme_cluster.ml > src/uuseg_grapheme_cluster.ml.depends
- ocamlfind ocamldep -package uucp -modules src/uuseg_grapheme_cluster.mli > src/uuseg_grapheme_cluster.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg_grapheme_cluster.cmi src/uuseg_grapheme_cluster.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg_base.cmx src/uuseg_base.ml
- ocamlfind ocamldep -package uucp -modules src/uuseg_word.ml > src/uuseg_word.ml.depends
- ocamlfind ocamldep -package uucp -modules src/uuseg_word.mli > src/uuseg_word.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg_word.cmi src/uuseg_word.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg_buf.cmx src/uuseg_buf.ml
- ocamlfind ocamldep -package uucp -modules src/uuseg_sentence.ml > src/uuseg_sentence.ml.depends
- ocamlfind ocamldep -package uucp -modules src/uuseg_sentence.mli > src/uuseg_sentence.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg_sentence.cmi src/uuseg_sentence.mli
- ocamlfind ocamldep -package uucp -modules src/uuseg_line_break.ml > src/uuseg_line_break.ml.depends
- ocamlfind ocamldep -package uucp -modules src/uuseg_line_break.mli > src/uuseg_line_break.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg_line_break.cmi src/uuseg_line_break.mli
- ocamlfind ocamldep -package uucp -modules src/uuseg.ml > src/uuseg.ml.depends
- ocamlfind ocamldep -package uucp -modules src/uuseg.mli > src/uuseg.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg.cmi src/uuseg.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg_grapheme_cluster.cmx src/uuseg_grapheme_cluster.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg_line_break.cmx src/uuseg_line_break.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg_sentence.cmx src/uuseg_sentence.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg_word.cmx src/uuseg_word.ml
- ocamlfind ocamldep -package uucp -modules src/uuseg_string.ml > src/uuseg_string.ml.depends
- ocamlfind ocamldep -package uucp -modules src/uuseg_string.mli > src/uuseg_string.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg_string.cmi src/uuseg_string.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg.cmx src/uuseg.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg_string.cmx src/uuseg_string.ml
- ocamlfind ocamlopt -a -package uucp -I src src/uuseg_base.cmx src/uuseg_buf.cmx src/uuseg_grapheme_cluster.cmx src/uuseg_word.cmx src/uuseg_sentence.cmx src/uuseg_line_break.cmx src/uuseg.cmx src/uuseg_string.cmx -o src/uuseg.cmxa
- ocamlfind ocamlopt -shared -linkall -package uucp -I src src/uuseg.cmxa -o src/uuseg.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg_base.cmo src/uuseg_base.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg_buf.cmo src/uuseg_buf.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg_grapheme_cluster.cmo src/uuseg_grapheme_cluster.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg_word.cmo src/uuseg_word.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg_sentence.cmo src/uuseg_sentence.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg_line_break.cmo src/uuseg_line_break.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg.cmo src/uuseg.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package uucp -I src -I test -o src/uuseg_string.cmo src/uuseg_string.ml
- ocamlfind ocamlc -a -package uucp -I src src/uuseg_base.cmo src/uuseg_buf.cmo src/uuseg_grapheme_cluster.cmo src/uuseg_word.cmo src/uuseg_sentence.cmo src/uuseg_line_break.cmo src/uuseg.cmo src/uuseg_string.cmo -o src/uuseg.cma
- ocamlfind ocamldep -package 'cmdliner uutf' -package uucp -modules test/usegtrip.ml > test/usegtrip.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package 'cmdliner uutf' -package uucp -I test -I src -o test/usegtrip.cmo test/usegtrip.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package 'cmdliner uutf' -package uucp -I test -I src -o test/usegtrip.cmx test/usegtrip.ml
- ocamlfind ocamlopt -linkpkg -g -package 'cmdliner uutf' -package uucp -I src -I test src/uuseg_base.cmx src/uuseg_buf.cmx src/uuseg_grapheme_cluster.cmx src/uuseg_line_break.cmx src/uuseg_sentence.cmx src/uuseg_word.cmx src/uuseg.cmx test/usegtrip.cmx -o test/usegtrip.native
- # Parallel statistics: { count(total): 1(41), max: 8, min: 8, average(total): 8.000(1.171) }
-> compiled  uuseg.15.1.0
Processing 263/346: [oasis: ocaml setup.ml] [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_hash: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
-> installed uuseg.15.1.0
Processing 264/346: [oasis: ocaml setup.ml] [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_hash: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
Processing 265/346: [oasis: ocaml setup.ml] [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_hash: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build] [zed: dune build]
+ /home/opam/.opam/4.14.1/bin/ocaml "setup.ml" "-build" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/oasis.0.4.11)
- File "src/oasis/OASISFileSystem.ml", line 107, characters 4-15:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISFileSystem.ml", line 135, characters 19-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISFileSystem.ml", line 142, characters 37-48:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISFileSystem.ml", line 145, characters 17-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 85, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 87, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 88, characters 14-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 89, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 89, characters 28-40:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 90, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 90, characters 28-41:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 91, characters 11-24:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 92, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISFeatures.ml", line 32, characters 22-40:
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "src/base/BaseEnvLight.ml", line 37, characters 8-19:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 40, characters 21-32:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 43, characters 18-32:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 45, characters 6-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 48, characters 12-24:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 49, characters 9-21:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 49, characters 26-36:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 49, characters 42-55:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 50, characters 8-19:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 50, characters 25-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 50, characters 42-53:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 62, characters 17-34:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 69, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 88, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 90, characters 17-29:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 91, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 91, characters 37-49:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 93, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 93, characters 37-50:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 95, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 95, characters 46-58:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 97, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 97, characters 46-59:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 99, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 112, characters 13-25:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 210, characters 16-34:
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "src/base/BaseLog.ml", line 49, characters 21-38:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 51, characters 19-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 52, characters 16-29:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 52, characters 33-46:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 54, characters 15-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 54, characters 32-43:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- ocamlfind ocamlopt unix.cmxa -I /home/opam/.opam/4.14.1/lib/ocamlbuild /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuildlib.cmxa -linkpkg myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- File "test/data/TestFull/dev/_tags", line 27, characters 8-17:
- Warning: the tag "pkg_oUnit" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/FormatExt.mli > src/oasis/FormatExt.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/FormatExt.cmi src/oasis/FormatExt.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/FormatExt.ml > src/oasis/FormatExt.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISString.ml > src/oasis/OASISString.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISString.cmo src/oasis/OASISString.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISString.cmo src/oasis/OASISString.ml
- File "src/oasis/OASISString.ml", line 233, characters 13-30:
- 233 |   let strm = Genlex.make_lexer tokens (Stream.of_string str) in
-                    ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISString.ml", line 233, characters 39-55:
- 233 |   let strm = Genlex.make_lexer tokens (Stream.of_string str) in
-                                              ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISString.ml", line 235, characters 2-13:
- 235 |   Stream.iter (fun tok -> lst := tok :: !lst) strm;
-         ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/PropList.mli > src/oasis/PropList.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/PropList.cmi src/oasis/PropList.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/PropList.ml > src/oasis/PropList.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISGettext.mli > src/oasis/OASISGettext.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISGettext.cmi src/oasis/OASISGettext.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISUtils.mli > src/oasis/OASISUtils.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISUtils.cmi src/oasis/OASISUtils.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISUtils.ml > src/oasis/OASISUtils.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISUnixPath.mli > src/oasis/OASISUnixPath.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISUnixPath.cmi src/oasis/OASISUnixPath.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISUnixPath.ml > src/oasis/OASISUnixPath.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISPath_intern.ml > src/oasis/OASISPath_intern.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISPath_intern.cmo src/oasis/OASISPath_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISFileSystem.mli > src/oasis/OASISFileSystem.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFileSystem.cmi src/oasis/OASISFileSystem.mli
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFileSystem.cmi src/oasis/OASISFileSystem.mli
- File "src/oasis/OASISFileSystem.mli", line 68, characters 38-46:
- 68 | val stream_of_reader: #reader -> char Stream.t
-                                            ^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISFileSystem.ml > src/oasis/OASISFileSystem.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISContext.mli > src/oasis/OASISContext.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISContext.cmi src/oasis/OASISContext.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISContext.ml > src/oasis/OASISContext.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISSourcePatterns.mli > src/oasis/OASISSourcePatterns.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISDataNotation.ml > src/oasis/OASISDataNotation.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISDataNotation.cmo src/oasis/OASISDataNotation.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSourcePatterns.cmi src/oasis/OASISSourcePatterns.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISSourcePatterns.ml > src/oasis/OASISSourcePatterns.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISGettext.ml > src/oasis/OASISGettext.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISMessage.mli > src/oasis/OASISMessage.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISMessage.cmi src/oasis/OASISMessage.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISMessage.ml > src/oasis/OASISMessage.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISText.ml > src/oasis/OASISText.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISValues.mli > src/oasis/OASISValues.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISValues.cmi src/oasis/OASISValues.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISTypes.mli > src/oasis/OASISTypes.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISExpr.mli > src/oasis/OASISExpr.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISLicense.mli > src/oasis/OASISLicense.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISVersion.mli > src/oasis/OASISVersion.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISVersion.cmi src/oasis/OASISVersion.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISText.cmo src/oasis/OASISText.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISExpr.cmi src/oasis/OASISExpr.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISLicense.cmi src/oasis/OASISLicense.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISTypes.cmi src/oasis/OASISTypes.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISTypes.ml > src/oasis/OASISTypes.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISParse.mli > src/oasis/OASISParse.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISParse.cmi src/oasis/OASISParse.mli
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISParse.cmi src/oasis/OASISParse.mli
- File "src/oasis/OASISParse.mli", line 44, characters 8-16:
- 44 |   (char Stream.t) ->
-              ^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISParse.ml > src/oasis/OASISParse.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISAst.ml > src/oasis/OASISAst.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISAst_types.ml > src/oasis/OASISAst_types.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISBuildSection.mli > src/oasis/OASISBuildSection.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISSection.mli > src/oasis/OASISSection.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSection.cmi src/oasis/OASISSection.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISCheck.ml > src/oasis/OASISCheck.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISFeatures.ml > src/oasis/OASISFeatures.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISPlugin.mli > src/oasis/OASISPlugin.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISFileTemplate.mli > src/oasis/OASISFileTemplate.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISSetupUpdate.ml > src/oasis/OASISSetupUpdate.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFileTemplate.cmi src/oasis/OASISFileTemplate.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSetupUpdate.cmo src/oasis/OASISSetupUpdate.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISSchema_intern.ml > src/oasis/OASISSchema_intern.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISAst_types.cmo src/oasis/OASISAst_types.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFeatures.cmo src/oasis/OASISFeatures.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFeatures.cmo src/oasis/OASISFeatures.ml
- File "src/oasis/OASISFeatures.ml", line 32, characters 20-38:
- 32 |       let compare = Pervasives.compare
-                          ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISPlugin.cmi src/oasis/OASISPlugin.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSchema_intern.cmo src/oasis/OASISSchema_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISDocument.mli > src/oasis/OASISDocument.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISSchema.mli > src/oasis/OASISSchema.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSchema.cmi src/oasis/OASISSchema.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISDocument_intern.ml > src/oasis/OASISDocument_intern.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISBuildSection_intern.ml > src/oasis/OASISBuildSection_intern.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISCustom.ml > src/oasis/OASISCustom.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISSection_intern.ml > src/oasis/OASISSection_intern.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISBuildSection_intern.cmo src/oasis/OASISBuildSection_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISCustom.cmo src/oasis/OASISCustom.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSection_intern.cmo src/oasis/OASISSection_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISExecutable.mli > src/oasis/OASISExecutable.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISExecutable_intern.ml > src/oasis/OASISExecutable_intern.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISFindlib.mli > src/oasis/OASISFindlib.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISFlag.mli > src/oasis/OASISFlag.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISFlag_intern.ml > src/oasis/OASISFlag_intern.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISLibrary.mli > src/oasis/OASISLibrary.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISLibrary_intern.ml > src/oasis/OASISLibrary_intern.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISObject.mli > src/oasis/OASISObject.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISObject_intern.ml > src/oasis/OASISObject_intern.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISPackage.mli > src/oasis/OASISPackage.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISPackage_intern.ml > src/oasis/OASISPackage_intern.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISConf.ml > src/oasis/OASISConf.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISConf.cmo src/oasis/OASISConf.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISSourceRepository.mli > src/oasis/OASISSourceRepository.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISSourceRepository_intern.ml > src/oasis/OASISSourceRepository_intern.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISTest.mli > src/oasis/OASISTest.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISTest_intern.ml > src/oasis/OASISTest_intern.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISBuildSection.cmi src/oasis/OASISBuildSection.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISCheck.cmo src/oasis/OASISCheck.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISDocument.cmi src/oasis/OASISDocument.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISDocument_intern.cmo src/oasis/OASISDocument_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISExecutable.cmi src/oasis/OASISExecutable.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISExecutable_intern.cmo src/oasis/OASISExecutable_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFindlib.cmi src/oasis/OASISFindlib.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFlag.cmi src/oasis/OASISFlag.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFlag_intern.cmo src/oasis/OASISFlag_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISLibrary.cmi src/oasis/OASISLibrary.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISLibrary_intern.cmo src/oasis/OASISLibrary_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISObject.cmi src/oasis/OASISObject.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISObject_intern.cmo src/oasis/OASISObject_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISPackage.cmi src/oasis/OASISPackage.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISPackage_intern.cmo src/oasis/OASISPackage_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSourceRepository.cmi src/oasis/OASISSourceRepository.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSourceRepository_intern.cmo src/oasis/OASISSourceRepository_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISTest.cmi src/oasis/OASISTest.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISTest_intern.cmo src/oasis/OASISTest_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamllex.opt -q src/oasis/OASISAst_lexer.mll
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISAst_lexer.ml > src/oasis/OASISAst_lexer.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlyacc src/oasis/OASISAst_parser.mly
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISAst_parser.mli > src/oasis/OASISAst_parser.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISAst_parser.cmi src/oasis/OASISAst_parser.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISMutex.ml > src/oasis/OASISMutex.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISAst.cmo src/oasis/OASISAst.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISAst_lexer.cmo src/oasis/OASISAst_lexer.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISMutex.cmo src/oasis/OASISMutex.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISValues.ml > src/oasis/OASISValues.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamllex.opt -q src/oasis/OASISValues_lexer.mll
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISValues_lexer.ml > src/oasis/OASISValues_lexer.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISValues_lexer.cmo src/oasis/OASISValues_lexer.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISExpr.ml > src/oasis/OASISExpr.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISVersion.ml > src/oasis/OASISVersion.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamllex.opt -q src/oasis/OASISVersion_lexer.mll
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISVersion_lexer.ml > src/oasis/OASISVersion_lexer.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlyacc src/oasis/OASISVersion_parser.mly
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISVersion_parser.mli > src/oasis/OASISVersion_parser.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISVersion_types.ml > src/oasis/OASISVersion_types.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISVersion_types.cmo src/oasis/OASISVersion_types.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISVersion_parser.cmi src/oasis/OASISVersion_parser.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISVersion_lexer.cmo src/oasis/OASISVersion_lexer.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISLicense.ml > src/oasis/OASISLicense.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamllex.opt -q src/oasis/OASISLicense_lexer.mll
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISLicense_lexer.ml > src/oasis/OASISLicense_lexer.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlyacc src/oasis/OASISLicense_parser.mly
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISLicense_parser.mli > src/oasis/OASISLicense_parser.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISLicense_types.ml > src/oasis/OASISLicense_types.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISLicense_types.cmo src/oasis/OASISLicense_types.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISLicense_parser.cmi src/oasis/OASISLicense_parser.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISLicense_lexer.cmo src/oasis/OASISLicense_lexer.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISFileTemplate.ml > src/oasis/OASISFileTemplate.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISFileUtil.mli > src/oasis/OASISFileUtil.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISHostPath.mli > src/oasis/OASISHostPath.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFileUtil.cmi src/oasis/OASISFileUtil.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISHostPath.cmi src/oasis/OASISHostPath.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISBuildSection.ml > src/oasis/OASISBuildSection.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISGraph.ml > src/oasis/OASISGraph.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISGraph.cmo src/oasis/OASISGraph.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISDocument.ml > src/oasis/OASISDocument.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISExecutable.ml > src/oasis/OASISExecutable.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISFlag.ml > src/oasis/OASISFlag.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISLibrary.ml > src/oasis/OASISLibrary.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISObject.ml > src/oasis/OASISObject.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISPackage.ml > src/oasis/OASISPackage.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISSourceRepository.ml > src/oasis/OASISSourceRepository.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISTest.ml > src/oasis/OASISTest.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISPlugin.ml > src/oasis/OASISPlugin.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISFindlib.ml > src/oasis/OASISFindlib.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISSchema.ml > src/oasis/OASISSchema.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISSection.ml > src/oasis/OASISSection.ml.depends
- ocamlify --depends --output src/oasis/OASISData.mlify.depends src/oasis/OASISData.mlify
- ocamlmod src/oasis/OASISSys.mod
- ocamlmod src/oasis/OASISSysLight.mod
- ocamlmod src/oasis/OASISSysBundle.mod
- ocamlify --output src/oasis/OASISData.ml src/oasis/OASISData.mlify
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISData.ml > src/oasis/OASISData.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISExec.mli > src/oasis/OASISExec.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISExec.cmi src/oasis/OASISExec.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISExec.ml > src/oasis/OASISExec.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISFileUtil.ml > src/oasis/OASISFileUtil.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISHostPath.ml > src/oasis/OASISHostPath.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISVersion_parser.ml > src/oasis/OASISVersion_parser.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISLicense_parser.ml > src/oasis/OASISLicense_parser.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISAst_parser.ml > src/oasis/OASISAst_parser.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISQuickstart.ml > src/oasis/OASISQuickstart.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISFormat.ml > src/oasis/OASISFormat.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFormat.cmo src/oasis/OASISFormat.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/oasis/OASISHelp.ml > src/oasis/OASISHelp.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISData.cmo src/oasis/OASISData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/FormatExt.cmo src/oasis/FormatExt.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/PropList.cmo src/oasis/PropList.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISUtils.cmo src/oasis/OASISUtils.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISUtils.cmo src/oasis/OASISUtils.ml
- File "src/oasis/OASISUtils.ml", line 302, characters 12-23:
- 302 |       match Stream.peek strm with
-                   ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 306, characters 16-27:
- 306 |                 Stream.junk strm;
-                       ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 315, characters 14-25:
- 315 |         match Stream.next strm with
-                     ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 323, characters 11-25:
- 323 |       with Stream.Failure ->
-                  ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 338, characters 12-23:
- 338 |       match Stream.peek strm with
-                   ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 341, characters 12-23:
- 341 |             Stream.junk strm
-                   ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 349, characters 14-25:
- 349 |         match Stream.next strm with
-                     ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 353, characters 50-61:
- 353 |           | '\\' when is_doubly_quoted_escapable (Stream.peek strm)  ->
-                                                         ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 360, characters 11-25:
- 360 |       with Stream.Failure ->
-                  ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 368, characters 6-22:
- 368 |       Stream.of_string str
-             ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 378, characters 12-23:
- 378 |       while Stream.peek strm <> None do
-                   ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 379, characters 14-25:
- 379 |         match Stream.next strm with
-                     ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISUnixPath.cmo src/oasis/OASISUnixPath.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFileSystem.cmo src/oasis/OASISFileSystem.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFileSystem.cmo src/oasis/OASISFileSystem.ml
- File "src/oasis/OASISFileSystem.ml", line 107, characters 2-13:
- 107 |   Stream.from next
-         ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISFileSystem.ml", line 135, characters 17-34:
- 135 |       let strm = Stream.of_channel chn in
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISFileSystem.ml", line 142, characters 35-46:
- 142 |               Buffer.add_char buf (Stream.next strm);
-                                          ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISFileSystem.ml", line 145, characters 15-29:
- 145 |           with Stream.Failure ->
-                      ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISContext.cmo src/oasis/OASISContext.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSourcePatterns.cmo src/oasis/OASISSourcePatterns.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSourcePatterns.cmo src/oasis/OASISSourcePatterns.ml
- File "src/oasis/OASISSourcePatterns.ml", line 85, characters 14-31:
- 85 |     let lxr = Genlex.make_lexer [] in
-                    ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 87, characters 20-36:
- 87 |       let st = lxr (Stream.of_string s) in
-                          ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 88, characters 12-24:
- 88 |       match Stream.npeek 3 st with
-                  ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 89, characters 9-21:
- 89 |       | [Genlex.Ident fn; Genlex.Ident nm] -> Call(fn, Ident nm)
-               ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 89, characters 26-38:
- 89 |       | [Genlex.Ident fn; Genlex.Ident nm] -> Call(fn, Ident nm)
-                                ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 90, characters 9-21:
- 90 |       | [Genlex.Ident fn; Genlex.String str] -> Call(fn, String str)
-               ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 90, characters 26-39:
- 90 |       | [Genlex.Ident fn; Genlex.String str] -> Call(fn, String str)
-                                ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 91, characters 9-22:
- 91 |       | [Genlex.String str] -> String str
-               ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 92, characters 9-21:
- 92 |       | [Genlex.Ident nm] -> Ident nm
-               ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISGettext.cmo src/oasis/OASISGettext.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISMessage.cmo src/oasis/OASISMessage.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISTypes.cmo src/oasis/OASISTypes.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISParse.cmo src/oasis/OASISParse.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISParse.cmo src/oasis/OASISParse.ml
- File "src/oasis/OASISParse.ml", line 50, characters 4-15:
- 50 |     Stream.iter (Buffer.add_char buf) st;
-          ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISValues.cmo src/oasis/OASISValues.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISExpr.cmo src/oasis/OASISExpr.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISVersion.cmo src/oasis/OASISVersion.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISLicense.cmo src/oasis/OASISLicense.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFileTemplate.cmo src/oasis/OASISFileTemplate.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFileTemplate.cmo src/oasis/OASISFileTemplate.ml
- File "src/oasis/OASISFileTemplate.ml", line 306, characters 9-20:
- 306 |       if starts_with "#" (trim str) then
-                ^^^^^^^^^^^
- Warning 6 [labels-omitted]: label what was omitted in the application of this function.
- File "src/oasis/OASISFileTemplate.ml", line 309, characters 15-27:
- 309 |             | [Genlex.Ident "#"; Genlex.Int _; Genlex.String fn] ->
-                      ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISFileTemplate.ml", line 309, characters 33-43:
- 309 |             | [Genlex.Ident "#"; Genlex.Int _; Genlex.String fn] ->
-                                        ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISFileTemplate.ml", line 309, characters 47-60:
- 309 |             | [Genlex.Ident "#"; Genlex.Int _; Genlex.String fn] ->
-                                                      ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISBuildSection.cmo src/oasis/OASISBuildSection.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISDocument.cmo src/oasis/OASISDocument.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISExecutable.cmo src/oasis/OASISExecutable.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFlag.cmo src/oasis/OASISFlag.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISLibrary.cmo src/oasis/OASISLibrary.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISObject.cmo src/oasis/OASISObject.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISPackage.cmo src/oasis/OASISPackage.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSourceRepository.cmo src/oasis/OASISSourceRepository.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISTest.cmo src/oasis/OASISTest.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISPlugin.cmo src/oasis/OASISPlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFindlib.cmo src/oasis/OASISFindlib.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSchema.cmo src/oasis/OASISSchema.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSection.cmo src/oasis/OASISSection.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISExec.cmo src/oasis/OASISExec.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFileUtil.cmo src/oasis/OASISFileUtil.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISHostPath.cmo src/oasis/OASISHostPath.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISVersion_parser.cmo src/oasis/OASISVersion_parser.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISLicense_parser.cmo src/oasis/OASISLicense_parser.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISAst_parser.cmo src/oasis/OASISAst_parser.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISQuickstart.cmo src/oasis/OASISQuickstart.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISHelp.cmo src/oasis/OASISHelp.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -a -I src/oasis src/oasis/OASISString.cmo src/oasis/FormatExt.cmo src/oasis/OASISGettext.cmo src/oasis/PropList.cmo src/oasis/OASISUtils.cmo src/oasis/OASISPath_intern.cmo src/oasis/OASISUnixPath.cmo src/oasis/OASISFileSystem.cmo src/oasis/OASISContext.cmo src/oasis/OASISDataNotation.cmo src/oasis/OASISSourcePatterns.cmo src/oasis/OASISMessage.cmo src/oasis/OASISValues_lexer.cmo src/oasis/OASISValues.cmo src/oasis/OASISText.cmo src/oasis/OASISExpr.cmo src/oasis/OASISLicense_types.cmo src/oasis/OASISLicense_parser.cmo src/oasis/OASISLicense_lexer.cmo src/oasis/OASISVersion_types.cmo src/oasis/OASISVersion_parser.cmo src/oasis/OASISVersion_lexer.cmo src/oasis/OASISVersion.cmo src/oasis/OASISLicense.cmo src/oasis/OASISTypes.cmo src/oasis/OASISAst_types.cmo src/oasis/OASISGraph.cmo src/oasis/OASISSection.cmo src/oasis/OASISBuildSection.cmo src/oasis/OASISFeatures.cmo src/oasis/OASISConf.cmo src/oasis/OASISExec.cmo src/oasis/OASISFileUtil.cmo src/oasis/OASISHostPath.cmo src/oasis/OASISFileTemplate.cmo src/oasis/OASISSetupUpdate.cmo src/oasis/OASISPlugin.cmo src/oasis/OASISSchema_intern.cmo src/oasis/OASISCheck.cmo src/oasis/OASISBuildSection_intern.cmo src/oasis/OASISCustom.cmo src/oasis/OASISSection_intern.cmo src/oasis/OASISDocument_intern.cmo src/oasis/OASISSchema.cmo src/oasis/OASISDocument.cmo src/oasis/OASISExecutable_intern.cmo src/oasis/OASISExecutable.cmo src/oasis/OASISFindlib.cmo src/oasis/OASISFlag_intern.cmo src/oasis/OASISFlag.cmo src/oasis/OASISLibrary_intern.cmo src/oasis/OASISLibrary.cmo src/oasis/OASISObject_intern.cmo src/oasis/OASISObject.cmo src/oasis/OASISPackage_intern.cmo src/oasis/OASISPackage.cmo src/oasis/OASISSourceRepository_intern.cmo src/oasis/OASISSourceRepository.cmo src/oasis/OASISTest_intern.cmo src/oasis/OASISTest.cmo src/oasis/OASISAst.cmo src/oasis/OASISAst_parser.cmo src/oasis/OASISAst_lexer.cmo src/oasis/OASISMutex.cmo src/oasis/OASISParse.cmo src/oasis/OASISData.cmo src/oasis/OASISFormat.cmo src/oasis/OASISQuickstart.cmo src/oasis/OASISHelp.cmo -o src/oasis/oasis.cma
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISString.cmx src/oasis/OASISString.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISString.cmx src/oasis/OASISString.ml
- File "src/oasis/OASISString.ml", line 233, characters 13-30:
- 233 |   let strm = Genlex.make_lexer tokens (Stream.of_string str) in
-                    ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISString.ml", line 233, characters 39-55:
- 233 |   let strm = Genlex.make_lexer tokens (Stream.of_string str) in
-                                              ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISString.ml", line 235, characters 2-13:
- 235 |   Stream.iter (fun tok -> lst := tok :: !lst) strm;
-         ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISGettext.cmx src/oasis/OASISGettext.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISUtils.cmx src/oasis/OASISUtils.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISUtils.cmx src/oasis/OASISUtils.ml
- File "src/oasis/OASISUtils.ml", line 302, characters 12-23:
- 302 |       match Stream.peek strm with
-                   ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 306, characters 16-27:
- 306 |                 Stream.junk strm;
-                       ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 315, characters 14-25:
- 315 |         match Stream.next strm with
-                     ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 323, characters 11-25:
- 323 |       with Stream.Failure ->
-                  ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 338, characters 12-23:
- 338 |       match Stream.peek strm with
-                   ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 341, characters 12-23:
- 341 |             Stream.junk strm
-                   ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 349, characters 14-25:
- 349 |         match Stream.next strm with
-                     ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 353, characters 50-61:
- 353 |           | '\\' when is_doubly_quoted_escapable (Stream.peek strm)  ->
-                                                         ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 360, characters 11-25:
- 360 |       with Stream.Failure ->
-                  ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 368, characters 6-22:
- 368 |       Stream.of_string str
-             ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 378, characters 12-23:
- 378 |       while Stream.peek strm <> None do
-                   ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISUtils.ml", line 379, characters 14-25:
- 379 |         match Stream.next strm with
-                     ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISPath_intern.cmx src/oasis/OASISPath_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISUnixPath.cmx src/oasis/OASISUnixPath.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFileSystem.cmx src/oasis/OASISFileSystem.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFileSystem.cmx src/oasis/OASISFileSystem.ml
- File "src/oasis/OASISFileSystem.ml", line 107, characters 2-13:
- 107 |   Stream.from next
-         ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISFileSystem.ml", line 135, characters 17-34:
- 135 |       let strm = Stream.of_channel chn in
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISFileSystem.ml", line 142, characters 35-46:
- 142 |               Buffer.add_char buf (Stream.next strm);
-                                          ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISFileSystem.ml", line 145, characters 15-29:
- 145 |           with Stream.Failure ->
-                      ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISDataNotation.cmx src/oasis/OASISDataNotation.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISContext.cmx src/oasis/OASISContext.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/FormatExt.cmx src/oasis/FormatExt.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISValues_lexer.cmx src/oasis/OASISValues_lexer.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISValues.cmx src/oasis/OASISValues.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISLicense_types.cmx src/oasis/OASISLicense_types.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISLicense_parser.cmx src/oasis/OASISLicense_parser.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISMessage.cmx src/oasis/OASISMessage.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISVersion_types.cmx src/oasis/OASISVersion_types.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISVersion_parser.cmx src/oasis/OASISVersion_parser.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISVersion_lexer.cmx src/oasis/OASISVersion_lexer.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISLicense_lexer.cmx src/oasis/OASISLicense_lexer.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISVersion.cmx src/oasis/OASISVersion.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSourcePatterns.cmx src/oasis/OASISSourcePatterns.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSourcePatterns.cmx src/oasis/OASISSourcePatterns.ml
- File "src/oasis/OASISSourcePatterns.ml", line 85, characters 14-31:
- 85 |     let lxr = Genlex.make_lexer [] in
-                    ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 87, characters 20-36:
- 87 |       let st = lxr (Stream.of_string s) in
-                          ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 88, characters 12-24:
- 88 |       match Stream.npeek 3 st with
-                  ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 89, characters 9-21:
- 89 |       | [Genlex.Ident fn; Genlex.Ident nm] -> Call(fn, Ident nm)
-               ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 89, characters 26-38:
- 89 |       | [Genlex.Ident fn; Genlex.Ident nm] -> Call(fn, Ident nm)
-                                ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 90, characters 9-21:
- 90 |       | [Genlex.Ident fn; Genlex.String str] -> Call(fn, String str)
-               ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 90, characters 26-39:
- 90 |       | [Genlex.Ident fn; Genlex.String str] -> Call(fn, String str)
-                                ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 91, characters 9-22:
- 91 |       | [Genlex.String str] -> String str
-               ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 92, characters 9-21:
- 92 |       | [Genlex.Ident nm] -> Ident nm
-               ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISText.cmx src/oasis/OASISText.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/PropList.cmx src/oasis/PropList.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISExpr.cmx src/oasis/OASISExpr.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISLicense.cmx src/oasis/OASISLicense.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISTypes.cmx src/oasis/OASISTypes.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISGraph.cmx src/oasis/OASISGraph.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSection.cmx src/oasis/OASISSection.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISExec.cmx src/oasis/OASISExec.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFileUtil.cmx src/oasis/OASISFileUtil.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISHostPath.cmx src/oasis/OASISHostPath.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISConf.cmx src/oasis/OASISConf.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFileTemplate.cmx src/oasis/OASISFileTemplate.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFileTemplate.cmx src/oasis/OASISFileTemplate.ml
- File "src/oasis/OASISFileTemplate.ml", line 306, characters 9-20:
- 306 |       if starts_with "#" (trim str) then
-                ^^^^^^^^^^^
- Warning 6 [labels-omitted]: label what was omitted in the application of this function.
- File "src/oasis/OASISFileTemplate.ml", line 309, characters 15-27:
- 309 |             | [Genlex.Ident "#"; Genlex.Int _; Genlex.String fn] ->
-                      ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISFileTemplate.ml", line 309, characters 33-43:
- 309 |             | [Genlex.Ident "#"; Genlex.Int _; Genlex.String fn] ->
-                                        ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISFileTemplate.ml", line 309, characters 47-60:
- 309 |             | [Genlex.Ident "#"; Genlex.Int _; Genlex.String fn] ->
-                                                      ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSetupUpdate.cmx src/oasis/OASISSetupUpdate.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISAst_types.cmx src/oasis/OASISAst_types.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFeatures.cmx src/oasis/OASISFeatures.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFeatures.cmx src/oasis/OASISFeatures.ml
- File "src/oasis/OASISFeatures.ml", line 32, characters 20-38:
- 32 |       let compare = Pervasives.compare
-                          ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISPlugin.cmx src/oasis/OASISPlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSchema_intern.cmx src/oasis/OASISSchema_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISBuildSection_intern.cmx src/oasis/OASISBuildSection_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISCustom.cmx src/oasis/OASISCustom.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSection_intern.cmx src/oasis/OASISSection_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISDocument_intern.cmx src/oasis/OASISDocument_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSchema.cmx src/oasis/OASISSchema.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISExecutable_intern.cmx src/oasis/OASISExecutable_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFlag_intern.cmx src/oasis/OASISFlag_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISBuildSection.cmx src/oasis/OASISBuildSection.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISLibrary_intern.cmx src/oasis/OASISLibrary_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISObject_intern.cmx src/oasis/OASISObject_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISPackage_intern.cmx src/oasis/OASISPackage_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSourceRepository_intern.cmx src/oasis/OASISSourceRepository_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISTest_intern.cmx src/oasis/OASISTest_intern.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISCheck.cmx src/oasis/OASISCheck.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISDocument.cmx src/oasis/OASISDocument.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISExecutable.cmx src/oasis/OASISExecutable.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFindlib.cmx src/oasis/OASISFindlib.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFlag.cmx src/oasis/OASISFlag.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISLibrary.cmx src/oasis/OASISLibrary.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISObject.cmx src/oasis/OASISObject.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISPackage.cmx src/oasis/OASISPackage.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISSourceRepository.cmx src/oasis/OASISSourceRepository.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISTest.cmx src/oasis/OASISTest.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISAst_parser.cmx src/oasis/OASISAst_parser.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISAst.cmx src/oasis/OASISAst.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISAst_lexer.cmx src/oasis/OASISAst_lexer.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISMutex.cmx src/oasis/OASISMutex.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISFormat.cmx src/oasis/OASISFormat.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISData.cmx src/oasis/OASISData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISParse.cmx src/oasis/OASISParse.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISParse.cmx src/oasis/OASISParse.ml
- File "src/oasis/OASISParse.ml", line 50, characters 4-15:
- 50 |     Stream.iter (Buffer.add_char buf) st;
-          ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISQuickstart.cmx src/oasis/OASISQuickstart.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package unix -I src/oasis -o src/oasis/OASISHelp.cmx src/oasis/OASISHelp.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -a -I src/oasis src/oasis/OASISString.cmx src/oasis/FormatExt.cmx src/oasis/OASISGettext.cmx src/oasis/PropList.cmx src/oasis/OASISUtils.cmx src/oasis/OASISPath_intern.cmx src/oasis/OASISUnixPath.cmx src/oasis/OASISFileSystem.cmx src/oasis/OASISContext.cmx src/oasis/OASISDataNotation.cmx src/oasis/OASISSourcePatterns.cmx src/oasis/OASISMessage.cmx src/oasis/OASISValues_lexer.cmx src/oasis/OASISValues.cmx src/oasis/OASISText.cmx src/oasis/OASISExpr.cmx src/oasis/OASISLicense_types.cmx src/oasis/OASISLicense_parser.cmx src/oasis/OASISLicense_lexer.cmx src/oasis/OASISVersion_types.cmx src/oasis/OASISVersion_parser.cmx src/oasis/OASISVersion_lexer.cmx src/oasis/OASISVersion.cmx src/oasis/OASISLicense.cmx src/oasis/OASISTypes.cmx src/oasis/OASISAst_types.cmx src/oasis/OASISGraph.cmx src/oasis/OASISSection.cmx src/oasis/OASISBuildSection.cmx src/oasis/OASISConf.cmx src/oasis/OASISExec.cmx src/oasis/OASISFeatures.cmx src/oasis/OASISFileUtil.cmx src/oasis/OASISHostPath.cmx src/oasis/OASISFileTemplate.cmx src/oasis/OASISSetupUpdate.cmx src/oasis/OASISPlugin.cmx src/oasis/OASISSchema_intern.cmx src/oasis/OASISBuildSection_intern.cmx src/oasis/OASISCheck.cmx src/oasis/OASISCustom.cmx src/oasis/OASISSection_intern.cmx src/oasis/OASISDocument_intern.cmx src/oasis/OASISSchema.cmx src/oasis/OASISDocument.cmx src/oasis/OASISExecutable_intern.cmx src/oasis/OASISExecutable.cmx src/oasis/OASISFindlib.cmx src/oasis/OASISFlag_intern.cmx src/oasis/OASISFlag.cmx src/oasis/OASISLibrary_intern.cmx src/oasis/OASISLibrary.cmx src/oasis/OASISObject_intern.cmx src/oasis/OASISObject.cmx src/oasis/OASISPackage_intern.cmx src/oasis/OASISPackage.cmx src/oasis/OASISSourceRepository_intern.cmx src/oasis/OASISSourceRepository.cmx src/oasis/OASISTest_intern.cmx src/oasis/OASISTest.cmx src/oasis/OASISAst.cmx src/oasis/OASISAst_parser.cmx src/oasis/OASISAst_lexer.cmx src/oasis/OASISMutex.cmx src/oasis/OASISParse.cmx src/oasis/OASISData.cmx src/oasis/OASISFormat.cmx src/oasis/OASISQuickstart.cmx src/oasis/OASISHelp.cmx -o src/oasis/oasis.cmxa
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -shared -I src/oasis src/oasis/oasis.cmxa src/oasis/OASISString.cmx src/oasis/FormatExt.cmx src/oasis/OASISGettext.cmx src/oasis/PropList.cmx src/oasis/OASISUtils.cmx src/oasis/OASISPath_intern.cmx src/oasis/OASISUnixPath.cmx src/oasis/OASISFileSystem.cmx src/oasis/OASISContext.cmx src/oasis/OASISDataNotation.cmx src/oasis/OASISSourcePatterns.cmx src/oasis/OASISMessage.cmx src/oasis/OASISValues_lexer.cmx src/oasis/OASISValues.cmx src/oasis/OASISText.cmx src/oasis/OASISExpr.cmx src/oasis/OASISLicense_types.cmx src/oasis/OASISLicense_parser.cmx src/oasis/OASISLicense_lexer.cmx src/oasis/OASISVersion_types.cmx src/oasis/OASISVersion_parser.cmx src/oasis/OASISVersion_lexer.cmx src/oasis/OASISVersion.cmx src/oasis/OASISLicense.cmx src/oasis/OASISTypes.cmx src/oasis/OASISAst_types.cmx src/oasis/OASISGraph.cmx src/oasis/OASISSection.cmx src/oasis/OASISBuildSection.cmx src/oasis/OASISConf.cmx src/oasis/OASISExec.cmx src/oasis/OASISFeatures.cmx src/oasis/OASISFileUtil.cmx src/oasis/OASISHostPath.cmx src/oasis/OASISFileTemplate.cmx src/oasis/OASISSetupUpdate.cmx src/oasis/OASISPlugin.cmx src/oasis/OASISSchema_intern.cmx src/oasis/OASISBuildSection_intern.cmx src/oasis/OASISCheck.cmx src/oasis/OASISCustom.cmx src/oasis/OASISSection_intern.cmx src/oasis/OASISDocument_intern.cmx src/oasis/OASISSchema.cmx src/oasis/OASISDocument.cmx src/oasis/OASISExecutable_intern.cmx src/oasis/OASISExecutable.cmx src/oasis/OASISFindlib.cmx src/oasis/OASISFlag_intern.cmx src/oasis/OASISFlag.cmx src/oasis/OASISLibrary_intern.cmx src/oasis/OASISLibrary.cmx src/oasis/OASISObject_intern.cmx src/oasis/OASISObject.cmx src/oasis/OASISPackage_intern.cmx src/oasis/OASISPackage.cmx src/oasis/OASISSourceRepository_intern.cmx src/oasis/OASISSourceRepository.cmx src/oasis/OASISTest_intern.cmx src/oasis/OASISTest.cmx src/oasis/OASISAst.cmx src/oasis/OASISAst_parser.cmx src/oasis/OASISAst_lexer.cmx src/oasis/OASISMutex.cmx src/oasis/OASISParse.cmx src/oasis/OASISData.cmx src/oasis/OASISFormat.cmx src/oasis/OASISQuickstart.cmx src/oasis/OASISHelp.cmx -o src/oasis/oasis.cmxs
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseArgExt.mli > src/base/BaseArgExt.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseArgExt.cmi src/base/BaseArgExt.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseArgExt.ml > src/base/BaseArgExt.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseBuilt.mli > src/base/BaseBuilt.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseBuilt.cmi src/base/BaseBuilt.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseBuilt.ml > src/base/BaseBuilt.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseContext.mli > src/base/BaseContext.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseLog.mli > src/base/BaseLog.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseMessage.mli > src/base/BaseMessage.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseStandardVar.mli > src/base/BaseStandardVar.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseContext.cmi src/base/BaseContext.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseLog.cmi src/base/BaseLog.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseMessage.cmi src/base/BaseMessage.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseStandardVar.cmi src/base/BaseStandardVar.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseCheck.mli > src/base/BaseCheck.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseCheck.cmi src/base/BaseCheck.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseCheck.ml > src/base/BaseCheck.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseEnv.mli > src/base/BaseEnv.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseEnv.cmi src/base/BaseEnv.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseCustom.mli > src/base/BaseCustom.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseCustom.cmi src/base/BaseCustom.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseCustom.ml > src/base/BaseCustom.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseData.mli > src/base/BaseData.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseData.cmi src/base/BaseData.mli
- ocamlify --depends --output src/base/BaseData.mlify.depends src/base/BaseData.mlify
- ocamlmod src/base/BaseSys.mod
- ocamlmod src/base/BaseSysEnvironment.mod
- ocamlmod src/base/BaseSysBundle.mod
- ocamlify --output src/base/BaseData.ml src/base/BaseData.mlify
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseData.ml > src/base/BaseData.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseDoc.mli > src/base/BaseDoc.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseDoc.cmi src/base/BaseDoc.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseDoc.ml > src/base/BaseDoc.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseEnvLight.mli > src/base/BaseEnvLight.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseEnvLight.cmi src/base/BaseEnvLight.mli
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseEnvLight.cmi src/base/BaseEnvLight.mli
- File "src/base/BaseEnvLight.mli", line 49, characters 15-23:
- 49 |   ?stream:char Stream.t ->
-                     ^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseEnvLight.ml > src/base/BaseEnvLight.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseEnv.ml > src/base/BaseEnv.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseFileAB.mli > src/base/BaseFileAB.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseFileAB.cmi src/base/BaseFileAB.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseFileAB.ml > src/base/BaseFileAB.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseGenerate.mli > src/base/BaseGenerate.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseGenerate.cmi src/base/BaseGenerate.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseGenerate.ml > src/base/BaseGenerate.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseCompat.ml > src/base/BaseCompat.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseSetup.mli > src/base/BaseSetup.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseSetup.cmi src/base/BaseSetup.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseCompat.cmo src/base/BaseCompat.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseLog.ml > src/base/BaseLog.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseOCamlcConfig.mli > src/base/BaseOCamlcConfig.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseOCamlcConfig.cmi src/base/BaseOCamlcConfig.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseOCamlcConfig.ml > src/base/BaseOCamlcConfig.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseSetup.ml > src/base/BaseSetup.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseDynVar.mli > src/base/BaseDynVar.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseTest.mli > src/base/BaseTest.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseDynVar.cmi src/base/BaseDynVar.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseTest.cmi src/base/BaseTest.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseStandardVar.ml > src/base/BaseStandardVar.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseTest.ml > src/base/BaseTest.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseDynVar.ml > src/base/BaseDynVar.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseMessage.ml > src/base/BaseMessage.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -modules src/base/BaseContext.ml > src/base/BaseContext.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseArgExt.cmo src/base/BaseArgExt.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseBuilt.cmo src/base/BaseBuilt.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseCheck.cmo src/base/BaseCheck.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseCustom.cmo src/base/BaseCustom.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseData.cmo src/base/BaseData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseDoc.cmo src/base/BaseDoc.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseEnvLight.cmo src/base/BaseEnvLight.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseEnvLight.cmo src/base/BaseEnvLight.ml
- File "src/base/BaseEnvLight.ml", line 37, characters 6-17:
- 37 |       Stream.from
-            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 40, characters 19-30:
- 40 |              match Stream.next st with
-                         ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 43, characters 16-30:
- 43 |            with Stream.Failure -> None)
-                      ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 45, characters 4-21:
- 45 |     Genlex.make_lexer ["="] st_line
-          ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 48, characters 10-22:
- 48 |     match Stream.npeek 3 lxr with
-                ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 49, characters 7-19:
- 49 |     | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-             ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 49, characters 24-34:
- 49 |     | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                              ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 49, characters 40-53:
- 49 |     | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                              ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 50, characters 6-17:
- 50 |       Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 50, characters 23-34:
- 50 |       Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                             ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 50, characters 40-51:
- 50 |       Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                              ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 62, characters 15-32:
- 62 |       let st = Stream.of_channel chn in
-                     ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseEnv.cmo src/base/BaseEnv.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseEnv.cmo src/base/BaseEnv.ml
- File "src/base/BaseEnv.ml", line 69, characters 14-31:
- 69 | let var_lxr = Genlex.make_lexer []
-                    ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 88, characters 20-36:
- 88 |            var_lxr (Stream.of_string var)
-                          ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 90, characters 15-27:
- 90 |          match Stream.npeek 3 st with
-                     ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 91, characters 14-26:
- 91 |            | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 91, characters 35-47:
- 91 |            | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                                         ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 93, characters 14-26:
- 93 |            | [Genlex.Ident "utoh"; Genlex.String s] ->
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 93, characters 35-48:
- 93 |            | [Genlex.Ident "utoh"; Genlex.String s] ->
-                                         ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 95, characters 14-26:
- 95 |            | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 95, characters 44-56:
- 95 |            | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                                                  ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 97, characters 14-26:
- 97 |            | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 97, characters 44-57:
- 97 |            | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                                                  ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 99, characters 14-26:
- 99 |            | [Genlex.Ident nm] ->
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 112, characters 11-23:
- 112 |          | Stream.Error e ->
-                  ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 210, characters 14-32:
- 210 |               Pervasives.compare o2 o1)
-                     ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseFileAB.cmo src/base/BaseFileAB.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseGenerate.cmo src/base/BaseGenerate.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseLog.cmo src/base/BaseLog.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseLog.cmo src/base/BaseLog.ml
- File "src/base/BaseLog.ml", line 49, characters 19-36:
- 49 |          let lxr = Genlex.make_lexer [] (stream_of_reader rdr) in
-                         ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 51, characters 17-29:
- 51 |            match Stream.npeek 2 lxr with
-                       ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 52, characters 14-27:
- 52 |            | [Genlex.String e; Genlex.String d] ->
-                    ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 52, characters 31-44:
- 52 |            | [Genlex.String e; Genlex.String d] ->
-                                     ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 54, characters 13-24:
- 54 |              Stream.junk lxr; Stream.junk lxr;
-                   ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 54, characters 30-41:
- 54 |              Stream.junk lxr; Stream.junk lxr;
-                                    ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseOCamlcConfig.cmo src/base/BaseOCamlcConfig.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseSetup.cmo src/base/BaseSetup.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseStandardVar.cmo src/base/BaseStandardVar.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseTest.cmo src/base/BaseTest.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseDynVar.cmo src/base/BaseDynVar.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseMessage.cmo src/base/BaseMessage.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseContext.cmo src/base/BaseContext.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -a -I src/base src/base/BaseArgExt.cmo src/base/BaseContext.cmo src/base/BaseLog.cmo src/base/BaseMessage.cmo src/base/BaseEnvLight.cmo src/base/BaseEnv.cmo src/base/BaseCheck.cmo src/base/BaseOCamlcConfig.cmo src/base/BaseStandardVar.cmo src/base/BaseBuilt.cmo src/base/BaseCustom.cmo src/base/BaseData.cmo src/base/BaseDoc.cmo src/base/BaseFileAB.cmo src/base/BaseDynVar.cmo src/base/BaseTest.cmo src/base/BaseSetup.cmo src/base/BaseCompat.cmo src/base/BaseGenerate.cmo -o src/base/base.cma
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseContext.cmx src/base/BaseContext.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseEnvLight.cmx src/base/BaseEnvLight.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseEnvLight.cmx src/base/BaseEnvLight.ml
- File "src/base/BaseEnvLight.ml", line 37, characters 6-17:
- 37 |       Stream.from
-            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 40, characters 19-30:
- 40 |              match Stream.next st with
-                         ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 43, characters 16-30:
- 43 |            with Stream.Failure -> None)
-                      ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 45, characters 4-21:
- 45 |     Genlex.make_lexer ["="] st_line
-          ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 48, characters 10-22:
- 48 |     match Stream.npeek 3 lxr with
-                ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 49, characters 7-19:
- 49 |     | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-             ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 49, characters 24-34:
- 49 |     | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                              ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 49, characters 40-53:
- 49 |     | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                              ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 50, characters 6-17:
- 50 |       Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 50, characters 23-34:
- 50 |       Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                             ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 50, characters 40-51:
- 50 |       Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                              ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 62, characters 15-32:
- 62 |       let st = Stream.of_channel chn in
-                     ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseMessage.cmx src/base/BaseMessage.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseEnv.cmx src/base/BaseEnv.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseEnv.cmx src/base/BaseEnv.ml
- File "src/base/BaseEnv.ml", line 69, characters 14-31:
- 69 | let var_lxr = Genlex.make_lexer []
-                    ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 88, characters 20-36:
- 88 |            var_lxr (Stream.of_string var)
-                          ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 90, characters 15-27:
- 90 |          match Stream.npeek 3 st with
-                     ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 91, characters 14-26:
- 91 |            | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 91, characters 35-47:
- 91 |            | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                                         ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 93, characters 14-26:
- 93 |            | [Genlex.Ident "utoh"; Genlex.String s] ->
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 93, characters 35-48:
- 93 |            | [Genlex.Ident "utoh"; Genlex.String s] ->
-                                         ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 95, characters 14-26:
- 95 |            | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 95, characters 44-56:
- 95 |            | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                                                  ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 97, characters 14-26:
- 97 |            | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 97, characters 44-57:
- 97 |            | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                                                  ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 99, characters 14-26:
- 99 |            | [Genlex.Ident nm] ->
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 112, characters 11-23:
- 112 |          | Stream.Error e ->
-                  ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 210, characters 14-32:
- 210 |               Pervasives.compare o2 o1)
-                     ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseCheck.cmx src/base/BaseCheck.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseOCamlcConfig.cmx src/base/BaseOCamlcConfig.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseLog.cmx src/base/BaseLog.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseLog.cmx src/base/BaseLog.ml
- File "src/base/BaseLog.ml", line 49, characters 19-36:
- 49 |          let lxr = Genlex.make_lexer [] (stream_of_reader rdr) in
-                         ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 51, characters 17-29:
- 51 |            match Stream.npeek 2 lxr with
-                       ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 52, characters 14-27:
- 52 |            | [Genlex.String e; Genlex.String d] ->
-                    ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 52, characters 31-44:
- 52 |            | [Genlex.String e; Genlex.String d] ->
-                                     ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 54, characters 13-24:
- 54 |              Stream.junk lxr; Stream.junk lxr;
-                   ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 54, characters 30-41:
- 54 |              Stream.junk lxr; Stream.junk lxr;
-                                    ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseStandardVar.cmx src/base/BaseStandardVar.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseCustom.cmx src/base/BaseCustom.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseData.cmx src/base/BaseData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseDoc.cmx src/base/BaseDoc.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseBuilt.cmx src/base/BaseBuilt.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseFileAB.cmx src/base/BaseFileAB.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseDynVar.cmx src/base/BaseDynVar.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseTest.cmx src/base/BaseTest.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseSetup.cmx src/base/BaseSetup.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseCompat.cmx src/base/BaseCompat.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseArgExt.cmx src/base/BaseArgExt.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -package unix -I src/base -I src/oasis -o src/base/BaseGenerate.cmx src/base/BaseGenerate.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -a -I src/base src/base/BaseArgExt.cmx src/base/BaseContext.cmx src/base/BaseEnvLight.cmx src/base/BaseEnv.cmx src/base/BaseMessage.cmx src/base/BaseCheck.cmx src/base/BaseLog.cmx src/base/BaseOCamlcConfig.cmx src/base/BaseStandardVar.cmx src/base/BaseBuilt.cmx src/base/BaseCustom.cmx src/base/BaseData.cmx src/base/BaseDoc.cmx src/base/BaseFileAB.cmx src/base/BaseDynVar.cmx src/base/BaseTest.cmx src/base/BaseSetup.cmx src/base/BaseCompat.cmx src/base/BaseGenerate.cmx -o src/base/base.cmxa
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -shared -I src/base src/base/base.cmxa src/base/BaseArgExt.cmx src/base/BaseContext.cmx src/base/BaseEnvLight.cmx src/base/BaseEnv.cmx src/base/BaseMessage.cmx src/base/BaseCheck.cmx src/base/BaseLog.cmx src/base/BaseOCamlcConfig.cmx src/base/BaseStandardVar.cmx src/base/BaseBuilt.cmx src/base/BaseCustom.cmx src/base/BaseData.cmx src/base/BaseDoc.cmx src/base/BaseFileAB.cmx src/base/BaseDynVar.cmx src/base/BaseTest.cmx src/base/BaseSetup.cmx src/base/BaseCompat.cmx src/base/BaseGenerate.cmx -o src/base/base.cmxs
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/OASISBuiltinPlugins.ml > src/OASISBuiltinPlugins.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/custom/CustomPlugin.ml > src/plugins/custom/CustomPlugin.ml.depends
- ocamlify --depends --output src/plugins/custom/CustomData.mlify.depends src/plugins/custom/CustomData.mlify
- ocamlmod src/plugins/custom/CustomSys.mod
- ocamlify --output src/plugins/custom/CustomData.ml src/plugins/custom/CustomData.mlify
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/custom/CustomData.ml > src/plugins/custom/CustomData.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/custom -o src/plugins/custom/CustomData.cmo src/plugins/custom/CustomData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/extra/devfiles/DevFilesPlugin.ml > src/plugins/extra/devfiles/DevFilesPlugin.ml.depends
- ocamlify --depends --output src/plugins/extra/devfiles/DevFilesData.mlify.depends src/plugins/extra/devfiles/DevFilesData.mlify
- ocamlify --output src/plugins/extra/devfiles/DevFilesData.ml src/plugins/extra/devfiles/DevFilesData.mlify
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/extra/devfiles/DevFilesData.ml > src/plugins/extra/devfiles/DevFilesData.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/extra/devfiles -o src/plugins/extra/devfiles/DevFilesData.cmo src/plugins/extra/devfiles/DevFilesData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/internal/InternalConfigurePlugin.ml > src/plugins/internal/InternalConfigurePlugin.ml.depends
- ocamlify --depends --output src/plugins/internal/InternalData.mlify.depends src/plugins/internal/InternalData.mlify
- ocamlmod src/plugins/internal/InternalSys.mod
- ocamlify --output src/plugins/internal/InternalData.ml src/plugins/internal/InternalData.mlify
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/internal/InternalData.ml > src/plugins/internal/InternalData.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/internal/InternalId.ml > src/plugins/internal/InternalId.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/internal -o src/plugins/internal/InternalData.cmo src/plugins/internal/InternalData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/internal -o src/plugins/internal/InternalId.cmo src/plugins/internal/InternalId.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/internal/InternalInstallPlugin.ml > src/plugins/internal/InternalInstallPlugin.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/extra/META/METAPlugin.ml > src/plugins/extra/META/METAPlugin.ml.depends
- ocamlify --depends --output src/plugins/extra/META/METAData.mlify.depends src/plugins/extra/META/METAData.mlify
- ocamlify --output src/plugins/extra/META/METAData.ml src/plugins/extra/META/METAData.mlify
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/extra/META/METAData.ml > src/plugins/extra/META/METAData.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/extra/META -o src/plugins/extra/META/METAData.cmo src/plugins/extra/META/METAData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/none/NonePlugin.ml > src/plugins/none/NonePlugin.ml.depends
- ocamlify --depends --output src/plugins/none/NoneData.mlify.depends src/plugins/none/NoneData.mlify
- ocamlmod src/plugins/none/NoneSys.mod
- ocamlify --output src/plugins/none/NoneData.ml src/plugins/none/NoneData.mlify
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/none/NoneData.ml > src/plugins/none/NoneData.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/none -o src/plugins/none/NoneData.cmo src/plugins/none/NoneData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/ocamlbuild/OCamlbuildDocPlugin.ml > src/plugins/ocamlbuild/OCamlbuildDocPlugin.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/ocamlbuild/OCamlbuildCommon.ml > src/plugins/ocamlbuild/OCamlbuildCommon.ml.depends
- ocamlify --depends --output src/plugins/ocamlbuild/OCamlbuildData.mlify.depends src/plugins/ocamlbuild/OCamlbuildData.mlify
- ocamlmod src/plugins/ocamlbuild/MyOCamlbuildSys.mod
- ocamlmod src/plugins/ocamlbuild/OCamlbuildSys.mod
- ocamlify --output src/plugins/ocamlbuild/OCamlbuildData.ml src/plugins/ocamlbuild/OCamlbuildData.mlify
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/ocamlbuild/OCamlbuildData.ml > src/plugins/ocamlbuild/OCamlbuildData.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/ocamlbuild/OCamlbuildId.ml > src/plugins/ocamlbuild/OCamlbuildId.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/omake -I src/plugins/ocamlbuild -o src/plugins/ocamlbuild/OCamlbuildData.cmo src/plugins/ocamlbuild/OCamlbuildData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/omake -I src/plugins/ocamlbuild -o src/plugins/ocamlbuild/OCamlbuildCommon.cmo src/plugins/ocamlbuild/OCamlbuildCommon.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/omake -I src/plugins/ocamlbuild -o src/plugins/ocamlbuild/OCamlbuildId.cmo src/plugins/ocamlbuild/OCamlbuildId.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/ocamlbuild/OCamlbuildPlugin.ml > src/plugins/ocamlbuild/OCamlbuildPlugin.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/ocamlbuild/MyOCamlbuildBase.ml > src/plugins/ocamlbuild/MyOCamlbuildBase.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/ocamlbuild/MyOCamlbuildFindlib.ml > src/plugins/ocamlbuild/MyOCamlbuildFindlib.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -I +ocamlbuild -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/omake -I src/plugins/ocamlbuild -o src/plugins/ocamlbuild/MyOCamlbuildFindlib.cmo src/plugins/ocamlbuild/MyOCamlbuildFindlib.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -I +ocamlbuild -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/omake -I src/plugins/ocamlbuild -o src/plugins/ocamlbuild/MyOCamlbuildBase.cmo src/plugins/ocamlbuild/MyOCamlbuildBase.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/omake/OMakePlugin.ml > src/plugins/omake/OMakePlugin.ml.depends
- ocamlify --depends --output src/plugins/omake/OMakeData.mlify.depends src/plugins/omake/OMakeData.mlify
- ocamlmod src/plugins/omake/OMakeSys.mod
- ocamlify --output src/plugins/omake/OMakeData.ml src/plugins/omake/OMakeData.mlify
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/omake/OMakeData.ml > src/plugins/omake/OMakeData.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/omake/OMakeEquip.ml > src/plugins/omake/OMakeEquip.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/plugins/omake/OMakeData.cmo src/plugins/omake/OMakeData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/omake/OMakeFields.ml > src/plugins/omake/OMakeFields.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/omake/OMakeFormat.ml > src/plugins/omake/OMakeFormat.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/plugins/omake/OMakeFields.cmo src/plugins/omake/OMakeFields.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/plugins/omake/OMakeFormat.cmo src/plugins/omake/OMakeFormat.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/plugins/omake/OMakeEquip.cmo src/plugins/omake/OMakeEquip.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/extra/stdfiles/StdFilesPlugin.ml > src/plugins/extra/stdfiles/StdFilesPlugin.ml.depends
- ocamlify --depends --output src/plugins/extra/stdfiles/StdFilesData.mlify.depends src/plugins/extra/stdfiles/StdFilesData.mlify
- ocamlify --output src/plugins/extra/stdfiles/StdFilesData.ml src/plugins/extra/stdfiles/StdFilesData.mlify
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/plugins/extra/stdfiles/StdFilesData.ml > src/plugins/extra/stdfiles/StdFilesData.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/extra/stdfiles -o src/plugins/extra/stdfiles/StdFilesData.cmo src/plugins/extra/stdfiles/StdFilesData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/custom -o src/plugins/custom/CustomPlugin.cmo src/plugins/custom/CustomPlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/extra/devfiles -o src/plugins/extra/devfiles/DevFilesPlugin.cmo src/plugins/extra/devfiles/DevFilesPlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/internal -o src/plugins/internal/InternalConfigurePlugin.cmo src/plugins/internal/InternalConfigurePlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/internal -o src/plugins/internal/InternalInstallPlugin.cmo src/plugins/internal/InternalInstallPlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/extra/META -o src/plugins/extra/META/METAPlugin.cmo src/plugins/extra/META/METAPlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/none -o src/plugins/none/NonePlugin.cmo src/plugins/none/NonePlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/omake -I src/plugins/ocamlbuild -o src/plugins/ocamlbuild/OCamlbuildDocPlugin.cmo src/plugins/ocamlbuild/OCamlbuildDocPlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -I +ocamlbuild -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/omake -I src/plugins/ocamlbuild -o src/plugins/ocamlbuild/OCamlbuildPlugin.cmo src/plugins/ocamlbuild/OCamlbuildPlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/plugins/omake/OMakePlugin.cmo src/plugins/omake/OMakePlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/extra/stdfiles -o src/plugins/extra/stdfiles/StdFilesPlugin.cmo src/plugins/extra/stdfiles/StdFilesPlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/OASISBuiltinPlugins.cmo src/OASISBuiltinPlugins.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -a -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src src/plugins/custom/CustomData.cmo src/plugins/custom/CustomPlugin.cmo src/plugins/extra/META/METAData.cmo src/plugins/extra/META/METAPlugin.cmo src/plugins/extra/devfiles/DevFilesData.cmo src/plugins/extra/devfiles/DevFilesPlugin.cmo src/plugins/extra/stdfiles/StdFilesData.cmo src/plugins/extra/stdfiles/StdFilesPlugin.cmo src/plugins/internal/InternalData.cmo src/plugins/internal/InternalId.cmo src/plugins/internal/InternalConfigurePlugin.cmo src/plugins/internal/InternalInstallPlugin.cmo src/plugins/none/NoneData.cmo src/plugins/none/NonePlugin.cmo src/plugins/ocamlbuild/OCamlbuildCommon.cmo src/plugins/ocamlbuild/OCamlbuildData.cmo src/plugins/ocamlbuild/OCamlbuildId.cmo src/plugins/ocamlbuild/OCamlbuildDocPlugin.cmo src/plugins/ocamlbuild/MyOCamlbuildFindlib.cmo src/plugins/ocamlbuild/MyOCamlbuildBase.cmo src/plugins/ocamlbuild/OCamlbuildPlugin.cmo src/plugins/omake/OMakeData.cmo src/plugins/omake/OMakeFields.cmo src/plugins/omake/OMakeFormat.cmo src/plugins/omake/OMakeEquip.cmo src/plugins/omake/OMakePlugin.cmo src/OASISBuiltinPlugins.cmo -o src/builtin-plugins.cma
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/custom -o src/plugins/custom/CustomData.cmx src/plugins/custom/CustomData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/extra/devfiles -o src/plugins/extra/devfiles/DevFilesData.cmx src/plugins/extra/devfiles/DevFilesData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/internal -o src/plugins/internal/InternalData.cmx src/plugins/internal/InternalData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/internal -o src/plugins/internal/InternalId.cmx src/plugins/internal/InternalId.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/extra/META -o src/plugins/extra/META/METAData.cmx src/plugins/extra/META/METAData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/none -o src/plugins/none/NoneData.cmx src/plugins/none/NoneData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/omake -I src/plugins/ocamlbuild -o src/plugins/ocamlbuild/OCamlbuildData.cmx src/plugins/ocamlbuild/OCamlbuildData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/omake -I src/plugins/ocamlbuild -o src/plugins/ocamlbuild/OCamlbuildCommon.cmx src/plugins/ocamlbuild/OCamlbuildCommon.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/omake -I src/plugins/ocamlbuild -o src/plugins/ocamlbuild/OCamlbuildId.cmx src/plugins/ocamlbuild/OCamlbuildId.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -I +ocamlbuild -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/omake -I src/plugins/ocamlbuild -o src/plugins/ocamlbuild/MyOCamlbuildFindlib.cmx src/plugins/ocamlbuild/MyOCamlbuildFindlib.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -I +ocamlbuild -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/omake -I src/plugins/ocamlbuild -o src/plugins/ocamlbuild/MyOCamlbuildBase.cmx src/plugins/ocamlbuild/MyOCamlbuildBase.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/plugins/omake/OMakeData.cmx src/plugins/omake/OMakeData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/plugins/omake/OMakeFields.cmx src/plugins/omake/OMakeFields.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/plugins/omake/OMakeFormat.cmx src/plugins/omake/OMakeFormat.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/plugins/omake/OMakeEquip.cmx src/plugins/omake/OMakeEquip.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/extra/stdfiles -o src/plugins/extra/stdfiles/StdFilesData.cmx src/plugins/extra/stdfiles/StdFilesData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/custom -o src/plugins/custom/CustomPlugin.cmx src/plugins/custom/CustomPlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/extra/devfiles -o src/plugins/extra/devfiles/DevFilesPlugin.cmx src/plugins/extra/devfiles/DevFilesPlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/internal -o src/plugins/internal/InternalConfigurePlugin.cmx src/plugins/internal/InternalConfigurePlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/internal -o src/plugins/internal/InternalInstallPlugin.cmx src/plugins/internal/InternalInstallPlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/extra/META -o src/plugins/extra/META/METAPlugin.cmx src/plugins/extra/META/METAPlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/none -o src/plugins/none/NonePlugin.cmx src/plugins/none/NonePlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/omake -I src/plugins/ocamlbuild -o src/plugins/ocamlbuild/OCamlbuildDocPlugin.cmx src/plugins/ocamlbuild/OCamlbuildDocPlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -I +ocamlbuild -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/omake -I src/plugins/ocamlbuild -o src/plugins/ocamlbuild/OCamlbuildPlugin.cmx src/plugins/ocamlbuild/OCamlbuildPlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/plugins/omake/OMakePlugin.cmx src/plugins/omake/OMakePlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/plugins/extra/stdfiles -o src/plugins/extra/stdfiles/StdFilesPlugin.cmx src/plugins/extra/stdfiles/StdFilesPlugin.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -package unix -package ocamlbuild -I src -I src/base -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/OASISBuiltinPlugins.cmx src/OASISBuiltinPlugins.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -a -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src src/plugins/custom/CustomData.cmx src/plugins/custom/CustomPlugin.cmx src/plugins/extra/META/METAData.cmx src/plugins/extra/META/METAPlugin.cmx src/plugins/extra/devfiles/DevFilesData.cmx src/plugins/extra/devfiles/DevFilesPlugin.cmx src/plugins/extra/stdfiles/StdFilesData.cmx src/plugins/extra/stdfiles/StdFilesPlugin.cmx src/plugins/internal/InternalData.cmx src/plugins/internal/InternalId.cmx src/plugins/internal/InternalConfigurePlugin.cmx src/plugins/internal/InternalInstallPlugin.cmx src/plugins/none/NoneData.cmx src/plugins/none/NonePlugin.cmx src/plugins/ocamlbuild/MyOCamlbuildFindlib.cmx src/plugins/ocamlbuild/MyOCamlbuildBase.cmx src/plugins/ocamlbuild/OCamlbuildCommon.cmx src/plugins/ocamlbuild/OCamlbuildData.cmx src/plugins/ocamlbuild/OCamlbuildId.cmx src/plugins/ocamlbuild/OCamlbuildDocPlugin.cmx src/plugins/ocamlbuild/OCamlbuildPlugin.cmx src/plugins/omake/OMakeData.cmx src/plugins/omake/OMakeFields.cmx src/plugins/omake/OMakeFormat.cmx src/plugins/omake/OMakeEquip.cmx src/plugins/omake/OMakePlugin.cmx src/OASISBuiltinPlugins.cmx -o src/builtin-plugins.cmxa
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -shared -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake src/builtin-plugins.cmxa src/plugins/custom/CustomData.cmx src/plugins/custom/CustomPlugin.cmx src/plugins/extra/META/METAData.cmx src/plugins/extra/META/METAPlugin.cmx src/plugins/extra/devfiles/DevFilesData.cmx src/plugins/extra/devfiles/DevFilesPlugin.cmx src/plugins/extra/stdfiles/StdFilesData.cmx src/plugins/extra/stdfiles/StdFilesPlugin.cmx src/plugins/internal/InternalData.cmx src/plugins/internal/InternalId.cmx src/plugins/internal/InternalConfigurePlugin.cmx src/plugins/internal/InternalInstallPlugin.cmx src/plugins/none/NoneData.cmx src/plugins/none/NonePlugin.cmx src/plugins/ocamlbuild/MyOCamlbuildFindlib.cmx src/plugins/ocamlbuild/MyOCamlbuildBase.cmx src/plugins/ocamlbuild/OCamlbuildCommon.cmx src/plugins/ocamlbuild/OCamlbuildData.cmx src/plugins/ocamlbuild/OCamlbuildId.cmx src/plugins/ocamlbuild/OCamlbuildDocPlugin.cmx src/plugins/ocamlbuild/OCamlbuildPlugin.cmx src/plugins/omake/OMakeData.cmx src/plugins/omake/OMakeFields.cmx src/plugins/omake/OMakeFormat.cmx src/plugins/omake/OMakeEquip.cmx src/plugins/omake/OMakePlugin.cmx src/OASISBuiltinPlugins.cmx -o src/builtin-plugins.cmxs
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package unix -package ocamlbuild -modules src/dynrun/OASISDynRun.ml > src/dynrun/OASISDynRun.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -package unix -package ocamlbuild -I src/dynrun -I src -I src/base -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/dynrun/OASISDynRun.cmo src/dynrun/OASISDynRun.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -a -I src/dynrun src/dynrun/OASISDynRun.cmo -o src/dynrun/dynrun.cma
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -package unix -package ocamlbuild -I src/dynrun -I src -I src/base -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/dynrun/OASISDynRun.cmx src/dynrun/OASISDynRun.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -a -I src/dynrun src/dynrun/OASISDynRun.cmx -o src/dynrun/dynrun.cmxa
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -shared -I src/dynrun src/dynrun/dynrun.cmxa src/dynrun/OASISDynRun.cmx -o src/dynrun/dynrun.cmxs
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -modules src/ext/plugin-loader/src/PluginLoader.ml > src/ext/plugin-loader/src/PluginLoader.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -package findlib -package dynlink -I src/ext/plugin-loader/src -o src/ext/plugin-loader/src/PluginLoader.cmo src/ext/plugin-loader/src/PluginLoader.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -a -I src/ext/plugin-loader/src src/ext/plugin-loader/src/PluginLoader.cmo -o src/ext/plugin-loader/src/plugin-loader.cma
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -package findlib -package dynlink -I src/ext/plugin-loader/src -o src/ext/plugin-loader/src/PluginLoader.cmx src/ext/plugin-loader/src/PluginLoader.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -a -I src/ext/plugin-loader/src src/ext/plugin-loader/src/PluginLoader.cmx -o src/ext/plugin-loader/src/plugin-loader.cmxa
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -shared -I src/ext/plugin-loader/src src/ext/plugin-loader/src/plugin-loader.cmxa src/ext/plugin-loader/src/PluginLoader.cmx -o src/ext/plugin-loader/src/plugin-loader.cmxs
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/CLISubCommand.mli > src/cli/CLISubCommand.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/CLISubCommand.cmi src/cli/CLISubCommand.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/CLISubCommand.ml > src/cli/CLISubCommand.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/CLIPluginLoader.ml > src/cli/CLIPluginLoader.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/CLIPluginsLoaded.ml > src/cli/CLIPluginsLoaded.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/CLIPluginsLoaded.cmo src/cli/CLIPluginsLoaded.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/CLIPluginLoader.cmo src/cli/CLIPluginLoader.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/CLIArgExt.ml > src/cli/CLIArgExt.ml.depends
- ocamlify --depends --output src/cli/CLIData.mlify.depends src/cli/CLIData.mlify
- ocamlify --output src/cli/CLIData.ml src/cli/CLIData.mlify
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/CLIData.ml > src/cli/CLIData.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/CLIData.cmo src/cli/CLIData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/CLICommon.mli > src/cli/CLICommon.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/CLICommon.cmi src/cli/CLICommon.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/CLICommon.ml > src/cli/CLICommon.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/CLIPager.ml > src/cli/CLIPager.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/CLISubCommand.cmo src/cli/CLISubCommand.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/CLIArgExt.cmo src/cli/CLIArgExt.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/CLICommon.cmo src/cli/CLICommon.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/CLIPager.cmo src/cli/CLIPager.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -a -I src/cli src/cli/CLIPluginsLoaded.cmo src/cli/CLIPluginLoader.cmo src/cli/CLISubCommand.cmo src/cli/CLIData.cmo src/cli/CLIArgExt.cmo src/cli/CLICommon.cmo src/cli/CLIPager.cmo -o src/cli/cli.cma
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/Main.ml > src/cli/Main.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/Check.ml > src/cli/Check.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/Help.ml > src/cli/Help.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/Manual.ml > src/cli/Manual.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/Query.ml > src/cli/Query.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamllex.opt -q src/cli/Query_lexer.mll
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/Query_lexer.ml > src/cli/Query_lexer.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlyacc src/cli/Query_parser.mly
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/Query_parser.mli > src/cli/Query_parser.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/Query_types.ml > src/cli/Query_types.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Query_types.cmo src/cli/Query_types.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Query_parser.cmi src/cli/Query_parser.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Query_lexer.cmo src/cli/Query_lexer.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/Quickstart.ml > src/cli/Quickstart.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/Setup.ml > src/cli/Setup.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Setup.cmo src/cli/Setup.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Setup.cmo src/cli/Setup.ml
- File "src/cli/Setup.ml", line 109, characters 2-24:
- 109 |   CLISubCommand.register "setup"
-         ^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: labels synopsis, help were omitted in the application of this function.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/SetupClean.ml > src/cli/SetupClean.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/SetupDev.ml > src/cli/SetupDev.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/Version.ml > src/cli/Version.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Check.cmo src/cli/Check.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Check.cmo src/cli/Check.ml
- File "src/cli/Check.ml", line 39, characters 2-24:
- 39 |   CLISubCommand.register "check"
-        ^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: labels synopsis, help were omitted in the application of this function.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Help.cmo src/cli/Help.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Manual.cmo src/cli/Manual.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Manual.cmo src/cli/Manual.ml
- File "src/cli/Manual.ml", line 72, characters 2-24:
- 72 |   CLISubCommand.register "manual"
-        ^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: labels synopsis, help were omitted in the application of this function.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Query.cmo src/cli/Query.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Quickstart.cmo src/cli/Quickstart.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Quickstart.cmo src/cli/Quickstart.ml
- File "src/cli/Quickstart.ml", line 70, characters 2-24:
- 70 |   CLISubCommand.register "quickstart"
-        ^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: labels synopsis, help were omitted in the application of this function.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/SetupClean.cmo src/cli/SetupClean.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/SetupClean.cmo src/cli/SetupClean.ml
- File "src/cli/SetupClean.ml", line 61, characters 2-24:
- 61 |   CLISubCommand.register "setup-clean"
-        ^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: labels synopsis, help were omitted in the application of this function.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/SetupDev.cmo src/cli/SetupDev.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Version.cmo src/cli/Version.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Main.cmo src/cli/Main.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/CLIPluginsLoaded.cmx src/cli/CLIPluginsLoaded.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/CLIPluginLoader.cmx src/cli/CLIPluginLoader.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/CLIData.cmx src/cli/CLIData.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/CLISubCommand.cmx src/cli/CLISubCommand.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/CLICommon.cmx src/cli/CLICommon.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/CLIArgExt.cmx src/cli/CLIArgExt.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/CLIPager.cmx src/cli/CLIPager.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package findlib -package dynlink -package unix -package ocamlbuild -modules src/cli/Query_parser.ml > src/cli/Query_parser.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Query_types.cmx src/cli/Query_types.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Query_parser.cmx src/cli/Query_parser.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Query_lexer.cmx src/cli/Query_lexer.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Setup.cmx src/cli/Setup.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Setup.cmx src/cli/Setup.ml
- File "src/cli/Setup.ml", line 109, characters 2-24:
- 109 |   CLISubCommand.register "setup"
-         ^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: labels synopsis, help were omitted in the application of this function.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Check.cmx src/cli/Check.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Check.cmx src/cli/Check.ml
- File "src/cli/Check.ml", line 39, characters 2-24:
- 39 |   CLISubCommand.register "check"
-        ^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: labels synopsis, help were omitted in the application of this function.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Help.cmx src/cli/Help.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Manual.cmx src/cli/Manual.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Manual.cmx src/cli/Manual.ml
- File "src/cli/Manual.ml", line 72, characters 2-24:
- 72 |   CLISubCommand.register "manual"
-        ^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: labels synopsis, help were omitted in the application of this function.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Query.cmx src/cli/Query.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Quickstart.cmx src/cli/Quickstart.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Quickstart.cmx src/cli/Quickstart.ml
- File "src/cli/Quickstart.ml", line 70, characters 2-24:
- 70 |   CLISubCommand.register "quickstart"
-        ^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: labels synopsis, help were omitted in the application of this function.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/SetupClean.cmx src/cli/SetupClean.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/SetupClean.cmx src/cli/SetupClean.ml
- File "src/cli/SetupClean.ml", line 61, characters 2-24:
- 61 |   CLISubCommand.register "setup-clean"
-        ^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: labels synopsis, help were omitted in the application of this function.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/SetupDev.cmx src/cli/SetupDev.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Version.cmx src/cli/Version.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -safe-string -I src/oasis -I src/base -I src -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -I src/ext/plugin-loader/src -I src/cli -package findlib -package dynlink -package unix -package ocamlbuild -I src/cli -I src -I src/base -I src/ext/plugin-loader/src -I src/oasis -I src/plugins/custom -I src/plugins/extra/META -I src/plugins/extra/devfiles -I src/plugins/extra/stdfiles -I src/plugins/internal -I src/plugins/none -I src/plugins/ocamlbuild -I src/plugins/omake -o src/cli/Main.cmx src/cli/Main.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -a -I src/cli src/cli/CLIPluginsLoaded.cmx src/cli/CLIPluginLoader.cmx src/cli/CLISubCommand.cmx src/cli/CLIData.cmx src/cli/CLIArgExt.cmx src/cli/CLICommon.cmx src/cli/CLIPager.cmx -o src/cli/cli.cmxa
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -linkpkg -g -linkpkg -package findlib -package dynlink -package unix -package ocamlbuild -I src/oasis -I src/base -I src -I src/ext/plugin-loader/src -I src/cli src/oasis/oasis.cmxa src/base/base.cmxa src/builtin-plugins.cmxa src/ext/plugin-loader/src/plugin-loader.cmxa src/cli/cli.cmxa src/cli/Check.cmx src/cli/Help.cmx src/cli/Manual.cmx src/cli/Query_types.cmx src/cli/Query_parser.cmx src/cli/Query_lexer.cmx src/cli/Query.cmx src/cli/Setup.cmx src/cli/Quickstart.cmx src/cli/SetupClean.cmx src/cli/SetupDev.cmx src/cli/Version.cmx src/cli/Main.cmx -o src/cli/Main.native
- + ocamlfind ocamlopt unix.cmxa -I /home/opam/.opam/4.14.1/lib/ocamlbuild /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuildlib.cmxa -linkpkg myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- File "src/base/BaseEnvLight.ml", line 37, characters 8-19:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 40, characters 21-32:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 43, characters 18-32:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 45, characters 6-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 48, characters 12-24:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 49, characters 9-21:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 49, characters 26-36:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 49, characters 42-55:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 50, characters 8-19:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 50, characters 25-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 50, characters 42-53:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 62, characters 17-34:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
-> compiled  oasis.0.4.11
Processing 265/346: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_hash: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build] [zed: dune build]
Processing 266/346: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_hash: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build] [zed: dune build] [oasis: ocaml setup.ml]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_hash" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_hash.v0.14.0)
-> compiled  ppx_hash.v0.14.0
Processing 266/346: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build] [zed: dune build] [oasis: ocaml setup.ml]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_sexp_message" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_sexp_message.v0.14.1)
-> compiled  ppx_sexp_message.v0.14.1
Processing 266/346: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_sexp_value: dune build] [zed: dune build] [oasis: ocaml setup.ml]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_sexp_value" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_sexp_value.v0.14.0)
-> compiled  ppx_sexp_value.v0.14.0
Processing 266/346: [ppx_assert: dune build] [ppx_custom_printf: dune build] [zed: dune build] [oasis: ocaml setup.ml]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "zed" "-j" "7" "@install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/zed.3.2.3)
-> compiled  zed.3.2.3
Processing 266/346: [ppx_assert: dune build] [ppx_custom_printf: dune build] [oasis: ocaml setup.ml]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_assert" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_assert.v0.14.0)
- (cd _build/default && /home/opam/.opam/4.14.1/bin/ocamlc.opt -w -40 -g -bin-annot -I runtime-lib/.ppx_assert_lib.objs/byte -I /home/opam/.opam/4.14.1/lib/base -I /home/opam/.opam/4.14.1/lib/base/base_internalhash_types -I /home/opam/.opam/4.14.1/lib/base/caml -I /home/opam/.opam/4.14.1/lib/base/shadow_stdlib -I /home/opam/.opam/4.14.1/lib/ppx_sexp_conv/runtime-lib -I /home/opam/.opam/4.14.1/lib/sexplib0 -intf-suffix .ml -no-alias-deps -open Ppx_assert_lib -o runtime-lib/.ppx_assert_lib.objs/byte/ppx_assert_lib__Runtime.cmo -c -impl runtime-lib/runtime.pp.ml)
- File "runtime-lib/runtime.ml", line 74, characters 46-51:
- 74 | let test_result_or_eq ~sexpifier ~comparator ?equal ~expect ~got =
-                                                    ^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "runtime-lib/runtime.ml", line 102, characters 60-65:
- 102 | let test_result ~pos ~sexpifier ~comparator ~here ?message ?equal ~expect ~got =
-                                                                   ^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "runtime-lib/runtime.ml", line 102, characters 51-58:
- 102 | let test_result ~pos ~sexpifier ~comparator ~here ?message ?equal ~expect ~got =
-                                                          ^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- (cd _build/default && /home/opam/.opam/4.14.1/bin/ocamlopt.opt -w -40 -g -I runtime-lib/.ppx_assert_lib.objs/byte -I runtime-lib/.ppx_assert_lib.objs/native -I /home/opam/.opam/4.14.1/lib/base -I /home/opam/.opam/4.14.1/lib/base/base_internalhash_types -I /home/opam/.opam/4.14.1/lib/base/caml -I /home/opam/.opam/4.14.1/lib/base/shadow_stdlib -I /home/opam/.opam/4.14.1/lib/ppx_sexp_conv/runtime-lib -I /home/opam/.opam/4.14.1/lib/sexplib0 -intf-suffix .ml -no-alias-deps -open Ppx_assert_lib -o runtime-lib/.ppx_assert_lib.objs/native/ppx_assert_lib__Runtime.cmx -c -impl runtime-lib/runtime.pp.ml)
- File "runtime-lib/runtime.ml", line 74, characters 46-51:
- 74 | let test_result_or_eq ~sexpifier ~comparator ?equal ~expect ~got =
-                                                    ^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "runtime-lib/runtime.ml", line 102, characters 60-65:
- 102 | let test_result ~pos ~sexpifier ~comparator ~here ?message ?equal ~expect ~got =
-                                                                   ^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "runtime-lib/runtime.ml", line 102, characters 51-58:
- 102 | let test_result ~pos ~sexpifier ~comparator ~here ?message ?equal ~expect ~got =
-                                                          ^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
-> compiled  ppx_assert.v0.14.0
Processing 266/346: [ppx_custom_printf: dune build] [oasis: ocaml setup.ml]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_custom_printf" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_custom_printf.v0.14.1)
-> compiled  ppx_custom_printf.v0.14.1
Processing 266/346: [oasis: ocaml setup.ml]
+ /home/opam/.opam/4.14.1/bin/ocaml "setup.ml" "-install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/oasis.0.4.11)
- File "src/oasis/OASISFileSystem.ml", line 107, characters 4-15:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISFileSystem.ml", line 135, characters 19-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISFileSystem.ml", line 142, characters 37-48:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISFileSystem.ml", line 145, characters 17-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 85, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 87, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 88, characters 14-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 89, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 89, characters 28-40:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 90, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 90, characters 28-41:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 91, characters 11-24:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISSourcePatterns.ml", line 92, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/oasis/OASISFeatures.ml", line 32, characters 22-40:
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "src/base/BaseEnvLight.ml", line 37, characters 8-19:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 40, characters 21-32:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 43, characters 18-32:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 45, characters 6-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 48, characters 12-24:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 49, characters 9-21:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 49, characters 26-36:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 49, characters 42-55:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 50, characters 8-19:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 50, characters 25-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 50, characters 42-53:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnvLight.ml", line 62, characters 17-34:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 69, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 88, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 90, characters 17-29:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 91, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 91, characters 37-49:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 93, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 93, characters 37-50:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 95, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 95, characters 46-58:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 97, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 97, characters 46-59:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 99, characters 16-28:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 112, characters 13-25:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseEnv.ml", line 210, characters 16-34:
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "src/base/BaseLog.ml", line 49, characters 21-38:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 51, characters 19-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 52, characters 16-29:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 52, characters 33-46:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 54, characters 15-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "src/base/BaseLog.ml", line 54, characters 32-43:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- W: Nothing to install for findlib library 'test-common'
- W: Nothing to install for findlib library 'pluginloaderLib'
- W: Nothing to install for findlib library 'plugin3'
- W: Nothing to install for findlib library 'plugin2'
- W: Nothing to install for findlib library 'plugin1'
- Installed /home/opam/.opam/4.14.1/lib/plugin-loader/PluginLoader.ml
- Installed /home/opam/.opam/4.14.1/lib/plugin-loader/plugin-loader.cma
- Installed /home/opam/.opam/4.14.1/lib/plugin-loader/plugin-loader.cmxa
- Installed /home/opam/.opam/4.14.1/lib/plugin-loader/plugin-loader.a
- Installed /home/opam/.opam/4.14.1/lib/plugin-loader/plugin-loader.cmxs
- Installed /home/opam/.opam/4.14.1/lib/plugin-loader/PluginLoader.cmi
- Installed /home/opam/.opam/4.14.1/lib/plugin-loader/PluginLoader.cmt
- Installed /home/opam/.opam/4.14.1/lib/plugin-loader/PluginLoader.annot
- Installed /home/opam/.opam/4.14.1/lib/plugin-loader/PluginLoader.cmx
- Installed /home/opam/.opam/4.14.1/lib/plugin-loader/META
- W: Cannot find source header for module library in OASISData oasis
- Installed /home/opam/.opam/4.14.1/lib/oasis/FormatExt.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/PropList.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISUtils.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISUnixPath.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFileSystem.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISContext.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSourcePatterns.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISGettext.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISMessage.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISText.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISTypes.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISParse.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISValues.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISExpr.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISVersion.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISLicense.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFileTemplate.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISBuildSection.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISDocument.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISExecutable.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFlag.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSetupUpdate.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISLibrary.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISObject.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISPackage.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSourceRepository.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISTest.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISPlugin.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFindlib.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSchema.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSection.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISString.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISExec.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFileUtil.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISHostPath.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISGraph.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFeatures.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISDataNotation.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/oasis.cma
- Installed /home/opam/.opam/4.14.1/lib/oasis/oasis.cmxa
- Installed /home/opam/.opam/4.14.1/lib/oasis/oasis.a
- Installed /home/opam/.opam/4.14.1/lib/oasis/oasis.cmxs
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISDataNotation.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISDataNotation.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISDataNotation.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFeatures.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFeatures.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFeatures.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISGraph.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISGraph.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISGraph.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISHostPath.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISHostPath.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISHostPath.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISHostPath.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFileUtil.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFileUtil.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFileUtil.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFileUtil.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISExec.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISExec.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISExec.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISExec.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISString.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISString.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISString.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISData.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISData.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISData.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSection.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSection.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSection.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSection.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSchema.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSchema.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSchema.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSchema.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFindlib.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFindlib.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFindlib.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFindlib.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISPlugin.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISPlugin.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISPlugin.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISPlugin.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISTest.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISTest.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISTest.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISTest.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSourceRepository.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSourceRepository.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSourceRepository.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSourceRepository.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISPackage.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISPackage.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISPackage.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISPackage.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISObject.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISObject.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISObject.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISObject.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISLibrary.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISLibrary.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISLibrary.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISLibrary.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSetupUpdate.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSetupUpdate.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSetupUpdate.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFlag.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFlag.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFlag.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFlag.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISExecutable.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISExecutable.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISExecutable.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISExecutable.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISDocument.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISDocument.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISDocument.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISDocument.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISBuildSection.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISBuildSection.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISBuildSection.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISBuildSection.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFileTemplate.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFileTemplate.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFileTemplate.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFileTemplate.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISLicense.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISLicense.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISLicense.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISLicense.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISVersion.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISVersion.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISVersion.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISVersion.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISExpr.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISExpr.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISExpr.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISExpr.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISValues.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISValues.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISValues.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISValues.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISParse.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISParse.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISParse.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISParse.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISTypes.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISTypes.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISTypes.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISTypes.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISText.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISText.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISText.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISMessage.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISMessage.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISMessage.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISMessage.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISGettext.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISGettext.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISGettext.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISGettext.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSourcePatterns.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSourcePatterns.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSourcePatterns.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSourcePatterns.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISContext.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISContext.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISContext.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISContext.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFileSystem.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFileSystem.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFileSystem.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFileSystem.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISUnixPath.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISUnixPath.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISUnixPath.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISUnixPath.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISUtils.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISUtils.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISUtils.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISUtils.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/PropList.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/PropList.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/PropList.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/PropList.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/FormatExt.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/FormatExt.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/FormatExt.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/FormatExt.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISPath_intern.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSchema_intern.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISTest_intern.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSourceRepository_intern.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISPackage_intern.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISObject_intern.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISLibrary_intern.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFlag_intern.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISExecutable_intern.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISDocument_intern.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISBuildSection_intern.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSection_intern.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFormat.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISHelp.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISQuickstart.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISCustom.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISCheck.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISAst.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISAst_parser.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISAst_lexer.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISAst_types.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISConf.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISValues_lexer.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISLicense_parser.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISLicense_lexer.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISLicense_types.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISVersion_parser.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISVersion_lexer.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISVersion_types.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISMutex.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISDataNotation.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFeatures.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISGraph.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISHostPath.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFileUtil.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISExec.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISString.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISData.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSection.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSchema.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFindlib.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISPlugin.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISTest.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSourceRepository.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISPackage.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISObject.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISLibrary.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSetupUpdate.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFlag.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISExecutable.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISDocument.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISBuildSection.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFileTemplate.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISLicense.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISVersion.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISExpr.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISValues.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISParse.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISTypes.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISText.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISMessage.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISGettext.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISSourcePatterns.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISContext.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISFileSystem.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISUnixPath.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISUtils.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/PropList.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/FormatExt.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISDynRun.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/dynrun.cma
- Installed /home/opam/.opam/4.14.1/lib/oasis/dynrun.cmxa
- Installed /home/opam/.opam/4.14.1/lib/oasis/dynrun.a
- Installed /home/opam/.opam/4.14.1/lib/oasis/dynrun.cmxs
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISDynRun.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISDynRun.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISDynRun.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISDynRun.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/CLISubCommand.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/CLIArgExt.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/CLICommon.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/CLIPager.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/cli.cma
- Installed /home/opam/.opam/4.14.1/lib/oasis/CLIPager.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/CLIPager.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/CLIPager.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/CLICommon.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/CLICommon.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/CLICommon.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/CLICommon.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/CLIArgExt.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/CLIArgExt.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/CLIArgExt.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/CLISubCommand.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/CLISubCommand.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/CLISubCommand.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/CLISubCommand.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISBuiltinPlugins.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/METAPlugin.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/InternalConfigurePlugin.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/InternalInstallPlugin.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/NonePlugin.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/OCamlbuildPlugin.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/OCamlbuildDocPlugin.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/OCamlbuildCommon.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/CustomPlugin.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/DevFilesPlugin.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/StdFilesPlugin.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/OMakePlugin.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/builtin-plugins.cma
- Installed /home/opam/.opam/4.14.1/lib/oasis/builtin-plugins.cmxa
- Installed /home/opam/.opam/4.14.1/lib/oasis/builtin-plugins.a
- Installed /home/opam/.opam/4.14.1/lib/oasis/builtin-plugins.cmxs
- Installed /home/opam/.opam/4.14.1/lib/oasis/OMakePlugin.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OMakePlugin.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OMakePlugin.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/StdFilesPlugin.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/StdFilesPlugin.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/StdFilesPlugin.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/DevFilesPlugin.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/DevFilesPlugin.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/DevFilesPlugin.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/CustomPlugin.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/CustomPlugin.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/CustomPlugin.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OCamlbuildCommon.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OCamlbuildCommon.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OCamlbuildCommon.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OCamlbuildDocPlugin.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OCamlbuildDocPlugin.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OCamlbuildDocPlugin.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OCamlbuildPlugin.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OCamlbuildPlugin.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OCamlbuildPlugin.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/NonePlugin.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/NonePlugin.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/NonePlugin.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/InternalInstallPlugin.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/InternalInstallPlugin.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/InternalInstallPlugin.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/InternalConfigurePlugin.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/InternalConfigurePlugin.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/InternalConfigurePlugin.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/METAPlugin.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/METAPlugin.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/METAPlugin.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISBuiltinPlugins.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISBuiltinPlugins.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISBuiltinPlugins.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/OMakeFormat.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OMakeEquip.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OMakeFields.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OMakeData.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/StdFilesData.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/DevFilesData.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/METAData.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/CustomData.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/MyOCamlbuildFindlib.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/MyOCamlbuildBase.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OCamlbuildId.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OCamlbuildData.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/InternalId.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/InternalData.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/NoneData.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OMakePlugin.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/StdFilesPlugin.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/DevFilesPlugin.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/CustomPlugin.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OCamlbuildCommon.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OCamlbuildDocPlugin.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OCamlbuildPlugin.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/NonePlugin.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/InternalInstallPlugin.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/InternalConfigurePlugin.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/METAPlugin.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/OASISBuiltinPlugins.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseArgExt.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseBuilt.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseCheck.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseCustom.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseData.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseDoc.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseEnvLight.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseEnv.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseFileAB.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseGenerate.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseLog.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseOCamlcConfig.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseSetup.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseStandardVar.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseTest.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseDynVar.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseMessage.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseContext.mli
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseCompat.ml
- Installed /home/opam/.opam/4.14.1/lib/oasis/base.cma
- Installed /home/opam/.opam/4.14.1/lib/oasis/base.cmxa
- Installed /home/opam/.opam/4.14.1/lib/oasis/base.a
- Installed /home/opam/.opam/4.14.1/lib/oasis/base.cmxs
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseCompat.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseCompat.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseCompat.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseContext.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseContext.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseContext.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseContext.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseMessage.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseMessage.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseMessage.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseMessage.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseDynVar.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseDynVar.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseDynVar.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseDynVar.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseTest.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseTest.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseTest.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseTest.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseStandardVar.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseStandardVar.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseStandardVar.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseStandardVar.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseSetup.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseSetup.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseSetup.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseSetup.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseOCamlcConfig.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseOCamlcConfig.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseOCamlcConfig.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseOCamlcConfig.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseLog.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseLog.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseLog.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseLog.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseGenerate.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseGenerate.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseGenerate.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseGenerate.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseFileAB.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseFileAB.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseFileAB.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseFileAB.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseEnv.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseEnv.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseEnv.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseEnv.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseEnvLight.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseEnvLight.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseEnvLight.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseEnvLight.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseDoc.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseDoc.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseDoc.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseDoc.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseData.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseData.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseData.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseData.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseCustom.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseCustom.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseCustom.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseCustom.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseCheck.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseCheck.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseCheck.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseCheck.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseBuilt.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseBuilt.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseBuilt.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseBuilt.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseArgExt.cmi
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseArgExt.cmti
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseArgExt.cmt
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseArgExt.annot
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseCompat.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseContext.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseMessage.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseDynVar.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseTest.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseStandardVar.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseSetup.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseOCamlcConfig.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseLog.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseGenerate.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseFileAB.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseEnv.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseEnvLight.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseDoc.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseData.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseCustom.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseCheck.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseBuilt.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/BaseArgExt.cmx
- Installed /home/opam/.opam/4.14.1/lib/oasis/META
-> installed oasis.0.4.11
Processing 267/346: [bap-recipe: ./configure]
Processing 268/346: [bap-recipe: ./configure] [bap-relation: ./configure]
Processing 269/346: [bap-recipe: ./configure] [bap-relation: ./configure] [bitvec: ./configure]
-> installed ppx_assert.v0.14.0
Processing 270/346: [bap-recipe: ./configure] [bap-relation: ./configure] [bitvec: ./configure]
Processing 271/346: [bap-recipe: ./configure] [bap-relation: ./configure] [bitvec: ./configure] [jst-config: dune build]
-> installed ppx_custom_printf.v0.14.1
Processing 272/346: [bap-recipe: ./configure] [bap-relation: ./configure] [bitvec: ./configure] [jst-config: dune build]
Processing 273/346: [bap-recipe: ./configure] [bap-relation: ./configure] [bin_prot: dune build] [bitvec: ./configure] [jst-config: dune build]
-> installed ppx_hash.v0.14.0
Processing 274/346: [bap-recipe: ./configure] [bap-relation: ./configure] [bin_prot: dune build] [bitvec: ./configure] [jst-config: dune build]
Processing 275/346: [bap-recipe: ./configure] [bap-relation: ./configure] [bin_prot: dune build] [bitvec: ./configure] [jst-config: dune build] [ppx_base: dune build]
-> installed ppx_sexp_message.v0.14.1
Processing 276/346: [bap-recipe: ./configure] [bap-relation: ./configure] [bin_prot: dune build] [bitvec: ./configure] [jst-config: dune build] [ppx_base: dune build]
-> installed ppx_sexp_value.v0.14.0
Processing 277/346: [bap-recipe: ./configure] [bap-relation: ./configure] [bin_prot: dune build] [bitvec: ./configure] [jst-config: dune build] [ppx_base: dune build]
-> installed zed.3.2.3
Processing 278/346: [bap-recipe: ./configure] [bap-relation: ./configure] [bin_prot: dune build] [bitvec: ./configure] [jst-config: dune build] [ppx_base: dune build]
Processing 279/346: [bap-recipe: ./configure] [bap-relation: ./configure] [bin_prot: dune build] [bitvec: ./configure] [jst-config: dune build] [lambda-term: dune build] [ppx_base: dune build]
+ /home/opam/.opam/4.14.1/.opam-switch/build/bap-recipe.2.5.0/./configure "--prefix=/home/opam/.opam/4.14.1" "--enable-recipe" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bap-recipe.2.5.0)
- File "oasis/common.setup.ml.in", line 573, characters 4-15:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 601, characters 19-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 608, characters 37-48:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 611, characters 17-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1429, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1431, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1432, characters 14-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 28-40:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 28-41:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1435, characters 11-24:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1436, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3176, characters 8-19:
- 3176 |         Stream.from
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3179, characters 21-32:
- 3179 |                match Stream.next st with
-                             ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3182, characters 18-32:
- 3182 |              with Stream.Failure -> None)
-                          ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3184, characters 6-23:
- 3184 |       Genlex.make_lexer ["="] st_line
-              ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3187, characters 12-24:
- 3187 |       match Stream.npeek 3 lxr with
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 9-21:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                 ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 26-36:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                  ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 42-55:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                  ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 8-19:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 25-36:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 42-53:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                  ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3201, characters 17-34:
- 3201 |         let st = Stream.of_channel chn in
-                         ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3326, characters 16-33:
- 3326 |   let var_lxr = Genlex.make_lexer []
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3345, characters 22-38:
- 3345 |              var_lxr (Stream.of_string var)
-                              ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3347, characters 17-29:
- 3347 |            match Stream.npeek 3 st with
-                         ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 16-28:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 37-49:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                                             ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 16-28:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 37-50:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                                             ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 16-28:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 46-58:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                                                      ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 16-28:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 46-59:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                                                      ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3356, characters 16-28:
- 3356 |              | [Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3369, characters 13-25:
- 3369 |            | Stream.Error e ->
-                     ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4518, characters 21-38:
- 4518 |            let lxr = Genlex.make_lexer [] (stream_of_reader rdr) in
-                             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4520, characters 19-31:
- 4520 |              match Stream.npeek 2 lxr with
-                           ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 16-29:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                        ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 33-46:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                                         ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 15-26:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                       ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 32-43:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                                        ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- 
- Configuration:
- ocamlfind: ........................................... /home/opam/.opam/4.14.1/bin/ocamlfind
- ocamlc: .............................................. /home/opam/.opam/4.14.1/bin/ocamlc.opt
- ocamlopt: ............................................ /home/opam/.opam/4.14.1/bin/ocamlopt.opt
- ocamlbuild: .......................................... /home/opam/.opam/4.14.1/bin/ocamlbuild
- Package name: ........................................ bap
- Package version: ..................................... 2.5.0
- os_type: ............................................. Unix
- system: .............................................. freebsd
- architecture: ........................................ amd64
- ccomp_type: .......................................... cc
- ocaml_version: ....................................... 4.14.1
- standard_library_default: ............................ /home/opam/.opam/4.14.1/lib/ocaml
- standard_library: .................................... /home/opam/.opam/4.14.1/lib/ocaml
- bytecomp_c_compiler: ................................. cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- native_c_compiler: ................................... cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- model: ............................................... default
- ext_obj: ............................................. .o
- ext_asm: ............................................. .s
- ext_lib: ............................................. .a
- ext_dll: ............................................. .so
- default_executable_name: ............................. a.out
- systhread_supported: ................................. true
- Install architecture-independent files dir: .......... /home/opam/.opam/4.14.1
- Install architecture-dependent files in dir: ......... $prefix
- User executables: .................................... $exec_prefix/bin
- System admin executables: ............................ $exec_prefix/sbin
- Program executables: ................................. $exec_prefix/libexec
- Read-only single-machine data: ....................... $prefix/etc
- Modifiable architecture-independent data: ............ $prefix/com
- Modifiable single-machine data: ...................... $prefix/var
- Object code libraries: ............................... $exec_prefix/lib
- Read-only arch-independent data root: ................ $prefix/share
- Read-only architecture-independent data: ............. $datarootdir
- Info documentation: .................................. $datarootdir/info
- Locale-dependent data: ............................... $datarootdir/locale
- Man documentation: ................................... $datarootdir/man
- Documentation root: .................................. $datarootdir/doc/$pkg_name
- HTML documentation: .................................. $docdir
- DVI documentation: ................................... $docdir
- PDF documentation: ................................... $docdir
- PS documentation: .................................... $docdir
- findlib_version: ..................................... 1.9.6
- is_native: ........................................... true
- suffix_program: ......................................
- Remove a file.: ...................................... rm -f
- Remove a directory.: ................................. rm -rf
- Turn ocaml debug flag on: ............................ true
- Turn ocaml profile flag on: .......................... false
- Compiler support generation of .cmxs.: ............... true
- OCamlbuild additional flags: .........................
- A default folder for plugins: ........................ /home/opam/.opam/4.14.1/lib/bap
- c++ compiler: ........................................ /usr/bin/c++
- C compiler optimization level: ....................... -O2
- Build every feature by default: ...................... false
- Enable development mode: ............................. false
- Build the BAP recipe library: ........................ true
- Create documentations: ............................... true
- Compile tests executable and library and run them: ... false
- pkg_stdlib_shims: .................................... /home/opam/.opam/4.14.1/lib/stdlib-shims
- pkg_base: ............................................ /home/opam/.opam/4.14.1/lib/base
- pkg_stdio: ........................................... /home/opam/.opam/4.14.1/lib/stdio
- pkg_parsexp: ......................................... /home/opam/.opam/4.14.1/lib/parsexp
- pkg_fileutils: ....................................... /home/opam/.opam/4.14.1/lib/fileutils
- pkg_camlzip: ......................................... /home/opam/.opam/4.14.1/lib/camlzip
- pkg_uuidm: ........................................... /home/opam/.opam/4.14.1/lib/uuidm
- 
Processing 279/346: [bap-recipe: gmake] [bap-relation: ./configure] [bin_prot: dune build] [bitvec: ./configure] [jst-config: dune build] [lambda-term: dune build] [ppx_base: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_base" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_base.v0.14.0)
-> compiled  ppx_base.v0.14.0
Processing 279/346: [bap-recipe: gmake] [bap-relation: ./configure] [bin_prot: dune build] [bitvec: ./configure] [jst-config: dune build] [lambda-term: dune build]
-> installed ppx_base.v0.14.0
Processing 280/346: [bap-recipe: gmake] [bap-relation: ./configure] [bin_prot: dune build] [bitvec: ./configure] [jst-config: dune build] [lambda-term: dune build]
Processing 281/346: [bap-recipe: gmake] [bap-relation: ./configure] [bin_prot: dune build] [bitvec: ./configure] [jst-config: dune build] [lambda-term: dune build] [ppx_string: dune build]
+ /home/opam/.opam/4.14.1/.opam-switch/build/bap-relation.2.5.0/./configure "--prefix=/home/opam/.opam/4.14.1" "--enable-relation" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bap-relation.2.5.0)
- File "oasis/common.setup.ml.in", line 573, characters 4-15:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 601, characters 19-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 608, characters 37-48:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 611, characters 17-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1429, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1431, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1432, characters 14-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 28-40:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 28-41:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1435, characters 11-24:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1436, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3176, characters 8-19:
- 3176 |         Stream.from
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3179, characters 21-32:
- 3179 |                match Stream.next st with
-                             ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3182, characters 18-32:
- 3182 |              with Stream.Failure -> None)
-                          ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3184, characters 6-23:
- 3184 |       Genlex.make_lexer ["="] st_line
-              ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3187, characters 12-24:
- 3187 |       match Stream.npeek 3 lxr with
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 9-21:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                 ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 26-36:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                  ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 42-55:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                  ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 8-19:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 25-36:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 42-53:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                  ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3201, characters 17-34:
- 3201 |         let st = Stream.of_channel chn in
-                         ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3326, characters 16-33:
- 3326 |   let var_lxr = Genlex.make_lexer []
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3345, characters 22-38:
- 3345 |              var_lxr (Stream.of_string var)
-                              ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3347, characters 17-29:
- 3347 |            match Stream.npeek 3 st with
-                         ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 16-28:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 37-49:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                                             ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 16-28:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 37-50:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                                             ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 16-28:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 46-58:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                                                      ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 16-28:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 46-59:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                                                      ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3356, characters 16-28:
- 3356 |              | [Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3369, characters 13-25:
- 3369 |            | Stream.Error e ->
-                     ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4518, characters 21-38:
- 4518 |            let lxr = Genlex.make_lexer [] (stream_of_reader rdr) in
-                             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4520, characters 19-31:
- 4520 |              match Stream.npeek 2 lxr with
-                           ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 16-29:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                        ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 33-46:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                                         ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 15-26:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                       ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 32-43:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                                        ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- 
- Configuration:
- ocamlfind: ........................................... /home/opam/.opam/4.14.1/bin/ocamlfind
- ocamlc: .............................................. /home/opam/.opam/4.14.1/bin/ocamlc.opt
- ocamlopt: ............................................ /home/opam/.opam/4.14.1/bin/ocamlopt.opt
- ocamlbuild: .......................................... /home/opam/.opam/4.14.1/bin/ocamlbuild
- Package name: ........................................ bap
- Package version: ..................................... 2.5.0
- os_type: ............................................. Unix
- system: .............................................. freebsd
- architecture: ........................................ amd64
- ccomp_type: .......................................... cc
- ocaml_version: ....................................... 4.14.1
- standard_library_default: ............................ /home/opam/.opam/4.14.1/lib/ocaml
- standard_library: .................................... /home/opam/.opam/4.14.1/lib/ocaml
- bytecomp_c_compiler: ................................. cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- native_c_compiler: ................................... cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- model: ............................................... default
- ext_obj: ............................................. .o
- ext_asm: ............................................. .s
- ext_lib: ............................................. .a
- ext_dll: ............................................. .so
- default_executable_name: ............................. a.out
- systhread_supported: ................................. true
- Install architecture-independent files dir: .......... /home/opam/.opam/4.14.1
- Install architecture-dependent files in dir: ......... $prefix
- User executables: .................................... $exec_prefix/bin
- System admin executables: ............................ $exec_prefix/sbin
- Program executables: ................................. $exec_prefix/libexec
- Read-only single-machine data: ....................... $prefix/etc
- Modifiable architecture-independent data: ............ $prefix/com
- Modifiable single-machine data: ...................... $prefix/var
- Object code libraries: ............................... $exec_prefix/lib
- Read-only arch-independent data root: ................ $prefix/share
- Read-only architecture-independent data: ............. $datarootdir
- Info documentation: .................................. $datarootdir/info
- Locale-dependent data: ............................... $datarootdir/locale
- Man documentation: ................................... $datarootdir/man
- Documentation root: .................................. $datarootdir/doc/$pkg_name
- HTML documentation: .................................. $docdir
- DVI documentation: ................................... $docdir
- PDF documentation: ................................... $docdir
- PS documentation: .................................... $docdir
- findlib_version: ..................................... 1.9.6
- is_native: ........................................... true
- suffix_program: ......................................
- Remove a file.: ...................................... rm -f
- Remove a directory.: ................................. rm -rf
- Turn ocaml debug flag on: ............................ true
- Turn ocaml profile flag on: .......................... false
- Compiler support generation of .cmxs.: ............... true
- OCamlbuild additional flags: .........................
- A default folder for plugins: ........................ /home/opam/.opam/4.14.1/lib/bap
- c++ compiler: ........................................ /usr/bin/c++
- C compiler optimization level: ....................... -O2
- Build every feature by default: ...................... false
- Enable development mode: ............................. false
- Build the relation library: .......................... true
- Create documentations: ............................... true
- Compile tests executable and library and run them: ... false
- pkg_base: ............................................ /home/opam/.opam/4.14.1/lib/base
- 
Processing 281/346: [bap-recipe: gmake] [bap-relation: gmake] [bin_prot: dune build] [bitvec: ./configure] [jst-config: dune build] [lambda-term: dune build] [ppx_string: dune build]
+ /home/opam/.opam/4.14.1/.opam-switch/build/bitvec.2.5.0/./configure "--prefix=/home/opam/.opam/4.14.1" "--enable-bitvec" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bitvec.2.5.0)
- File "oasis/common.setup.ml.in", line 573, characters 4-15:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 601, characters 19-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 608, characters 37-48:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 611, characters 17-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1429, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1431, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1432, characters 14-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 28-40:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 28-41:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1435, characters 11-24:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1436, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3176, characters 8-19:
- 3176 |         Stream.from
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3179, characters 21-32:
- 3179 |                match Stream.next st with
-                             ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3182, characters 18-32:
- 3182 |              with Stream.Failure -> None)
-                          ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3184, characters 6-23:
- 3184 |       Genlex.make_lexer ["="] st_line
-              ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3187, characters 12-24:
- 3187 |       match Stream.npeek 3 lxr with
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 9-21:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                 ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 26-36:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                  ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 42-55:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                  ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 8-19:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 25-36:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 42-53:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                  ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3201, characters 17-34:
- 3201 |         let st = Stream.of_channel chn in
-                         ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3326, characters 16-33:
- 3326 |   let var_lxr = Genlex.make_lexer []
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3345, characters 22-38:
- 3345 |              var_lxr (Stream.of_string var)
-                              ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3347, characters 17-29:
- 3347 |            match Stream.npeek 3 st with
-                         ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 16-28:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 37-49:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                                             ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 16-28:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 37-50:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                                             ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 16-28:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 46-58:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                                                      ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 16-28:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 46-59:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                                                      ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3356, characters 16-28:
- 3356 |              | [Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3369, characters 13-25:
- 3369 |            | Stream.Error e ->
-                     ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4518, characters 21-38:
- 4518 |            let lxr = Genlex.make_lexer [] (stream_of_reader rdr) in
-                             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4520, characters 19-31:
- 4520 |              match Stream.npeek 2 lxr with
-                           ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 16-29:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                        ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 33-46:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                                         ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 15-26:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                       ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 32-43:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                                        ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- 
- Configuration:
- ocamlfind: ........................................... /home/opam/.opam/4.14.1/bin/ocamlfind
- ocamlc: .............................................. /home/opam/.opam/4.14.1/bin/ocamlc.opt
- ocamlopt: ............................................ /home/opam/.opam/4.14.1/bin/ocamlopt.opt
- ocamlbuild: .......................................... /home/opam/.opam/4.14.1/bin/ocamlbuild
- Package name: ........................................ bap
- Package version: ..................................... 2.5.0
- os_type: ............................................. Unix
- system: .............................................. freebsd
- architecture: ........................................ amd64
- ccomp_type: .......................................... cc
- ocaml_version: ....................................... 4.14.1
- standard_library_default: ............................ /home/opam/.opam/4.14.1/lib/ocaml
- standard_library: .................................... /home/opam/.opam/4.14.1/lib/ocaml
- bytecomp_c_compiler: ................................. cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- native_c_compiler: ................................... cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- model: ............................................... default
- ext_obj: ............................................. .o
- ext_asm: ............................................. .s
- ext_lib: ............................................. .a
- ext_dll: ............................................. .so
- default_executable_name: ............................. a.out
- systhread_supported: ................................. true
- Install architecture-independent files dir: .......... /home/opam/.opam/4.14.1
- Install architecture-dependent files in dir: ......... $prefix
- User executables: .................................... $exec_prefix/bin
- System admin executables: ............................ $exec_prefix/sbin
- Program executables: ................................. $exec_prefix/libexec
- Read-only single-machine data: ....................... $prefix/etc
- Modifiable architecture-independent data: ............ $prefix/com
- Modifiable single-machine data: ...................... $prefix/var
- Object code libraries: ............................... $exec_prefix/lib
- Read-only arch-independent data root: ................ $prefix/share
- Read-only architecture-independent data: ............. $datarootdir
- Info documentation: .................................. $datarootdir/info
- Locale-dependent data: ............................... $datarootdir/locale
- Man documentation: ................................... $datarootdir/man
- Documentation root: .................................. $datarootdir/doc/$pkg_name
- HTML documentation: .................................. $docdir
- DVI documentation: ................................... $docdir
- PDF documentation: ................................... $docdir
- PS documentation: .................................... $docdir
- findlib_version: ..................................... 1.9.6
- is_native: ........................................... true
- suffix_program: ......................................
- Remove a file.: ...................................... rm -f
- Remove a directory.: ................................. rm -rf
- Turn ocaml debug flag on: ............................ true
- Turn ocaml profile flag on: .......................... false
- Compiler support generation of .cmxs.: ............... true
- OCamlbuild additional flags: .........................
- A default folder for plugins: ........................ /home/opam/.opam/4.14.1/lib/bap
- c++ compiler: ........................................ /usr/bin/c++
- C compiler optimization level: ....................... -O2
- Build every feature by default: ...................... false
- Enable development mode: ............................. false
- Build the bitvec library: ............................ true
- Create documentations: ............................... true
- Compile tests executable and library and run them: ... false
- pkg_zarith: .......................................... /home/opam/.opam/4.14.1/lib/zarith
- 
Processing 281/346: [bap-recipe: gmake] [bap-relation: gmake] [bin_prot: dune build] [bitvec: gmake] [jst-config: dune build] [lambda-term: dune build] [ppx_string: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "jst-config" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/jst-config.v0.14.1)
-> compiled  jst-config.v0.14.1
Processing 281/346: [bap-recipe: gmake] [bap-relation: gmake] [bin_prot: dune build] [bitvec: gmake] [lambda-term: dune build] [ppx_string: dune build]
-> installed jst-config.v0.14.1
Processing 282/346: [bap-recipe: gmake] [bap-relation: gmake] [bin_prot: dune build] [bitvec: gmake] [lambda-term: dune build] [ppx_string: dune build]
Processing 283/346: [bap-recipe: gmake] [bap-relation: gmake] [bin_prot: dune build] [bitvec: gmake] [lambda-term: dune build] [ppx_string: dune build] [time_now: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "bin_prot" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bin_prot.v0.14.1)
-> compiled  bin_prot.v0.14.1
Processing 283/346: [bap-recipe: gmake] [bap-relation: gmake] [bitvec: gmake] [lambda-term: dune build] [ppx_string: dune build] [time_now: dune build]
-> installed bin_prot.v0.14.1
Processing 284/346: [bap-recipe: gmake] [bap-relation: gmake] [bitvec: gmake] [lambda-term: dune build] [ppx_string: dune build] [time_now: dune build]
Processing 285/346: [bap-recipe: gmake] [bap-relation: gmake] [bitvec: gmake] [lambda-term: dune build] [ppx_bin_prot: dune build] [ppx_string: dune build] [time_now: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_string" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_string.v0.14.1)
-> compiled  ppx_string.v0.14.1
Processing 285/346: [bap-recipe: gmake] [bap-relation: gmake] [bitvec: gmake] [lambda-term: dune build] [ppx_bin_prot: dune build] [time_now: dune build]
-> installed ppx_string.v0.14.1
Processing 286/346: [bap-recipe: gmake] [bap-relation: gmake] [bitvec: gmake] [lambda-term: dune build] [ppx_bin_prot: dune build] [time_now: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "time_now" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/time_now.v0.14.0)
-> compiled  time_now.v0.14.0
Processing 286/346: [bap-recipe: gmake] [bap-relation: gmake] [bitvec: gmake] [lambda-term: dune build] [ppx_bin_prot: dune build]
-> installed time_now.v0.14.0
Processing 287/346: [bap-recipe: gmake] [bap-relation: gmake] [bitvec: gmake] [lambda-term: dune build] [ppx_bin_prot: dune build]
Processing 288/346: [bap-recipe: gmake] [bap-relation: gmake] [bitvec: gmake] [lambda-term: dune build] [ppx_bin_prot: dune build] [ppx_inline_test: dune build]
Processing 289/346: [bap-recipe: gmake] [bap-relation: gmake] [bitvec: gmake] [lambda-term: dune build] [ppx_bin_prot: dune build] [ppx_inline_test: dune build] [ppx_module_timer: dune build]
+ /usr/local/bin/gmake  (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bap-recipe.2.5.0)
- ./setup.exe -quiet -build 
- ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -modules tools/postinstall.ml > tools/postinstall.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -linkpkg -g -linkpkg -I tools tools/postinstall.cmx -o tools/postinstall.native
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package uuidm -package stdlib-shims -package stdio -package parsexp -package fileutils -package camlzip -package base -modules lib/bap_recipe/bap_recipe.mli > lib/bap_recipe/bap_recipe.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uuidm -package stdlib-shims -package stdio -package parsexp -package fileutils -package camlzip -package base -I lib/bap_recipe -o lib/bap_recipe/bap_recipe.cmi lib/bap_recipe/bap_recipe.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package uuidm -package stdlib-shims -package stdio -package parsexp -package fileutils -package camlzip -package base -modules lib/bap_recipe/bap_recipe.ml > lib/bap_recipe/bap_recipe.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uuidm -package stdlib-shims -package stdio -package parsexp -package fileutils -package camlzip -package base -I lib/bap_recipe -o lib/bap_recipe/bap_recipe.cmo lib/bap_recipe/bap_recipe.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uuidm -package stdlib-shims -package stdio -package parsexp -package fileutils -package camlzip -package base -I lib/bap_recipe -o lib/bap_recipe/bap_recipe.cmo lib/bap_recipe/bap_recipe.ml
- File "lib/bap_recipe/bap_recipe.ml", line 48, characters 14-28:
- 48 | type entry = {path : string;}
-                    ^^^^^^^^^^^^^^
- Warning 69 [unused-field]: unused record field path.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -a -I lib/bap_recipe lib/bap_recipe/bap_recipe.cmo -o lib/bap_recipe/recipe.cma
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uuidm -package stdlib-shims -package stdio -package parsexp -package fileutils -package camlzip -package base -I lib/bap_recipe -o lib/bap_recipe/bap_recipe.cmx lib/bap_recipe/bap_recipe.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uuidm -package stdlib-shims -package stdio -package parsexp -package fileutils -package camlzip -package base -I lib/bap_recipe -o lib/bap_recipe/bap_recipe.cmx lib/bap_recipe/bap_recipe.ml
- File "lib/bap_recipe/bap_recipe.ml", line 48, characters 14-28:
- 48 | type entry = {path : string;}
-                    ^^^^^^^^^^^^^^
- Warning 69 [unused-field]: unused record field path.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -a -I lib/bap_recipe lib/bap_recipe/bap_recipe.cmx -o lib/bap_recipe/recipe.cmxa
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -shared -linkall -I lib/bap_recipe lib/bap_recipe/recipe.cmxa -o lib/bap_recipe/recipe.cmxs
- + ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- File "myocamlbuild.ml", line 454, characters 8-19:
- 454 |         Stream.from
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 457, characters 21-32:
- 457 |                match Stream.next st with
-                            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 460, characters 18-32:
- 460 |              with Stream.Failure -> None)
-                         ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 462, characters 6-23:
- 462 |       Genlex.make_lexer ["="] st_line
-             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 465, characters 12-24:
- 465 |       match Stream.npeek 3 lxr with
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 9-21:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 26-36:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                 ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 42-55:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                 ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 8-19:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 25-36:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 42-53:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 479, characters 17-34:
- 479 |         let st = Stream.of_channel chn in
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
-> compiled  bap-recipe.2.5.0
Processing 289/346: [bap-relation: gmake] [bitvec: gmake] [lambda-term: dune build] [ppx_bin_prot: dune build] [ppx_inline_test: dune build] [ppx_module_timer: dune build]
Processing 290/346: [bap-relation: gmake] [bitvec: gmake] [lambda-term: dune build] [ppx_bin_prot: dune build] [ppx_inline_test: dune build] [ppx_module_timer: dune build] [bap-recipe: gmake install]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "lambda-term" "-j" "7" "@install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/lambda-term.3.3.2)
-> compiled  lambda-term.3.3.2
Processing 290/346: [bap-relation: gmake] [bitvec: gmake] [ppx_bin_prot: dune build] [ppx_inline_test: dune build] [ppx_module_timer: dune build] [bap-recipe: gmake install]
+ /usr/local/bin/gmake  (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bap-relation.2.5.0)
- ./setup.exe -quiet -build 
- ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -modules tools/postinstall.ml > tools/postinstall.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -linkpkg -g -linkpkg -I tools tools/postinstall.cmx -o tools/postinstall.native
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package base -modules lib/bap_relation/bap_relation.mli > lib/bap_relation/bap_relation.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package base -I lib/bap_relation -o lib/bap_relation/bap_relation.cmi lib/bap_relation/bap_relation.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package base -modules lib/bap_relation/bap_relation.ml > lib/bap_relation/bap_relation.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package base -I lib/bap_relation -o lib/bap_relation/bap_relation.cmo lib/bap_relation/bap_relation.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -a -I lib/bap_relation lib/bap_relation/bap_relation.cmo -o lib/bap_relation/bap_relation.cma
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package base -I lib/bap_relation -o lib/bap_relation/bap_relation.cmx lib/bap_relation/bap_relation.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -a -I lib/bap_relation lib/bap_relation/bap_relation.cmx -o lib/bap_relation/bap_relation.cmxa
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -shared -linkall -I lib/bap_relation lib/bap_relation/bap_relation.cmxa -o lib/bap_relation/bap_relation.cmxs
- + ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- File "myocamlbuild.ml", line 454, characters 8-19:
- 454 |         Stream.from
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 457, characters 21-32:
- 457 |                match Stream.next st with
-                            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 460, characters 18-32:
- 460 |              with Stream.Failure -> None)
-                         ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 462, characters 6-23:
- 462 |       Genlex.make_lexer ["="] st_line
-             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 465, characters 12-24:
- 465 |       match Stream.npeek 3 lxr with
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 9-21:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 26-36:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                 ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 42-55:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                 ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 8-19:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 25-36:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 42-53:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 479, characters 17-34:
- 479 |         let st = Stream.of_channel chn in
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
-> compiled  bap-relation.2.5.0
Processing 290/346: [bitvec: gmake] [ppx_bin_prot: dune build] [ppx_inline_test: dune build] [ppx_module_timer: dune build] [bap-recipe: gmake install]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_bin_prot" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_bin_prot.v0.14.0)
-> compiled  ppx_bin_prot.v0.14.0
Processing 290/346: [bitvec: gmake] [ppx_inline_test: dune build] [ppx_module_timer: dune build] [bap-recipe: gmake install]
+ /usr/local/bin/gmake  (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bitvec.2.5.0)
- ./setup.exe -quiet -build 
- ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -modules tools/postinstall.ml > tools/postinstall.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -linkpkg -g -linkpkg -I tools tools/postinstall.cmx -o tools/postinstall.native
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package zarith -modules lib/bitvec/bitvec.mli > lib/bitvec/bitvec.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package zarith -I lib/bitvec -o lib/bitvec/bitvec.cmi lib/bitvec/bitvec.mli
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package zarith -I lib/bitvec -o lib/bitvec/bitvec.cmi lib/bitvec/bitvec.mli
- File "lib/bitvec/bitvec.mli", line 579, characters 12-13:
- 579 | module Make(M : Modulus) : sig
-                   ^
- Warning 67 [unused-functor-parameter]: unused functor parameter M.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package zarith -modules lib/bitvec/bitvec.ml > lib/bitvec/bitvec.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package zarith -I lib/bitvec -o lib/bitvec/bitvec.cmo lib/bitvec/bitvec.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -a -I lib/bitvec lib/bitvec/bitvec.cmo -o lib/bitvec/bitvec.cma
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package zarith -I lib/bitvec -o lib/bitvec/bitvec.cmx lib/bitvec/bitvec.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -a -I lib/bitvec lib/bitvec/bitvec.cmx -o lib/bitvec/bitvec.cmxa
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -shared -linkall -I lib/bitvec lib/bitvec/bitvec.cmxa -o lib/bitvec/bitvec.cmxs
- + ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- File "myocamlbuild.ml", line 454, characters 8-19:
- 454 |         Stream.from
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 457, characters 21-32:
- 457 |                match Stream.next st with
-                            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 460, characters 18-32:
- 460 |              with Stream.Failure -> None)
-                         ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 462, characters 6-23:
- 462 |       Genlex.make_lexer ["="] st_line
-             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 465, characters 12-24:
- 465 |       match Stream.npeek 3 lxr with
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 9-21:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 26-36:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                 ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 42-55:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                 ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 8-19:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 25-36:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 42-53:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 479, characters 17-34:
- 479 |         let st = Stream.of_channel chn in
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
-> compiled  bitvec.2.5.0
Processing 290/346: [ppx_inline_test: dune build] [ppx_module_timer: dune build] [bap-recipe: gmake install]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_module_timer" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_module_timer.v0.14.0)
-> compiled  ppx_module_timer.v0.14.0
Processing 290/346: [ppx_inline_test: dune build] [bap-recipe: gmake install]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_inline_test" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_inline_test.v0.14.1)
-> compiled  ppx_inline_test.v0.14.1
Processing 290/346: [bap-recipe: gmake install]
+ /usr/local/bin/gmake "install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bap-recipe.2.5.0)
- ./setup.exe -quiet -install 
- Installed /home/opam/.opam/4.14.1/lib/bap-recipe/bap_recipe.mli
- Installed /home/opam/.opam/4.14.1/lib/bap-recipe/recipe.cma
- Installed /home/opam/.opam/4.14.1/lib/bap-recipe/recipe.cmxa
- Installed /home/opam/.opam/4.14.1/lib/bap-recipe/recipe.a
- Installed /home/opam/.opam/4.14.1/lib/bap-recipe/recipe.cmxs
- Installed /home/opam/.opam/4.14.1/lib/bap-recipe/bap_recipe.cmi
- Installed /home/opam/.opam/4.14.1/lib/bap-recipe/bap_recipe.cmti
- Installed /home/opam/.opam/4.14.1/lib/bap-recipe/bap_recipe.cmt
- Installed /home/opam/.opam/4.14.1/lib/bap-recipe/bap_recipe.annot
- Installed /home/opam/.opam/4.14.1/lib/bap-recipe/bap_recipe.cmx
- Installed /home/opam/.opam/4.14.1/lib/bap-recipe/META
- sh tools/build_plugins.sh
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- Finished updating plugins
- if [ -f ./postinstall.native ]; then ./postinstall.native; fi
- if [ -f ./postinstall.byte ]; then ./postinstall.byte; fi
- if [ -f ./postinstall ]; then ./postinstall; fi
-> installed bap-recipe.2.5.0
Processing 291/346: [bap-relation: gmake install]
+ /usr/local/bin/gmake "install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bap-relation.2.5.0)
- ./setup.exe -quiet -install 
- Installed /home/opam/.opam/4.14.1/lib/bap-relation/bap_relation.mli
- Installed /home/opam/.opam/4.14.1/lib/bap-relation/bap_relation.cma
- Installed /home/opam/.opam/4.14.1/lib/bap-relation/bap_relation.cmxa
- Installed /home/opam/.opam/4.14.1/lib/bap-relation/bap_relation.a
- Installed /home/opam/.opam/4.14.1/lib/bap-relation/bap_relation.cmxs
- Installed /home/opam/.opam/4.14.1/lib/bap-relation/bap_relation.cmi
- Installed /home/opam/.opam/4.14.1/lib/bap-relation/bap_relation.cmti
- Installed /home/opam/.opam/4.14.1/lib/bap-relation/bap_relation.cmt
- Installed /home/opam/.opam/4.14.1/lib/bap-relation/bap_relation.annot
- Installed /home/opam/.opam/4.14.1/lib/bap-relation/bap_relation.cmx
- Installed /home/opam/.opam/4.14.1/lib/bap-relation/META
- sh tools/build_plugins.sh
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- Finished updating plugins
- if [ -f ./postinstall.native ]; then ./postinstall.native; fi
- if [ -f ./postinstall.byte ]; then ./postinstall.byte; fi
- if [ -f ./postinstall ]; then ./postinstall; fi
-> installed bap-relation.2.5.0
Processing 292/346: [bitvec: gmake install]
+ /usr/local/bin/gmake "install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bitvec.2.5.0)
- ./setup.exe -quiet -install 
- Installed /home/opam/.opam/4.14.1/lib/bitvec/bitvec.mli
- Installed /home/opam/.opam/4.14.1/lib/bitvec/bitvec.cma
- Installed /home/opam/.opam/4.14.1/lib/bitvec/bitvec.cmxa
- Installed /home/opam/.opam/4.14.1/lib/bitvec/bitvec.a
- Installed /home/opam/.opam/4.14.1/lib/bitvec/bitvec.cmxs
- Installed /home/opam/.opam/4.14.1/lib/bitvec/bitvec.cmi
- Installed /home/opam/.opam/4.14.1/lib/bitvec/bitvec.cmti
- Installed /home/opam/.opam/4.14.1/lib/bitvec/bitvec.cmt
- Installed /home/opam/.opam/4.14.1/lib/bitvec/bitvec.annot
- Installed /home/opam/.opam/4.14.1/lib/bitvec/bitvec.cmx
- Installed /home/opam/.opam/4.14.1/lib/bitvec/META
- sh tools/build_plugins.sh
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- Finished updating plugins
- if [ -f ./postinstall.native ]; then ./postinstall.native; fi
- if [ -f ./postinstall.byte ]; then ./postinstall.byte; fi
- if [ -f ./postinstall ]; then ./postinstall; fi
-> installed bitvec.2.5.0
Processing 293/346: [bitvec-sexp: ./configure]
-> installed lambda-term.3.3.2
Processing 294/346: [bitvec-sexp: ./configure]
Processing 295/346: [bitvec-sexp: ./configure] [utop: dune build]
-> installed ppx_bin_prot.v0.14.0
Processing 296/346: [bitvec-sexp: ./configure] [utop: dune build]
-> installed ppx_inline_test.v0.14.1
Processing 297/346: [bitvec-sexp: ./configure] [utop: dune build]
Processing 298/346: [bitvec-sexp: ./configure] [ppx_bench: dune build] [utop: dune build]
Processing 299/346: [bitvec-sexp: ./configure] [ppx_bench: dune build] [ppx_expect: dune build] [utop: dune build]
-> installed ppx_module_timer.v0.14.0
Processing 300/346: [bitvec-sexp: ./configure] [ppx_bench: dune build] [ppx_expect: dune build] [utop: dune build]
+ /home/opam/.opam/4.14.1/.opam-switch/build/bitvec-sexp.2.5.0/./configure "--prefix=/home/opam/.opam/4.14.1" "--enable-bitvec-sexp" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bitvec-sexp.2.5.0)
- File "oasis/common.setup.ml.in", line 573, characters 4-15:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 601, characters 19-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 608, characters 37-48:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 611, characters 17-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1429, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1431, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1432, characters 14-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 28-40:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 28-41:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1435, characters 11-24:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1436, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3176, characters 8-19:
- 3176 |         Stream.from
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3179, characters 21-32:
- 3179 |                match Stream.next st with
-                             ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3182, characters 18-32:
- 3182 |              with Stream.Failure -> None)
-                          ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3184, characters 6-23:
- 3184 |       Genlex.make_lexer ["="] st_line
-              ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3187, characters 12-24:
- 3187 |       match Stream.npeek 3 lxr with
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 9-21:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                 ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 26-36:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                  ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 42-55:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                  ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 8-19:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 25-36:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 42-53:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                  ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3201, characters 17-34:
- 3201 |         let st = Stream.of_channel chn in
-                         ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3326, characters 16-33:
- 3326 |   let var_lxr = Genlex.make_lexer []
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3345, characters 22-38:
- 3345 |              var_lxr (Stream.of_string var)
-                              ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3347, characters 17-29:
- 3347 |            match Stream.npeek 3 st with
-                         ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 16-28:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 37-49:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                                             ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 16-28:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 37-50:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                                             ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 16-28:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 46-58:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                                                      ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 16-28:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 46-59:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                                                      ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3356, characters 16-28:
- 3356 |              | [Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3369, characters 13-25:
- 3369 |            | Stream.Error e ->
-                     ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4518, characters 21-38:
- 4518 |            let lxr = Genlex.make_lexer [] (stream_of_reader rdr) in
-                             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4520, characters 19-31:
- 4520 |              match Stream.npeek 2 lxr with
-                           ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 16-29:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                        ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 33-46:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                                         ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 15-26:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                       ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 32-43:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                                        ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- 
- Configuration:
- ocamlfind: ........................................... /home/opam/.opam/4.14.1/bin/ocamlfind
- ocamlc: .............................................. /home/opam/.opam/4.14.1/bin/ocamlc.opt
- ocamlopt: ............................................ /home/opam/.opam/4.14.1/bin/ocamlopt.opt
- ocamlbuild: .......................................... /home/opam/.opam/4.14.1/bin/ocamlbuild
- Package name: ........................................ bap
- Package version: ..................................... 2.5.0
- os_type: ............................................. Unix
- system: .............................................. freebsd
- architecture: ........................................ amd64
- ccomp_type: .......................................... cc
- ocaml_version: ....................................... 4.14.1
- standard_library_default: ............................ /home/opam/.opam/4.14.1/lib/ocaml
- standard_library: .................................... /home/opam/.opam/4.14.1/lib/ocaml
- bytecomp_c_compiler: ................................. cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- native_c_compiler: ................................... cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- model: ............................................... default
- ext_obj: ............................................. .o
- ext_asm: ............................................. .s
- ext_lib: ............................................. .a
- ext_dll: ............................................. .so
- default_executable_name: ............................. a.out
- systhread_supported: ................................. true
- Install architecture-independent files dir: .......... /home/opam/.opam/4.14.1
- Install architecture-dependent files in dir: ......... $prefix
- User executables: .................................... $exec_prefix/bin
- System admin executables: ............................ $exec_prefix/sbin
- Program executables: ................................. $exec_prefix/libexec
- Read-only single-machine data: ....................... $prefix/etc
- Modifiable architecture-independent data: ............ $prefix/com
- Modifiable single-machine data: ...................... $prefix/var
- Object code libraries: ............................... $exec_prefix/lib
- Read-only arch-independent data root: ................ $prefix/share
- Read-only architecture-independent data: ............. $datarootdir
- Info documentation: .................................. $datarootdir/info
- Locale-dependent data: ............................... $datarootdir/locale
- Man documentation: ................................... $datarootdir/man
- Documentation root: .................................. $datarootdir/doc/$pkg_name
- HTML documentation: .................................. $docdir
- DVI documentation: ................................... $docdir
- PDF documentation: ................................... $docdir
- PS documentation: .................................... $docdir
- findlib_version: ..................................... 1.9.6
- is_native: ........................................... true
- suffix_program: ......................................
- Remove a file.: ...................................... rm -f
- Remove a directory.: ................................. rm -rf
- Turn ocaml debug flag on: ............................ true
- Turn ocaml profile flag on: .......................... false
- Compiler support generation of .cmxs.: ............... true
- OCamlbuild additional flags: .........................
- A default folder for plugins: ........................ /home/opam/.opam/4.14.1/lib/bap
- c++ compiler: ........................................ /usr/bin/c++
- C compiler optimization level: ....................... -O2
- Build every feature by default: ...................... false
- Enable development mode: ............................. false
- Provides sexp converters for bitvectors: ............. true
- Create documentations: ............................... true
- Compile tests executable and library and run them: ... false
- pkg_bitvec: .......................................... /home/opam/.opam/4.14.1/lib/bitvec
- pkg_sexplib0: ........................................ /home/opam/.opam/4.14.1/lib/sexplib0
- 
Processing 300/346: [bitvec-sexp: gmake] [ppx_bench: dune build] [ppx_expect: dune build] [utop: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "utop" "-j" "7" "@install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/utop.2.14.0)
-> compiled  utop.2.14.0
Processing 300/346: [bitvec-sexp: gmake] [ppx_bench: dune build] [ppx_expect: dune build]
-> installed utop.2.14.0
Processing 301/346: [bitvec-sexp: gmake] [ppx_bench: dune build] [ppx_expect: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_bench" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_bench.v0.14.1)
-> compiled  ppx_bench.v0.14.1
Processing 301/346: [bitvec-sexp: gmake] [ppx_expect: dune build]
-> installed ppx_bench.v0.14.1
Processing 302/346: [bitvec-sexp: gmake] [ppx_expect: dune build]
Processing 303/346: [bitvec-sexp: gmake] [ppx_expect: dune build] [splittable_random: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "splittable_random" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/splittable_random.v0.14.0)
-> compiled  splittable_random.v0.14.0
Processing 303/346: [bitvec-sexp: gmake] [ppx_expect: dune build]
-> installed splittable_random.v0.14.0
Processing 304/346: [bitvec-sexp: gmake] [ppx_expect: dune build]
Processing 305/346: [base_quickcheck: dune build] [bitvec-sexp: gmake] [ppx_expect: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_expect" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_expect.v0.14.2)
-> compiled  ppx_expect.v0.14.2
Processing 305/346: [base_quickcheck: dune build] [bitvec-sexp: gmake]
-> installed ppx_expect.v0.14.2
Processing 306/346: [base_quickcheck: dune build] [bitvec-sexp: gmake]
+ /usr/local/bin/gmake  (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bitvec-sexp.2.5.0)
- ./setup.exe -quiet -build 
- ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -modules tools/postinstall.ml > tools/postinstall.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -linkpkg -g -linkpkg -I tools tools/postinstall.cmx -o tools/postinstall.native
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package sexplib0 -package bitvec -modules lib/bitvec_sexp/bitvec_sexp.mli > lib/bitvec_sexp/bitvec_sexp.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package sexplib0 -package bitvec -I lib/bitvec_sexp -o lib/bitvec_sexp/bitvec_sexp.cmi lib/bitvec_sexp/bitvec_sexp.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package sexplib0 -package bitvec -modules lib/bitvec_sexp/bitvec_sexp.ml > lib/bitvec_sexp/bitvec_sexp.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package sexplib0 -package bitvec -I lib/bitvec_sexp -o lib/bitvec_sexp/bitvec_sexp.cmo lib/bitvec_sexp/bitvec_sexp.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -a -I lib/bitvec_sexp lib/bitvec_sexp/bitvec_sexp.cmo -o lib/bitvec_sexp/bitvec_sexp.cma
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package sexplib0 -package bitvec -I lib/bitvec_sexp -o lib/bitvec_sexp/bitvec_sexp.cmx lib/bitvec_sexp/bitvec_sexp.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -a -I lib/bitvec_sexp lib/bitvec_sexp/bitvec_sexp.cmx -o lib/bitvec_sexp/bitvec_sexp.cmxa
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -shared -linkall -I lib/bitvec_sexp lib/bitvec_sexp/bitvec_sexp.cmxa -o lib/bitvec_sexp/bitvec_sexp.cmxs
- + ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- File "myocamlbuild.ml", line 454, characters 8-19:
- 454 |         Stream.from
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 457, characters 21-32:
- 457 |                match Stream.next st with
-                            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 460, characters 18-32:
- 460 |              with Stream.Failure -> None)
-                         ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 462, characters 6-23:
- 462 |       Genlex.make_lexer ["="] st_line
-             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 465, characters 12-24:
- 465 |       match Stream.npeek 3 lxr with
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 9-21:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 26-36:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                 ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 42-55:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                 ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 8-19:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 25-36:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 42-53:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 479, characters 17-34:
- 479 |         let st = Stream.of_channel chn in
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
-> compiled  bitvec-sexp.2.5.0
Processing 306/346: [base_quickcheck: dune build]
Processing 307/346: [base_quickcheck: dune build] [bitvec-sexp: gmake install]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "base_quickcheck" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/base_quickcheck.v0.14.1)
-> compiled  base_quickcheck.v0.14.1
Processing 307/346: [bitvec-sexp: gmake install]
+ /usr/local/bin/gmake "install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bitvec-sexp.2.5.0)
- ./setup.exe -quiet -install 
- Installed /home/opam/.opam/4.14.1/lib/bitvec-sexp/bitvec_sexp.mli
- Installed /home/opam/.opam/4.14.1/lib/bitvec-sexp/bitvec_sexp.cma
- Installed /home/opam/.opam/4.14.1/lib/bitvec-sexp/bitvec_sexp.cmxa
- Installed /home/opam/.opam/4.14.1/lib/bitvec-sexp/bitvec_sexp.a
- Installed /home/opam/.opam/4.14.1/lib/bitvec-sexp/bitvec_sexp.cmxs
- Installed /home/opam/.opam/4.14.1/lib/bitvec-sexp/bitvec_sexp.cmi
- Installed /home/opam/.opam/4.14.1/lib/bitvec-sexp/bitvec_sexp.cmti
- Installed /home/opam/.opam/4.14.1/lib/bitvec-sexp/bitvec_sexp.cmt
- Installed /home/opam/.opam/4.14.1/lib/bitvec-sexp/bitvec_sexp.annot
- Installed /home/opam/.opam/4.14.1/lib/bitvec-sexp/bitvec_sexp.cmx
- Installed /home/opam/.opam/4.14.1/lib/bitvec-sexp/META
- sh tools/build_plugins.sh
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- Finished updating plugins
- if [ -f ./postinstall.native ]; then ./postinstall.native; fi
- if [ -f ./postinstall.byte ]; then ./postinstall.byte; fi
- if [ -f ./postinstall ]; then ./postinstall; fi
-> installed bitvec-sexp.2.5.0
Processing 308/346: [bitvec-order: ./configure]
-> installed base_quickcheck.v0.14.1
Processing 309/346: [bitvec-order: ./configure]
Processing 310/346: [bitvec-order: ./configure] [ppx_bap: dune build]
Processing 311/346: [bitvec-order: ./configure] [ppx_bap: dune build] [ppx_jane: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_bap" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_bap.v0.14.0)
-> compiled  ppx_bap.v0.14.0
Processing 311/346: [bitvec-order: ./configure] [ppx_jane: dune build]
-> installed ppx_bap.v0.14.0
Processing 312/346: [bitvec-order: ./configure] [ppx_jane: dune build]
Processing 313/346: [bitvec-binprot: ./configure] [bitvec-order: ./configure] [ppx_jane: dune build]
+ /home/opam/.opam/4.14.1/.opam-switch/build/bitvec-order.2.5.0/./configure "--prefix=/home/opam/.opam/4.14.1" "--enable-bitvec-order" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bitvec-order.2.5.0)
- File "oasis/common.setup.ml.in", line 573, characters 4-15:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 601, characters 19-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 608, characters 37-48:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 611, characters 17-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1429, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1431, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1432, characters 14-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 28-40:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 28-41:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1435, characters 11-24:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1436, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3176, characters 8-19:
- 3176 |         Stream.from
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3179, characters 21-32:
- 3179 |                match Stream.next st with
-                             ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3182, characters 18-32:
- 3182 |              with Stream.Failure -> None)
-                          ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3184, characters 6-23:
- 3184 |       Genlex.make_lexer ["="] st_line
-              ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3187, characters 12-24:
- 3187 |       match Stream.npeek 3 lxr with
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 9-21:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                 ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 26-36:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                  ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 42-55:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                  ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 8-19:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 25-36:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 42-53:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                  ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3201, characters 17-34:
- 3201 |         let st = Stream.of_channel chn in
-                         ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3326, characters 16-33:
- 3326 |   let var_lxr = Genlex.make_lexer []
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3345, characters 22-38:
- 3345 |              var_lxr (Stream.of_string var)
-                              ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3347, characters 17-29:
- 3347 |            match Stream.npeek 3 st with
-                         ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 16-28:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 37-49:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                                             ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 16-28:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 37-50:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                                             ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 16-28:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 46-58:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                                                      ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 16-28:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 46-59:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                                                      ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3356, characters 16-28:
- 3356 |              | [Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3369, characters 13-25:
- 3369 |            | Stream.Error e ->
-                     ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4518, characters 21-38:
- 4518 |            let lxr = Genlex.make_lexer [] (stream_of_reader rdr) in
-                             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4520, characters 19-31:
- 4520 |              match Stream.npeek 2 lxr with
-                           ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 16-29:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                        ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 33-46:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                                         ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 15-26:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                       ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 32-43:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                                        ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- 
- Configuration:
- ocamlfind: ........................................... /home/opam/.opam/4.14.1/bin/ocamlfind
- ocamlc: .............................................. /home/opam/.opam/4.14.1/bin/ocamlc.opt
- ocamlopt: ............................................ /home/opam/.opam/4.14.1/bin/ocamlopt.opt
- ocamlbuild: .......................................... /home/opam/.opam/4.14.1/bin/ocamlbuild
- Package name: ........................................ bap
- Package version: ..................................... 2.5.0
- os_type: ............................................. Unix
- system: .............................................. freebsd
- architecture: ........................................ amd64
- ccomp_type: .......................................... cc
- ocaml_version: ....................................... 4.14.1
- standard_library_default: ............................ /home/opam/.opam/4.14.1/lib/ocaml
- standard_library: .................................... /home/opam/.opam/4.14.1/lib/ocaml
- bytecomp_c_compiler: ................................. cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- native_c_compiler: ................................... cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- model: ............................................... default
- ext_obj: ............................................. .o
- ext_asm: ............................................. .s
- ext_lib: ............................................. .a
- ext_dll: ............................................. .so
- default_executable_name: ............................. a.out
- systhread_supported: ................................. true
- Install architecture-independent files dir: .......... /home/opam/.opam/4.14.1
- Install architecture-dependent files in dir: ......... $prefix
- User executables: .................................... $exec_prefix/bin
- System admin executables: ............................ $exec_prefix/sbin
- Program executables: ................................. $exec_prefix/libexec
- Read-only single-machine data: ....................... $prefix/etc
- Modifiable architecture-independent data: ............ $prefix/com
- Modifiable single-machine data: ...................... $prefix/var
- Object code libraries: ............................... $exec_prefix/lib
- Read-only arch-independent data root: ................ $prefix/share
- Read-only architecture-independent data: ............. $datarootdir
- Info documentation: .................................. $datarootdir/info
- Locale-dependent data: ............................... $datarootdir/locale
- Man documentation: ................................... $datarootdir/man
- Documentation root: .................................. $datarootdir/doc/$pkg_name
- HTML documentation: .................................. $docdir
- DVI documentation: ................................... $docdir
- PDF documentation: ................................... $docdir
- PS documentation: .................................... $docdir
- findlib_version: ..................................... 1.9.6
- is_native: ........................................... true
- suffix_program: ......................................
- Remove a file.: ...................................... rm -f
- Remove a directory.: ................................. rm -rf
- Turn ocaml debug flag on: ............................ true
- Turn ocaml profile flag on: .......................... false
- Compiler support generation of .cmxs.: ............... true
- OCamlbuild additional flags: .........................
- A default folder for plugins: ........................ /home/opam/.opam/4.14.1/lib/bap
- c++ compiler: ........................................ /usr/bin/c++
- C compiler optimization level: ....................... -O2
- Build every feature by default: ...................... false
- Enable development mode: ............................. false
- Provides comparators for use with JS Core: ........... true
- Create documentations: ............................... true
- Compile tests executable and library and run them: ... false
- pkg_base: ............................................ /home/opam/.opam/4.14.1/lib/base
- pkg_bitvec: .......................................... /home/opam/.opam/4.14.1/lib/bitvec
- pkg_bitvec_sexp: ..................................... /home/opam/.opam/4.14.1/lib/bitvec-sexp
- 
Processing 313/346: [bitvec-binprot: ./configure] [bitvec-order: gmake] [ppx_jane: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "ppx_jane" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ppx_jane.v0.14.0)
-> compiled  ppx_jane.v0.14.0
Processing 313/346: [bitvec-binprot: ./configure] [bitvec-order: gmake]
-> installed ppx_jane.v0.14.0
Processing 314/346: [bitvec-binprot: ./configure] [bitvec-order: gmake]
Processing 315/346: [base_bigstring: dune build] [bitvec-binprot: ./configure] [bitvec-order: gmake]
+ /home/opam/.opam/4.14.1/.opam-switch/build/bitvec-binprot.2.5.0/./configure "--prefix=/home/opam/.opam/4.14.1" "--enable-bitvec-binprot" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bitvec-binprot.2.5.0)
- File "oasis/common.setup.ml.in", line 573, characters 4-15:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 601, characters 19-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 608, characters 37-48:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 611, characters 17-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1429, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1431, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1432, characters 14-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 28-40:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 28-41:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1435, characters 11-24:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1436, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3176, characters 8-19:
- 3176 |         Stream.from
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3179, characters 21-32:
- 3179 |                match Stream.next st with
-                             ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3182, characters 18-32:
- 3182 |              with Stream.Failure -> None)
-                          ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3184, characters 6-23:
- 3184 |       Genlex.make_lexer ["="] st_line
-              ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3187, characters 12-24:
- 3187 |       match Stream.npeek 3 lxr with
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 9-21:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                 ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 26-36:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                  ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 42-55:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                  ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 8-19:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 25-36:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 42-53:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                  ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3201, characters 17-34:
- 3201 |         let st = Stream.of_channel chn in
-                         ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3326, characters 16-33:
- 3326 |   let var_lxr = Genlex.make_lexer []
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3345, characters 22-38:
- 3345 |              var_lxr (Stream.of_string var)
-                              ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3347, characters 17-29:
- 3347 |            match Stream.npeek 3 st with
-                         ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 16-28:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 37-49:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                                             ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 16-28:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 37-50:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                                             ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 16-28:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 46-58:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                                                      ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 16-28:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 46-59:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                                                      ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3356, characters 16-28:
- 3356 |              | [Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3369, characters 13-25:
- 3369 |            | Stream.Error e ->
-                     ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4518, characters 21-38:
- 4518 |            let lxr = Genlex.make_lexer [] (stream_of_reader rdr) in
-                             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4520, characters 19-31:
- 4520 |              match Stream.npeek 2 lxr with
-                           ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 16-29:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                        ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 33-46:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                                         ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 15-26:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                       ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 32-43:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                                        ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- 
- Configuration:
- ocamlfind: ........................................... /home/opam/.opam/4.14.1/bin/ocamlfind
- ocamlc: .............................................. /home/opam/.opam/4.14.1/bin/ocamlc.opt
- ocamlopt: ............................................ /home/opam/.opam/4.14.1/bin/ocamlopt.opt
- ocamlbuild: .......................................... /home/opam/.opam/4.14.1/bin/ocamlbuild
- Package name: ........................................ bap
- Package version: ..................................... 2.5.0
- os_type: ............................................. Unix
- system: .............................................. freebsd
- architecture: ........................................ amd64
- ccomp_type: .......................................... cc
- ocaml_version: ....................................... 4.14.1
- standard_library_default: ............................ /home/opam/.opam/4.14.1/lib/ocaml
- standard_library: .................................... /home/opam/.opam/4.14.1/lib/ocaml
- bytecomp_c_compiler: ................................. cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- native_c_compiler: ................................... cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- model: ............................................... default
- ext_obj: ............................................. .o
- ext_asm: ............................................. .s
- ext_lib: ............................................. .a
- ext_dll: ............................................. .so
- default_executable_name: ............................. a.out
- systhread_supported: ................................. true
- Install architecture-independent files dir: .......... /home/opam/.opam/4.14.1
- Install architecture-dependent files in dir: ......... $prefix
- User executables: .................................... $exec_prefix/bin
- System admin executables: ............................ $exec_prefix/sbin
- Program executables: ................................. $exec_prefix/libexec
- Read-only single-machine data: ....................... $prefix/etc
- Modifiable architecture-independent data: ............ $prefix/com
- Modifiable single-machine data: ...................... $prefix/var
- Object code libraries: ............................... $exec_prefix/lib
- Read-only arch-independent data root: ................ $prefix/share
- Read-only architecture-independent data: ............. $datarootdir
- Info documentation: .................................. $datarootdir/info
- Locale-dependent data: ............................... $datarootdir/locale
- Man documentation: ................................... $datarootdir/man
- Documentation root: .................................. $datarootdir/doc/$pkg_name
- HTML documentation: .................................. $docdir
- DVI documentation: ................................... $docdir
- PDF documentation: ................................... $docdir
- PS documentation: .................................... $docdir
- findlib_version: ..................................... 1.9.6
- is_native: ........................................... true
- suffix_program: ......................................
- Remove a file.: ...................................... rm -f
- Remove a directory.: ................................. rm -rf
- Turn ocaml debug flag on: ............................ true
- Turn ocaml profile flag on: .......................... false
- Compiler support generation of .cmxs.: ............... true
- OCamlbuild additional flags: .........................
- A default folder for plugins: ........................ /home/opam/.opam/4.14.1/lib/bap
- c++ compiler: ........................................ /usr/bin/c++
- C compiler optimization level: ....................... -O2
- Build every feature by default: ...................... false
- Enable development mode: ............................. false
- Enables support for Core's Binprot protocol: ......... true
- Create documentations: ............................... true
- Compile tests executable and library and run them: ... false
- pkg_bitvec: .......................................... /home/opam/.opam/4.14.1/lib/bitvec
- pkg_bin_prot: ........................................ /home/opam/.opam/4.14.1/lib/bin_prot
- pkg_ppx_bap: ......................................... /home/opam/.opam/4.14.1/lib/ppx_bap
- 
Processing 315/346: [base_bigstring: dune build] [bitvec-binprot: gmake] [bitvec-order: gmake]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "base_bigstring" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/base_bigstring.v0.14.0)
-> compiled  base_bigstring.v0.14.0
Processing 315/346: [bitvec-binprot: gmake] [bitvec-order: gmake]
-> installed base_bigstring.v0.14.0
Processing 316/346: [bitvec-binprot: gmake] [bitvec-order: gmake]
Processing 317/346: [bitvec-binprot: gmake] [bitvec-order: gmake] [core_kernel: dune build]
+ /usr/local/bin/gmake  (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bitvec-order.2.5.0)
- ./setup.exe -quiet -build 
- ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -modules tools/postinstall.ml > tools/postinstall.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -linkpkg -g -linkpkg -I tools tools/postinstall.cmx -o tools/postinstall.native
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package bitvec-sexp -package bitvec -package base -modules lib/bitvec_order/bitvec_order.mli > lib/bitvec_order/bitvec_order.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package bitvec-sexp -package bitvec -package base -I lib/bitvec_order -o lib/bitvec_order/bitvec_order.cmi lib/bitvec_order/bitvec_order.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package bitvec-sexp -package bitvec -package base -modules lib/bitvec_order/bitvec_order.ml > lib/bitvec_order/bitvec_order.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package bitvec-sexp -package bitvec -package base -I lib/bitvec_order -o lib/bitvec_order/bitvec_order.cmo lib/bitvec_order/bitvec_order.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -a -I lib/bitvec_order lib/bitvec_order/bitvec_order.cmo -o lib/bitvec_order/bitvec_order.cma
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package bitvec-sexp -package bitvec -package base -I lib/bitvec_order -o lib/bitvec_order/bitvec_order.cmx lib/bitvec_order/bitvec_order.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -a -I lib/bitvec_order lib/bitvec_order/bitvec_order.cmx -o lib/bitvec_order/bitvec_order.cmxa
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -shared -linkall -I lib/bitvec_order lib/bitvec_order/bitvec_order.cmxa -o lib/bitvec_order/bitvec_order.cmxs
- + ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- File "myocamlbuild.ml", line 454, characters 8-19:
- 454 |         Stream.from
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 457, characters 21-32:
- 457 |                match Stream.next st with
-                            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 460, characters 18-32:
- 460 |              with Stream.Failure -> None)
-                         ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 462, characters 6-23:
- 462 |       Genlex.make_lexer ["="] st_line
-             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 465, characters 12-24:
- 465 |       match Stream.npeek 3 lxr with
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 9-21:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 26-36:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                 ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 42-55:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                 ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 8-19:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 25-36:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 42-53:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 479, characters 17-34:
- 479 |         let st = Stream.of_channel chn in
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
-> compiled  bitvec-order.2.5.0
Processing 317/346: [bitvec-binprot: gmake] [core_kernel: dune build]
Processing 318/346: [bitvec-binprot: gmake] [core_kernel: dune build] [bitvec-order: gmake install]
+ /usr/local/bin/gmake  (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bitvec-binprot.2.5.0)
- ./setup.exe -quiet -build 
- ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -modules tools/postinstall.ml > tools/postinstall.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -linkpkg -g -linkpkg -I tools tools/postinstall.cmx -o tools/postinstall.native
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package bitvec -package bin_prot -modules lib/bitvec_binprot/bitvec_binprot.mli > lib/bitvec_binprot/bitvec_binprot.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package bitvec -package bin_prot -I lib/bitvec_binprot -o lib/bitvec_binprot/bitvec_binprot.cmi lib/bitvec_binprot/bitvec_binprot.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package bitvec -package bin_prot -modules lib/bitvec_binprot/bitvec_binprot.ml > lib/bitvec_binprot/bitvec_binprot.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package bitvec -package bin_prot -I lib/bitvec_binprot -o lib/bitvec_binprot/bitvec_binprot.cmo lib/bitvec_binprot/bitvec_binprot.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -a -I lib/bitvec_binprot lib/bitvec_binprot/bitvec_binprot.cmo -o lib/bitvec_binprot/bitvec_binprot.cma
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package bitvec -package bin_prot -I lib/bitvec_binprot -o lib/bitvec_binprot/bitvec_binprot.cmx lib/bitvec_binprot/bitvec_binprot.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -a -I lib/bitvec_binprot lib/bitvec_binprot/bitvec_binprot.cmx -o lib/bitvec_binprot/bitvec_binprot.cmxa
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -shared -linkall -I lib/bitvec_binprot lib/bitvec_binprot/bitvec_binprot.cmxa -o lib/bitvec_binprot/bitvec_binprot.cmxs
- + ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- File "myocamlbuild.ml", line 454, characters 8-19:
- 454 |         Stream.from
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 457, characters 21-32:
- 457 |                match Stream.next st with
-                            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 460, characters 18-32:
- 460 |              with Stream.Failure -> None)
-                         ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 462, characters 6-23:
- 462 |       Genlex.make_lexer ["="] st_line
-             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 465, characters 12-24:
- 465 |       match Stream.npeek 3 lxr with
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 9-21:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 26-36:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                 ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 42-55:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                 ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 8-19:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 25-36:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 42-53:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 479, characters 17-34:
- 479 |         let st = Stream.of_channel chn in
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
-> compiled  bitvec-binprot.2.5.0
Processing 318/346: [core_kernel: dune build] [bitvec-order: gmake install]
+ /usr/local/bin/gmake "install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bitvec-order.2.5.0)
- ./setup.exe -quiet -install 
- Installed /home/opam/.opam/4.14.1/lib/bitvec-order/bitvec_order.mli
- Installed /home/opam/.opam/4.14.1/lib/bitvec-order/bitvec_order.cma
- Installed /home/opam/.opam/4.14.1/lib/bitvec-order/bitvec_order.cmxa
- Installed /home/opam/.opam/4.14.1/lib/bitvec-order/bitvec_order.a
- Installed /home/opam/.opam/4.14.1/lib/bitvec-order/bitvec_order.cmxs
- Installed /home/opam/.opam/4.14.1/lib/bitvec-order/bitvec_order.cmi
- Installed /home/opam/.opam/4.14.1/lib/bitvec-order/bitvec_order.cmti
- Installed /home/opam/.opam/4.14.1/lib/bitvec-order/bitvec_order.cmt
- Installed /home/opam/.opam/4.14.1/lib/bitvec-order/bitvec_order.annot
- Installed /home/opam/.opam/4.14.1/lib/bitvec-order/bitvec_order.cmx
- Installed /home/opam/.opam/4.14.1/lib/bitvec-order/META
- sh tools/build_plugins.sh
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- Finished updating plugins
- if [ -f ./postinstall.native ]; then ./postinstall.native; fi
- if [ -f ./postinstall.byte ]; then ./postinstall.byte; fi
- if [ -f ./postinstall ]; then ./postinstall; fi
-> installed bitvec-order.2.5.0
Processing 318/346: [core_kernel: dune build]
Processing 319/346: [core_kernel: dune build] [bitvec-binprot: gmake install]
+ /usr/local/bin/gmake "install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bitvec-binprot.2.5.0)
- ./setup.exe -quiet -install 
- Installed /home/opam/.opam/4.14.1/lib/bitvec-binprot/bitvec_binprot.mli
- Installed /home/opam/.opam/4.14.1/lib/bitvec-binprot/bitvec_binprot.cma
- Installed /home/opam/.opam/4.14.1/lib/bitvec-binprot/bitvec_binprot.cmxa
- Installed /home/opam/.opam/4.14.1/lib/bitvec-binprot/bitvec_binprot.a
- Installed /home/opam/.opam/4.14.1/lib/bitvec-binprot/bitvec_binprot.cmxs
- Installed /home/opam/.opam/4.14.1/lib/bitvec-binprot/bitvec_binprot.cmi
- Installed /home/opam/.opam/4.14.1/lib/bitvec-binprot/bitvec_binprot.cmti
- Installed /home/opam/.opam/4.14.1/lib/bitvec-binprot/bitvec_binprot.cmt
- Installed /home/opam/.opam/4.14.1/lib/bitvec-binprot/bitvec_binprot.annot
- Installed /home/opam/.opam/4.14.1/lib/bitvec-binprot/bitvec_binprot.cmx
- Installed /home/opam/.opam/4.14.1/lib/bitvec-binprot/META
- sh tools/build_plugins.sh
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- Finished updating plugins
- if [ -f ./postinstall.native ]; then ./postinstall.native; fi
- if [ -f ./postinstall.byte ]; then ./postinstall.byte; fi
- if [ -f ./postinstall ]; then ./postinstall; fi
-> installed bitvec-binprot.2.5.0
Processing 319/346: [core_kernel: dune build]
+ /home/opam/.opam/4.14.1/bin/dune "build" "-p" "core_kernel" "-j" "7" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/core_kernel.v0.14.2)
- (cd _build/default/src && /usr/bin/cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC -D_FILE_OFFSET_BITS=64 -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC -D_LARGEFILE64_SOURCE -g -I /home/opam/.opam/4.14.1/lib/ocaml -I /home/opam/.opam/4.14.1/lib/base -I /home/opam/.opam/4.14.1/lib/base/base_internalhash_types -I /home/opam/.opam/4.14.1/lib/base/caml -I /home/opam/.opam/4.14.1/lib/base/md5 -I /home/opam/.opam/4.14.1/lib/base/shadow_stdlib -I /home/opam/.opam/4.14.1/lib/base_bigstring -I /home/opam/.opam/4.14.1/lib/base_quickcheck -I /home/opam/.opam/4.14.1/lib/bin_prot -I /home/opam/.opam/4.14.1/lib/bin_prot/shape -I /home/opam/.opam/4.14.1/lib/fieldslib -I /home/opam/.opam/4.14.1/lib/jane-street-headers -I /home/opam/.opam/4.14.1/lib/parsexp -I /home/opam/.opam/4.14.1/lib/ppx_assert/runtime-lib -I /home/opam/.opam/4.14.1/lib/ppx_bench/runtime-lib -I /home/opam/.opam/4.14.1/lib/ppx_compare/runtime-lib -I /home/opam/.opam/4.14.1/lib/ppx_enumerate/runtime-lib -I /home/opam/.opam/4.14.1/lib/ppx_expect/collector -I /home/opam/.opam/4.14.1/lib/ppx_expect/common -I /home/opam/.opam/4.14.1/lib/ppx_expect/config -I /home/opam/.opam/4.14.1/lib/ppx_expect/config_types -I /home/opam/.opam/4.14.1/lib/ppx_hash/runtime-lib -I /home/opam/.opam/4.14.1/lib/ppx_here/runtime-lib -I /home/opam/.opam/4.14.1/lib/ppx_inline_test/config -I /home/opam/.opam/4.14.1/lib/ppx_inline_test/runtime-lib -I /home/opam/.opam/4.14.1/lib/ppx_module_timer/runtime -I /home/opam/.opam/4.14.1/lib/ppx_sexp_conv/runtime-lib -I /home/opam/.opam/4.14.1/lib/sexplib -I /home/opam/.opam/4.14.1/lib/sexplib0 -I /home/opam/.opam/4.14.1/lib/splittable_random -I /home/opam/.opam/4.14.1/lib/stdio -I /home/opam/.opam/4.14.1/lib/time_now -I /home/opam/.opam/4.14.1/lib/typerep -I /home/opam/.opam/4.14.1/lib/variantslib -I ../base_for_tests/src -o md5_stubs.o -c md5_stubs.c)
- md5_stubs.c:11:32: warning: pragma diagnostic expected option name (e.g. "-Wundef") [-Wunknown-pragmas]
- #pragma GCC diagnostic ignored "-pedantic"
-                                ^
- 1 warning generated.
- (cd _build/default && /home/opam/.opam/4.14.1/bin/ocamlc.opt -w -40 -g -bin-annot -I src/.core_kernel.objs/byte -I /home/opam/.opam/4.14.1/lib/base -I /home/opam/.opam/4.14.1/lib/base/base_internalhash_types -I /home/opam/.opam/4.14.1/lib/base/caml -I /home/opam/.opam/4.14.1/lib/base/md5 -I /home/opam/.opam/4.14.1/lib/base/shadow_stdlib -I /home/opam/.opam/4.14.1/lib/base_bigstring -I /home/opam/.opam/4.14.1/lib/base_quickcheck -I /home/opam/.opam/4.14.1/lib/bin_prot -I /home/opam/.opam/4.14.1/lib/bin_prot/shape -I /home/opam/.opam/4.14.1/lib/fieldslib -I /home/opam/.opam/4.14.1/lib/jane-street-headers -I /home/opam/.opam/4.14.1/lib/parsexp -I /home/opam/.opam/4.14.1/lib/ppx_assert/runtime-lib -I /home/opam/.opam/4.14.1/lib/ppx_bench/runtime-lib -I /home/opam/.opam/4.14.1/lib/ppx_compare/runtime-lib -I /home/opam/.opam/4.14.1/lib/ppx_enumerate/runtime-lib -I /home/opam/.opam/4.14.1/lib/ppx_expect/collector -I /home/opam/.opam/4.14.1/lib/ppx_expect/common -I /home/opam/.opam/4.14.1/lib/ppx_expect/config -I /home/opam/.opam/4.14.1/lib/ppx_expect/config_types -I /home/opam/.opam/4.14.1/lib/ppx_hash/runtime-lib -I /home/opam/.opam/4.14.1/lib/ppx_here/runtime-lib -I /home/opam/.opam/4.14.1/lib/ppx_inline_test/config -I /home/opam/.opam/4.14.1/lib/ppx_inline_test/runtime-lib -I /home/opam/.opam/4.14.1/lib/ppx_module_timer/runtime -I /home/opam/.opam/4.14.1/lib/ppx_sexp_conv/runtime-lib -I /home/opam/.opam/4.14.1/lib/sexplib -I /home/opam/.opam/4.14.1/lib/sexplib0 -I /home/opam/.opam/4.14.1/lib/splittable_random -I /home/opam/.opam/4.14.1/lib/stdio -I /home/opam/.opam/4.14.1/lib/time_now -I /home/opam/.opam/4.14.1/lib/typerep -I /home/opam/.opam/4.14.1/lib/variantslib -I base_for_tests/src/.base_for_tests.objs/byte -intf-suffix .ml -no-alias-deps -open Core_kernel__ -o src/.core_kernel.objs/byte/core_kernel__Ephemeron.cmo -c -impl src/ephemeron.pp.ml)
- File "src/ephemeron.ml", line 7, characters 13-29:
- 7 | let create = Ephemeron.create
-                  ^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Ephemeron.create
- This function won't be available in 5.0
- File "src/ephemeron.ml", line 10, characters 12-31:
- 10 |   | None -> Ephemeron.unset_key t
-                  ^^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Ephemeron.unset_key
- This function won't be available in 5.0
- File "src/ephemeron.ml", line 11, characters 14-31:
- 11 |   | Some v -> Ephemeron.set_key t v
-                    ^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Ephemeron.set_key
- This function won't be available in 5.0
- File "src/ephemeron.ml", line 14, characters 14-31:
- 14 | let get_key = Ephemeron.get_key
-                    ^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Ephemeron.get_key
- This function won't be available in 5.0
- File "src/ephemeron.ml", line 17, characters 12-32:
- 17 |   | None -> Ephemeron.unset_data t
-                  ^^^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Ephemeron.unset_data
- This function won't be available in 5.0
- File "src/ephemeron.ml", line 18, characters 14-32:
- 18 |   | Some v -> Ephemeron.set_data t v
-                    ^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Ephemeron.set_data
- This function won't be available in 5.0
- File "src/ephemeron.ml", line 21, characters 15-33:
- 21 | let get_data = Ephemeron.get_data
-                     ^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Ephemeron.get_data
- This function won't be available in 5.0
- File "src/ephemeron.ml", line 22, characters 20-39:
- 22 | let is_key_some t = Ephemeron.check_key t
-                          ^^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Ephemeron.check_key
- This function won't be available in 5.0
- File "src/ephemeron.ml", line 24, characters 21-41:
- 24 | let is_data_some t = Ephemeron.check_data t
-                           ^^^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Ephemeron.check_data
- This function won't be available in 5.0
- (cd _build/default && /home/opam/.opam/4.14.1/bin/ocamlopt.opt -w -40 -g -I src/.core_kernel.objs/byte -I src/.core_kernel.objs/native -I /home/opam/.opam/4.14.1/lib/base -I /home/opam/.opam/4.14.1/lib/base/base_internalhash_types -I /home/opam/.opam/4.14.1/lib/base/caml -I /home/opam/.opam/4.14.1/lib/base/md5 -I /home/opam/.opam/4.14.1/lib/base/shadow_stdlib -I /home/opam/.opam/4.14.1/lib/base_bigstring -I /home/opam/.opam/4.14.1/lib/base_quickcheck -I /home/opam/.opam/4.14.1/lib/bin_prot -I /home/opam/.opam/4.14.1/lib/bin_prot/shape -I /home/opam/.opam/4.14.1/lib/fieldslib -I /home/opam/.opam/4.14.1/lib/jane-street-headers -I /home/opam/.opam/4.14.1/lib/parsexp -I /home/opam/.opam/4.14.1/lib/ppx_assert/runtime-lib -I /home/opam/.opam/4.14.1/lib/ppx_bench/runtime-lib -I /home/opam/.opam/4.14.1/lib/ppx_compare/runtime-lib -I /home/opam/.opam/4.14.1/lib/ppx_enumerate/runtime-lib -I /home/opam/.opam/4.14.1/lib/ppx_expect/collector -I /home/opam/.opam/4.14.1/lib/ppx_expect/common -I /home/opam/.opam/4.14.1/lib/ppx_expect/config -I /home/opam/.opam/4.14.1/lib/ppx_expect/config_types -I /home/opam/.opam/4.14.1/lib/ppx_hash/runtime-lib -I /home/opam/.opam/4.14.1/lib/ppx_here/runtime-lib -I /home/opam/.opam/4.14.1/lib/ppx_inline_test/config -I /home/opam/.opam/4.14.1/lib/ppx_inline_test/runtime-lib -I /home/opam/.opam/4.14.1/lib/ppx_module_timer/runtime -I /home/opam/.opam/4.14.1/lib/ppx_sexp_conv/runtime-lib -I /home/opam/.opam/4.14.1/lib/sexplib -I /home/opam/.opam/4.14.1/lib/sexplib0 -I /home/opam/.opam/4.14.1/lib/splittable_random -I /home/opam/.opam/4.14.1/lib/stdio -I /home/opam/.opam/4.14.1/lib/time_now -I /home/opam/.opam/4.14.1/lib/typerep -I /home/opam/.opam/4.14.1/lib/variantslib -I base_for_tests/src/.base_for_tests.objs/byte -I base_for_tests/src/.base_for_tests.objs/native -intf-suffix .ml -no-alias-deps -open Core_kernel__ -o src/.core_kernel.objs/native/core_kernel__Ephemeron.cmx -c -impl src/ephemeron.pp.ml)
- File "src/ephemeron.ml", line 7, characters 13-29:
- 7 | let create = Ephemeron.create
-                  ^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Ephemeron.create
- This function won't be available in 5.0
- File "src/ephemeron.ml", line 10, characters 12-31:
- 10 |   | None -> Ephemeron.unset_key t
-                  ^^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Ephemeron.unset_key
- This function won't be available in 5.0
- File "src/ephemeron.ml", line 11, characters 14-31:
- 11 |   | Some v -> Ephemeron.set_key t v
-                    ^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Ephemeron.set_key
- This function won't be available in 5.0
- File "src/ephemeron.ml", line 14, characters 14-31:
- 14 | let get_key = Ephemeron.get_key
-                    ^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Ephemeron.get_key
- This function won't be available in 5.0
- File "src/ephemeron.ml", line 17, characters 12-32:
- 17 |   | None -> Ephemeron.unset_data t
-                  ^^^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Ephemeron.unset_data
- This function won't be available in 5.0
- File "src/ephemeron.ml", line 18, characters 14-32:
- 18 |   | Some v -> Ephemeron.set_data t v
-                    ^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Ephemeron.set_data
- This function won't be available in 5.0
- File "src/ephemeron.ml", line 21, characters 15-33:
- 21 | let get_data = Ephemeron.get_data
-                     ^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Ephemeron.get_data
- This function won't be available in 5.0
- File "src/ephemeron.ml", line 22, characters 20-39:
- 22 | let is_key_some t = Ephemeron.check_key t
-                          ^^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Ephemeron.check_key
- This function won't be available in 5.0
- File "src/ephemeron.ml", line 24, characters 21-41:
- 24 | let is_data_some t = Ephemeron.check_data t
-                           ^^^^^^^^^^^^^^^^^^^^
- Alert old_ephemeron_api: Ephemeron.check_data
- This function won't be available in 5.0
-> compiled  core_kernel.v0.14.2
-> installed core_kernel.v0.14.2
Processing 321/346: [bap-build: ./configure]
Processing 322/346: [bap-build: ./configure] [bap-bundle: ./configure]
Processing 323/346: [bap-build: ./configure] [bap-bundle: ./configure] [monads: ./configure]
Processing 324/346: [bap-build: ./configure] [bap-bundle: ./configure] [monads: ./configure] [regular: ./configure]
+ /home/opam/.opam/4.14.1/.opam-switch/build/bap-build.2.5.0/./configure "--prefix=/home/opam/.opam/4.14.1" "--enable-build" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bap-build.2.5.0)
- File "oasis/common.setup.ml.in", line 573, characters 4-15:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 601, characters 19-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 608, characters 37-48:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 611, characters 17-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1429, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1431, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1432, characters 14-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 28-40:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 28-41:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1435, characters 11-24:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1436, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3176, characters 8-19:
- 3176 |         Stream.from
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3179, characters 21-32:
- 3179 |                match Stream.next st with
-                             ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3182, characters 18-32:
- 3182 |              with Stream.Failure -> None)
-                          ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3184, characters 6-23:
- 3184 |       Genlex.make_lexer ["="] st_line
-              ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3187, characters 12-24:
- 3187 |       match Stream.npeek 3 lxr with
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 9-21:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                 ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 26-36:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                  ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 42-55:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                  ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 8-19:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 25-36:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 42-53:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                  ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3201, characters 17-34:
- 3201 |         let st = Stream.of_channel chn in
-                         ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3326, characters 16-33:
- 3326 |   let var_lxr = Genlex.make_lexer []
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3345, characters 22-38:
- 3345 |              var_lxr (Stream.of_string var)
-                              ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3347, characters 17-29:
- 3347 |            match Stream.npeek 3 st with
-                         ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 16-28:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 37-49:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                                             ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 16-28:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 37-50:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                                             ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 16-28:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 46-58:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                                                      ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 16-28:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 46-59:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                                                      ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3356, characters 16-28:
- 3356 |              | [Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3369, characters 13-25:
- 3369 |            | Stream.Error e ->
-                     ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4518, characters 21-38:
- 4518 |            let lxr = Genlex.make_lexer [] (stream_of_reader rdr) in
-                             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4520, characters 19-31:
- 4520 |              match Stream.npeek 2 lxr with
-                           ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 16-29:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                        ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 33-46:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                                         ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 15-26:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                       ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 32-43:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                                        ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- 
- Configuration:
- ocamlfind: ........................................... /home/opam/.opam/4.14.1/bin/ocamlfind
- ocamlc: .............................................. /home/opam/.opam/4.14.1/bin/ocamlc.opt
- ocamlopt: ............................................ /home/opam/.opam/4.14.1/bin/ocamlopt.opt
- ocamlbuild: .......................................... /home/opam/.opam/4.14.1/bin/ocamlbuild
- Package name: ........................................ bap
- Package version: ..................................... 2.5.0
- os_type: ............................................. Unix
- system: .............................................. freebsd
- architecture: ........................................ amd64
- ccomp_type: .......................................... cc
- ocaml_version: ....................................... 4.14.1
- standard_library_default: ............................ /home/opam/.opam/4.14.1/lib/ocaml
- standard_library: .................................... /home/opam/.opam/4.14.1/lib/ocaml
- bytecomp_c_compiler: ................................. cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- native_c_compiler: ................................... cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- model: ............................................... default
- ext_obj: ............................................. .o
- ext_asm: ............................................. .s
- ext_lib: ............................................. .a
- ext_dll: ............................................. .so
- default_executable_name: ............................. a.out
- systhread_supported: ................................. true
- Install architecture-independent files dir: .......... /home/opam/.opam/4.14.1
- Install architecture-dependent files in dir: ......... $prefix
- User executables: .................................... $exec_prefix/bin
- System admin executables: ............................ $exec_prefix/sbin
- Program executables: ................................. $exec_prefix/libexec
- Read-only single-machine data: ....................... $prefix/etc
- Modifiable architecture-independent data: ............ $prefix/com
- Modifiable single-machine data: ...................... $prefix/var
- Object code libraries: ............................... $exec_prefix/lib
- Read-only arch-independent data root: ................ $prefix/share
- Read-only architecture-independent data: ............. $datarootdir
- Info documentation: .................................. $datarootdir/info
- Locale-dependent data: ............................... $datarootdir/locale
- Man documentation: ................................... $datarootdir/man
- Documentation root: .................................. $datarootdir/doc/$pkg_name
- HTML documentation: .................................. $docdir
- DVI documentation: ................................... $docdir
- PDF documentation: ................................... $docdir
- PS documentation: .................................... $docdir
- findlib_version: ..................................... 1.9.6
- is_native: ........................................... true
- suffix_program: ......................................
- Remove a file.: ...................................... rm -f
- Remove a directory.: ................................. rm -rf
- Turn ocaml debug flag on: ............................ true
- Turn ocaml profile flag on: .......................... false
- Compiler support generation of .cmxs.: ............... true
- OCamlbuild additional flags: .........................
- A default folder for plugins: ........................ /home/opam/.opam/4.14.1/lib/bap
- c++ compiler: ........................................ /usr/bin/c++
- C compiler optimization level: ....................... -O2
- Build every feature by default: ...................... false
- Enable development mode: ............................. false
- Build BAP build automation tools: .................... true
- Create documentations: ............................... true
- Compile tests executable and library and run them: ... false
- pkg_findlib: ......................................... /home/opam/.opam/4.14.1/lib/findlib
- pkg_ocamlbuild: ...................................... /home/opam/.opam/4.14.1/lib/ocamlbuild
- pkg_core_kernel: ..................................... /home/opam/.opam/4.14.1/lib/core_kernel
- pkg_compiler_libs: ................................... /home/opam/.opam/4.14.1/lib/ocaml/compiler-libs
- pkg_ppx_bap: ......................................... /home/opam/.opam/4.14.1/lib/ppx_bap
- 
Processing 324/346: [bap-build: gmake] [bap-bundle: ./configure] [monads: ./configure] [regular: ./configure]
+ /home/opam/.opam/4.14.1/.opam-switch/build/bap-bundle.2.5.0/./configure "--prefix=/home/opam/.opam/4.14.1" "--enable-bundle" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bap-bundle.2.5.0)
- File "oasis/common.setup.ml.in", line 573, characters 4-15:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 601, characters 19-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 608, characters 37-48:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 611, characters 17-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1429, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1431, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1432, characters 14-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 28-40:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 28-41:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1435, characters 11-24:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1436, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3176, characters 8-19:
- 3176 |         Stream.from
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3179, characters 21-32:
- 3179 |                match Stream.next st with
-                             ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3182, characters 18-32:
- 3182 |              with Stream.Failure -> None)
-                          ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3184, characters 6-23:
- 3184 |       Genlex.make_lexer ["="] st_line
-              ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3187, characters 12-24:
- 3187 |       match Stream.npeek 3 lxr with
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 9-21:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                 ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 26-36:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                  ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 42-55:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                  ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 8-19:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 25-36:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 42-53:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                  ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3201, characters 17-34:
- 3201 |         let st = Stream.of_channel chn in
-                         ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3326, characters 16-33:
- 3326 |   let var_lxr = Genlex.make_lexer []
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3345, characters 22-38:
- 3345 |              var_lxr (Stream.of_string var)
-                              ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3347, characters 17-29:
- 3347 |            match Stream.npeek 3 st with
-                         ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 16-28:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 37-49:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                                             ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 16-28:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 37-50:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                                             ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 16-28:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 46-58:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                                                      ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 16-28:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 46-59:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                                                      ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3356, characters 16-28:
- 3356 |              | [Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3369, characters 13-25:
- 3369 |            | Stream.Error e ->
-                     ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4518, characters 21-38:
- 4518 |            let lxr = Genlex.make_lexer [] (stream_of_reader rdr) in
-                             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4520, characters 19-31:
- 4520 |              match Stream.npeek 2 lxr with
-                           ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 16-29:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                        ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 33-46:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                                         ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 15-26:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                       ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 32-43:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                                        ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- 
- Configuration:
- ocamlfind: ........................................... /home/opam/.opam/4.14.1/bin/ocamlfind
- ocamlc: .............................................. /home/opam/.opam/4.14.1/bin/ocamlc.opt
- ocamlopt: ............................................ /home/opam/.opam/4.14.1/bin/ocamlopt.opt
- ocamlbuild: .......................................... /home/opam/.opam/4.14.1/bin/ocamlbuild
- Package name: ........................................ bap
- Package version: ..................................... 2.5.0
- os_type: ............................................. Unix
- system: .............................................. freebsd
- architecture: ........................................ amd64
- ccomp_type: .......................................... cc
- ocaml_version: ....................................... 4.14.1
- standard_library_default: ............................ /home/opam/.opam/4.14.1/lib/ocaml
- standard_library: .................................... /home/opam/.opam/4.14.1/lib/ocaml
- bytecomp_c_compiler: ................................. cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- native_c_compiler: ................................... cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- model: ............................................... default
- ext_obj: ............................................. .o
- ext_asm: ............................................. .s
- ext_lib: ............................................. .a
- ext_dll: ............................................. .so
- default_executable_name: ............................. a.out
- systhread_supported: ................................. true
- Install architecture-independent files dir: .......... /home/opam/.opam/4.14.1
- Install architecture-dependent files in dir: ......... $prefix
- User executables: .................................... $exec_prefix/bin
- System admin executables: ............................ $exec_prefix/sbin
- Program executables: ................................. $exec_prefix/libexec
- Read-only single-machine data: ....................... $prefix/etc
- Modifiable architecture-independent data: ............ $prefix/com
- Modifiable single-machine data: ...................... $prefix/var
- Object code libraries: ............................... $exec_prefix/lib
- Read-only arch-independent data root: ................ $prefix/share
- Read-only architecture-independent data: ............. $datarootdir
- Info documentation: .................................. $datarootdir/info
- Locale-dependent data: ............................... $datarootdir/locale
- Man documentation: ................................... $datarootdir/man
- Documentation root: .................................. $datarootdir/doc/$pkg_name
- HTML documentation: .................................. $docdir
- DVI documentation: ................................... $docdir
- PDF documentation: ................................... $docdir
- PS documentation: .................................... $docdir
- findlib_version: ..................................... 1.9.6
- is_native: ........................................... true
- suffix_program: ......................................
- Remove a file.: ...................................... rm -f
- Remove a directory.: ................................. rm -rf
- Turn ocaml debug flag on: ............................ true
- Turn ocaml profile flag on: .......................... false
- Compiler support generation of .cmxs.: ............... true
- OCamlbuild additional flags: .........................
- A default folder for plugins: ........................ /home/opam/.opam/4.14.1/lib/bap
- c++ compiler: ........................................ /usr/bin/c++
- C compiler optimization level: ....................... -O2
- Build every feature by default: ...................... false
- Enable development mode: ............................. false
- Build BAP bundler: ................................... true
- Create documentations: ............................... true
- Compile tests executable and library and run them: ... false
- pkg_uri: ............................................. /home/opam/.opam/4.14.1/lib/uri
- pkg_camlzip: ......................................... /home/opam/.opam/4.14.1/lib/camlzip
- pkg_unix: ............................................ /home/opam/.opam/4.14.1/lib/ocaml
- pkg_core_kernel: ..................................... /home/opam/.opam/4.14.1/lib/core_kernel
- pkg_core_kernel_caml_unix: ........................... /home/opam/.opam/4.14.1/lib/core_kernel/caml_unix
- pkg_ppx_bap: ......................................... /home/opam/.opam/4.14.1/lib/ppx_bap
- pkg_fileutils: ....................................... /home/opam/.opam/4.14.1/lib/fileutils
- 
Processing 324/346: [bap-build: gmake] [bap-bundle: gmake] [monads: ./configure] [regular: ./configure]
+ /home/opam/.opam/4.14.1/.opam-switch/build/regular.2.5.0/./configure "--prefix=/home/opam/.opam/4.14.1" "--mandir=/home/opam/.opam/4.14.1/man" "--enable-regular" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/regular.2.5.0)
- File "oasis/common.setup.ml.in", line 573, characters 4-15:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 601, characters 19-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 608, characters 37-48:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 611, characters 17-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1429, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1431, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1432, characters 14-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 28-40:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 28-41:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1435, characters 11-24:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1436, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3176, characters 8-19:
- 3176 |         Stream.from
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3179, characters 21-32:
- 3179 |                match Stream.next st with
-                             ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3182, characters 18-32:
- 3182 |              with Stream.Failure -> None)
-                          ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3184, characters 6-23:
- 3184 |       Genlex.make_lexer ["="] st_line
-              ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3187, characters 12-24:
- 3187 |       match Stream.npeek 3 lxr with
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 9-21:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                 ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 26-36:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                  ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 42-55:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                  ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 8-19:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 25-36:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 42-53:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                  ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3201, characters 17-34:
- 3201 |         let st = Stream.of_channel chn in
-                         ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3326, characters 16-33:
- 3326 |   let var_lxr = Genlex.make_lexer []
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3345, characters 22-38:
- 3345 |              var_lxr (Stream.of_string var)
-                              ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3347, characters 17-29:
- 3347 |            match Stream.npeek 3 st with
-                         ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 16-28:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 37-49:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                                             ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 16-28:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 37-50:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                                             ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 16-28:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 46-58:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                                                      ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 16-28:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 46-59:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                                                      ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3356, characters 16-28:
- 3356 |              | [Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3369, characters 13-25:
- 3369 |            | Stream.Error e ->
-                     ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4518, characters 21-38:
- 4518 |            let lxr = Genlex.make_lexer [] (stream_of_reader rdr) in
-                             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4520, characters 19-31:
- 4520 |              match Stream.npeek 2 lxr with
-                           ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 16-29:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                        ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 33-46:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                                         ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 15-26:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                       ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 32-43:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                                        ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- 
- Configuration:
- ocamlfind: ........................................... /home/opam/.opam/4.14.1/bin/ocamlfind
- ocamlc: .............................................. /home/opam/.opam/4.14.1/bin/ocamlc.opt
- ocamlopt: ............................................ /home/opam/.opam/4.14.1/bin/ocamlopt.opt
- ocamlbuild: .......................................... /home/opam/.opam/4.14.1/bin/ocamlbuild
- Package name: ........................................ bap
- Package version: ..................................... 2.5.0
- os_type: ............................................. Unix
- system: .............................................. freebsd
- architecture: ........................................ amd64
- ccomp_type: .......................................... cc
- ocaml_version: ....................................... 4.14.1
- standard_library_default: ............................ /home/opam/.opam/4.14.1/lib/ocaml
- standard_library: .................................... /home/opam/.opam/4.14.1/lib/ocaml
- bytecomp_c_compiler: ................................. cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- native_c_compiler: ................................... cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- model: ............................................... default
- ext_obj: ............................................. .o
- ext_asm: ............................................. .s
- ext_lib: ............................................. .a
- ext_dll: ............................................. .so
- default_executable_name: ............................. a.out
- systhread_supported: ................................. true
- Install architecture-independent files dir: .......... /home/opam/.opam/4.14.1
- Install architecture-dependent files in dir: ......... $prefix
- User executables: .................................... $exec_prefix/bin
- System admin executables: ............................ $exec_prefix/sbin
- Program executables: ................................. $exec_prefix/libexec
- Read-only single-machine data: ....................... $prefix/etc
- Modifiable architecture-independent data: ............ $prefix/com
- Modifiable single-machine data: ...................... $prefix/var
- Object code libraries: ............................... $exec_prefix/lib
- Read-only arch-independent data root: ................ $prefix/share
- Read-only architecture-independent data: ............. $datarootdir
- Info documentation: .................................. $datarootdir/info
- Locale-dependent data: ............................... $datarootdir/locale
- Man documentation: ................................... /home/opam/.opam/4.14.1/man
- Documentation root: .................................. $datarootdir/doc/$pkg_name
- HTML documentation: .................................. $docdir
- DVI documentation: ................................... $docdir
- PDF documentation: ................................... $docdir
- PS documentation: .................................... $docdir
- findlib_version: ..................................... 1.9.6
- is_native: ........................................... true
- suffix_program: ......................................
- Remove a file.: ...................................... rm -f
- Remove a directory.: ................................. rm -rf
- Turn ocaml debug flag on: ............................ true
- Turn ocaml profile flag on: .......................... false
- Compiler support generation of .cmxs.: ............... true
- OCamlbuild additional flags: .........................
- A default folder for plugins: ........................ /home/opam/.opam/4.14.1/lib/bap
- c++ compiler: ........................................ /usr/bin/c++
- C compiler optimization level: ....................... -O2
- Build every feature by default: ...................... false
- Enable development mode: ............................. false
- Build regular library: ............................... true
- Create documentations: ............................... true
- Compile tests executable and library and run them: ... false
- pkg_core_kernel: ..................................... /home/opam/.opam/4.14.1/lib/core_kernel
- pkg_ppx_bap: ......................................... /home/opam/.opam/4.14.1/lib/ppx_bap
- 
Processing 324/346: [bap-build: gmake] [bap-bundle: gmake] [monads: ./configure] [regular: gmake]
+ /home/opam/.opam/4.14.1/.opam-switch/build/monads.2.5.0/./configure "--prefix=/home/opam/.opam/4.14.1" "--enable-monads" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/monads.2.5.0)
- File "oasis/common.setup.ml.in", line 573, characters 4-15:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 601, characters 19-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 608, characters 37-48:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 611, characters 17-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1429, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1431, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1432, characters 14-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 28-40:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 28-41:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1435, characters 11-24:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1436, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3176, characters 8-19:
- 3176 |         Stream.from
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3179, characters 21-32:
- 3179 |                match Stream.next st with
-                             ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3182, characters 18-32:
- 3182 |              with Stream.Failure -> None)
-                          ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3184, characters 6-23:
- 3184 |       Genlex.make_lexer ["="] st_line
-              ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3187, characters 12-24:
- 3187 |       match Stream.npeek 3 lxr with
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 9-21:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                 ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 26-36:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                  ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 42-55:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                  ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 8-19:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 25-36:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 42-53:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                  ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3201, characters 17-34:
- 3201 |         let st = Stream.of_channel chn in
-                         ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3326, characters 16-33:
- 3326 |   let var_lxr = Genlex.make_lexer []
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3345, characters 22-38:
- 3345 |              var_lxr (Stream.of_string var)
-                              ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3347, characters 17-29:
- 3347 |            match Stream.npeek 3 st with
-                         ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 16-28:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 37-49:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                                             ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 16-28:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 37-50:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                                             ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 16-28:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 46-58:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                                                      ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 16-28:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 46-59:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                                                      ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3356, characters 16-28:
- 3356 |              | [Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3369, characters 13-25:
- 3369 |            | Stream.Error e ->
-                     ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4518, characters 21-38:
- 4518 |            let lxr = Genlex.make_lexer [] (stream_of_reader rdr) in
-                             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4520, characters 19-31:
- 4520 |              match Stream.npeek 2 lxr with
-                           ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 16-29:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                        ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 33-46:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                                         ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 15-26:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                       ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 32-43:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                                        ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- 
- Configuration:
- ocamlfind: ........................................... /home/opam/.opam/4.14.1/bin/ocamlfind
- ocamlc: .............................................. /home/opam/.opam/4.14.1/bin/ocamlc.opt
- ocamlopt: ............................................ /home/opam/.opam/4.14.1/bin/ocamlopt.opt
- ocamlbuild: .......................................... /home/opam/.opam/4.14.1/bin/ocamlbuild
- Package name: ........................................ bap
- Package version: ..................................... 2.5.0
- os_type: ............................................. Unix
- system: .............................................. freebsd
- architecture: ........................................ amd64
- ccomp_type: .......................................... cc
- ocaml_version: ....................................... 4.14.1
- standard_library_default: ............................ /home/opam/.opam/4.14.1/lib/ocaml
- standard_library: .................................... /home/opam/.opam/4.14.1/lib/ocaml
- bytecomp_c_compiler: ................................. cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- native_c_compiler: ................................... cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- model: ............................................... default
- ext_obj: ............................................. .o
- ext_asm: ............................................. .s
- ext_lib: ............................................. .a
- ext_dll: ............................................. .so
- default_executable_name: ............................. a.out
- systhread_supported: ................................. true
- Install architecture-independent files dir: .......... /home/opam/.opam/4.14.1
- Install architecture-dependent files in dir: ......... $prefix
- User executables: .................................... $exec_prefix/bin
- System admin executables: ............................ $exec_prefix/sbin
- Program executables: ................................. $exec_prefix/libexec
- Read-only single-machine data: ....................... $prefix/etc
- Modifiable architecture-independent data: ............ $prefix/com
- Modifiable single-machine data: ...................... $prefix/var
- Object code libraries: ............................... $exec_prefix/lib
- Read-only arch-independent data root: ................ $prefix/share
- Read-only architecture-independent data: ............. $datarootdir
- Info documentation: .................................. $datarootdir/info
- Locale-dependent data: ............................... $datarootdir/locale
- Man documentation: ................................... $datarootdir/man
- Documentation root: .................................. $datarootdir/doc/$pkg_name
- HTML documentation: .................................. $docdir
- DVI documentation: ................................... $docdir
- PDF documentation: ................................... $docdir
- PS documentation: .................................... $docdir
- findlib_version: ..................................... 1.9.6
- is_native: ........................................... true
- suffix_program: ......................................
- Remove a file.: ...................................... rm -f
- Remove a directory.: ................................. rm -rf
- Turn ocaml debug flag on: ............................ true
- Turn ocaml profile flag on: .......................... false
- Compiler support generation of .cmxs.: ............... true
- OCamlbuild additional flags: .........................
- A default folder for plugins: ........................ /home/opam/.opam/4.14.1/lib/bap
- c++ compiler: ........................................ /usr/bin/c++
- C compiler optimization level: ....................... -O2
- Build every feature by default: ...................... false
- Enable development mode: ............................. false
- Build monad library: ................................. true
- Create documentations: ............................... true
- Compile tests executable and library and run them: ... false
- pkg_core_kernel: ..................................... /home/opam/.opam/4.14.1/lib/core_kernel
- pkg_ppx_bap: ......................................... /home/opam/.opam/4.14.1/lib/ppx_bap
- pkg_core_kernel_rope: ................................ /home/opam/.opam/4.14.1/lib/core_kernel/rope
- 
Processing 324/346: [bap-build: gmake] [bap-bundle: gmake] [monads: gmake] [regular: gmake]
+ /usr/local/bin/gmake  (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bap-build.2.5.0)
- ./setup.exe -quiet -build 
- ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package ocamlbuild -package findlib -package core_kernel -package compiler-libs -modules tools/postinstall.ml > tools/postinstall.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -I lib/bap_build -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package ocamlbuild -package findlib -package core_kernel -package compiler-libs -I tools -I lib/bap_build -o tools/postinstall.cmo tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -I lib/bap_build -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package ocamlbuild -package findlib -package core_kernel -package compiler-libs -I tools -I lib/bap_build -o tools/postinstall.cmo tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -I lib/bap_build -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package ocamlbuild -package findlib -package core_kernel -package compiler-libs -I tools -I lib/bap_build -o tools/postinstall.cmx tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -I lib/bap_build -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package ocamlbuild -package findlib -package core_kernel -package compiler-libs -I tools -I lib/bap_build -o tools/postinstall.cmx tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -linkpkg -g -linkpkg -I tools tools/postinstall.cmx -o tools/postinstall.native
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ocamlbuild -package findlib -modules lib/bap_build/bap_build.mli > lib/bap_build/bap_build.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ocamlbuild -package findlib -I lib/bap_build -o lib/bap_build/bap_build.cmi lib/bap_build/bap_build.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ocamlbuild -package findlib -modules lib/bap_build/bap_build.ml > lib/bap_build/bap_build.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ocamlbuild -package findlib -I lib/bap_build -o lib/bap_build/bap_build.cmo lib/bap_build/bap_build.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -a -I lib/bap_build lib/bap_build/bap_build.cmo -o lib/bap_build/bap-build.cma
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ocamlbuild -package findlib -I lib/bap_build -o lib/bap_build/bap_build.cmx lib/bap_build/bap_build.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -a -I lib/bap_build lib/bap_build/bap_build.cmx -o lib/bap_build/bap-build.cmxa
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -shared -linkall -I lib/bap_build lib/bap_build/bap-build.cmxa -o lib/bap_build/bap-build.cmxs
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package ocamlbuild -package findlib -package core_kernel -package compiler-libs -modules tools/bapbuild.ml > tools/bapbuild.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -I lib/bap_build -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package ocamlbuild -package findlib -package core_kernel -package compiler-libs -I tools -I lib/bap_build -o tools/bapbuild.cmo tools/bapbuild.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -I lib/bap_build -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package ocamlbuild -package findlib -package core_kernel -package compiler-libs -I tools -I lib/bap_build -o tools/bapbuild.cmo tools/bapbuild.ml
- File "tools/bapbuild.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -I lib/bap_build -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package ocamlbuild -package findlib -package core_kernel -package compiler-libs -I tools -I lib/bap_build -o tools/bapbuild.cmx tools/bapbuild.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -I lib/bap_build -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package ocamlbuild -package findlib -package core_kernel -package compiler-libs -I tools -I lib/bap_build -o tools/bapbuild.cmx tools/bapbuild.ml
- File "tools/bapbuild.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -linkpkg -g -linkpkg -predicates used_bap-build -package ppx_bap -package ocamlbuild -package findlib -package core_kernel -package compiler-libs -I lib/bap_build -I tools lib/bap_build/bap-build.cmxa tools/bapbuild.cmx -o tools/bapbuild.native
- + ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- File "myocamlbuild.ml", line 454, characters 8-19:
- 454 |         Stream.from
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 457, characters 21-32:
- 457 |                match Stream.next st with
-                            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 460, characters 18-32:
- 460 |              with Stream.Failure -> None)
-                         ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 462, characters 6-23:
- 462 |       Genlex.make_lexer ["="] st_line
-             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 465, characters 12-24:
- 465 |       match Stream.npeek 3 lxr with
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 9-21:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 26-36:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                 ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 42-55:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                 ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 8-19:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 25-36:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 42-53:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 479, characters 17-34:
- 479 |         let st = Stream.of_channel chn in
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
-> compiled  bap-build.2.5.0
Processing 324/346: [bap-bundle: gmake] [monads: gmake] [regular: gmake]
Processing 325/346: [bap-bundle: gmake] [monads: gmake] [regular: gmake] [bap-build: gmake install]
+ /usr/local/bin/gmake  (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bap-bundle.2.5.0)
- ./setup.exe -quiet -build 
- ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package uri -package unix -package ppx_bap -package fileutils -package core_kernel.caml_unix -package core_kernel -package camlzip -modules tools/postinstall.ml > tools/postinstall.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -I lib/bap_bundle -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package unix -package ppx_bap -package fileutils -package core_kernel.caml_unix -package core_kernel -package camlzip -I tools -I lib/bap_bundle -o tools/postinstall.cmo tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -I lib/bap_bundle -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package unix -package ppx_bap -package fileutils -package core_kernel.caml_unix -package core_kernel -package camlzip -I tools -I lib/bap_bundle -o tools/postinstall.cmo tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -I lib/bap_bundle -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package unix -package ppx_bap -package fileutils -package core_kernel.caml_unix -package core_kernel -package camlzip -I tools -I lib/bap_bundle -o tools/postinstall.cmx tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -I lib/bap_bundle -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package unix -package ppx_bap -package fileutils -package core_kernel.caml_unix -package core_kernel -package camlzip -I tools -I lib/bap_bundle -o tools/postinstall.cmx tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -linkpkg -g -linkpkg -I tools tools/postinstall.cmx -o tools/postinstall.native
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package uri -package unix -package ppx_bap -package core_kernel.caml_unix -package core_kernel -package camlzip -modules lib/bap_bundle/bap_bundle.mli > lib/bap_bundle/bap_bundle.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package unix -package ppx_bap -package core_kernel.caml_unix -package core_kernel -package camlzip -I lib/bap_bundle -o lib/bap_bundle/bap_bundle.cmi lib/bap_bundle/bap_bundle.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package uri -package unix -package ppx_bap -package core_kernel.caml_unix -package core_kernel -package camlzip -modules lib/bap_bundle/bap_bundle.ml > lib/bap_bundle/bap_bundle.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package uri -package unix -package ppx_bap -package core_kernel.caml_unix -package core_kernel -package camlzip -modules lib/bap_bundle/bap_bundle_config.ml > lib/bap_bundle/bap_bundle_config.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package unix -package ppx_bap -package core_kernel.caml_unix -package core_kernel -package camlzip -I lib/bap_bundle -o lib/bap_bundle/bap_bundle.cmo lib/bap_bundle/bap_bundle.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package unix -package ppx_bap -package core_kernel.caml_unix -package core_kernel -package camlzip -I lib/bap_bundle -o lib/bap_bundle/bap_bundle.cmo lib/bap_bundle/bap_bundle.ml
- File "lib/bap_bundle/bap_bundle.ml", line 78, characters 6-20:
- 78 |       name : string;
-            ^^^^^^^^^^^^^^
- Warning 69 [unused-field]: record field name is never read.
- (However, this field is used to build or mutate values.)
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package unix -package ppx_bap -package core_kernel.caml_unix -package core_kernel -package camlzip -I lib/bap_bundle -o lib/bap_bundle/bap_bundle_config.cmo lib/bap_bundle/bap_bundle_config.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package unix -package ppx_bap -package core_kernel.caml_unix -package core_kernel -package camlzip -I lib/bap_bundle -o lib/bap_bundle/bap_bundle_config.cmo lib/bap_bundle/bap_bundle_config.ml
- File "lib/bap_bundle/bap_bundle_config.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -a -I lib/bap_bundle lib/bap_bundle/bap_bundle.cmo lib/bap_bundle/bap_bundle_config.cmo -o lib/bap_bundle/bundle.cma
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package unix -package ppx_bap -package core_kernel.caml_unix -package core_kernel -package camlzip -I lib/bap_bundle -o lib/bap_bundle/bap_bundle.cmx lib/bap_bundle/bap_bundle.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package unix -package ppx_bap -package core_kernel.caml_unix -package core_kernel -package camlzip -I lib/bap_bundle -o lib/bap_bundle/bap_bundle.cmx lib/bap_bundle/bap_bundle.ml
- File "lib/bap_bundle/bap_bundle.ml", line 78, characters 6-20:
- 78 |       name : string;
-            ^^^^^^^^^^^^^^
- Warning 69 [unused-field]: record field name is never read.
- (However, this field is used to build or mutate values.)
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package unix -package ppx_bap -package core_kernel.caml_unix -package core_kernel -package camlzip -I lib/bap_bundle -o lib/bap_bundle/bap_bundle_config.cmx lib/bap_bundle/bap_bundle_config.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package unix -package ppx_bap -package core_kernel.caml_unix -package core_kernel -package camlzip -I lib/bap_bundle -o lib/bap_bundle/bap_bundle_config.cmx lib/bap_bundle/bap_bundle_config.ml
- File "lib/bap_bundle/bap_bundle_config.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -a -I lib/bap_bundle lib/bap_bundle/bap_bundle.cmx lib/bap_bundle/bap_bundle_config.cmx -o lib/bap_bundle/bundle.cmxa
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -shared -linkall -I lib/bap_bundle lib/bap_bundle/bundle.cmxa -o lib/bap_bundle/bundle.cmxs
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package uri -package unix -package ppx_bap -package fileutils -package core_kernel.caml_unix -package core_kernel -package camlzip -modules tools/bapbundle.ml > tools/bapbundle.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package uri -package unix -package ppx_bap -package fileutils -package core_kernel.caml_unix -package core_kernel -package camlzip -modules tools/bapbundle.mli > tools/bapbundle.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -I lib/bap_bundle -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package unix -package ppx_bap -package fileutils -package core_kernel.caml_unix -package core_kernel -package camlzip -I tools -I lib/bap_bundle -o tools/bapbundle.cmi tools/bapbundle.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -I lib/bap_bundle -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package unix -package ppx_bap -package fileutils -package core_kernel.caml_unix -package core_kernel -package camlzip -I tools -I lib/bap_bundle -o tools/bapbundle.cmx tools/bapbundle.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -linkpkg -g -linkpkg -predicates used_bundle -package uri -package unix -package ppx_bap -package fileutils -package core_kernel.caml_unix -package core_kernel -package camlzip -I lib/bap_bundle -I tools lib/bap_bundle/bundle.cmxa tools/bapbundle.cmx -o tools/bapbundle.native
- + ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- File "myocamlbuild.ml", line 454, characters 8-19:
- 454 |         Stream.from
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 457, characters 21-32:
- 457 |                match Stream.next st with
-                            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 460, characters 18-32:
- 460 |              with Stream.Failure -> None)
-                         ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 462, characters 6-23:
- 462 |       Genlex.make_lexer ["="] st_line
-             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 465, characters 12-24:
- 465 |       match Stream.npeek 3 lxr with
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 9-21:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 26-36:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                 ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 42-55:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                 ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 8-19:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 25-36:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 42-53:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 479, characters 17-34:
- 479 |         let st = Stream.of_channel chn in
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
-> compiled  bap-bundle.2.5.0
Processing 325/346: [monads: gmake] [regular: gmake] [bap-build: gmake install]
+ /usr/local/bin/gmake "install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bap-build.2.5.0)
- ./setup.exe -quiet -install 
- Installed /home/opam/.opam/4.14.1/lib/bap-build/bap_build.mli
- Installed /home/opam/.opam/4.14.1/lib/bap-build/bap-build.cma
- Installed /home/opam/.opam/4.14.1/lib/bap-build/bap-build.cmxa
- Installed /home/opam/.opam/4.14.1/lib/bap-build/bap-build.a
- Installed /home/opam/.opam/4.14.1/lib/bap-build/bap-build.cmxs
- Installed /home/opam/.opam/4.14.1/lib/bap-build/bap_build.cmi
- Installed /home/opam/.opam/4.14.1/lib/bap-build/bap_build.cmti
- Installed /home/opam/.opam/4.14.1/lib/bap-build/bap_build.cmt
- Installed /home/opam/.opam/4.14.1/lib/bap-build/bap_build.annot
- Installed /home/opam/.opam/4.14.1/lib/bap-build/bap_build.cmx
- Installed /home/opam/.opam/4.14.1/lib/bap-build/META
- sh tools/build_plugins.sh
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- Finished updating plugins
- if [ -f ./postinstall.native ]; then ./postinstall.native; fi
- if [ -f ./postinstall.byte ]; then ./postinstall.byte; fi
- if [ -f ./postinstall ]; then ./postinstall; fi
-> installed bap-build.2.5.0
Processing 325/346: [monads: gmake] [regular: gmake]
Processing 326/346: [monads: gmake] [regular: gmake] [bap-bundle: gmake install]
+ /usr/local/bin/gmake  (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/regular.2.5.0)
- ./setup.exe -quiet -build 
- ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -modules tools/postinstall.ml > tools/postinstall.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -linkpkg -g -linkpkg -I tools tools/postinstall.cmx -o tools/postinstall.native
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel -modules lib/regular/regular.mli > lib/regular/regular.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular.cmi lib/regular/regular.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel -modules lib/regular/regular.ml > lib/regular/regular.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel -modules lib/regular/regular_bytes.mli > lib/regular/regular_bytes.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel -modules lib/regular/regular_cache.mli > lib/regular/regular_cache.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel -modules lib/regular/regular_data_intf.ml > lib/regular/regular_data_intf.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_bytes.cmi lib/regular/regular_bytes.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel -modules lib/regular/regular_data_read.mli > lib/regular/regular_data_read.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel -modules lib/regular/regular_data_types.ml > lib/regular/regular_data_types.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_data_types.cmo lib/regular/regular_data_types.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_data_types.cmo lib/regular/regular_data_types.ml
- File "lib/regular/regular_data_types.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel -modules lib/regular/regular_data_write.mli > lib/regular/regular_data_write.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_data_read.cmi lib/regular/regular_data_read.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_data_write.cmi lib/regular/regular_data_write.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_data_intf.cmo lib/regular/regular_data_intf.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_data_intf.cmo lib/regular/regular_data_intf.ml
- File "lib/regular/regular_data_intf.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel -modules lib/regular/regular_data.mli > lib/regular/regular_data.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel -modules lib/regular/regular_opaque.ml > lib/regular/regular_opaque.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel -modules lib/regular/regular_regular.mli > lib/regular/regular_regular.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_regular.cmi lib/regular/regular_regular.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel -modules lib/regular/regular_seq.mli > lib/regular/regular_seq.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_cache.cmi lib/regular/regular_cache.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_data.cmi lib/regular/regular_data.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_opaque.cmo lib/regular/regular_opaque.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_opaque.cmo lib/regular/regular_opaque.ml
- File "lib/regular/regular_opaque.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_seq.cmi lib/regular/regular_seq.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel -modules lib/regular/regular_bytes.ml > lib/regular/regular_bytes.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel -modules lib/regular/regular_cache.ml > lib/regular/regular_cache.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel -modules lib/regular/regular_data.ml > lib/regular/regular_data.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel -modules lib/regular/regular_data_write.ml > lib/regular/regular_data_write.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel -modules lib/regular/regular_data_read.ml > lib/regular/regular_data_read.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel -modules lib/regular/regular_regular.ml > lib/regular/regular_regular.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel -modules lib/regular/regular_seq.ml > lib/regular/regular_seq.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular.cmo lib/regular/regular.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_bytes.cmo lib/regular/regular_bytes.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_cache.cmo lib/regular/regular_cache.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_data.cmo lib/regular/regular_data.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_data_write.cmo lib/regular/regular_data_write.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_data_read.cmo lib/regular/regular_data_read.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_regular.cmo lib/regular/regular_regular.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_seq.cmo lib/regular/regular_seq.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -a -I lib/regular lib/regular/regular_bytes.cmo lib/regular/regular_data_types.cmo lib/regular/regular_data_read.cmo lib/regular/regular_data_write.cmo lib/regular/regular_data_intf.cmo lib/regular/regular_cache.cmo lib/regular/regular_data.cmo lib/regular/regular_seq.cmo lib/regular/regular_regular.cmo lib/regular/regular_opaque.cmo lib/regular/regular.cmo -o lib/regular/regular.cma
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_bytes.cmx lib/regular/regular_bytes.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_data_types.cmx lib/regular/regular_data_types.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_data_types.cmx lib/regular/regular_data_types.ml
- File "lib/regular/regular_data_types.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_data_read.cmx lib/regular/regular_data_read.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_data_write.cmx lib/regular/regular_data_write.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_data_intf.cmx lib/regular/regular_data_intf.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_data_intf.cmx lib/regular/regular_data_intf.ml
- File "lib/regular/regular_data_intf.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_cache.cmx lib/regular/regular_cache.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_data.cmx lib/regular/regular_data.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_seq.cmx lib/regular/regular_seq.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_regular.cmx lib/regular/regular_regular.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_opaque.cmx lib/regular/regular_opaque.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular_opaque.cmx lib/regular/regular_opaque.ml
- File "lib/regular/regular_opaque.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel -I lib/regular -o lib/regular/regular.cmx lib/regular/regular.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -a -I lib/regular lib/regular/regular_bytes.cmx lib/regular/regular_data_types.cmx lib/regular/regular_data_read.cmx lib/regular/regular_data_write.cmx lib/regular/regular_data_intf.cmx lib/regular/regular_cache.cmx lib/regular/regular_data.cmx lib/regular/regular_seq.cmx lib/regular/regular_regular.cmx lib/regular/regular_opaque.cmx lib/regular/regular.cmx -o lib/regular/regular.cmxa
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -shared -linkall -I lib/regular lib/regular/regular.cmxa -o lib/regular/regular.cmxs
- + ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- File "myocamlbuild.ml", line 454, characters 8-19:
- 454 |         Stream.from
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 457, characters 21-32:
- 457 |                match Stream.next st with
-                            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 460, characters 18-32:
- 460 |              with Stream.Failure -> None)
-                         ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 462, characters 6-23:
- 462 |       Genlex.make_lexer ["="] st_line
-             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 465, characters 12-24:
- 465 |       match Stream.npeek 3 lxr with
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 9-21:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 26-36:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                 ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 42-55:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                 ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 8-19:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 25-36:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 42-53:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 479, characters 17-34:
- 479 |         let st = Stream.of_channel chn in
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
-> compiled  regular.2.5.0
Processing 326/346: [monads: gmake] [bap-bundle: gmake install]
+ /usr/local/bin/gmake  (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/monads.2.5.0)
- ./setup.exe -quiet -build 
- ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -modules tools/postinstall.ml > tools/postinstall.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -linkpkg -g -linkpkg -I tools tools/postinstall.cmx -o tools/postinstall.native
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel.rope -package core_kernel -modules lib/monads/monads.mli > lib/monads/monads.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel.rope -package core_kernel -I lib/monads -o lib/monads/monads.cmi lib/monads/monads.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel.rope -package core_kernel -modules lib/monads/monads.ml > lib/monads/monads.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel.rope -package core_kernel -modules lib/monads/monads_monad.mli > lib/monads/monads_monad.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel.rope -package core_kernel -modules lib/monads/monads_monoid.mli > lib/monads/monads_monoid.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel.rope -package core_kernel -modules lib/monads/monads_types.ml > lib/monads/monads_types.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel.rope -package core_kernel -I lib/monads -o lib/monads/monads_monoid.cmi lib/monads/monads_monoid.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel.rope -package core_kernel -I lib/monads -o lib/monads/monads_types.cmo lib/monads/monads_types.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel.rope -package core_kernel -I lib/monads -o lib/monads/monads_types.cmo lib/monads/monads_types.ml
- File "lib/monads/monads_types.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel.rope -package core_kernel -I lib/monads -o lib/monads/monads_monad.cmi lib/monads/monads_monad.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel.rope -package core_kernel -modules lib/monads/monads_monad.ml > lib/monads/monads_monad.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package core_kernel.rope -package core_kernel -modules lib/monads/monads_monoid.ml > lib/monads/monads_monoid.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel.rope -package core_kernel -I lib/monads -o lib/monads/monads.cmo lib/monads/monads.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel.rope -package core_kernel -I lib/monads -o lib/monads/monads_monad.cmo lib/monads/monads_monad.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel.rope -package core_kernel -I lib/monads -o lib/monads/monads_monad.cmo lib/monads/monads_monad.ml
- File "lib/monads/monads_monad.ml", line 112, characters 19-37:
- 112 |       let expect ?(finally=Fn.nothing) ~f ~catch =
-                          ^^^^^^^^^^^^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel.rope -package core_kernel -I lib/monads -o lib/monads/monads_monoid.cmo lib/monads/monads_monoid.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -a -I lib/monads lib/monads/monads_monoid.cmo lib/monads/monads_types.cmo lib/monads/monads_monad.cmo lib/monads/monads.cmo -o lib/monads/monads.cma
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel.rope -package core_kernel -I lib/monads -o lib/monads/monads_monoid.cmx lib/monads/monads_monoid.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel.rope -package core_kernel -I lib/monads -o lib/monads/monads_types.cmx lib/monads/monads_types.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel.rope -package core_kernel -I lib/monads -o lib/monads/monads_types.cmx lib/monads/monads_types.ml
- File "lib/monads/monads_types.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel.rope -package core_kernel -I lib/monads -o lib/monads/monads_monad.cmx lib/monads/monads_monad.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel.rope -package core_kernel -I lib/monads -o lib/monads/monads_monad.cmx lib/monads/monads_monad.ml
- File "lib/monads/monads_monad.ml", line 112, characters 19-37:
- 112 |       let expect ?(finally=Fn.nothing) ~f ~catch =
-                          ^^^^^^^^^^^^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package core_kernel.rope -package core_kernel -I lib/monads -o lib/monads/monads.cmx lib/monads/monads.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -a -I lib/monads lib/monads/monads_monoid.cmx lib/monads/monads_types.cmx lib/monads/monads_monad.cmx lib/monads/monads.cmx -o lib/monads/monads.cmxa
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -shared -linkall -I lib/monads lib/monads/monads.cmxa -o lib/monads/monads.cmxs
- + ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- File "myocamlbuild.ml", line 454, characters 8-19:
- 454 |         Stream.from
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 457, characters 21-32:
- 457 |                match Stream.next st with
-                            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 460, characters 18-32:
- 460 |              with Stream.Failure -> None)
-                         ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 462, characters 6-23:
- 462 |       Genlex.make_lexer ["="] st_line
-             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 465, characters 12-24:
- 465 |       match Stream.npeek 3 lxr with
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 9-21:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 26-36:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                 ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 42-55:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                 ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 8-19:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 25-36:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 42-53:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 479, characters 17-34:
- 479 |         let st = Stream.of_channel chn in
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
-> compiled  monads.2.5.0
Processing 326/346: [bap-bundle: gmake install]
+ /usr/local/bin/gmake "install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bap-bundle.2.5.0)
- ./setup.exe -quiet -install 
- Installed /home/opam/.opam/4.14.1/lib/bap-bundle/bap_bundle.mli
- Installed /home/opam/.opam/4.14.1/lib/bap-bundle/bundle.cma
- Installed /home/opam/.opam/4.14.1/lib/bap-bundle/bundle.cmxa
- Installed /home/opam/.opam/4.14.1/lib/bap-bundle/bundle.a
- Installed /home/opam/.opam/4.14.1/lib/bap-bundle/bundle.cmxs
- Installed /home/opam/.opam/4.14.1/lib/bap-bundle/bap_bundle.cmi
- Installed /home/opam/.opam/4.14.1/lib/bap-bundle/bap_bundle.cmti
- Installed /home/opam/.opam/4.14.1/lib/bap-bundle/bap_bundle.cmt
- Installed /home/opam/.opam/4.14.1/lib/bap-bundle/bap_bundle.annot
- Installed /home/opam/.opam/4.14.1/lib/bap-bundle/bap_bundle_config.cmx
- Installed /home/opam/.opam/4.14.1/lib/bap-bundle/bap_bundle.cmx
- Installed /home/opam/.opam/4.14.1/lib/bap-bundle/META
- sh tools/build_plugins.sh
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- Finished updating plugins
- if [ -f ./postinstall.native ]; then ./postinstall.native; fi
- if [ -f ./postinstall.byte ]; then ./postinstall.byte; fi
- if [ -f ./postinstall ]; then ./postinstall; fi
-> installed bap-bundle.2.5.0
Processing 327/346: [monads: gmake install]
+ /usr/local/bin/gmake "install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/monads.2.5.0)
- ./setup.exe -quiet -install 
- Installed /home/opam/.opam/4.14.1/lib/monads/monads.mli
- Installed /home/opam/.opam/4.14.1/lib/monads/monads.cma
- Installed /home/opam/.opam/4.14.1/lib/monads/monads.cmxa
- Installed /home/opam/.opam/4.14.1/lib/monads/monads.a
- Installed /home/opam/.opam/4.14.1/lib/monads/monads.cmxs
- Installed /home/opam/.opam/4.14.1/lib/monads/monads.cmi
- Installed /home/opam/.opam/4.14.1/lib/monads/monads.cmti
- Installed /home/opam/.opam/4.14.1/lib/monads/monads.cmt
- Installed /home/opam/.opam/4.14.1/lib/monads/monads.annot
- Installed /home/opam/.opam/4.14.1/lib/monads/monads_types.cmx
- Installed /home/opam/.opam/4.14.1/lib/monads/monads_monoid.cmx
- Installed /home/opam/.opam/4.14.1/lib/monads/monads_monad.cmx
- Installed /home/opam/.opam/4.14.1/lib/monads/monads.cmx
- Installed /home/opam/.opam/4.14.1/lib/monads/META
- sh tools/build_plugins.sh
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- Finished updating plugins
- if [ -f ./postinstall.native ]; then ./postinstall.native; fi
- if [ -f ./postinstall.byte ]; then ./postinstall.byte; fi
- if [ -f ./postinstall ]; then ./postinstall; fi
-> installed monads.2.5.0
Processing 328/346: [bap-future: ./configure]
Processing 329/346: [bap-future: ./configure] [bap-knowledge: ./configure]
Processing 330/346: [bap-future: ./configure] [bap-knowledge: ./configure] [ogre: ./configure]
Processing 331/346: [bap-future: ./configure] [bap-knowledge: ./configure] [ogre: ./configure] [regular: gmake install]
+ /home/opam/.opam/4.14.1/.opam-switch/build/bap-knowledge.2.5.0/./configure "--prefix=/home/opam/.opam/4.14.1" "--enable-knowledge" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bap-knowledge.2.5.0)
- File "oasis/common.setup.ml.in", line 573, characters 4-15:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 601, characters 19-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 608, characters 37-48:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 611, characters 17-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1429, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1431, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1432, characters 14-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 28-40:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 28-41:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1435, characters 11-24:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1436, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3176, characters 8-19:
- 3176 |         Stream.from
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3179, characters 21-32:
- 3179 |                match Stream.next st with
-                             ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3182, characters 18-32:
- 3182 |              with Stream.Failure -> None)
-                          ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3184, characters 6-23:
- 3184 |       Genlex.make_lexer ["="] st_line
-              ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3187, characters 12-24:
- 3187 |       match Stream.npeek 3 lxr with
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 9-21:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                 ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 26-36:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                  ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 42-55:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                  ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 8-19:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 25-36:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 42-53:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                  ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3201, characters 17-34:
- 3201 |         let st = Stream.of_channel chn in
-                         ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3326, characters 16-33:
- 3326 |   let var_lxr = Genlex.make_lexer []
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3345, characters 22-38:
- 3345 |              var_lxr (Stream.of_string var)
-                              ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3347, characters 17-29:
- 3347 |            match Stream.npeek 3 st with
-                         ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 16-28:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 37-49:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                                             ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 16-28:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 37-50:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                                             ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 16-28:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 46-58:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                                                      ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 16-28:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 46-59:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                                                      ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3356, characters 16-28:
- 3356 |              | [Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3369, characters 13-25:
- 3369 |            | Stream.Error e ->
-                     ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4518, characters 21-38:
- 4518 |            let lxr = Genlex.make_lexer [] (stream_of_reader rdr) in
-                             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4520, characters 19-31:
- 4520 |              match Stream.npeek 2 lxr with
-                           ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 16-29:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                        ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 33-46:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                                         ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 15-26:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                       ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 32-43:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                                        ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- 
- Configuration:
- ocamlfind: ........................................... /home/opam/.opam/4.14.1/bin/ocamlfind
- ocamlc: .............................................. /home/opam/.opam/4.14.1/bin/ocamlc.opt
- ocamlopt: ............................................ /home/opam/.opam/4.14.1/bin/ocamlopt.opt
- ocamlbuild: .......................................... /home/opam/.opam/4.14.1/bin/ocamlbuild
- Package name: ........................................ bap
- Package version: ..................................... 2.5.0
- os_type: ............................................. Unix
- system: .............................................. freebsd
- architecture: ........................................ amd64
- ccomp_type: .......................................... cc
- ocaml_version: ....................................... 4.14.1
- standard_library_default: ............................ /home/opam/.opam/4.14.1/lib/ocaml
- standard_library: .................................... /home/opam/.opam/4.14.1/lib/ocaml
- bytecomp_c_compiler: ................................. cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- native_c_compiler: ................................... cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- model: ............................................... default
- ext_obj: ............................................. .o
- ext_asm: ............................................. .s
- ext_lib: ............................................. .a
- ext_dll: ............................................. .so
- default_executable_name: ............................. a.out
- systhread_supported: ................................. true
- Install architecture-independent files dir: .......... /home/opam/.opam/4.14.1
- Install architecture-dependent files in dir: ......... $prefix
- User executables: .................................... $exec_prefix/bin
- System admin executables: ............................ $exec_prefix/sbin
- Program executables: ................................. $exec_prefix/libexec
- Read-only single-machine data: ....................... $prefix/etc
- Modifiable architecture-independent data: ............ $prefix/com
- Modifiable single-machine data: ...................... $prefix/var
- Object code libraries: ............................... $exec_prefix/lib
- Read-only arch-independent data root: ................ $prefix/share
- Read-only architecture-independent data: ............. $datarootdir
- Info documentation: .................................. $datarootdir/info
- Locale-dependent data: ............................... $datarootdir/locale
- Man documentation: ................................... $datarootdir/man
- Documentation root: .................................. $datarootdir/doc/$pkg_name
- HTML documentation: .................................. $docdir
- DVI documentation: ................................... $docdir
- PDF documentation: ................................... $docdir
- PS documentation: .................................... $docdir
- findlib_version: ..................................... 1.9.6
- is_native: ........................................... true
- suffix_program: ......................................
- Remove a file.: ...................................... rm -f
- Remove a directory.: ................................. rm -rf
- Turn ocaml debug flag on: ............................ true
- Turn ocaml profile flag on: .......................... false
- Compiler support generation of .cmxs.: ............... true
- OCamlbuild additional flags: .........................
- A default folder for plugins: ........................ /home/opam/.opam/4.14.1/lib/bap
- c++ compiler: ........................................ /usr/bin/c++
- C compiler optimization level: ....................... -O2
- Build every feature by default: ...................... false
- Enable development mode: ............................. false
- Build the knowledge library: ......................... true
- Create documentations: ............................... true
- Compile tests executable and library and run them: ... false
- pkg_core_kernel: ..................................... /home/opam/.opam/4.14.1/lib/core_kernel
- pkg_core_kernel_caml_unix: ........................... /home/opam/.opam/4.14.1/lib/core_kernel/caml_unix
- pkg_monads: .......................................... /home/opam/.opam/4.14.1/lib/monads
- pkg_ppx_bap: ......................................... /home/opam/.opam/4.14.1/lib/ppx_bap
- 
Processing 331/346: [bap-future: ./configure] [bap-knowledge: gmake] [ogre: ./configure] [regular: gmake install]
+ /home/opam/.opam/4.14.1/.opam-switch/build/bap-future.2.5.0/./configure "--prefix=/home/opam/.opam/4.14.1" "--enable-future" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bap-future.2.5.0)
- File "oasis/common.setup.ml.in", line 573, characters 4-15:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 601, characters 19-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 608, characters 37-48:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 611, characters 17-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1429, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1431, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1432, characters 14-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 28-40:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 28-41:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1435, characters 11-24:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1436, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3176, characters 8-19:
- 3176 |         Stream.from
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3179, characters 21-32:
- 3179 |                match Stream.next st with
-                             ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3182, characters 18-32:
- 3182 |              with Stream.Failure -> None)
-                          ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3184, characters 6-23:
- 3184 |       Genlex.make_lexer ["="] st_line
-              ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3187, characters 12-24:
- 3187 |       match Stream.npeek 3 lxr with
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 9-21:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                 ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 26-36:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                  ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 42-55:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                  ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 8-19:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 25-36:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 42-53:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                  ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3201, characters 17-34:
- 3201 |         let st = Stream.of_channel chn in
-                         ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3326, characters 16-33:
- 3326 |   let var_lxr = Genlex.make_lexer []
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3345, characters 22-38:
- 3345 |              var_lxr (Stream.of_string var)
-                              ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3347, characters 17-29:
- 3347 |            match Stream.npeek 3 st with
-                         ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 16-28:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 37-49:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                                             ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 16-28:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 37-50:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                                             ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 16-28:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 46-58:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                                                      ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 16-28:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 46-59:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                                                      ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3356, characters 16-28:
- 3356 |              | [Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3369, characters 13-25:
- 3369 |            | Stream.Error e ->
-                     ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4518, characters 21-38:
- 4518 |            let lxr = Genlex.make_lexer [] (stream_of_reader rdr) in
-                             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4520, characters 19-31:
- 4520 |              match Stream.npeek 2 lxr with
-                           ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 16-29:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                        ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 33-46:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                                         ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 15-26:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                       ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 32-43:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                                        ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- 
- Configuration:
- ocamlfind: ........................................... /home/opam/.opam/4.14.1/bin/ocamlfind
- ocamlc: .............................................. /home/opam/.opam/4.14.1/bin/ocamlc.opt
- ocamlopt: ............................................ /home/opam/.opam/4.14.1/bin/ocamlopt.opt
- ocamlbuild: .......................................... /home/opam/.opam/4.14.1/bin/ocamlbuild
- Package name: ........................................ bap
- Package version: ..................................... 2.5.0
- os_type: ............................................. Unix
- system: .............................................. freebsd
- architecture: ........................................ amd64
- ccomp_type: .......................................... cc
- ocaml_version: ....................................... 4.14.1
- standard_library_default: ............................ /home/opam/.opam/4.14.1/lib/ocaml
- standard_library: .................................... /home/opam/.opam/4.14.1/lib/ocaml
- bytecomp_c_compiler: ................................. cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- native_c_compiler: ................................... cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- model: ............................................... default
- ext_obj: ............................................. .o
- ext_asm: ............................................. .s
- ext_lib: ............................................. .a
- ext_dll: ............................................. .so
- default_executable_name: ............................. a.out
- systhread_supported: ................................. true
- Install architecture-independent files dir: .......... /home/opam/.opam/4.14.1
- Install architecture-dependent files in dir: ......... $prefix
- User executables: .................................... $exec_prefix/bin
- System admin executables: ............................ $exec_prefix/sbin
- Program executables: ................................. $exec_prefix/libexec
- Read-only single-machine data: ....................... $prefix/etc
- Modifiable architecture-independent data: ............ $prefix/com
- Modifiable single-machine data: ...................... $prefix/var
- Object code libraries: ............................... $exec_prefix/lib
- Read-only arch-independent data root: ................ $prefix/share
- Read-only architecture-independent data: ............. $datarootdir
- Info documentation: .................................. $datarootdir/info
- Locale-dependent data: ............................... $datarootdir/locale
- Man documentation: ................................... $datarootdir/man
- Documentation root: .................................. $datarootdir/doc/$pkg_name
- HTML documentation: .................................. $docdir
- DVI documentation: ................................... $docdir
- PDF documentation: ................................... $docdir
- PS documentation: .................................... $docdir
- findlib_version: ..................................... 1.9.6
- is_native: ........................................... true
- suffix_program: ......................................
- Remove a file.: ...................................... rm -f
- Remove a directory.: ................................. rm -rf
- Turn ocaml debug flag on: ............................ true
- Turn ocaml profile flag on: .......................... false
- Compiler support generation of .cmxs.: ............... true
- OCamlbuild additional flags: .........................
- A default folder for plugins: ........................ /home/opam/.opam/4.14.1/lib/bap
- c++ compiler: ........................................ /usr/bin/c++
- C compiler optimization level: ....................... -O2
- Build every feature by default: ...................... false
- Enable development mode: ............................. false
- Build future library: ................................ true
- Create documentations: ............................... true
- Compile tests executable and library and run them: ... false
- pkg_core_kernel: ..................................... /home/opam/.opam/4.14.1/lib/core_kernel
- pkg_monads: .......................................... /home/opam/.opam/4.14.1/lib/monads
- 
Processing 331/346: [bap-future: gmake] [bap-knowledge: gmake] [ogre: ./configure] [regular: gmake install]
+ /home/opam/.opam/4.14.1/.opam-switch/build/ogre.2.5.0/./configure "--prefix=/home/opam/.opam/4.14.1" "--enable-ogre" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ogre.2.5.0)
- File "oasis/common.setup.ml.in", line 573, characters 4-15:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 601, characters 19-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 608, characters 37-48:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 611, characters 17-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1429, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1431, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1432, characters 14-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 28-40:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 28-41:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1435, characters 11-24:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1436, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3176, characters 8-19:
- 3176 |         Stream.from
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3179, characters 21-32:
- 3179 |                match Stream.next st with
-                             ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3182, characters 18-32:
- 3182 |              with Stream.Failure -> None)
-                          ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3184, characters 6-23:
- 3184 |       Genlex.make_lexer ["="] st_line
-              ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3187, characters 12-24:
- 3187 |       match Stream.npeek 3 lxr with
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 9-21:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                 ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 26-36:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                  ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 42-55:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                  ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 8-19:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 25-36:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 42-53:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                  ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3201, characters 17-34:
- 3201 |         let st = Stream.of_channel chn in
-                         ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3326, characters 16-33:
- 3326 |   let var_lxr = Genlex.make_lexer []
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3345, characters 22-38:
- 3345 |              var_lxr (Stream.of_string var)
-                              ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3347, characters 17-29:
- 3347 |            match Stream.npeek 3 st with
-                         ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 16-28:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 37-49:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                                             ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 16-28:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 37-50:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                                             ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 16-28:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 46-58:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                                                      ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 16-28:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 46-59:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                                                      ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3356, characters 16-28:
- 3356 |              | [Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3369, characters 13-25:
- 3369 |            | Stream.Error e ->
-                     ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4518, characters 21-38:
- 4518 |            let lxr = Genlex.make_lexer [] (stream_of_reader rdr) in
-                             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4520, characters 19-31:
- 4520 |              match Stream.npeek 2 lxr with
-                           ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 16-29:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                        ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 33-46:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                                         ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 15-26:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                       ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 32-43:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                                        ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- 
- Configuration:
- ocamlfind: ........................................... /home/opam/.opam/4.14.1/bin/ocamlfind
- ocamlc: .............................................. /home/opam/.opam/4.14.1/bin/ocamlc.opt
- ocamlopt: ............................................ /home/opam/.opam/4.14.1/bin/ocamlopt.opt
- ocamlbuild: .......................................... /home/opam/.opam/4.14.1/bin/ocamlbuild
- Package name: ........................................ bap
- Package version: ..................................... 2.5.0
- os_type: ............................................. Unix
- system: .............................................. freebsd
- architecture: ........................................ amd64
- ccomp_type: .......................................... cc
- ocaml_version: ....................................... 4.14.1
- standard_library_default: ............................ /home/opam/.opam/4.14.1/lib/ocaml
- standard_library: .................................... /home/opam/.opam/4.14.1/lib/ocaml
- bytecomp_c_compiler: ................................. cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- native_c_compiler: ................................... cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- model: ............................................... default
- ext_obj: ............................................. .o
- ext_asm: ............................................. .s
- ext_lib: ............................................. .a
- ext_dll: ............................................. .so
- default_executable_name: ............................. a.out
- systhread_supported: ................................. true
- Install architecture-independent files dir: .......... /home/opam/.opam/4.14.1
- Install architecture-dependent files in dir: ......... $prefix
- User executables: .................................... $exec_prefix/bin
- System admin executables: ............................ $exec_prefix/sbin
- Program executables: ................................. $exec_prefix/libexec
- Read-only single-machine data: ....................... $prefix/etc
- Modifiable architecture-independent data: ............ $prefix/com
- Modifiable single-machine data: ...................... $prefix/var
- Object code libraries: ............................... $exec_prefix/lib
- Read-only arch-independent data root: ................ $prefix/share
- Read-only architecture-independent data: ............. $datarootdir
- Info documentation: .................................. $datarootdir/info
- Locale-dependent data: ............................... $datarootdir/locale
- Man documentation: ................................... $datarootdir/man
- Documentation root: .................................. $datarootdir/doc/$pkg_name
- HTML documentation: .................................. $docdir
- DVI documentation: ................................... $docdir
- PDF documentation: ................................... $docdir
- PS documentation: .................................... $docdir
- findlib_version: ..................................... 1.9.6
- is_native: ........................................... true
- suffix_program: ......................................
- Remove a file.: ...................................... rm -f
- Remove a directory.: ................................. rm -rf
- Turn ocaml debug flag on: ............................ true
- Turn ocaml profile flag on: .......................... false
- Compiler support generation of .cmxs.: ............... true
- OCamlbuild additional flags: .........................
- A default folder for plugins: ........................ /home/opam/.opam/4.14.1/lib/bap
- c++ compiler: ........................................ /usr/bin/c++
- C compiler optimization level: ....................... -O2
- Build every feature by default: ...................... false
- Enable development mode: ............................. false
- Build ogre library: .................................. true
- Create documentations: ............................... true
- Compile tests executable and library and run them: ... false
- pkg_core_kernel: ..................................... /home/opam/.opam/4.14.1/lib/core_kernel
- pkg_monads: .......................................... /home/opam/.opam/4.14.1/lib/monads
- pkg_ppx_bap: ......................................... /home/opam/.opam/4.14.1/lib/ppx_bap
- 
Processing 331/346: [bap-future: gmake] [bap-knowledge: gmake] [ogre: gmake] [regular: gmake install]
+ /usr/local/bin/gmake "install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/regular.2.5.0)
- ./setup.exe -quiet -install 
- Installed /home/opam/.opam/4.14.1/lib/regular/regular.mli
- Installed /home/opam/.opam/4.14.1/lib/regular/regular.cma
- Installed /home/opam/.opam/4.14.1/lib/regular/regular.cmxa
- Installed /home/opam/.opam/4.14.1/lib/regular/regular.a
- Installed /home/opam/.opam/4.14.1/lib/regular/regular.cmxs
- Installed /home/opam/.opam/4.14.1/lib/regular/regular.cmi
- Installed /home/opam/.opam/4.14.1/lib/regular/regular.cmti
- Installed /home/opam/.opam/4.14.1/lib/regular/regular.cmt
- Installed /home/opam/.opam/4.14.1/lib/regular/regular.annot
- Installed /home/opam/.opam/4.14.1/lib/regular/regular_seq.cmx
- Installed /home/opam/.opam/4.14.1/lib/regular/regular_regular.cmx
- Installed /home/opam/.opam/4.14.1/lib/regular/regular_opaque.cmx
- Installed /home/opam/.opam/4.14.1/lib/regular/regular_data_read.cmx
- Installed /home/opam/.opam/4.14.1/lib/regular/regular_data_write.cmx
- Installed /home/opam/.opam/4.14.1/lib/regular/regular_data_types.cmx
- Installed /home/opam/.opam/4.14.1/lib/regular/regular_data_intf.cmx
- Installed /home/opam/.opam/4.14.1/lib/regular/regular_data.cmx
- Installed /home/opam/.opam/4.14.1/lib/regular/regular_cache.cmx
- Installed /home/opam/.opam/4.14.1/lib/regular/regular_bytes.cmx
- Installed /home/opam/.opam/4.14.1/lib/regular/regular.cmx
- Installed /home/opam/.opam/4.14.1/lib/regular/META
- sh tools/build_plugins.sh
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- Finished updating plugins
- if [ -f ./postinstall.native ]; then ./postinstall.native; fi
- if [ -f ./postinstall.byte ]; then ./postinstall.byte; fi
- if [ -f ./postinstall ]; then ./postinstall; fi
-> installed regular.2.5.0
Processing 331/346: [bap-future: gmake] [bap-knowledge: gmake] [ogre: gmake]
Processing 332/346: [bap-future: gmake] [bap-knowledge: gmake] [graphlib: ./configure] [ogre: gmake]
+ /home/opam/.opam/4.14.1/.opam-switch/build/graphlib.2.5.0/./configure "--prefix=/home/opam/.opam/4.14.1" "--mandir=/home/opam/.opam/4.14.1/man" "--enable-graphlib" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/graphlib.2.5.0)
- File "oasis/common.setup.ml.in", line 573, characters 4-15:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 601, characters 19-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 608, characters 37-48:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 611, characters 17-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1429, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1431, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1432, characters 14-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 28-40:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 28-41:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1435, characters 11-24:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1436, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3176, characters 8-19:
- 3176 |         Stream.from
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3179, characters 21-32:
- 3179 |                match Stream.next st with
-                             ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3182, characters 18-32:
- 3182 |              with Stream.Failure -> None)
-                          ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3184, characters 6-23:
- 3184 |       Genlex.make_lexer ["="] st_line
-              ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3187, characters 12-24:
- 3187 |       match Stream.npeek 3 lxr with
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 9-21:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                 ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 26-36:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                  ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 42-55:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                  ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 8-19:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 25-36:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 42-53:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                  ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3201, characters 17-34:
- 3201 |         let st = Stream.of_channel chn in
-                         ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3326, characters 16-33:
- 3326 |   let var_lxr = Genlex.make_lexer []
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3345, characters 22-38:
- 3345 |              var_lxr (Stream.of_string var)
-                              ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3347, characters 17-29:
- 3347 |            match Stream.npeek 3 st with
-                         ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 16-28:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 37-49:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                                             ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 16-28:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 37-50:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                                             ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 16-28:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 46-58:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                                                      ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 16-28:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 46-59:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                                                      ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3356, characters 16-28:
- 3356 |              | [Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3369, characters 13-25:
- 3369 |            | Stream.Error e ->
-                     ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4518, characters 21-38:
- 4518 |            let lxr = Genlex.make_lexer [] (stream_of_reader rdr) in
-                             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4520, characters 19-31:
- 4520 |              match Stream.npeek 2 lxr with
-                           ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 16-29:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                        ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 33-46:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                                         ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 15-26:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                       ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 32-43:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                                        ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- 
- Configuration:
- ocamlfind: ........................................... /home/opam/.opam/4.14.1/bin/ocamlfind
- ocamlc: .............................................. /home/opam/.opam/4.14.1/bin/ocamlc.opt
- ocamlopt: ............................................ /home/opam/.opam/4.14.1/bin/ocamlopt.opt
- ocamlbuild: .......................................... /home/opam/.opam/4.14.1/bin/ocamlbuild
- Package name: ........................................ bap
- Package version: ..................................... 2.5.0
- os_type: ............................................. Unix
- system: .............................................. freebsd
- architecture: ........................................ amd64
- ccomp_type: .......................................... cc
- ocaml_version: ....................................... 4.14.1
- standard_library_default: ............................ /home/opam/.opam/4.14.1/lib/ocaml
- standard_library: .................................... /home/opam/.opam/4.14.1/lib/ocaml
- bytecomp_c_compiler: ................................. cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- native_c_compiler: ................................... cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- model: ............................................... default
- ext_obj: ............................................. .o
- ext_asm: ............................................. .s
- ext_lib: ............................................. .a
- ext_dll: ............................................. .so
- default_executable_name: ............................. a.out
- systhread_supported: ................................. true
- Install architecture-independent files dir: .......... /home/opam/.opam/4.14.1
- Install architecture-dependent files in dir: ......... $prefix
- User executables: .................................... $exec_prefix/bin
- System admin executables: ............................ $exec_prefix/sbin
- Program executables: ................................. $exec_prefix/libexec
- Read-only single-machine data: ....................... $prefix/etc
- Modifiable architecture-independent data: ............ $prefix/com
- Modifiable single-machine data: ...................... $prefix/var
- Object code libraries: ............................... $exec_prefix/lib
- Read-only arch-independent data root: ................ $prefix/share
- Read-only architecture-independent data: ............. $datarootdir
- Info documentation: .................................. $datarootdir/info
- Locale-dependent data: ............................... $datarootdir/locale
- Man documentation: ................................... /home/opam/.opam/4.14.1/man
- Documentation root: .................................. $datarootdir/doc/$pkg_name
- HTML documentation: .................................. $docdir
- DVI documentation: ................................... $docdir
- PDF documentation: ................................... $docdir
- PS documentation: .................................... $docdir
- findlib_version: ..................................... 1.9.6
- is_native: ........................................... true
- suffix_program: ......................................
- Remove a file.: ...................................... rm -f
- Remove a directory.: ................................. rm -rf
- Turn ocaml debug flag on: ............................ true
- Turn ocaml profile flag on: .......................... false
- Compiler support generation of .cmxs.: ............... true
- OCamlbuild additional flags: .........................
- A default folder for plugins: ........................ /home/opam/.opam/4.14.1/lib/bap
- c++ compiler: ........................................ /usr/bin/c++
- C compiler optimization level: ....................... -O2
- Build every feature by default: ...................... false
- Enable development mode: ............................. false
- Build graphlib library: .............................. true
- Create documentations: ............................... true
- Compile tests executable and library and run them: ... false
- pkg_core_kernel: ..................................... /home/opam/.opam/4.14.1/lib/core_kernel
- pkg_regular: ......................................... /home/opam/.opam/4.14.1/lib/regular
- pkg_ocamlgraph: ...................................... /home/opam/.opam/4.14.1/lib/ocamlgraph
- pkg_ppx_bap: ......................................... /home/opam/.opam/4.14.1/lib/ppx_bap
- pkg_core_kernel_pairing_heap: ........................ /home/opam/.opam/4.14.1/lib/core_kernel/pairing_heap
- 
Processing 332/346: [bap-future: gmake] [bap-knowledge: gmake] [graphlib: gmake] [ogre: gmake]
+ /usr/local/bin/gmake  (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bap-future.2.5.0)
- ./setup.exe -quiet -build 
- ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -modules tools/postinstall.ml > tools/postinstall.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -linkpkg -g -linkpkg -I tools tools/postinstall.cmx -o tools/postinstall.native
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package monads -package core_kernel -modules lib/bap_future/bap_future.mli > lib/bap_future/bap_future.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package monads -package core_kernel -I lib/bap_future -o lib/bap_future/bap_future.cmi lib/bap_future/bap_future.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package monads -package core_kernel -modules lib/bap_future/bap_future.ml > lib/bap_future/bap_future.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package monads -package core_kernel -I lib/bap_future -o lib/bap_future/bap_future.cmo lib/bap_future/bap_future.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -a -I lib/bap_future lib/bap_future/bap_future.cmo -o lib/bap_future/bap_future.cma
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package monads -package core_kernel -I lib/bap_future -o lib/bap_future/bap_future.cmx lib/bap_future/bap_future.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -a -I lib/bap_future lib/bap_future/bap_future.cmx -o lib/bap_future/bap_future.cmxa
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -shared -linkall -I lib/bap_future lib/bap_future/bap_future.cmxa -o lib/bap_future/bap_future.cmxs
- + ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- File "myocamlbuild.ml", line 454, characters 8-19:
- 454 |         Stream.from
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 457, characters 21-32:
- 457 |                match Stream.next st with
-                            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 460, characters 18-32:
- 460 |              with Stream.Failure -> None)
-                         ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 462, characters 6-23:
- 462 |       Genlex.make_lexer ["="] st_line
-             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 465, characters 12-24:
- 465 |       match Stream.npeek 3 lxr with
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 9-21:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 26-36:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                 ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 42-55:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                 ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 8-19:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 25-36:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 42-53:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 479, characters 17-34:
- 479 |         let st = Stream.of_channel chn in
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
-> compiled  bap-future.2.5.0
Processing 332/346: [bap-knowledge: gmake] [graphlib: gmake] [ogre: gmake]
Processing 333/346: [bap-knowledge: gmake] [graphlib: gmake] [ogre: gmake] [bap-future: gmake install]
+ /usr/local/bin/gmake  (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ogre.2.5.0)
- ./setup.exe -quiet -build 
- ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -modules tools/postinstall.ml > tools/postinstall.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -linkpkg -g -linkpkg -I tools tools/postinstall.cmx -o tools/postinstall.native
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package monads -package core_kernel -modules lib/ogre/ogre.mli > lib/ogre/ogre.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package monads -package core_kernel -I lib/ogre -o lib/ogre/ogre.cmi lib/ogre/ogre.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package monads -package core_kernel -modules lib/ogre/ogre.ml > lib/ogre/ogre.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package monads -package core_kernel -I lib/ogre -o lib/ogre/ogre.cmo lib/ogre/ogre.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package monads -package core_kernel -I lib/ogre -o lib/ogre/ogre.cmo lib/ogre/ogre.ml
- File "lib/ogre/ogre.ml", line 805, characters 4-16:
- 805 |     doc : Doc.t;
-           ^^^^^^^^^^^^
- Warning 69 [unused-field]: unused record field doc.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -a -I lib/ogre lib/ogre/ogre.cmo -o lib/ogre/ogre.cma
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package monads -package core_kernel -I lib/ogre -o lib/ogre/ogre.cmx lib/ogre/ogre.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package monads -package core_kernel -I lib/ogre -o lib/ogre/ogre.cmx lib/ogre/ogre.ml
- File "lib/ogre/ogre.ml", line 805, characters 4-16:
- 805 |     doc : Doc.t;
-           ^^^^^^^^^^^^
- Warning 69 [unused-field]: unused record field doc.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -a -I lib/ogre lib/ogre/ogre.cmx -o lib/ogre/ogre.cmxa
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -shared -linkall -I lib/ogre lib/ogre/ogre.cmxa -o lib/ogre/ogre.cmxs
- + ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- File "myocamlbuild.ml", line 454, characters 8-19:
- 454 |         Stream.from
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 457, characters 21-32:
- 457 |                match Stream.next st with
-                            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 460, characters 18-32:
- 460 |              with Stream.Failure -> None)
-                         ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 462, characters 6-23:
- 462 |       Genlex.make_lexer ["="] st_line
-             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 465, characters 12-24:
- 465 |       match Stream.npeek 3 lxr with
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 9-21:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 26-36:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                 ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 42-55:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                 ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 8-19:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 25-36:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 42-53:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 479, characters 17-34:
- 479 |         let st = Stream.of_channel chn in
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
-> compiled  ogre.2.5.0
Processing 333/346: [bap-knowledge: gmake] [graphlib: gmake] [bap-future: gmake install]
+ /usr/local/bin/gmake  (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bap-knowledge.2.5.0)
- ./setup.exe -quiet -build 
- ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -modules tools/postinstall.ml > tools/postinstall.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -linkpkg -g -linkpkg -I tools tools/postinstall.cmx -o tools/postinstall.native
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package monads -package core_kernel.caml_unix -package core_kernel -modules lib/knowledge/bap_knowledge.mli > lib/knowledge/bap_knowledge.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package monads -package core_kernel.caml_unix -package core_kernel -I lib/knowledge -o lib/knowledge/bap_knowledge.cmi lib/knowledge/bap_knowledge.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package ppx_bap -package monads -package core_kernel.caml_unix -package core_kernel -modules lib/knowledge/bap_knowledge.ml > lib/knowledge/bap_knowledge.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package monads -package core_kernel.caml_unix -package core_kernel -I lib/knowledge -o lib/knowledge/bap_knowledge.cmo lib/knowledge/bap_knowledge.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package monads -package core_kernel.caml_unix -package core_kernel -I lib/knowledge -o lib/knowledge/bap_knowledge.cmo lib/knowledge/bap_knowledge.ml
- File "lib/knowledge/bap_knowledge.ml", line 1513, characters 4-38:
- 1513 |     app : 'a. 'a key -> 'a -> 'b -> 'r
-            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 69 [unused-field]: unused record field app.
- File "lib/knowledge/bap_knowledge.ml", line 2013, characters 4-41:
- 2013 |     inspect : 'a. 'a key -> 'a -> Sexp.t;
-            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 69 [unused-field]: record field inspect is never read.
- (However, this field is used to build or mutate values.)
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -a -I lib/knowledge lib/knowledge/bap_knowledge.cmo -o lib/knowledge/knowledge.cma
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package monads -package core_kernel.caml_unix -package core_kernel -I lib/knowledge -o lib/knowledge/bap_knowledge.cmx lib/knowledge/bap_knowledge.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package ppx_bap -package monads -package core_kernel.caml_unix -package core_kernel -I lib/knowledge -o lib/knowledge/bap_knowledge.cmx lib/knowledge/bap_knowledge.ml
- File "lib/knowledge/bap_knowledge.ml", line 1513, characters 4-38:
- 1513 |     app : 'a. 'a key -> 'a -> 'b -> 'r
-            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 69 [unused-field]: unused record field app.
- File "lib/knowledge/bap_knowledge.ml", line 2013, characters 4-41:
- 2013 |     inspect : 'a. 'a key -> 'a -> Sexp.t;
-            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 69 [unused-field]: record field inspect is never read.
- (However, this field is used to build or mutate values.)
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -a -I lib/knowledge lib/knowledge/bap_knowledge.cmx -o lib/knowledge/knowledge.cmxa
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -shared -linkall -I lib/knowledge lib/knowledge/knowledge.cmxa -o lib/knowledge/knowledge.cmxs
- + ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- File "myocamlbuild.ml", line 454, characters 8-19:
- 454 |         Stream.from
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 457, characters 21-32:
- 457 |                match Stream.next st with
-                            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 460, characters 18-32:
- 460 |              with Stream.Failure -> None)
-                         ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 462, characters 6-23:
- 462 |       Genlex.make_lexer ["="] st_line
-             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 465, characters 12-24:
- 465 |       match Stream.npeek 3 lxr with
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 9-21:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 26-36:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                 ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 42-55:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                 ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 8-19:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 25-36:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 42-53:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 479, characters 17-34:
- 479 |         let st = Stream.of_channel chn in
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
-> compiled  bap-knowledge.2.5.0
Processing 333/346: [graphlib: gmake] [bap-future: gmake install]
+ /usr/local/bin/gmake "install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bap-future.2.5.0)
- ./setup.exe -quiet -install 
- Installed /home/opam/.opam/4.14.1/lib/bap-future/bap_future.mli
- Installed /home/opam/.opam/4.14.1/lib/bap-future/bap_future.cma
- Installed /home/opam/.opam/4.14.1/lib/bap-future/bap_future.cmxa
- Installed /home/opam/.opam/4.14.1/lib/bap-future/bap_future.a
- Installed /home/opam/.opam/4.14.1/lib/bap-future/bap_future.cmxs
- Installed /home/opam/.opam/4.14.1/lib/bap-future/bap_future.cmi
- Installed /home/opam/.opam/4.14.1/lib/bap-future/bap_future.cmti
- Installed /home/opam/.opam/4.14.1/lib/bap-future/bap_future.cmt
- Installed /home/opam/.opam/4.14.1/lib/bap-future/bap_future.annot
- Installed /home/opam/.opam/4.14.1/lib/bap-future/bap_future.cmx
- Installed /home/opam/.opam/4.14.1/lib/bap-future/META
- sh tools/build_plugins.sh
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- Finished updating plugins
- if [ -f ./postinstall.native ]; then ./postinstall.native; fi
- if [ -f ./postinstall.byte ]; then ./postinstall.byte; fi
- if [ -f ./postinstall ]; then ./postinstall; fi
-> installed bap-future.2.5.0
Processing 333/346: [graphlib: gmake]
Processing 334/346: [bap-plugins: ./configure] [graphlib: gmake]
Processing 335/346: [bap-plugins: ./configure] [graphlib: gmake] [bap-knowledge: gmake install]
+ /home/opam/.opam/4.14.1/.opam-switch/build/bap-plugins.2.5.0/./configure "--prefix=/home/opam/.opam/4.14.1" "--enable-plugins" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bap-plugins.2.5.0)
- File "oasis/common.setup.ml.in", line 573, characters 4-15:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 601, characters 19-36:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 608, characters 37-48:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 611, characters 17-31:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1429, characters 16-33:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1431, characters 22-38:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1432, characters 14-26:
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1433, characters 28-40:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1434, characters 28-41:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1435, characters 11-24:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "oasis/common.setup.ml.in", line 1436, characters 11-23:
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3176, characters 8-19:
- 3176 |         Stream.from
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3179, characters 21-32:
- 3179 |                match Stream.next st with
-                             ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3182, characters 18-32:
- 3182 |              with Stream.Failure -> None)
-                          ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3184, characters 6-23:
- 3184 |       Genlex.make_lexer ["="] st_line
-              ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3187, characters 12-24:
- 3187 |       match Stream.npeek 3 lxr with
-                    ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 9-21:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                 ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 26-36:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                  ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3188, characters 42-55:
- 3188 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                  ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 8-19:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 25-36:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3189, characters 42-53:
- 3189 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                  ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3201, characters 17-34:
- 3201 |         let st = Stream.of_channel chn in
-                         ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3326, characters 16-33:
- 3326 |   let var_lxr = Genlex.make_lexer []
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3345, characters 22-38:
- 3345 |              var_lxr (Stream.of_string var)
-                              ^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3347, characters 17-29:
- 3347 |            match Stream.npeek 3 st with
-                         ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 16-28:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3348, characters 37-49:
- 3348 |              | [Genlex.Ident "utoh"; Genlex.Ident nm] ->
-                                             ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 16-28:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3350, characters 37-50:
- 3350 |              | [Genlex.Ident "utoh"; Genlex.String s] ->
-                                             ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 16-28:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3352, characters 46-58:
- 3352 |              | [Genlex.Ident "ocaml_escaped"; Genlex.Ident nm] ->
-                                                      ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 16-28:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3354, characters 46-59:
- 3354 |              | [Genlex.Ident "ocaml_escaped"; Genlex.String s] ->
-                                                      ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3356, characters 16-28:
- 3356 |              | [Genlex.Ident nm] ->
-                        ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 3369, characters 13-25:
- 3369 |            | Stream.Error e ->
-                     ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4518, characters 21-38:
- 4518 |            let lxr = Genlex.make_lexer [] (stream_of_reader rdr) in
-                             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4520, characters 19-31:
- 4520 |              match Stream.npeek 2 lxr with
-                           ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 16-29:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                        ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4521, characters 33-46:
- 4521 |              | [Genlex.String e; Genlex.String d] ->
-                                         ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 15-26:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                       ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "setup.ml", line 4523, characters 32-43:
- 4523 |                Stream.junk lxr; Stream.junk lxr;
-                                        ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- 
- Configuration:
- ocamlfind: ........................................... /home/opam/.opam/4.14.1/bin/ocamlfind
- ocamlc: .............................................. /home/opam/.opam/4.14.1/bin/ocamlc.opt
- ocamlopt: ............................................ /home/opam/.opam/4.14.1/bin/ocamlopt.opt
- ocamlbuild: .......................................... /home/opam/.opam/4.14.1/bin/ocamlbuild
- Package name: ........................................ bap
- Package version: ..................................... 2.5.0
- os_type: ............................................. Unix
- system: .............................................. freebsd
- architecture: ........................................ amd64
- ccomp_type: .......................................... cc
- ocaml_version: ....................................... 4.14.1
- standard_library_default: ............................ /home/opam/.opam/4.14.1/lib/ocaml
- standard_library: .................................... /home/opam/.opam/4.14.1/lib/ocaml
- bytecomp_c_compiler: ................................. cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- native_c_compiler: ................................... cc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- model: ............................................... default
- ext_obj: ............................................. .o
- ext_asm: ............................................. .s
- ext_lib: ............................................. .a
- ext_dll: ............................................. .so
- default_executable_name: ............................. a.out
- systhread_supported: ................................. true
- Install architecture-independent files dir: .......... /home/opam/.opam/4.14.1
- Install architecture-dependent files in dir: ......... $prefix
- User executables: .................................... $exec_prefix/bin
- System admin executables: ............................ $exec_prefix/sbin
- Program executables: ................................. $exec_prefix/libexec
- Read-only single-machine data: ....................... $prefix/etc
- Modifiable architecture-independent data: ............ $prefix/com
- Modifiable single-machine data: ...................... $prefix/var
- Object code libraries: ............................... $exec_prefix/lib
- Read-only arch-independent data root: ................ $prefix/share
- Read-only architecture-independent data: ............. $datarootdir
- Info documentation: .................................. $datarootdir/info
- Locale-dependent data: ............................... $datarootdir/locale
- Man documentation: ................................... $datarootdir/man
- Documentation root: .................................. $datarootdir/doc/$pkg_name
- HTML documentation: .................................. $docdir
- DVI documentation: ................................... $docdir
- PDF documentation: ................................... $docdir
- PS documentation: .................................... $docdir
- findlib_version: ..................................... 1.9.6
- is_native: ........................................... true
- suffix_program: ......................................
- Remove a file.: ...................................... rm -f
- Remove a directory.: ................................. rm -rf
- Turn ocaml debug flag on: ............................ true
- Turn ocaml profile flag on: .......................... false
- Compiler support generation of .cmxs.: ............... true
- OCamlbuild additional flags: .........................
- A default folder for plugins: ........................ /home/opam/.opam/4.14.1/lib/bap
- c++ compiler: ........................................ /usr/bin/c++
- C compiler optimization level: ....................... -O2
- Build every feature by default: ...................... false
- Enable development mode: ............................. false
- Build BAP plugins support library: ................... true
- Create documentations: ............................... true
- Compile tests executable and library and run them: ... false
- pkg_core_kernel: ..................................... /home/opam/.opam/4.14.1/lib/core_kernel
- pkg_dynlink: ......................................... /home/opam/.opam/4.14.1/lib/ocaml
- pkg_fileutils: ....................................... /home/opam/.opam/4.14.1/lib/fileutils
- pkg_findlib: ......................................... /home/opam/.opam/4.14.1/lib/findlib
- pkg_bap_bundle: ...................................... /home/opam/.opam/4.14.1/lib/bap-bundle
- pkg_bap_future: ...................................... /home/opam/.opam/4.14.1/lib/bap-future
- pkg_uri: ............................................. /home/opam/.opam/4.14.1/lib/uri
- pkg_ppx_bap: ......................................... /home/opam/.opam/4.14.1/lib/ppx_bap
- 
Processing 335/346: [bap-plugins: gmake] [graphlib: gmake] [bap-knowledge: gmake install]
+ /usr/local/bin/gmake "install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bap-knowledge.2.5.0)
- ./setup.exe -quiet -install 
- Installed /home/opam/.opam/4.14.1/lib/bap-knowledge/bap_knowledge.mli
- Installed /home/opam/.opam/4.14.1/lib/bap-knowledge/knowledge.cma
- Installed /home/opam/.opam/4.14.1/lib/bap-knowledge/knowledge.cmxa
- Installed /home/opam/.opam/4.14.1/lib/bap-knowledge/knowledge.a
- Installed /home/opam/.opam/4.14.1/lib/bap-knowledge/knowledge.cmxs
- Installed /home/opam/.opam/4.14.1/lib/bap-knowledge/bap_knowledge.cmi
- Installed /home/opam/.opam/4.14.1/lib/bap-knowledge/bap_knowledge.cmti
- Installed /home/opam/.opam/4.14.1/lib/bap-knowledge/bap_knowledge.cmt
- Installed /home/opam/.opam/4.14.1/lib/bap-knowledge/bap_knowledge.annot
- Installed /home/opam/.opam/4.14.1/lib/bap-knowledge/bap_knowledge.cmx
- Installed /home/opam/.opam/4.14.1/lib/bap-knowledge/META
- sh tools/build_plugins.sh
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- Finished updating plugins
- if [ -f ./postinstall.native ]; then ./postinstall.native; fi
- if [ -f ./postinstall.byte ]; then ./postinstall.byte; fi
- if [ -f ./postinstall ]; then ./postinstall; fi
-> installed bap-knowledge.2.5.0
Processing 335/346: [bap-plugins: gmake] [graphlib: gmake]
Processing 336/346: [bap-plugins: gmake] [graphlib: gmake] [ogre: gmake install]
+ /usr/local/bin/gmake "install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/ogre.2.5.0)
- ./setup.exe -quiet -install 
- Installed /home/opam/.opam/4.14.1/lib/ogre/ogre.mli
- Installed /home/opam/.opam/4.14.1/lib/ogre/ogre.cma
- Installed /home/opam/.opam/4.14.1/lib/ogre/ogre.cmxa
- Installed /home/opam/.opam/4.14.1/lib/ogre/ogre.a
- Installed /home/opam/.opam/4.14.1/lib/ogre/ogre.cmxs
- Installed /home/opam/.opam/4.14.1/lib/ogre/ogre.cmi
- Installed /home/opam/.opam/4.14.1/lib/ogre/ogre.cmti
- Installed /home/opam/.opam/4.14.1/lib/ogre/ogre.cmt
- Installed /home/opam/.opam/4.14.1/lib/ogre/ogre.annot
- Installed /home/opam/.opam/4.14.1/lib/ogre/ogre.cmx
- Installed /home/opam/.opam/4.14.1/lib/ogre/META
- sh tools/build_plugins.sh
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- Finished updating plugins
- if [ -f ./postinstall.native ]; then ./postinstall.native; fi
- if [ -f ./postinstall.byte ]; then ./postinstall.byte; fi
- if [ -f ./postinstall ]; then ./postinstall; fi
-> installed ogre.2.5.0
Processing 336/346: [bap-plugins: gmake] [graphlib: gmake]
+ /usr/local/bin/gmake  (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bap-plugins.2.5.0)
- ./setup.exe -quiet -build 
- ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -modules tools/postinstall.ml > tools/postinstall.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmo tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -I tools -o tools/postinstall.cmx tools/postinstall.ml
- File "tools/postinstall.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -linkpkg -g -linkpkg -I tools tools/postinstall.cmx -o tools/postinstall.native
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package uri -package ppx_bap -package findlib -package fileutils -package dynlink -package core_kernel -package bap-future -package bap-bundle -modules lib/bap_plugins/bap_plugins.mli > lib/bap_plugins/bap_plugins.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package ppx_bap -package findlib -package fileutils -package dynlink -package core_kernel -package bap-future -package bap-bundle -I lib/bap_plugins -o lib/bap_plugins/bap_plugins.cmi lib/bap_plugins/bap_plugins.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package uri -package ppx_bap -package findlib -package fileutils -package dynlink -package core_kernel -package bap-future -package bap-bundle -modules lib/bap_plugins/bap_plugins.ml > lib/bap_plugins/bap_plugins.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package uri -package ppx_bap -package findlib -package fileutils -package dynlink -package core_kernel -package bap-future -package bap-bundle -modules lib/bap_plugins/bap_plugins_config.ml > lib/bap_plugins/bap_plugins_config.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package uri -package ppx_bap -package findlib -package fileutils -package dynlink -package core_kernel -package bap-future -package bap-bundle -modules lib/bap_plugins/bap_plugins_units.mli > lib/bap_plugins/bap_plugins_units.mli.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package ppx_bap -package findlib -package fileutils -package dynlink -package core_kernel -package bap-future -package bap-bundle -I lib/bap_plugins -o lib/bap_plugins/bap_plugins_config.cmo lib/bap_plugins/bap_plugins_config.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package ppx_bap -package findlib -package fileutils -package dynlink -package core_kernel -package bap-future -package bap-bundle -I lib/bap_plugins -o lib/bap_plugins/bap_plugins_config.cmo lib/bap_plugins/bap_plugins_config.ml
- File "lib/bap_plugins/bap_plugins_config.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package ppx_bap -package findlib -package fileutils -package dynlink -package core_kernel -package bap-future -package bap-bundle -I lib/bap_plugins -o lib/bap_plugins/bap_plugins_units.cmi lib/bap_plugins/bap_plugins_units.mli
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamldep -package uri -package ppx_bap -package findlib -package fileutils -package dynlink -package core_kernel -package bap-future -package bap-bundle -modules lib/bap_plugins/bap_plugins_units.ml > lib/bap_plugins/bap_plugins_units.ml.depends
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package ppx_bap -package findlib -package fileutils -package dynlink -package core_kernel -package bap-future -package bap-bundle -I lib/bap_plugins -o lib/bap_plugins/bap_plugins.cmo lib/bap_plugins/bap_plugins.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package ppx_bap -package findlib -package fileutils -package dynlink -package core_kernel -package bap-future -package bap-bundle -I lib/bap_plugins -o lib/bap_plugins/bap_plugins_units.cmo lib/bap_plugins/bap_plugins_units.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlc -a -I lib/bap_plugins lib/bap_plugins/bap_plugins_config.cmo lib/bap_plugins/bap_plugins_units.cmo lib/bap_plugins/bap_plugins.cmo -o lib/bap_plugins/bap_plugins.cma
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package ppx_bap -package findlib -package fileutils -package dynlink -package core_kernel -package bap-future -package bap-bundle -I lib/bap_plugins -o lib/bap_plugins/bap_plugins_config.cmx lib/bap_plugins/bap_plugins_config.ml
- + /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package ppx_bap -package findlib -package fileutils -package dynlink -package core_kernel -package bap-future -package bap-bundle -I lib/bap_plugins -o lib/bap_plugins/bap_plugins_config.cmx lib/bap_plugins/bap_plugins_config.ml
- File "lib/bap_plugins/bap_plugins_config.ml", line 1:
- Warning 70 [missing-mli]: Cannot find interface file.
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package ppx_bap -package findlib -package fileutils -package dynlink -package core_kernel -package bap-future -package bap-bundle -I lib/bap_plugins -o lib/bap_plugins/bap_plugins_units.cmx lib/bap_plugins/bap_plugins_units.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -w +a-4-6-7-9-27-29-32..42-44-45-48-50-60 -package uri -package ppx_bap -package findlib -package fileutils -package dynlink -package core_kernel -package bap-future -package bap-bundle -I lib/bap_plugins -o lib/bap_plugins/bap_plugins.cmx lib/bap_plugins/bap_plugins.ml
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -a -I lib/bap_plugins lib/bap_plugins/bap_plugins_config.cmx lib/bap_plugins/bap_plugins_units.cmx lib/bap_plugins/bap_plugins.cmx -o lib/bap_plugins/bap_plugins.cmxa
- /home/opam/.opam/4.14.1/bin/ocamlfind ocamlopt -shared -linkall -I lib/bap_plugins lib/bap_plugins/bap_plugins.cmxa -o lib/bap_plugins/bap_plugins.cmxs
- + ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package findlib myocamlbuild.ml /home/opam/.opam/4.14.1/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- File "myocamlbuild.ml", line 454, characters 8-19:
- 454 |         Stream.from
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 457, characters 21-32:
- 457 |                match Stream.next st with
-                            ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 460, characters 18-32:
- 460 |              with Stream.Failure -> None)
-                         ^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 462, characters 6-23:
- 462 |       Genlex.make_lexer ["="] st_line
-             ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 465, characters 12-24:
- 465 |       match Stream.npeek 3 lxr with
-                   ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 9-21:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                ^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 26-36:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                 ^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 466, characters 42-55:
- 466 |       | [Genlex.Ident nm; Genlex.Kwd "="; Genlex.String value] ->
-                                                 ^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Genlex
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 8-19:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-               ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 25-36:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 467, characters 42-53:
- 467 |         Stream.junk lxr; Stream.junk lxr; Stream.junk lxr;
-                                                 ^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
- File "myocamlbuild.ml", line 479, characters 17-34:
- 479 |         let st = Stream.of_channel chn in
-                        ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Stream
- Use the camlp-streams library instead.
-> compiled  bap-plugins.2.5.0
Processing 336/346: [graphlib: gmake]
Processing 337/346: [graphlib: gmake] [bap-plugins: gmake install]
+ /usr/local/bin/gmake "install" (CWD=/home/opam/.opam/4.14.1/.opam-switch/build/bap-plugins.2.5.0)
- ./setup.exe -quiet -install 
- Installed /home/opam/.opam/4.14.1/lib/bap-plugins/bap_plugins.mli
- Installed /home/opam/.opam/4.14.1/lib/bap-plugins/bap_plugins.cma
- Installed /home/opam/.opam/4.14.1/lib/bap-plugins/bap_plugins.cmxa
- Installed /home/opam/.opam/4.14.1/lib/bap-plugins/bap_plugins.a
- Installed /home/opam/.opam/4.14.1/lib/bap-plugins/bap_plugins.cmxs
- Installed /home/opam/.opam/4.14.1/lib/bap-plugins/bap_plugins.cmi
- Installed /home/opam/.opam/4.14.1/lib/bap-plugins/bap_plugins.cmti
- Installed /home/opam/.opam/4.14.1/lib/bap-plugins/bap_plugins.cmt
- Installed /home/opam/.opam/4.14.1/lib/bap-plugins/bap_plugins.annot
- Installed /home/opam/.opam/4.14.1/lib/bap-plugins/bap_plugins_units.cmx
- Installed /home/opam/.opam/4.14.1/lib/bap-plugins/bap_plugins_config.cmx
- Installed /home/opam/.opam/4.14.1/lib/bap-plugins/bap_plugins.cmx
- Installed /home/opam/.opam/4.14.1/lib/bap-plugins/META
- sh tools/build_plugins.sh
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: parameter not set
- eval: prefix: pa